[Решено]gnome40 Ha Debian 11

Автор Whowka, 03 сентября 2021, 22:50:07

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Whowka

Нарыл  статеечку и пару роликов про установку нового гнома  на новый Дебиан
Тыц
Один из роликов
Попытался повторить. Подправил  sources.list
Открыть содержимое (спойлер)
# deb cdrom:[Debian GNU/Linux 11.0.0 _Bullseye_ - Official amd64 DVD Binary-1 2>

#deb cdrom:[Debian GNU/Linux 11.0.0 _Bullseye_ - Official amd64 DVD Binary-1 20>

deb http://deb.debian.org/debian/ bullseye main contrib non-free
deb-src http://deb.debian.org/debian/ bullseye main contrib non-free

deb http://security.debian.org/debian-security bullseye-security main contrib n>
deb-src http://security.debian.org/debian-security bullseye-security main contr>

# bullseye-updates, to get updates before a point release is made;
# see https://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_updates>
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian/ bullseye-updates main contrib non-free

deb http://deb.debian.org/debian/ experimental main

[свернуть]
(пробовал и со слешем перед experimental и без него)
apt update выдаёт в терминале:
Открыть содержимое (спойлер)

gnome40@debian11:~$ sudo apt update
[sudo] пароль для gnome40:
Сущ:1 http://deb.debian.org/debian bullseye InRelease
Сущ:2 http://security.debian.org/debian-security bullseye-security InRelease
Сущ:3 http://deb.debian.org/debian bullseye-updates InRelease
Сущ:4 http://deb.debian.org/debian experimental InRelease
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
Чтение информации о состоянии... Готово         
Все пакеты имеют последние версии.
gnome40@debian11:~$
[свернуть]
Как я понимаю experimental не подключился, ну и соответственно:
Открыть содержимое (спойлер)
gnome40@debian11:~$ sudo apt -t experimental install gnome-shell gnome-backgrounds gnome-applets gnome-control-center mutter gjs
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
Чтение информации о состоянии... Готово         
Уже установлен пакет gjs самой новой версии (1.66.2-1).
gjs помечен как установленный вручную.
Уже установлен пакет gnome-backgrounds самой новой версии (3.38.0-1).
gnome-backgrounds помечен как установленный вручную.
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
gnome-applets : Зависит: gnome-panel (>= 3.10) но он не будет установлен
                 Зависит: libgnome-panel0 (>= 3.41.1) но он не будет установлен
                 Зависит: libgweather-3-16 (>= 40.0) но 3.36.1-3 должен быть установлен
                 Зависит: libtracker-sparql-3.0-0 (>= 3.1.1) но он не может быть установлен
gnome-shell : Зависит: gir1.2-mutter-8 (>= 40.0) но он не будет установлен
               Зависит: libglib2.0-0 (>= 2.67.3) но 2.66.8-1 должен быть установлен
               Зависит: libgtk-4-1 (>= 4.0.0) но он не будет установлен
               Зависит: libmutter-8-0 (>= 40.0) но он не будет установлен
mutter : Зависит: libglib2.0-0 (>= 2.67.3) но 2.66.8-1 должен быть установлен
          Зависит: libmutter-8-0 (>= 3.29.4) но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
[свернуть]
  ЧЯНТД?


dzhoser

deb http://deb.debian.org/debian experimental main
Добавить в sources.list удалив предыдущее значение. Не вбивайте вручную используйте копирование.
su -
apt -f install
apt update
apt -t experimental install gnome-shell gnome-backgrounds gnome-applets gnome-control-center mutter gjs
Цитироватьdeb http://security.debian.org/debian-security bullseye-security main contrib n>
deb-src http://security.debian.org/debian-security bullseye-security main contr>

# bullseye-updates, to get updates before a point release is made;
# see https://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_updates>
deb http://deb.debian.org/debian/ bullseye-updates main
Репозитории не до конца прописаны или это редактор обрезает?
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

Whowka

Цитата: dzhoser от 04 сентября 2021, 04:27:17Репозитории не до конца прописаны

endru

Цитата: Whowka от 03 сентября 2021, 22:50:07Нарыл  статеечку и пару роликов про установку нового гнома  на новый Дебиан
Эти статьи были когда debian 11 был testing!
Сейчас gnome 40 есть в ветке testing! т.е. можете смело ставить debian 12 и там будет 40 гном.

Whowka

Цитата: endru от 04 сентября 2021, 11:20:42можете смело ставить debian 12
Хотелось бы стабильную, но с гномом 40-м. :) . Я-тт сегодня, с утра, докумекал  sid  прописать, пакеты поставились, но переключаться не хочет

Whowka

Чётт никак "лыжи не едут"(если, как не хуже вариант). Как я понимаю testing это сейчас bookworm? Так и там тоже гном  не 40-й...


ChubaDuba

#7
Цитата: Whowka от 04 сентября 2021, 13:55:13Я-тт сегодня, с утра, докумекал  sid  прописать, пакеты поставились, но переключаться не хочет
Ему ещё GTK4 нужен, а в sid'e его нет. Нужно самому собирать.
Бλог   @chuba_duba

Whowka

#8
Udachnik, Спасибо, но всё-равно не понятно. Возможно, я не совсем правильно сформулировал  вопрос. Хотелось бы увидетьтакое. А такое не получается :)
ChubaDuba,
Цитата: ChubaDuba от 06 сентября 2021, 19:57:18Ему ещё GTK4 нужен
Так а в тестинге он, как  я понял из отсюдова он есть? Его устанавливать нужно?

ChubaDuba

Бλог   @chuba_duba

Whowka

ChubaDuba, Спасибо! Видимо настал, для меня, момент потренироваться в сборке. Как долго я  его оттягивал... :) 

ChubaDuba

Цитата: Whowka от 06 сентября 2021, 20:21:18...Видимо настал, для меня, момент потренироваться в сборке. Как долго я  его оттягивал...
Тогда лучше ставьте Debian 12 (testing), от stable после того как притяните все зависимости для сборки останется одно название  :)
Бλог   @chuba_duba

Whowka

ChubaDuba,  Уже стоит. neofetch из bookworm :)

Udachnik

Какие исходники? Нужные версии gnome-shell и mutter собраны и находятся в experimental. Вполне нормальная практика для подобных обновлений. Только перед тем как ставить что-то оттуда стоит почитать как это делать правильно. Все же не зря репозиторий называется экспериментальным.

Whowka

Цитата: Udachnik от 07 сентября 2021, 16:22:18Только перед тем как ставить что-то оттуда стоит почитать как это делать правильно
ну вот в первом сообщении я указал инструкции, по которым действовал( других не нашёл, даже сейчас, спустя 5 дней. ) На данный момент, тренировался  на bullseye+sid+ experimental и на bookworm+sid+experimental. В обоих случаях, при подключениии  experimental  вылетала ошибка, как под 2-м спойлером. Я подписал вопрос ЧЯНТД. Уважаемый Udachnik,  Вы можете меня ткнуть носом в правильную инструкцию?