Ошибки при запуске snap

Автор Eyer, 16 сентября 2021, 15:52:26

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Eyer

Доброго дня.

Столкнулся с ошибками при запуске snap rambox.

note@debian:~$ sudo snap run rambox
[sudo] пароль для note:
WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement
mkdir: cannot create directory '/run/user/0': Permission denied
note@debian:~$

Debian Bullseye mate
Можно на ты

Eyer

Другой snap выдает одну из подобных ошибок, но запускается:


Открыть содержимое (спойлер)

note@debian $ snap run bitwarden
WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement
(node:23579) DeprecationWarning: file property is deprecated and will be removed in v5.
Error org.freedesktop.DBus.Error.Failed: cannot find desktop file "/var/lib/snapd/desktop/applications/bitwarden_Bitwarden.desktop"
(node:23579) electron: The default of contextIsolation is deprecated and will be changing from false to true in a future release of Electron.  See https://github.com/electron/electron/issues/23506 for more information
/usr/share/libdrm/amdgpu.ids: No such file or directory
si_init_perfcounters: max_sh_per_se = 2 not supported (inaccurate performance counters)
(node:23579) UnhandledPromiseRejectionWarning: TypeError: Cannot read property 'setContextMenu' of undefined
    at tray_main_TrayMain.updateContextMenu (/snap/bitwarden/55/resources/app.asar/main.js:2070:23)
    at messaging_main_MessagingMain.updateTrayMenu (/snap/bitwarden/55/resources/app.asar/main.js:1512:28)
    at messaging_main_MessagingMain.onMessage (/snap/bitwarden/55/resources/app.asar/main.js:1450:22)
    at messaging_main_MessagingMain.<anonymous> (/snap/bitwarden/55/resources/app.asar/main.js:1441:154)
    at Generator.next (<anonymous>)
    at /snap/bitwarden/55/resources/app.asar/main.js:1419:71
    at new Promise (<anonymous>)
    at messaging_main_awaiter (/snap/bitwarden/55/resources/app.asar/main.js:1415:12)
    at IpcMainImpl.<anonymous> (/snap/bitwarden/55/resources/app.asar/main.js:1441:82)
    at IpcMainImpl.emit (events.js:315:20)
(node:23579) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 1)
(node:23579) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
[свернуть]
Debian Bullseye mate
Можно на ты

dzhoser

#2
wget https://github.com/saenzramiro/rambox/releases/download/0.7.7/Rambox-0.7.7-linux-amd64.deb
sudo apt update
sudo apt install ./Rambox-0.7.7-linux-amd64.deb
Ну а snap я бы удалил

Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

Eyer

Спасибо, не знал, что он есть отдельным пакетом.

Цитата: dzhoser от 16 сентября 2021, 16:06:18sudo apt install ./Rambox-0.7.7-linux-amd64.deb

note@debian:~$ sudo apt install ./Rambox-0.7.7-linux-amd64.deb
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
Чтение информации о состоянии... Готово         
Заметьте, вместо «./Rambox-0.7.7-linux-amd64.deb» выбирается «rambox»
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
rambox : Зависит: libappindicator3-1 но он не может быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.


Через dpkg тоже не удаётся
note@debian:~$ sudo dpkg -i '/home/note/Rambox-0.7.7-linux-amd64.deb'
[sudo] пароль для note:
Выбор ранее не выбранного пакета rambox.
(Чтение базы данных ... на данный момент установлено 106733 файла и каталога.)
Подготовка к распаковке .../Rambox-0.7.7-linux-amd64.deb ...
Распаковывается rambox (0.7.7-182) ...
dpkg: зависимости пакетов не позволяют настроить пакет rambox:
rambox зависит от libappindicator3-1, однако:
  Пакет libappindicator3-1 не установлен.

dpkg: ошибка при обработке пакета rambox (--install):
проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.26-1) ...
Обрабатываются триггеры для mailcap (3.69) ...
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) ...
При обработке следующих пакетов произошли ошибки:
rambox



Debian Bullseye mate
Можно на ты

dzhoser

Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

Eyer

note@debian:~$ sudo apt install -f
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
Чтение информации о состоянии... Готово         
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
note@debian:~$ sudo apt install ./Rambox-0.7.7-linux-amd64.deb
Чтение списков пакетов... Готово
Построение дерева зависимостей... Готово
Чтение информации о состоянии... Готово         
Заметьте, вместо «./Rambox-0.7.7-linux-amd64.deb» выбирается «rambox»
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
rambox : Зависит: libappindicator3-1 но он не может быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
note@debian:~$
Debian Bullseye mate
Можно на ты

dzhoser

wget http://ftp.us.debian.org/debian/pool/main/libi/libindicator/libindicator3-7_0.5.0-4_amd64.deb
wget http://ftp.us.debian.org/debian/pool/main/liba/libappindicator/libappindicator3-1_0.4.92-7_amd64.deb
sudo apt install ./libindicator3-7_0.5.0-4_amd64.deb
sudo apt install ./libappindicator3-1_0.4.92-7_amd64.deb
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

Eyer

Debian Bullseye mate
Можно на ты

dzhoser

#8
Удалите snap :)он удлиняет загрузку, повышает права в песочнице (может выполнять обновление без уведомления пользователя. Именно из за этого его не включили в Linux Mint), занимает дольше места на диске чем стандартно установленные программы. Вобщем штука на мой взгляд не безопасная.
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

Eyer

Debian Bullseye mate
Можно на ты