Автор Тема: Глюки в приложениях в WM  (Прочитано 404 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ash

Глюки в приложениях в WM
« : 03 Ноября 2021, 16:44:32 »
Добрый день! Использую debian testing, icewm. Также установлены mate и xfce. В НЕКОТОРЫХ приложениях  появились непонятные глюки при открытии всплывающих окон, скороллинге: горизонтальные черточки, задержка ввода с клавиатуры (

* photo_2021-11-03_20-07-46.jpg (Filesize: 114.17 КБ, Dimensions: 960x1280)
) . Задержка на пару секунд.  Сделать снимок экрана не удаётся: как только окно становиться не активным, глюк пропадает. Наблюдается не во всех приложениях. Например: firefox, xpdf, texmaker, texstudio, octave, mendeley (пример на фото) - есть; xfce4-terminal, atril, chromium - всё нормально.  На машине стоит также mate. При работе в mate все эти приложения работают нормально.  Попробовал openbox и xfce. Результат тот же: глюки только в WM. Подскажите, пожалуйста, как это исправить.

 

Оффлайн dzhoser

Re: Глюки в приложениях в WM
« Ответ #1 : 03 Ноября 2021, 18:42:40 »
Видюшка Intel? Тesting это не стабильный дистрибутив там может и не работать! Возможно из за Wayland.
« Последнее редактирование: 03 Ноября 2021, 19:19:47 от dzhoser »
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков
 

Оффлайн ash

Re: Глюки в приложениях в WM
« Ответ #2 : 03 Ноября 2021, 21:45:06 »
Спасибо!  Да: UHD Graphics 630. Всё работало до apt update/upgrade:
Spoiler: ShowHide

Aptitude 0.8.13: log report Mon, Nov  1 2021 14:09:08 +0700

[REMOVE, NOT USED] libllvm11:i386 1:11.1.0-4
[REMOVE, NOT USED] pipewire-media-session:amd64 0.3.38-2
[HOLD, DEPENDENCIES] gcc-9-base:i386 9.2.1-25
[INSTALL, DEPENDENCIES] libjemalloc2:amd64 5.2.1-4
[INSTALL, DEPENDENCIES] libllvm12:amd64 1:12.0.1-16
[INSTALL, DEPENDENCIES] libllvm12:i386 1:12.0.1-16
[UPGRADE] bind9-host:amd64 1:9.16.21-1 -> 1:9.17.19-1
[UPGRADE] bind9-libs:amd64 1:9.16.21-1 -> 1:9.17.19-1
[UPGRADE] dash:amd64 0.5.11+git20210120+802ebd4-2 -> 0.5.11+git20210903+057cd650a4ed-1
[UPGRADE] ffmpeg:amd64 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] geany:amd64 1.37.1-3 -> 1.38-1
[UPGRADE] geany-common:amd64 1.37.1-3 -> 1.38-1
[UPGRADE] geany-plugin-shiftcolumn:amd64 1.37+dfsg-6 -> 1.38+dfsg-1
[UPGRADE] geany-plugin-spellcheck:amd64 1.37+dfsg-6 -> 1.38+dfsg-1
[UPGRADE] geany-plugin-tableconvert:amd64 1.37+dfsg-6 -> 1.38+dfsg-1
[UPGRADE] geany-plugins-common:amd64 1.37+dfsg-6 -> 1.38+dfsg-1
[UPGRADE] graphviz:amd64 2.42.2-5 -> 2.42.2-5+b1
[UPGRADE] hunspell-en-us:amd64 1:2019.10.06-1 -> 1:2020.12.07-1
[UPGRADE] libaom0:amd64 1.0.0.errata1-3 -> 1.0.0.errata1.ds-1
[UPGRADE] libavcodec58:amd64 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] libavcodec58:i386 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] libavdevice58:amd64 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] libavfilter7:amd64 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] libavformat58:amd64 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] libavutil56:amd64 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] libavutil56:i386 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] libbotan-2-18:amd64 2.18.1+dfsg-3 -> 2.18.2+dfsg-1
[UPGRADE] libcdt5:amd64 2.42.2-5 -> 2.42.2-5+b1
[UPGRADE] libcgraph6:amd64 2.42.2-5 -> 2.42.2-5+b1
[UPGRADE] libdouble-conversion3:amd64 3.1.5-6.1 -> 3.1.5-7
[UPGRADE] libegl-mesa0:amd64 20.3.5-1 -> 21.2.4-1
[UPGRADE] libegl1-mesa:amd64 20.3.5-1 -> 21.2.4-1
[UPGRADE] libexpat1:amd64 2.4.1-2+b1 -> 2.4.1-3
[UPGRADE] libexpat1:i386 2.4.1-2+b1 -> 2.4.1-3
[UPGRADE] libgbm1:amd64 20.3.5-1 -> 21.2.4-1
[UPGRADE] libgbm1:i386 20.3.5-1 -> 21.2.4-1
[UPGRADE] libgl1-mesa-dri:amd64 20.3.5-1 -> 21.2.4-1
[UPGRADE] libgl1-mesa-dri:i386 20.3.5-1 -> 21.2.4-1
[UPGRADE] libgl1-mesa-glx:amd64 20.3.5-1 -> 21.2.4-1
[UPGRADE] libglapi-mesa:amd64 20.3.5-1 -> 21.2.4-1
[UPGRADE] libglapi-mesa:i386 20.3.5-1 -> 21.2.4-1
[UPGRADE] libglib2.0-0:amd64 2.70.0-1+b1 -> 2.70.0-3
[UPGRADE] libglib2.0-0:i386 2.70.0-1+b1 -> 2.70.0-3
[UPGRADE] libglib2.0-bin:amd64 2.70.0-1+b1 -> 2.70.0-3
[UPGRADE] libglib2.0-data:amd64 2.70.0-1 -> 2.70.0-3
[UPGRADE] libglx-mesa0:amd64 20.3.5-1 -> 21.2.4-1
[UPGRADE] libglx-mesa0:i386 20.3.5-1 -> 21.2.4-1
[UPGRADE] libgvc6:amd64 2.42.2-5 -> 2.42.2-5+b1
[UPGRADE] libgvpr2:amd64 2.42.2-5 -> 2.42.2-5+b1
[UPGRADE] liblab-gamut1:amd64 2.42.2-5 -> 2.42.2-5+b1
[UPGRADE] libmarisa0:amd64 0.2.6-7 -> 0.2.6-7+b1
[UPGRADE] libnss-mdns:amd64 0.14.1-2 -> 0.15.1-1
[UPGRADE] libopenblas0:amd64 0.3.18+ds-1 -> 0.3.18+ds-2
[UPGRADE] libopenblas0-pthread:amd64 0.3.18+ds-1 -> 0.3.18+ds-2
[UPGRADE] libosmesa6:i386 20.3.5-1 -> 21.2.4-1
[UPGRADE] libpathplan4:amd64 2.42.2-5 -> 2.42.2-5+b1
[UPGRADE] libpipewire-0.3-0:amd64 0.3.38-2 -> 0.3.39-3
[UPGRADE] libpipewire-0.3-common:amd64 0.3.38-2 -> 0.3.39-3
[UPGRADE] libpipewire-0.3-modules:amd64 0.3.38-2 -> 0.3.39-3
[UPGRADE] libpostproc55:amd64 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] libprotobuf-lite23:amd64 3.12.4-1 -> 3.12.4-1+b1
[UPGRADE] libqt5webengine5:amd64 5.15.6+dfsg-2 -> 5.15.6+dfsg-2+b1
[UPGRADE] libqt5webenginecore5:amd64 5.15.6+dfsg-2 -> 5.15.6+dfsg-2+b1
[UPGRADE] libqt5webenginewidgets5:amd64 5.15.6+dfsg-2 -> 5.15.6+dfsg-2+b1
[UPGRADE] libselinux1:amd64 3.1-3 -> 3.1-3+b1
[UPGRADE] libselinux1:i386 3.1-3 -> 3.1-3+b1
[UPGRADE] libspa-0.2-modules:amd64 0.3.38-2 -> 0.3.39-3
[UPGRADE] libswresample3:amd64 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] libswresample3:i386 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] libswscale5:amd64 10:4.4-dmo6 -> 10:4.4.1-dmo1
[UPGRADE] libv4l-0:amd64 1.20.0-4 -> 1.22.1-2
[UPGRADE] libv4l-0:i386 1.20.0-4 -> 1.22.1-2
[UPGRADE] libv4lconvert0:amd64 1.20.0-4 -> 1.22.1-2
[UPGRADE] libv4lconvert0:i386 1.20.0-4 -> 1.22.1-2
[UPGRADE] libwacom-bin:amd64 1.11-1 -> 1.12-1
[UPGRADE] libwacom-common:amd64 1.11-1 -> 1.12-1
[UPGRADE] libwacom2:amd64 1.11-1 -> 1.12-1
[UPGRADE] libwww-perl:amd64 6.57-1 -> 6.58-1
[UPGRADE] libxatracker2:amd64 20.3.5-1 -> 21.2.4-1
[UPGRADE] mesa-va-drivers:amd64 20.3.5-1 -> 21.2.4-1
[UPGRADE] mesa-va-drivers:i386 20.3.5-1 -> 21.2.4-1
[UPGRADE] mesa-vdpau-drivers:amd64 20.3.5-1 -> 21.2.4-1
[UPGRADE] mesa-vdpau-drivers:i386 20.3.5-1 -> 21.2.4-1
[UPGRADE] pipewire:amd64 0.3.38-2 -> 0.3.39-3
[UPGRADE] pipewire-bin:amd64 0.3.38-2 -> 0.3.39-3
[UPGRADE] printer-driver-indexbraille:amd64 1.2.3-3 -> 1.2.3-4
[UPGRADE] python3-zeroconf:amd64 0.36.8-1 -> 0.36.9-1
[UPGRADE] tzdata:amd64 2021d-1 -> 2021e-1
[UPGRADE] wamerican:amd64 2019.10.06-1 -> 2020.12.07-1
[UPGRADE] x11-xserver-utils:amd64 7.7+8 -> 7.7+9
[UPGRADE] xserver-xorg-input-libinput:amd64 1.1.0-1 -> 1.2.0-1
 

Оффлайн dzhoser

Re: Глюки в приложениях в WM
« Ответ #3 : 03 Ноября 2021, 22:16:08 »
В файле sudo nano etc/X11/xorg.conf.d/20-intel.conf в открывшемся файле замените sna на uxa или glamor
Пример
Цитировать
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
EndSection
Цитировать
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection
Сохраните изменения CTRL+O,  Y, Enter
sudo reboot
« Последнее редактирование: 03 Ноября 2021, 22:18:39 от dzhoser »
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков
 

Оффлайн ash

Re: Глюки в приложениях в WM
« Ответ #4 : 03 Ноября 2021, 22:29:34 »
Спасибо! Пробую.
 

Оффлайн dzhoser

Re: Глюки в приложениях в WM
« Ответ #5 : 04 Ноября 2021, 11:03:01 »
Помогло?
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков
 

Оффлайн ash

Re: Глюки в приложениях в WM
« Ответ #6 : 04 Ноября 2021, 14:17:27 »
Большое спасибо! Первый же вариант с "uxa" сработал. В xorg.conf.d было пусто, создал 20-intel.conf из 5 строк, указанных Вами. Проблема решена. Спасибо!
 

Оффлайн ash

Re: Глюки в приложениях в WM
« Ответ #7 : 04 Ноября 2021, 17:46:55 »
Поторопился с uxa.  При изменении колесом мыши масштаба в lowriter icewm вылетал
Цитировать
Не удалось подключиться к менеджеру сессий: Не удалось подключиться к менеджеру сеансов: SESSION_MANAGER environment variable not defined
X connection to :0 broken (explicit kill or server shutdown).
X connection to :0 broken (explicit kill or server shutdown).
.
С другими приложениями такого не было. Заменил uxa на glamor, проблемы исчезли.
 

Теги:
 

Openbox+tint2 - глюки окон и самой панели

Автор Vic

Ответов: 10
Просмотров: 4555
Последний ответ 09 Сентября 2012, 10:34:35
от Vic