Проблема установки 9.11.0 на сокет 1200

Автор Graversss13, 24 ноября 2021, 15:26:31

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Graversss13

Подскажите пожалуйста, есть такая проблема, купил новый комп на нем новое поколение сокетов lga1200. Комп брал работодатель для работы! на него принципиально надо установить 9.11.0 версию что бы работала нужная программа! При попытке установить. Зависает после нажатия на "график инстал" да вообще на любой инстал жмешь и зависание тут же! На других машинах с более старыми поколениями сокетов типо 1151 итд, все ставиться на раз два! Пробовал астра линукс, та же беда, пробовал брать м2 накапитель и ставить в комп с другим железом, накатывать и возвращать в тот. Загрузка идет но после выбора рабочего стола, при попытке подгрузить разделы снова полное зависание! Есть подозрения что это либо проблема с совместимостью дров, либо с совместимостью в целом всей системы! Т.К этот сокет последнего поколения! Если кто то сталкивался с такой проблемой или же знает о том что это не совместимо, дайте знать пжл, а то всю голову сломал!

ferum

Не стоит ломать голову, ваша хотелка не выполнима. так как debian 9 разрабатывался за долго до появления вашего железа.
Думайте в сторону работы нужной программы на чём то другом, если это open source возможно пробовать собрать под что то другое.
Русские дебианщики против цифрового слабоумия !

Graversss13

Спасибо, я так и думал! Проблема в том что это программа для гос. организаций и прет она ток на 9 версии дебиана! Придется скорее думать на счет другого железа которое будет совместимо с данным релизом ОС

ferum

Цитата: Graversss13 от 24 ноября 2021, 15:50:51Проблема в том что это программа для гос. организаций
Не сложно было догадаться, раз был интерес к astra linux. 
Русские дебианщики против цифрового слабоумия !

dzhoser

Про какую версию astra linux идёт речь?
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

Graversss13

orel-2.12.43-14.09.2021_10.29 при установке данной ОС так же зависает при выборе инсталера!

ferum

Выскажу личное мнение по проблеме и возможному способу её решения. Оно ни в коем случае не является надёжным руководством к действию и если вы не понимаете о чём идёт речь. лучше забейте.
1) Ставим любой debian based дистрибутив, который встанет на ваш компьютер но желательно старее ( из за приложения ). Предпочтительнее debian 10, debian 11, ubuntu 21.04.
2) Берём deb пакет с вашей программой, распаковываем его и смотрим /debian/control находим зависимости которые не позволяют его установить, записываем имена и версии этих пакетов. Далее правим зависимости что бы соответствовали установленному дистрибутиву и собираем пакет заново.
за одно в разобранном пакете смотрим расположение исполняемого бинарника и его название ( варианты /usr/bin , /usr/local/bin , /opt/.../ )  или если найдёте файл .... .desktop посмотреть в нём команду на запуск приложения!
3) Устанавливаем пакет в систему и вручную ставим неудовлетворённые зависимости.
sudo dpkg -i *.deb # находясь в каталоге где лежит пакет
sudo apt -f install

4) Пробуем запустить приложение командой в терминале. Тут может быть успех или напротив ругань на библиотеку, то есть её отсутствие.
5) Если отсутствует необходимая библиотека ( может и несколько ) добываем их из пакетов от debian 9 или подходящих версий ubuntu и через midnight cmd толкаем их в систему ( но только с полным пониманием процесса) каждый раз пробуя запустить  приложение из терминала.
Вероятность успеха 50/50.  Если будете рассматривать этот вариант, что бы не убивать напрасно время, начните с распаковки пакета программы на любом установленном linux дистрибутиве. Изучив устройство пакета можно более или менее прикинуть шансы.
Русские дебианщики против цифрового слабоумия !

Aalexeey

Цитата: ferum от 24 ноября 2021, 16:54:51Берём deb пакет с вашей программой, распаковываем его и смотрим
Добавлю пересобрать пакет можно deb_Repacker'ом отсюда https://debianforum.ru/index.php/topic,9141.msg74708.html#msg74708
Вероятность что программа после правки зависимостей запустится высокая.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"

ChubaDuba

#8
Цитата: Graversss13 от 24 ноября 2021, 15:26:31...что бы работала нужная программа...
Нужно выяснить почему ей нужен Debian 9. Вполне вероятно может не работать по этой причине.
Если дело в Qt4, то посмотрите в сторону Ubuntu 20.04LTS. Для неё есть отдельный ppa с Qt4.
Бλог   @chuba_duba

Aalexeey

Цитата: ChubaDuba от 25 ноября 2021, 12:09:32Ubuntu 20.04LTS. Для неё есть отдельный ppa с Qt4
То есть можно этот QT4 оттедава взять и легко и непринуждённо пересобрать в Debian который без QT4? Этож не исходники ворочать.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"

ChubaDuba

Цитата: Aalexeey от 25 ноября 2021, 17:16:44ворочать
Сначала нужно выяснить чего не хватает программе...
Бλог   @chuba_duba

Aalexeey

Цитата: ChubaDuba от 25 ноября 2021, 18:25:21Сначала нужно выяснить чего не хватает программе...
Я не про программу а про перспективу, нарисовался потенциальный выход с положения. Много всего есть на QT4 расставаться с этим совсем не хочется.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"

ChubaDuba

Цитата: Aalexeey от 25 ноября 2021, 17:16:44легко и непринуждённо пересобрать в Debian который без QT4
Вообще не уверен, что это осуществимо, тем более легко и непринуждённо.
Бλог   @chuba_duba

Aalexeey

Цитата: ChubaDuba от 25 ноября 2021, 18:47:55Вообще не уверен, что это осуществимо, тем более легко и непринуждённо.
Ну вот так https://zenway.ru/page/debperesborka я до сих пор это делал, брал из Ubuntu PPA и пересобирал под Debian/Devuan, как правило никаких проблем не возникает.
https://debianforum.ru/index.php?topic=6879 100% защиты от "Ааааа у меня всё поломалось"

ChubaDuba

Цитата: Aalexeey от 25 ноября 2021, 18:54:34Ну вот так https://zenway.ru/page/debperesborka я до сих пор это делал, брал из Ubuntu PPA и пересобирал под Debian/Devuan

Цитировать
Сопровождение устаревшей ветки Qt 4, финальный выпуск которой был сформирован в мае 2015 года, вызывает определённые трудности. Первые попытки удаления Qt 4 из Debian отмечены ещё при подготовке Debian 9, но библиотека была оставлена в составе дистрибутива, а её сопровождение ограничено устранением критических проблем. Теперь возникли проблемы другого плана - для поддержки новых версий некоторых библиотек требуется внесение существенных изменений в Qt 4, поэтому проще вообще удалить из Qt 4 связанные с данными библиотеками подсистемы. Например, для обеспечения совместимости с OpenSSL 1.1 разработчики столкнулись с необходимостью применения непротестированных патчей, а для поддержки выпусков новее OpenSSL 1.1 остаётся только удалить из Qt 4 поддержку SSL. Аналогичная проблема наблюдается с поддержкой в Qt 4 движка WebKit.
Бλог   @chuba_duba