Chromium: ошибка нарушения конфиденциальности

Автор Листик, 02 декабря 2021, 22:54:13

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Листик

Привет! После очередного обновления сегодня перестали открываться многие сайты в Chromium: ошибка нарушения конфиденциальности, подключение не защищено, NET::ERR_CERT_IVALID
Главное, нет опции "принять риск и продолжить" или что-то в этом роде.
Что делать, подскажите? Как отключить эту проверку, например?

Как вариант, думаю откатить пакет libnss3 (его обновил сегодня, но при удалении он тащит полсистемы с собой) таким способом:

# dpkg -P --force-all libnss3
# apt-get install libnss3=2:3.26.2-1.1+deb9u1


Но не пропадет ли сеть? То есть старый удалится, а новый поставить просто не смогу.

Листик

Сколько ответов! -)

Рискнул - удалил libnss3 и установил предыдущую версию указанным способом. Помогло.

Но все же интересно, почему просроченные сертификаты даже у таких сайтов, как bbc.com?

ogost

Очень сильно сомневаюсь, что у bbc протухшие сертификаты. Тем более, что у меня оно норм открывется.

Листик

ogost,

А в чем же тогда дело может быть?

Вот тут нашел похожую проблему.

https://forum.altlinux.org/index.php?topic=32230.msg278956#msg278956


Листик

На Firefox тоже нормально открывалось, даже после обновления. Но Chromium - единственный браузер, на котором у меня видео без тормозов идут, bbc, youtube и т.п.

ogost

это у вас 9ый дебиан?
у меня 10ый и версия 2:3.61-1, всё норм открывается и в хромиуме, и в других браузерах.

Листик

ogost,

Да, девятка. Chromium version: 73.0.3683.75-1~deb9u1.

Сейчас и в Chromium все работает, после замены более нового пакета (libnss3) на предыдущую версию. Просто интересны причины.

Листик

#7
Хм, вообще мистика какая-то началась. Проверил обновления - все установлены.

dpkg -s libnss3
Package: libnss3
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 4056
Maintainer: Maintainers of Mozilla-related packages <pkg-mozilla-maintainers@lists.alioth.debian.org>
Architecture: i386
Multi-Arch: same
Source: nss
Version: 2:3.26.2-1.1+deb9u3


Хотя вчера его удалил и ничего больше не обновлял. Но по-прежнему все работает на Chromium. И снова проблема с сертификатами. Ничего не понимаю.

Листик

Проделал вчерашнюю манипуляцию, снова все работает.

dpkg -s libnss3
Package: libnss3
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 3847
Maintainer: Maintainers of Mozilla-related packages <pkg-mozilla-maintainers@lists.alioth.debian.org>
Architecture: i386
Multi-Arch: same
Source: nss
Version: 2:3.26.2-1.1+deb9u1
Depends: libc6 (>= 2.4), libnspr4 (>= 2:4.12), libsqlite3-0 (>= 3.5.9), zlib1g (>= 1:1.1.4)
Conflicts: libnss3-1d (<< 2:3.13.4-2)
Description: Network Security Service libraries
This is a set of libraries designed to support cross-platform development
of security-enabled client and server applications. It can support SSLv2
and  v4, TLS, PKCS #5, #7, #11, #12, S/MIME, X.509 v3 certificates and
other security standards.
Homepage: http://www.mozilla.org/projects/security/pki/nss/


Но не хотелось бы после каждой перезагрузки компа такое повторять.

dzhoser

Скорее всего дата слетела, потом засинхрилась.
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

Листик

Цитата: dzhoser от 03 декабря 2021, 12:27:02Скорее всего дата слетела, потом засинхрилась.

И из-за этого мог пакет сам обновиться?

Как бы то ни было, после новой перезагрузки остался libnss3 предыдущей версии, больше ничего не менялось. Поэтому считаю, что проблема решена.

yoric

А потому что обновляться надо своевременно, а не сидеть на устаревшем ПО. Я так думаю))

dzhoser

Цитата: Листик от 04 декабря 2021, 06:40:07И из-за этого мог пакет сам обновиться?
Пакет сам обновится не мог, а вот сертификаты не работать из за неправильной даты вполне.
Ubuntu->Linux mint->Astra Linux SE->Debian 11
Для новичков

ChubaDuba

Цитата: Листик от 03 декабря 2021, 10:31:56Да, девятка. Chromium version: 73.0.3683.75-1~deb9u1
Всё работает, тоже сижу  на 9-ке.

Листик

Цитата: dzhoser от 04 декабря 2021, 07:46:56Пакет сам обновится не мог, а вот сертификаты не работать из за неправильной даты вполне.

Так у меня обновился. Я же написал: установил версию 2:3.26.2-1.1+deb9u1, а после перезагрузки снова оказалась установлена версия 2:3.26.2-1.1+deb9u3.

Сейчас вот, кстати, опять, перезагрузил комп - версия 2:3.26.2-1.1+deb9u3. Хотя после предпоследней перезагрузки была версия 2:3.26.2-1.1+deb9u1.