Alien Arena 7.53

Автор jakson, 19 января 2012, 21:06:19

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

jakson

В инструкции написано
$ ./configure
$ make
$ sudo make install

Выполнение ./configure заканчивается фэйлом и команда make не найдена.
jakson@debian:~/alienarena-7.53$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... no
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... Invalid configuration `i686-pc-linux-': machine `i686-pc-linux' not recognized
configure: error: /bin/bash config/config.sub i686-pc-linux- failed
jakson@debian:~/alienarena-7.53$ make
bash: make: команда не найдена


ihammers

#1
Цитата: jakson от 19 января 2012, 21:06:19
...
checking for gawk... no
checking whether make sets $(MAKE)... no
...
bash: make: команда не найдена



Проверьте наличие таких программ как: gawk и make.  Возможно придётся доставлять и другие пакеты.

PS: также стоит обратить внимание на создание .deb пакета с помощью CheckInstall, или с помощью других методов.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

saint-denis

я бы не маялся дурью и нашел бы deb-пакеты.

jakson

#3
Цитата: ihammers от 19 января 2012, 21:35:23Проверьте наличие таких программ как: gawk и make.
Действительно, их нет у меня в системе.  А как такое возможно? Я думал они идут с "коробки" или их после установки дебиана надо самому ставить?
Цитата: saint-denis от 19 января 2012, 22:07:15я бы не маялся дурью и нашел бы deb-пакеты.
Ну, во-первых, люблю качать с оф сайтов, во-вторых, не получиться поставить найду деб или apt-get install alien-arena

Сообщение объединено: 19 января 2012, 22:51:34

Теперь вот это
jakson@debian:~/alienarena-7.53$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... Invalid configuration `i686-pc-linux-': machine `i686-pc-linux' not recognized
configure: error: /bin/bash config/config.sub i686-pc-linux- failed
jakson@debian:~/alienarena-7.53$ make
make: *** Не заданы цели и не найден make-файл.  Останов.

ihammers

#4
Цитата: jakson от 19 января 2012, 22:46:50
Цитата: ihammers от 19 января 2012, 21:35:23Проверьте наличие таких программ как: gawk и make.
Действительно, их нет у меня в системе.  А как такое возможно? Я думал они идут с "коробки" или их после установки дебиана надо самому ставить?
...

Сообщение объединено: 19 января 2012, 22:51:34

Теперь вот это
...
Да, так как эти пакеты "не обязательные" для системы, они (программы) в частности make для сборки программ.  А gawk -- pattern scanning and processing language.

PS: щас скачаются и я посмотрю что ещё нужно доставить.

Проверьте следующие пакеты:

dpkg -l | grep gcc
dpkg -l | grep g++
dpkg -l | grep libopenal-dev
dpkg -l | grep libfreetype6-dev
dpkg -l | grep libogg-dev
dpkg -l | grep libvorbis-dev


Возможно потребуются и другие пакеты.
Открыть содержимое (спойлер)

If the installation fails, check the error message for required
software packages that may be missing.  Alien Arena uses: X11,
OpenGL, OpenAL 1.1, Ogg-Vorbis, cURL, FreeType2, and JPEG.  Some
major distributions have "dev" versions of the libraries that are
needed to build programs.  These are not installed by default, so
you may need to install them using your distributions package
manager.  Version 7.53 does not require the ODE library (it is
integrated).  There is a configure option to use the system ODE
library (see below.)
[свернуть]

PS: для сборки из исходников требуется большое количество dev-пакетов:)
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

jakson

#5
g++ не хочет ставиться
root@debian:/home/jakson# apt-get install g++
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
g++ : Зависит: g++-4.4 (>= 4.4.5-1~) но он не будет установлен
E: Сломанные пакеты

ihammers

Открыть содержимое (спойлер)
Цитата: jakson от 19 января 2012, 23:33:05
g++ не хочет ставиться
root@debian:/home/jakson# apt-get install g++
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
g++ : Зависит: g++-4.4 (>= 4.4.5-1~) но он не будет установлен
E: Сломанные пакеты

Проверьте /etc/apt/sources.list. 
А также посмотрите другие версии gcc и g++ (apt-cache search gcc-4.5 (или 4.6), для g++ аналогично)
[свернуть]
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

jakson

Всё, я понял ему надо g++-4.4, я думал это версия пакета g++, а окалазалось это отдельный пакет, недосмотрел. А  g++-4.4 надо libstdc++6-4.4-dev, а ему надо ещё штук 6 файлов, неизвестно сколько надо будет потом, в общем лучше установить из репозитория с помощью apt-get install alien-arena, пусть сам тащит, что ему надо :)