ad-hoc winXP - Debian Squeeze

Автор razval, 20 января 2012, 02:44:28

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

razval

имеем две машины winXP & debian Squeeze, нужно с winXp брать инет по wifi на debSq
winXP: настроен интернет по lan и настроена точка доступа wifi (средством интегрированного адаптера)
debianSq: драйвер на адаптер настроен,
при команде iwlist wlan0 scan, находит требуемую точку.
wpasupplicant.conf прописаны essid и psk.
при запросе команды iwconf wlan0 выдает параметры и в строчке ESSID "name", пишет нашу точку подключения но связи нет.
что еще требуется указать, все настройки ведутся с консоли.

ihammers

Цитата: razval от 20 января 2012, 02:44:28
имеем две машины winXP & debian Squeeze, нужно с winXp брать инет по wifi на debSq
winXP: настроен интернет по lan и настроена точка доступа wifi (средством интегрированного адаптера)
debianSq: драйвер на адаптер настроен,
при команде iwlist wlan0 scan, находит требуемую точку.
wpasupplicant.conf прописаны essid и psk.
при запросе команды iwconf wlan0 выдает параметры и в строчке ESSID "name", пишет нашу точку подключения но связи нет.
что еще требуется указать, все настройки ведутся с консоли.
Связи нет с глобом или между машинами? 
Если с глобом, то нужно настроить проброс адресов NAT на win-машине, что выходит за рамки данного форума. 
А если между машинами, то команды в студию, которые вы используете.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

razval

по ходу связи нету между машинами, т.к карточку в debSq не могу перевести в режим ad-hoc, вылетает ошибка:
Error for wireless request "Set Mode" (8B06) :
     SET failed on device wlano ; Operation not supported.

з.ы. читал что, нужно установить пакет madwifi-tools, его нет ни в одном репозитории.

ihammers

#3
Цитата: razval от 20 января 2012, 17:03:07
по ходу связи нету между машинами, т.к карточку в debSq не могу перевести в режим ad-hoc, вылетает ошибка:
Error for wireless request "Set Mode" (8B06) :
     SET failed on device wlano ; Operation not supported.

з.ы. читал что, нужно установить пакет madwifi-tools, его нет ни в одном репозитории.
А где список команд, которые используете?
Пробовали следующий способ:

# ifconfig wlan0 down
# iwconfig wlan0 channel 1 essid MYNETWORK mode ad-hoc
# ifconfig wlan0 up


В студию:
lspci -nn | grep Network

PS: MadWifi -- (Multiband Atheros Driver for Wireless Fidelity), для Atheros AR5xxx PCI/PCI-E devices.  Доступен для Debian Lenny пакет madwifi-source.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

razval

#4
lspci -nn | grep Network
5:00.0 Network controller [0280] : Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

после ввода команды
# iwconfig wlan0 channel 1 essid MYNETWORK mode ad-hoc
показывает:
Error for wireless request "Set Mode" (8B06) :
     SET failed on device wlan0 ; Operation not supported.


пользуюсь командами утилиты iwconfig.

вообщем на winXP у меня настройка Ad-Hoc и debSq видит её.
вывод команды:
# iwconfig wlan0
wlan0    IEEE 802.11bgn ESSID:"wifilan"
            Mode:Managed Frequency:2.442 GHz Acces Point: Not-Associated
            ...

Mode:Managed ,здесь ведь должен быть Ad-Hoc?

Metrix

Цитата: razval от 20 января 2012, 19:33:13Mode:Managed ,здесь ведь должен быть Ad-Hoc?
Вроде как Master, если не ошибаюсь
Юзербар в отпуске

razval

#6
ЦитироватьВроде как Master, если не ошибаюсь
не переходит, аналогичная ошибка


Сообщение объединено: 21 января 2012, 23:27:07

может быть драйвер не поддерживает ad-hoc?