Не работают наушники

Автор stanis-morozov, 05 февраля 2012, 14:59:16

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

stanis-morozov

Добрый день!
При воспроизведении музыки или видео в системе звука в наушниках нет, хотя сама система их видит и звук по сути на них подавать умеет. В состоянии показанном во вложении звук в наушниках есть. Нажимаю на кнопку "Закрыть" и ничего не слышно при воспроизведении музыки. Звук для этого устройства стоит на максимуме. Очень прошу помочь решить данную проблему. Заранее благодарен!
  •  

vavun

У вас установлен gnome-alsamixer ? Если нет, то установите и проверьте вот эти два пункта

По умолчанию там выставлен минимум, может в этом дело.

Do you know why we call this beta ? Because it's betta than nothing.©
Have problems with windows, reboot. Have problems with linux, be root.©
  •  

stanis-morozov

gnome-alsamixer не стоял, я поставил, но эти 2 пункта не появились. Дело в том, что у меня эти наушники подключены по USB. Предыдущие были не по USB и звук отлично работал...Может в этом дело? И у меня в регуляторе громкости есть раздел отдельный для моих наушников.
  •  

vavun

#3
Про USB сразу не заметил
а вообще поищите на http://www.alsa-project.org/.
а я пока отправился в google

Сообщение объединено: 05 февраля 2012, 20:30:44

http://alsa.opensrc.org/Usb-audio

Do you know why we call this beta ? Because it's betta than nothing.©
Have problems with windows, reboot. Have problems with linux, be root.©
  •  

vladimir_ar

В параметрах больше никаких органов управления нельзя включить?
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

stanis-morozov

  •  

vladimir_ar

В плеере (плеерах) что стоит в качестве устройства вывода?
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

stanis-morozov

А где это можно посмотреть? Видеопроигрыватель Totem.
  •  

vladimir_ar

Попробуйте другой плеер - например, smplayer
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

stanis-morozov

Я поставил SMplayer, но в нем все равно звук не работает. А как в SMplayer можно поменять устройство вывода?
  •  

vladimir_ar

В параметрах, вкладка Аудио.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

stanis-morozov

Ура! Заработало! Спасибо большое!
Но вот еще такой вопросик...у меня работает звук, но только если я запускаю его в SMplayer. А как поменять устройство вывода например в браузере, или сделать, чтобы мои наушники были устройством по умолчанию?
  •  

vladimir_ar

Вообще через gstreamer-properties. Но, если у вас наушники не всегда подключены, то по умолчанию подхватит первую в конфигах алса. Вообще можно в каталоге алса создать файл soundcardorder и в нем прописать порядок карт. Где создать и что написать - на память не помню, найду - чуть позже отвечу (или из дому вечером). Или в google по словам "linux soundcardorder" поищите.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

stanis-morozov

Но у меня в gstreamer-properties установлены наушники USB, какие мне и нужны, и наушники я не отключаю, но все равно приходится каждой программе показывать куда воспроизводить...Так и должно быть?
И клавиши для увеличение/уменьшения громкости на клавиатуре все равно для другого, не подключенного устройства звук регулируют :'(
  •  

vladimir_ar

#14
У меня тоже без насилия мою ASUS-Xonar не хочет по умолчанию, все норовит HDMI впихнуть.
Идем сюда (http://linuxforum.ru/viewtopic.php?id=143) и читаем.
У меня так сделано - и карта всегда на месте.

ЦитироватьИ не ленитесь гуглить - первая ссылка

Сообщение объединено: 06 февраля 2012, 23:43:57

А про клавиши разговор отдельный - я так и не смог переназначить их на нужную мне карту. Т.е. если карта при установке определяется корректно (например, в тестинге моя звуковая уже детектится), то с этим проблем нет. Если же не свезло (алса в сквиз не видит мою звуковую) - медиаклавиши цепляются к обнаруженному по умолчанию. И все. Много копал нет - не нашел. Поставил volti, отключил в гноме меди-клавиши управления громкостью и доволен.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •