[РЕШЕНО] Японская раскладка + KDE

Автор elivin, 15 февраля 2012, 20:27:52

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

elivin

?????
Решился таки установить кеды. Но возникла такая проблема - не могу писать на японском в qt-приложениях. В gtk-шных работает при помощи iBus. В частности сейчас пишу в Iceweasel. В нём всё работает. Однако, каждый раз в нём писать и копировать в тот же Kopete как-то надоедает. Пол гугла уже обшарил - бесполезно. Может здесь найдутся люди, которые смогут подсказать?
P.S. ibus-qt4 установлен
Заранее, ??????????

ihammers

Цитата: elivin от 15 февраля 2012, 20:27:52
?????
Решился таки установить кеды. Но возникла такая проблема - не могу писать на японском в qt-приложениях. В gtk-шных работает при помощи iBus. В частности сейчас пишу в Iceweasel. В нём всё работает. Однако, каждый раз в нём писать и копировать в тот же Kopete как-то надоедает. Пол гугла уже обшарил - бесполезно. Может здесь найдутся люди, которые смогут подсказать?
P.S. ibus-qt4 установлен
Заранее, ??????????
Хоть и не использую KDE, но попытаюсь помочь с проблемой.  Какие пакеты ibus установлены?

У меня в goldendict нормально работает.  В качестве ввода использовал "Японский -- Anthy".
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

elivin

Цитата: ihammersКакие пакеты ibus установлены?
И нужные, и не нужные:
Открыть содержимое (спойлер)

# aptitude search ~iibus
i   ibus                                  - New input method framework using dbus         
i   ibus-anthy                            - anthy engine for IBus                         
i   ibus-gtk                              - New input method framework using dbus         
i   ibus-m17n                             - m17n engine for IBus                           
i   ibus-qt4                              - qt-immodule for ibus (QT4)                     
i   ibus-skk                              - SKK engine for IBus                           
i A libibus-qt1                           - qt-immodule for ibus (QT4)                     
i A libibus2                              - New input method framework using dbus         
i   libusb-0.1-4                          - userspace USB programming library             
i A libusb-1.0-0                          - userspace USB programming library             
i   plasma-widget-kimpanel-backend-ibus   - addons for KDE 4 Plasma - universal input metho
i A python-ibus                           - New input method framework using dbus
[свернуть]
Кстати, хоть plasma-widget-kimpanel-backend-ibus установлен, виджета не нашёл.
Цитата: ihammersВ качестве ввода использовал "Японский -- Anthy".
Я тоже. Под гномом всё вроде нормально работало, но тогда не пользовался приложениями с qt.

Brainey

Как вариант, для записи можно использовать этот плазмоид.


Сообщение объединено: 16 февраля 2012, 12:35:35

Сам не пробовал, но мне говорили, что ibus все же работал, но вроде нужно добавить в автозапуск то ли его самого, то ли что-то из его пакетов. Сейчас уже точно не помню.
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru

ihammers

Цитата: elivin от 16 февраля 2012, 09:03:38
Цитата: ihammersКакие пакеты ibus установлены?
И нужные, и не нужные:
...
Цитата: ihammersВ качестве ввода использовал "Японский -- Anthy".
Я тоже. Под гномом всё вроде нормально работало, но тогда не пользовался приложениями с qt.
У меня практически такие же пакеты.  Проверял под fxce4 & openbox.

PS: попробую под виртуалкой проверить.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

elivin

Цитата: Brainey от 16 февраля 2012, 12:34:36
Как вариант, для записи можно использовать этот плазмоид.
Плазмоид не устанавливается. Да и особо не вижу потребности в нём. Iceweasel и geany у меня открыты постоянно. Я их использую с тем же успехом.
Открыть содержимое (спойлер)
build# cmake -DCMAKE_INSTALL_PREFIX=/usr ..
-- Found Qt-Version 4.6.3 (using /usr/bin/qmake)
-- Found X11: /usr/lib/libX11.so
-- Phonon Version: 4.4.2
CMake Error at /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:1179 (message):
  Qt compiled without support for -fvisibility=hidden.  This will break
  plugins and linking of some applications.  Please fix your Qt installation.
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
  CMakeLists.txt:5 (find_package)


-- Configuring incomplete, errors occurred!
[свернуть]
И это уже после исправления кучи других ошибок сборки.
Цитата: Brainey от 16 февраля 2012, 12:34:36

Сообщение объединено: 16 февраля 2012, 12:35:35

Сам не пробовал, но мне говорили, что ibus все же работал, но вроде нужно добавить в автозапуск то ли его самого, то ли что-то из его пакетов. Сейчас уже точно не помню.
Нужно добавлять демона ibus (ibus-daemon). Но это не помогает.

Цитата: ihammersPS: попробую под виртуалкой проверить.
Жду результатов.

ihammers

Цитата: elivin от 16 февраля 2012, 19:31:29
...
Цитата: ihammersPS: попробую под виртуалкой проверить.
Жду результатов.
Установил testing (netinstall) с таким набором пакетов с зависимостями:

apt-get install kde-standard ibus ibus-qt4 ibus-anthy locales-all fonts-ipafont fonts-vlgothic

Работает.  Проверил в таких программах как Kate & Kopete.  В первой набор текста, а во второй при редактировании accaunt.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

elivin

Доустановил locales-all, ttf-ipafont, ttf-vlgothic. Шрифты стали более сглаженными. Больше изменений нет.

ihammers

Цитата: elivin от 16 февраля 2012, 21:52:05
Доустановил locales-all, ttf-ipafont, ttf-vlgothic. Шрифты стали более сглаженными. Больше изменений нет.
Странно, надо дальше разбираться.  Возможно это баг.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

Ghostdmn

8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100

elivin

Цитата: Ghostdmn от 17 февраля 2012, 12:22:57
http://wiki.debian.org/I18n/ibus
Здесь глянь. Там про экспорт как раз
??????????
Установил пакет ibus-table-array30 и выполнил 5 шаг из данной инструкции (судя по всему зря  :) ). Теперь работает во всех приложениях. Благодарю всех, кто проявил интерес к данной теме.