Автор Тема: Не работает 3G модем Pantech UM175 под Debian Squeeze  (Прочитано 2663 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Osho

  • Новичок форума
  • Topic Author
  • Сообщений: 2
Debian 6.0.4  Squeeze
Ядро 2.6.32-5-686
Gnome 2.30.2

Модем определяется:

# wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0   S1   S2   S3   
WvModem<*1>: Cannot get information for serial port.
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- Manufacturer: UTStarcom communication Inc.
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found an USB modem on /dev/ttyACM0.
Modem configuration written to /etc/wvdial.conf.
ttyACM0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

Но через стандартный менеджер в Gnome не подключается к интернет
(в настройках соединения я выбрал моего провайдера - Интертелеком, номер дозвона, логин и пароль ввёл)

Вычитал, что нужно поставить gnome-ppp, поставил, не помогло (правда советовали его запускать под рутом,
но я незнаю как это сделать, третий день на линуксе...)  ::)
Пишет - модем не определяется

Я делал, как посоветовали тут -http://akceptor.com/2008/11/27/nastraivaem-cdma-internet-v-linux/
Тоже не помогает...

Может у кого-то был опыт приручения этого модема?
Буду очень благодарен за совет.
 

Сообщение объединено: 19 Февраль 2012, 01:51:01
Сам себе и отвечу.

Помогло вот это:

В wvdial.conf  прописал -

Modem = /dev/ttyACM0
Baud = 460800
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Phone = #777
Username = IT
Password = IT
ISDN = 0
Auto DNS = 1
Modem Type = Analog Modem


Запустил Gnome-ppp с правами администратора

> sudo gnome-ppp

Если не хочется каждый раз запускать через консоль и вводить пароль, то можно это обойти, создать на рабочем столе ярлык gnome-ppp, в свойствах указать - запускать с правами администратора, но пароль придется вводить так же.
Можно и это обойти.
Далее “Система -> Администрирование -> Пользователи и группы”. Запускаем. Выбираем свою текущую учётную запись. Нажимаем "Дополнительные параметры”. Вводим пароль. Выбираем вкладку “права пользователя”. Теперь разрешаем себе использовать Dial-Up  соединением, отмечая галочкой пункт “Соединяться с Интернет через модем”.

Теперь всё работает!
Правда, хотелось бы, чтобы всё было через GUI, а не из под рута с запущенным процессом в терминале.
Может, кто-то подскажет, как это решить?
« Последнее редактирование: 19 Февраль 2012, 02:11:00 от Osho »
 


Оффлайн Nokman

  • Пользователь
  • *
  • Сообщений: 34
Re: Не работает 3G модем Pantech UM175 под Debian Squeeze
« Ответ #1 : 19 Февраль 2012, 02:00:43 »
Запустить gnome-ppp с правами root можно так:
$ su
Password: <вводите пароль суперпользователя>
Потом:
# gnome-ppp
 

Оффлайн Osho

  • Новичок форума
  • Topic Author
  • Сообщений: 2
Re: Не работает 3G модем Pantech UM175 под Debian Squeeze
« Ответ #2 : 19 Февраль 2012, 02:07:00 »
Благодарю!
Нашёл команду - sudo gnome-ppp

 

Оффлайн Malaheenee

  • Ветеран
  • *****
  • Сообщений: 2565
  • Учтите, мы можем дать и вредный совет.
Re: Не работает 3G модем Pantech UM175 под Debian Squeeze
« Ответ #3 : 19 Февраль 2012, 07:21:33 »
Через GUI у нас прекрасно работает связка "network-manager network-manager-gnome mobile-broadband-provider-info modemmanager usb-modeswitch usb-modeswitch-data" (список пакетов для установки).
Все мы где-то, когда-то и в чем-то были новичками.
 

Теги:
 

[Решено] Не работает монитор на intel atom

Автор mayor

Ответов: 6
Просмотров: 4068
Последний ответ 03 Октябрь 2014, 16:47:43
от Sferg
Не работает тачпад и не выключается система.

Автор Hjort

Ответов: 13
Просмотров: 4137
Последний ответ 12 Октябрь 2015, 09:47:19
от Hjort
Debian не видит кардридер

Автор SkyRewir

Ответов: 1
Просмотров: 1025
Последний ответ 28 Август 2018, 18:33:54
от ChubaDuba
[Решено] wireless brcm4313 на debian/wheezy

Автор ilyuha21st

Ответов: 0
Просмотров: 2034
Последний ответ 06 Июль 2012, 20:36:26
от ilyuha21st
Подключение Android 4.x к Debian

Автор Самир

Ответов: 1
Просмотров: 2937
Последний ответ 18 Май 2014, 21:36:26
от endru