установка драйвера на Intel HD Graphics 3000

Автор Aerlis, 12 апреля 2012, 15:57:34

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Aerlis

Добрый день (я новичок )  , помогите  пожалуйста установить (обновить ) драйвер на видяху Intel HD Graphics 3000
а то проблема с изображением + разрешение экрана не поменять

ноутбук asus K43E

Valeron

#1
Пакет xserver-xorg-video-intel установлен (и какая версия)? Можно, например, в Синаптике (Менеджере пакетов) посмотреть, или через Терминал:aptitude show xserver-xorg-video-intel
Заодно покажите, что установлено из mesa: aptitude search ~i~nmesa
Enter нажат, к чему теперь рыданья...

Aerlis

Цитата: Valeron от 13 апреля 2012, 05:15:54
Пакет xserver-xorg-video-intel установлен (и какая версия)? Можно, например, в Синаптике (Менеджере пакетов) посмотреть, или через Терминал:aptitude show xserver-xorg-video-intel
Заодно покажите, что установлено из mesa: aptitude search ~i~nmesa


Пакет: xserver-xorg-video-intel                 
Состояние: установлен
Автоматически установлен: да
Версия: 2:2.13.0-6
Приоритет: необязательный
Раздел: x11
Сопровождающий: Debian X Strike Force <debian-x@lists.debian.org>
Размер в распакованном виде: 1 339 k
Зависимости: libc6 (>= 2.2.5), libdrm-intel1 (>= 2.4.21), libdrm2 (>= 2.4.17),
                        libpciaccess0 (>= 0.8.0+git20071002), libx11-6,
                        libx11-xcb1, libxcb-aux0 (>= 0.3.6), libxcb-dri2-0,
                        libxcb1, libxext6, libxfixes3 (>= 1:4.0.1), libxv1,
                        libxvmc1, xorg-video-abi-6.0, xserver-xorg-core (>=
                        2:1.7.6.901)
Конфликтуют: 915resolution, xserver-xorg-driver-i810, xserver-xorg-video-i810 (<
                        2:1.9.91-1), xserver-xorg-video-i810-modesetting,
                        xserver-xorg-video-intel-modesetting
Заменяют: xserver-xorg (< 6.8.2-35), xserver-xorg-driver-i810,
                  xserver-xorg-video-i810 (< 2:1.9.91-1),
                  xserver-xorg-video-i810-modesetting,
                  xserver-xorg-video-intel-modesetting
Предоставляют: xorg-driver-video, xserver-xorg-video-6
Описание: X.Org X server -- Intel i8xx, i9xx display driver
This package provides the driver for the Intel i8xx and i9xx family of
chipsets, including i810, i815, i830, i845, i855, i865, i915, i945 and i965
series chips.

This package also provides XvMC (XVideo Motion Compensation) drivers for
i810/i815 and i9xx and newer chipsets.

More information about X.Org can be found at: <URL:http://www.x.org>

This package is built from the X.org xf86-video-intel driver module.

aptitude search ~i~nmesa


i   libgl1-mesa-dri                 - A free implementation of the OpenGL API --
i A libgl1-mesa-glx                 - A free implementation of the OpenGL API --
i A libglu1-mesa                    - The OpenGL utility library (GLU)         
i A mesa-utils                      - Miscellaneous Mesa GL utilities           




ihammers

Покажите что у вас находиться в /etc/apt/sources.list.  Похоже что часть пакетов из другой версии (ветки) стоит.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

Aerlis

Цитата: ihammers от 13 апреля 2012, 19:07:39
Покажите что у вас находиться в /etc/apt/sources.list.  Похоже что часть пакетов из другой версии (ветки) стоит.

это?

# deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official amd64 DVD Binary-1 20120128-13:42]/ squeeze contrib main

# deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official amd64 DVD Binary-1 20120128-13:42]/ squeeze contrib main

# Line commented out by installer because it failed to verify:
# deb http://security.debian.org/ squeeze/updates main contrib
# Line commented out by installer because it failed to verify:
# deb-src http://security.debian.org/ squeeze/updates main contrib

# squeeze-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
# deb http://ftp.debian.org/debian/ squeeze-updates main contrib
# deb-src http://ftp.debian.org/debian/ squeeze-updates main contrib

ihammers

Цитата: Aerlis от 13 апреля 2012, 19:13:23
Цитата: ihammers от 13 апреля 2012, 19:07:39
Покажите что у вас находиться в /etc/apt/sources.list.  Похоже что часть пакетов из другой версии (ветки) стоит.
это?

# deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official amd64 DVD Binary-1 20120128-13:42]/ squeeze contrib main
...
Добавите строчки для squeeze или раскомментируйте ваши.
### Squeeze
deb http://ftp.debian.org/debian squeeze main contrib non-free
deb-src http://ftp.debian.org/debian/ squeeze main contrib non-free

deb http://ftp.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ squeeze-updates main contrib non-free


Потом обновите список пакетов.  И покажите что выдаёт команда на обновление пакетов.
apt-get update
apt-get dist-upgrade -d
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

Aerlis

Цитата: ihammers от 13 апреля 2012, 19:24:22
Цитата: Aerlis от 13 апреля 2012, 19:13:23
Цитата: ihammers от 13 апреля 2012, 19:07:39
Покажите что у вас находиться в /etc/apt/sources.list.  Похоже что часть пакетов из другой версии (ветки) стоит.
это?

# deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official amd64 DVD Binary-1 20120128-13:42]/ squeeze contrib main
...
Добавите строчки для squeeze или раскомментируйте ваши.
### Squeeze
deb http://ftp.debian.org/debian squeeze main contrib non-free
deb-src http://ftp.debian.org/debian/ squeeze main contrib non-free

deb http://ftp.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.debian.org/debian/ squeeze-updates main contrib non-free


Потом обновите список пакетов.  И покажите что выдаёт команда на обновление пакетов.
apt-get update
apt-get dist-upgrade -d



это?

apt-get dist-upgrade -d
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Расчёт обновлений... Готово
Пакеты, которые будут обновлены:
  at libc-bin libc6 libc6-i386 locales
обновлено 5, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 13,7 MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 459 kB.
Хотите продолжить [Д/н]?


ihammers

Цитата: Aerlis от 13 апреля 2012, 19:37:11
это?

apt-get dist-upgrade -d
...
Да, это.  И на по следок какая версия ядра.
uname -a

Если версия старая (не 3.x), то если я правильно помню, потребуется обновить ядро и все должно заработать как надо.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

Aerlis

Цитата: ihammers от 13 апреля 2012, 19:52:13Цитата: Aerlis от Сегодня в 19:37:11

    это?

    apt-get dist-upgrade -d
    ...

Да, это.  И на по следок какая версия ядра.
Код: [Выделить]

uname -a


Если версия старая (не 3.x), то если я правильно помню, потребуется обновить ядро и все должно заработать как надо.



Linux debian 2.6.32-5-amd64 #1 SMP Mon Jan 16 16:22:28 UTC 2012 x86_64 GNU/Linux

а как его обновить ? ???

ihammers

#9
Нужно добавить backports в списки репозиториев:
deb http://backports.debian.org/debian-backports/ squeeze-backports main contrib non-free
Затем обновить список пакетов и установить ядро:

apt-get update
apt-get install linux-image-3.2.0-0.bpo.2-amd64

Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

Aerlis

Цитата: ihammers от 13 апреля 2012, 20:10:13
Нужно добавить backports в списки репозиториев:
deb backports.debian.org/debian-backports/ squeeze-backports main contrib non-free
Затем обновить список пакетов и установить ядро:

apt-get update
apt-get install linux-image-3.2.0-0.bpo.2-amd64





Нужно добавить backports в списки репозиториев:
deb backports.debian.org/debian-backports/ squeeze-backports main contrib non-free
Затем обновить список пакетов и установить ядро:


bash: deb: команда не найдена

пишит что не найдено , что я не так делаю

ihammers

Цитата: Aerlis от 13 апреля 2012, 20:18:00
Нужно добавить backports в списки репозиториев:
deb backports.debian.org/debian-backports/ squeeze-backports main contrib non-free
Затем обновить список пакетов и установить ядро:
...
пишит что не найдено , что я не так делаю
Я там в строчке не дописал "http://", теперь должно всё работать:
deb http://backports.debian.org/debian-backports/ squeeze-backports main contrib non-free
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

Aerlis

#12
Цитата: ihammers от 13 апреля 2012, 20:21:21
Цитата: Aerlis от 13 апреля 2012, 20:18:00
Нужно добавить backports в списки репозиториев:
deb backports.debian.org/debian-backports/ squeeze-backports main contrib non-free
Затем обновить список пакетов и установить ядро:
...
пишит что не найдено , что я не так делаю
Я там в строчке не дописал "http://", теперь должно всё работать:
deb http://backports.debian.org/debian-backports/ squeeze-backports main contrib non-free

спасибо огромное всё работает!!!!


ihammers

Цитата: Aerlis от 13 апреля 2012, 20:53:30
...
спасибо огромное всё работает!!!!
Раз тема решена, то в начальном посте измените название, т.е. добавьте в начало [РЕШЕНО].
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

Aerlis

#14
Цитата: ihammers от 13 апреля 2012, 21:04:30
Цитата: Aerlis от 13 апреля 2012, 20:53:30
...
спасибо огромное всё работает!!!!
Раз тема решена, то в начальном посте измените название, т.е. добавьте в начало [РЕШЕНО].

С разрешением всё стало хорошо, только вот если окно сворачивать или разворачивать чуть глючит, и если окно перемещать по рабочему столу то тоже тормозит...как это можно исправить