Автор Тема: Сломались пакеты при обновлении.  (Прочитано 2147 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн APL

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 30
  • LMDE
  • Jabber: andrewpl@jabber.ru
Сломались пакеты при обновлении.
« : 18 Апрель 2012, 19:05:14 »
Обновлялся удаленно.
# apt-get upgrade

Прервалась связь... переподключился, и снова apt-get upgrade

Пишет:
Spoiler: ShowHide
Настраивается пакет libgl1-nvidia-glx:i386 (295.40-1) ...
dpkg: не удалось обработать параметр libgl1-nvidia-glx:i386 (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
dpkg: зависимости пакетов не позволяют настроить пакет xserver-xorg-video-nvidia:
 xserver-xorg-video-nvidia зависит от libgl1-nvidia-glx (= 295.40-1), однако:
  Пакет libgl1-nvidia-glx:i386 пока не настроен.
dpkg: не удалось обработать параметр xserver-xorg-video-nvidia (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет nvidia-glx:
 nvidia-glx зависит от libgl1-nvidia-glx (= 295.40-1), однако:
  Пакет libgl1-nvidia-glx:i386 пока не настроен.
 nvidia-glx зависит от xserver-xorg-video-nconfigured to not write apport reports
                                                                                 configured to not write apport reports
                                                                                                                       vidia (= 295.40-1), однако:
  Пакет xserver-xorg-video-nvidia пока не настроен.
dpkg: не удалось обработать параметр nvidia-glx (--configure):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 libgl1-nvidia-glx:i386
 xserver-xorg-video-nvidia
 nvidia-glx
E: Sub-process /usr/bin/dpkg returned an error code (1)


# apt-get -f install
не помог.

Что делать?
 


Оффлайн foozzi

  • GNU
  • Пользователь
  • *
  • Сообщений: 21
  • Debian наше все!
    • Обзор GNU проектов
  • Jabber: foozzi@xmpp.ru
Re: Сломались пакеты при обновлении.
« Ответ #1 : 18 Апрель 2012, 23:25:55 »
попробуй
aptitude reinstall libgl1-nvidia-glx
 

Оффлайн APL

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 30
  • LMDE
  • Jabber: andrewpl@jabber.ru
Re: Сломались пакеты при обновлении.
« Ответ #2 : 19 Апрель 2012, 14:39:53 »
Сделал. Не помогло. Перестало ругаться после перезагрузки, но дрова встали криво... или кривые.. работать невозможно... все глючит и висит. Пишу с liveCD.

Дравера ставились так:

# aptitude install module-assistant
# module-assistant prepare
# module-assistant update
# module-assistant auto-install nvidia-kernel-source

Как мне переустановить дрова? Или починить их иным способом? Помогите плиз... Заранее спасибо!
 

Оффлайн foozzi

  • GNU
  • Пользователь
  • *
  • Сообщений: 21
  • Debian наше все!
    • Обзор GNU проектов
  • Jabber: foozzi@xmpp.ru
Re: Сломались пакеты при обновлении.
« Ответ #3 : 19 Апрель 2012, 15:32:54 »
aptitude purge nvidia-kernel-common nvidia-kernel-dkms nvidia-kernel-sourceкакая версия debian?
Я всегда ставил так:
apt-get install module-assistant nvidia-kernel-common
m-a auto-install nvidia-kernel${VERSION}-source
apt-get install nvidia-kernel-source nvidia-kernel-common
apt-get install linux-headers-$KVERS
apt-get install nvidia-glx${VERSION}
apt-get install nvidia-xconfig
cp -p /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
nvidia-xconfig
reboot
 

Оффлайн APL

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 30
  • LMDE
  • Jabber: andrewpl@jabber.ru
Re: Сломались пакеты при обновлении.
« Ответ #4 : 19 Апрель 2012, 16:21:17 »
Спасибо! Попробую... если получится... у меня не всегда стартуют иксы... (сейчас пишу с liveCD)

1. как мне сделать консольную загрузку?
2.  У меня LMDE (rolling release) Ядро 3.0.1-686-pae
3. Вместо ${VERSION} что писать? какую версию?

Сообщение объединено: 19 Апрель 2012, 17:23:20
какая версия debian?
m-a auto-install nvidia-kernel${VERSION}-source


Ошибка сборки пакета nvidia-kernel-source
:(
« Последнее редактирование: 19 Апрель 2012, 17:23:20 от APL »
 

Оффлайн Valeron

  • Местный житель
  • ***
  • Сообщений: 454
Re: Сломались пакеты при обновлении.
« Ответ #5 : 20 Апрель 2012, 21:42:53 »
1. как мне сделать консольную загрузку?
При включении компа, на этапе выбора ОС в грубе, надо выбрать строчку, где recovery mode (безопасный режим, или как он там еще называется).
2.  У меня LMDE (rolling release) Ядро 3.0.1-686-pae
3. Вместо ${VERSION} что писать? какую версию?
Это Вам здесь вряд ли подскажут (потому как вряд ли здесь есть LMDE-юзеры :) ), лучше такие вещи спрашивать на соответствующем форуме (там даже специальный раздел по LMDE есть).
« Последнее редактирование: 20 Апрель 2012, 21:46:29 от Valeron »
Enter нажат, к чему теперь рыданья...
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Re: Сломались пакеты при обновлении.
« Ответ #6 : 20 Апрель 2012, 22:09:22 »
3. Вместо ${VERSION} что писать? какую версию?
Если я правильно понимаю, то вместо этого ничего не нужно писать - так и оставить. Это команда или выбор параметра согласно вашей конфигурации.

А что значит встали криво и все глючит? У меня было при установке на комп с нвидиа, что слетало разрешение на 320/240 и через драйвер нвидиа не менялось (неактивно). Прописывал принудительно в xorg.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Теги:
 

[РЕШЕНО]Сломались приоритеты обновлений

Автор bemyak

Ответов: 4
Просмотров: 1624
Последний ответ 02 Ноябрь 2013, 00:14:21
от bemyak