Автор Тема: [РЕШЕНО] После обновления пропал звук  (Прочитано 12632 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн su16

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 191
  • Сообщений: 174
всем двоекратное Ку!

Вчера обновился, получил ядро 2.6.32-5-amd64, сегодня запускаю комп - звука нет. Лезу в регулятор громкости (в GNOME), а он мне в ответ:
Spoiler: ShowHide
Регулятору громкости не удается найти ни одного управляемого элемента и/или устройства. Это означает, что либо не установлен правильный модуль GStreamer, либо не настроена звуковая карта.

ок, что за модуль gstreamer ему нужен я не в курсах, но какие-то пакеты gstreamer0.10 у меня всё же стоят в системе...
выполнил
apt-get install gstreamer0.10
поставилась куча пакетов, я опять в аплет громкости - теже маты в ответ. может alsamixer поможет - фига, пишет нет такого файла. при этом пакет alsa-utils, в котором по идее миксер, установлен!

хорошо, смотрю что есть в системе:
Spoiler: ShowHide
lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation Cougar Point High Definition Audio Controller (rev 05)
01:00.1 Audio device: nVidia Corporation Device 0e09 (rev a1)

стоп! у меня же была nvidia и основная - realtek (!) откуда Intel ?! КАК?! :D
ладно, посмотрим что ещё осталось в системе:
Spoiler: ShowHide
aplay -l
aplay: device_list:235: no soundcards found...

а раньше был HD Audio ALC-8xx какой-то... точно не помню номер, драйвер я ставил с офсайта к нему.

Последние два ответа от системы поставили меня в тупик.
есть идеи куда копать? ???
« Последнее редактирование: 28 Апрель 2012, 10:20:59 от su16 »
Если вам дают бесплатное, то, скорее всего, товар - это вы.
http://ru.occupyflash.org/
 

Оффлайн Malaheenee

  • Ветеран
  • *****
  • Сообщений: 2565
  • Учтите, мы можем дать и вредный совет.
Re: После обновления пропал звук
« Ответ #1 : 28 Апрель 2012, 06:32:52 »
Spoiler: ShowHide
Что ответить не знаем, но за изложение 5+!  ;)
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн su16

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 191
  • Сообщений: 174
Re: После обновления пропал звук
« Ответ #2 : 28 Апрель 2012, 07:40:09 »
ну чтож, с виду было страшно... особенно новое название у карточки, но ларчик просто открывался:
sudo modprobe snd-hda-intel
;D вот и всё. и alsamixer тут же чудесным образом нашёлся в системе. :D
« Последнее редактирование: 28 Апрель 2012, 07:42:59 от su16 »
Если вам дают бесплатное, то, скорее всего, товар - это вы.
http://ru.occupyflash.org/
 


Оффлайн calambus

  • Почетный пользователь форума
  • Старожил
  • ****
  • Сообщений: 554
  • Ушел из жизни 14.07.2013
Re: [РЕШЕНО] После обновления пропал звук
« Ответ #3 : 28 Апрель 2012, 11:17:51 »
Можно ещё переконфигурировать ALSA : # dpkg-reconfigure linux-sound-base
                                                                     

затем выбрать ALSA ...
и ещё вариант :  Перезагрузка alsa
# alsa reload
« Последнее редактирование: 28 Апрель 2012, 17:00:09 от calambus »
 

Оффлайн su16

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 191
  • Сообщений: 174
Re: [РЕШЕНО] После обновления пропал звук
« Ответ #4 : 28 Апрель 2012, 16:56:01 »
calambus, спасибо, воспользуюсь.
но кажется тоже самое можно из ГУЯ
gstreamer-properties
« Последнее редактирование: 28 Апрель 2012, 20:42:43 от su16 »
Если вам дают бесплатное, то, скорее всего, товар - это вы.
http://ru.occupyflash.org/
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
Re: [РЕШЕНО] После обновления пропал звук
« Ответ #5 : 28 Апрель 2012, 22:17:08 »
Недавно сталкивался с тем, что некоторые пакеты с firmware блокировали начисто воспроизведение. Симптомы были похожие. Конечно, странно, но интересно было бы увидеть вывод aptitude search ~ifirmware
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн calambus

  • Почетный пользователь форума
  • Старожил
  • ****
  • Сообщений: 554
  • Ушел из жизни 14.07.2013
Re: [РЕШЕНО] После обновления пропал звук
« Ответ #6 : 29 Апрель 2012, 07:48:57 »
su16, [gstreamer-properties] - это графическая утилита , из состава DE Gnome , для тестирования Audio-Video Систем  , с её помощью легко и быстро можно проверить правильность установки и работы  драйверов .
Но "горячий" перезапуск и реконфигурирование  звуковых серверов Alsa и Pulseaudio  , без перезагрузки Системы , можно сделать только из под Консоли ...
# dpkg-reconfigure linux-sound-base
# alsa reload
# dpkg-reconfigure pulseaudio
« Последнее редактирование: 29 Апрель 2012, 07:51:58 от calambus »
 

Оффлайн su16

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 191
  • Сообщений: 174
Re: [РЕШЕНО] После обновления пропал звук
« Ответ #7 : 29 Апрель 2012, 08:51:43 »
Brainey,
Spoiler: ShowHide
aptitude search ~ifirmware
i A firmware-linux-free                           - Binary firmware for various drivers in the Linux kernel

ох уж этот аудио хэлл в линуксе... щас вот audacity 2.0 поставил с сайта - не видит аудио устройств, хотя звук в системе и в плеерах есть...

calambus, ага, ясно.
Если вам дают бесплатное, то, скорее всего, товар - это вы.
http://ru.occupyflash.org/
 

Оффлайн calambus

  • Почетный пользователь форума
  • Старожил
  • ****
  • Сообщений: 554
  • Ушел из жизни 14.07.2013
Re: [РЕШЕНО] После обновления пропал звук
« Ответ #8 : 29 Апрель 2012, 09:27:39 »
su16, выложите под [Sp]ойлер вывод консольной команды :
$ cat /proc/asound/card0/pcm0c/info

Оффлайн su16

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 191
  • Сообщений: 174
Re: [РЕШЕНО] После обновления пропал звук
« Ответ #9 : 30 Апрель 2012, 13:48:30 »
Spoiler: ShowHide
cat /proc/asound/card0/pcm0c/info
card: 0
device: 0
subdevice: 0
stream: CAPTURE
id: ALC889 Analog
name: ALC889 Analog
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1

calambus, если не секрет, а что ты хочешь выяснить?
Если вам дают бесплатное, то, скорее всего, товар - это вы.
http://ru.occupyflash.org/
 

Оффлайн calambus

  • Почетный пользователь форума
  • Старожил
  • ****
  • Сообщений: 554
  • Ушел из жизни 14.07.2013
Re: [РЕШЕНО] После обновления пропал звук
« Ответ #10 : 30 Апрель 2012, 16:06:24 »
Уже выяснил , какой чипсет звуковой карты ...

Оффлайн igorvek

  • Кто бы думал, что этот автомобиль можно починить...
  • Новичок форума
  • Сообщений: 1
  • Я знаю где плюс, а где минус. АВТОЭЛЕКТРИК.
    • блог
  • Jabber: не пользуюсь
Re: [РЕШЕНО] После обновления пропал звук
« Ответ #11 : 08 Май 2012, 11:01:47 »
С праздником победы!
После обновления нет звука, раньше был звук, который отставал от видео и звучал прерывисто, я включаю проигрыватель, там не активирован регулятор громкости, все предложения данные участниками топика выполнены; Компьютер с процессором amd 3200, Звуковая карта интегрирована в мать ASUS, то есть AC 97, Звук был на других Осях без проблем, а вот Дебиан 6 подкидывает заподло, ладно принтер Canon LBP 2900 и VPN настроил,  хоть в инете сижу и хелпы распечатывать можно, но со звуком, это вообще засада...
# cat /proc/asound/card0/pcm0c/info
card: 0
device: 0
subdevice: 0
stream: CAPTURE
id: SAA7134 PCM
name: SAA7134 PCM
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1

Так же попытка установки этого пакета ;
# dpkg-reconfigure pulseaudio
Пакет «pulseaudio» не установлен, информация о нём недоступна.
Для проверки файлов архивов используйте команду dpkg --info (dpkg-deb --info),
для вывода списка файлов в них -- команду dpkg--contents (dpkg-deb --contents).
/usr/sbin/dpkg-reconfigure: Пакет pulseaudio не установлен

Вот такая ситуёвина, может быть и не только у меня.
Так звук же был!!! :o
« Последнее редактирование: 08 Май 2012, 11:05:41 от igorvek »
И почему я родился в СССР?
 

Оффлайн calambus

  • Почетный пользователь форума
  • Старожил
  • ****
  • Сообщений: 554
  • Ушел из жизни 14.07.2013
Re: [РЕШЕНО] После обновления пропал звук
« Ответ #12 : 08 Май 2012, 12:24:04 »
igorvek , у Вас TV-тьюнер [name: SAA7134 PCM]   встал на место Звуковой Карты , выложите вывод под [Sp]ойлер :
lspci -k

Оффлайн su16

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 191
  • Сообщений: 174
Re: [РЕШЕНО] После обновления пропал звук
« Ответ #13 : 22 Май 2012, 18:07:31 »
у меня опять вопрос по сабжу.

поскольку я собирал и ставил дрова с офсайта, теперь почти после каждого серьёзного обновления у меня отваливается звук. приходится заново каждый раз переинстолить дровень и жать sudo modprobe snd-hda-intel.

подскажите способ попрочнее прикрепить драйвер чтоб он не отваливался? и вообще почему это происходит, может где-то что-то прописать надо? :-\
Если вам дают бесплатное, то, скорее всего, товар - это вы.
http://ru.occupyflash.org/
 

Теги:
 

Шум микрофона. [РЕШЕНО]

Автор sx88

Ответов: 7
Просмотров: 9370
Последний ответ 21 Февраль 2013, 18:31:27
от calambus
[Решено] Звуковая карта по умолчанию

Автор vg

Ответов: 1
Просмотров: 6407
Последний ответ 15 Октябрь 2014, 23:24:54
от vg
xfce4 (4.8), gnome-mplayer ,xscreensaver [РЕШЕНО]

Автор vladimirse

Ответов: 14
Просмотров: 3209
Последний ответ 13 Март 2012, 10:32:18
от vladimirse
Звук в Google Chrome

Автор executable

Ответов: 1
Просмотров: 1272
Последний ответ 14 Ноябрь 2013, 18:09:44
от avidim
Не сохраняется заданный микрофон после завершения сеанса

Автор obana

Ответов: 1
Просмотров: 883
Последний ответ 03 Ноябрь 2017, 20:01:29
от vcsasha