Автор Тема: Как обновить squeeze до wheezy/sid ?  (Прочитано 4806 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kakawkin

  • Пользователь
  • *
  • Сообщений: 37
Как обновить squeeze до wheezy/sid ?
« : 07 Мая 2012, 03:05:00 »
Я как понял по версий пакетов та же Ubuntu 12.04 схожа с Debian Sid ?
Если да то не подскажите способ обновить ?
 

Оффлайн Brainey

Re: Как обновить squeeze до wheezy/sid ?
« Ответ #1 : 07 Мая 2012, 12:22:14 »
Почитать wiki. См. Пример оформления sources.list.
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн kakawkin

  • Пользователь
  • *
  • Сообщений: 37
Re: Как обновить squeeze до wheezy/sid ?
« Ответ #2 : 07 Мая 2012, 12:45:05 »
В общем остановился на тестинг. Такой список репов будет правильным вот такой ?
deb http://ftp.debian.org/debian/ testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://ftp.debian.org/debian/ testing-proposed-updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free
И потом: apt-get update && apt-get install debian-multimedia-keyring && apt-get update
« Последнее редактирование: 07 Мая 2012, 12:59:49 от kakawkin »
 

Оффлайн SeHELLioN

Re: Как обновить squeeze до wheezy/sid ?
« Ответ #3 : 07 Мая 2012, 22:01:16 »
и# apt-get upgrade на последок....
Spoiler: ShowHide
по поводу реп: другу устанавливал сегодня дебиан, в репах только 1 и последний из вашего списка. У себя дома только первый
Asus m5a97+Amd fx-8350+4x4GB DDR3 1600MGz+asus gtx670 DCII (перешита в top)
Debian stable
 

Оффлайн Valeron

Re: Как обновить squeeze до wheezy/sid ?
« Ответ #4 : 08 Мая 2012, 03:46:02 »
Spoiler: ShowHide
по поводу реп: другу устанавливал сегодня дебиан, в репах только 1 и последний из вашего списка. У себя дома только первый
А у меня по умолчанию так было:
Цитировать
deb http://ftp.ru.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.ru.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb http://http.us.debian.org/debian/ wheezy main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main

Enter нажат, к чему теперь рыданья...
 

Оффлайн calambus

Re: Как обновить squeeze до wheezy/sid ?
« Ответ #5 : 09 Мая 2012, 11:55:33 »
Но имейте ввиду , при этом могу проявиться всякие-разные неприятные побочные эффекты , мне пришлось в конце-концов  Wheezy-XFCE4.8 переустанавливать начисто ...

Оффлайн Malaheenee

Re: Как обновить squeeze до wheezy/sid ?
« Ответ #6 : 09 Мая 2012, 14:14:41 »
Spoiler: ShowHide
calambus, мы так раз 50 ставили Debian -- для отработки практики автоматической установки да и просто для опыта - например не баловаться метапакетами. Так что переустановка - это благо. В некотором роде
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн calambus

Re: Как обновить squeeze до wheezy/sid ?
« Ответ #7 : 09 Мая 2012, 15:30:06 »
Spoiler: ShowHide

Коллега Malaheenee , я действую таким-же методом последовательного приближения , на пути к желаемому результату ...

Оффлайн kakawkin

  • Пользователь
  • *
  • Сообщений: 37
Re: Как обновить squeeze до wheezy/sid ?
« Ответ #8 : 09 Мая 2012, 22:37:19 »
В общем обновился до тестинга, и при установке чего либо теперь:
Spoiler: ShowHide
kakawkin@debian:~$ sudo apt-get install mc
[sudo] password for kakawkin:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  python-crypto mono-2.0-gac python-tagpy libxcb-aux0 libgnomekbd4
  libtracker-client-0.8-0 python-lazr.restfulclient libwpd8c2a python-pyasn1
  libswscale0 python-twisted-core ekiga python-opengl rpm2cpio libmtp9
  xsltproc pnm2ppa libboost-python1.49.0 libavutil49 openoffice.org-writer
  libntfs10 libxcb-render-util0 gnuchess-book gnome-nettool
  gnome-games-extra-data gnome-desktop-data libdb5.1-java
  libgnomepanel2.24-cil aisleriot gtali openoffice.org-impress libglade2.0-cil
  xulrunner-1.9.1 python-mako glchess libbabl-0.0-0 libxcb-event1
  gir1.2-javascriptcoregtk-3.0 python-zope.interface libgegl-0.0-0
  openoffice.org-filter-mobiledev genisoimage ttf-sil-gentium
  openoffice.org-draw libicu44 libraw2 openoffice.org-filter-binfilter
  libsrtp0 libsoundtouch1c2 tcptraceroute nmap gnome-video-effects brltty-x11
  iputils-tracepath python-clientform gnome-games cheese
  gnome-session-canberra gdebi quadrapassel openoffice.org-java-common
  python-twisted-web openoffice.org-gtk update-manager-core libsvga1 gnobots2
  libgnome-media0 python-wadllib gnome-cards-data gir1.2-atspi-2.0
  liferea-data libgraphite3 libwpg-0.1-1 rhythmbox bsh-gcj python-gdata gedit
  libnm-util1 xdg-user-dirs-gtk libgexiv2-0 python-gtksourceview2 gnome-office
  dvd+rw-tools update-manager-gnome brltty libwebkit-1.0-2 python-gtkglext1
  libart2.0-cil libjs-jquery libcamel1.2-14 libminiupnpc5 libvncserver0
  librpmio1 librpmio2 libdb5.1-java-gcj update-notifier-common libpostproc51
  librpm2 seahorse rpm-common libgnome2-perl remmina-plugin-rdp libeggdbus-1-0
  libcapi20-3 libnotify1 python-simplejson libedata-cal1.2-7 update-notifier
  python-mechanize libgnome2.24-cil libndesk-dbus1.0-cil libboost-thread1.42.0
  gnome-media-common librasqal2 libgpod4 remmina-plugin-vnc gnibbles
  libavformat52 rhythmbox-data libmono-cairo2.0-cil libboost-date-time1.42.0
  libgalago3 gedit-plugins libgrilo-0.1-0 zeitgeist-core
  gir1.2-gnomekeyring-1.0 system-tools-backends libgweather1 gir1.2-gdata-0.0
  libgnome-bluetooth7 python-configobj libmtp-common guile-1.8-libs
  wwwconfig-common shotwell libgupnp-av-1.0-2 libpt2.10.4 libdmapsharing-3.0-2
  python-serial gedit-common libdb4.7-java-gcj libxcb-atom1 libgmime2.4-cil
  python-gnomedesktop software-center libopal3.6.8 python-pam python-openssl
  openoffice.org-style-galaxy libmono-i18n-west2.0-cil libgssdp-1.0-2
  libcryptui0 simple-scan gir1.2-webkit-3.0 python-lazr.uri finger
  python-markupsafe libgp11-0 python-webkit libmono-posix2.0-cil bsh libgcr0
  rhythmbox-plugin-cdrecorder libhunspell-1.2-0 libgmp3c2 remmina-common
  librhythmbox-core5 libgtksourceview2.0-common libkpathsea5
  openoffice.org-math at-spi2-core libmono-security2.0-cil libgtkimageview0
  python-speechd libhal1 libgtksourceview2.0-0 libgnome2-vfs-perl gnotski
  openoffice.org-common libegroupwise1.2-13 libvpx0 telepathy-idle libnm-glib2
  gnome-doc-utils libecal1.2-7 python-twisted-conch
  libfreerdp-plugins-standard libpoppler5 gir1.2-wnck-3.0 libgmime-2.4-2
  python-louie libunique-1.0-0 libgirepository1.0-0 libgdata1.2-1
  libedataserver1.2-13 libevince2 libhal-storage1 libpython2.6
  libimobiledevice1 python-nevow gnome-games-data iagno libgdata-google1.2-1
  glines media-player-info gir1.2-goa-1.0 python-pysqlite2 libspeechd2
  libatk-adaptor-schemas libclutter-gtk-0.10-0 gnome-sudoku libslab0a
  libebook1.2-9 libmtp-runtime libmagickcore3 libaudiofile0 tcl
  gir1.2-gucharmap-2.90 libwps-0.1-1 libmono-sharpzip2.84-cil libmagick++3
  python-oauth libedataserverui1.2-8 gir1.2-tracker-0.14 libmono-corlib2.0-cil
  python-epsilon libgnome-window-settings1 libgpod-common libedata-book1.2-2
  rhythmbox-plugins libgdata7 libxss1 openoffice.org-officebean libgs8
  libchamplain-0.4-0 openoffice.org-emailmerge tcl8.4 tcl8.5
  libchamplain-gtk-0.4-0 gnome-documents libopal3.10.4 ntfsprogs python-axiom
  libmozjs2d libjpeg62 libgtkhtml-editor-common python-bugbuddy gir1.2-rb-3.0
  liferea libpt2.6.7 python-coherence libmagickwand3 libdb4.7-java
  libgupnp-1.0-3 python-gdbm gnotravex libmagickcore3-extra libcheese-gtk18
  gnome-netstatus-applet libatspi2.0-0 libnl1 gnect libavcodec52
  python-evolution grilo-plugins-0.1 openoffice.org-style-tango liboobs-1-4
  libgucharmap7 liboobs-1-5 mahjongg javascript-common
  libndesk-dbus-glib1.0-cil libid3tag0 libraptor1 gconf-editor
  foomatic-filters-ppds gnome-system-tools cpp-4.4 python-wnck
  libebackend1.2-0 unoconv openoffice.org-base speech-dispatcher
  libgnome-desktop-2-17 fuse-utils hamster-applet gnuchess libodbc1
  libfreerdp0 libfreerdp1 libnice0 openoffice.org-calc libssh-4
  libgnome-vfs2.0-cil min12xxw libwebkit-1.0-common minissdpd libavahi-ui0
  transmission-common p7zip-full libgtkglext1 libnatpmp1 libnet1
  python-twisted-bin freeglut3 libgupnp-igd-1.0-3 libmono-system2.0-cil
  libgnome2-canvas-perl libgtkhtml3.14-19 file-roller python-zeitgeist
  transmission-gtk python-rdflib libboost-python1.42.0 remmina
  libpoppler-glib4 sound-juicer libdotconf1.0 gnomine
Для их удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
  mc-data
Предлагаемые пакеты:
  zip arj dbview odt2txt gv catdvi djvulibre-bin python-boto python-tz
НОВЫЕ пакеты, которые будут установлены:
  mc mc-data
обновлено 0, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 3 пакетов не обновлено.
Необходимо скачать 0 B/2 197 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 6 176 kB.
Хотите продолжить [Д/н]? y
dpkg: предупреждение: «ldconfig» отсутствует в каталогах, перечисленных в PATH, или не является исполняемым.
dpkg: предупреждение: «start-stop-daemon» отсутствует в каталогах, перечисленных в PATH, или не является исполняемым.
dpkg: error: 2 expected programs not found in PATH or not executable.
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.
E: Sub-process /usr/bin/dpkg returned an error code (2)
kakawkin@debian:~$

 

Оффлайн calambus

Re: Как обновить squeeze до wheezy/sid ?
« Ответ #9 : 09 Мая 2012, 22:46:31 »
Что и следовало ожидать ...

Оффлайн kakawkin

  • Пользователь
  • *
  • Сообщений: 37
Re: Как обновить squeeze до wheezy/sid ?
« Ответ #10 : 09 Мая 2012, 22:50:14 »
На ЛОРе нашел ответ: запустить от рутаexport PATH=$PATH:/sbin и все прошло
 

Оффлайн calambus

Re: Как обновить squeeze до wheezy/sid ?
« Ответ #11 : 09 Мая 2012, 22:56:52 »
Вот так и приходится набираться ума-разума ...

Оффлайн kakawkin

  • Пользователь
  • *
  • Сообщений: 37
Re: Как обновить squeeze до wheezy/sid ?
« Ответ #12 : 09 Мая 2012, 23:05:02 »
А такая ошибка не из-за того что при предложении заменить файл visudo я отказался ?
 

Оффлайн calambus

Re: Как обновить squeeze до wheezy/sid ?
« Ответ #13 : 10 Мая 2012, 00:30:06 »
visudo тут не причём : Проблема с sudoers

Теги:
     

    обновить python

    Автор Budulianin

    Ответов: 1
    Просмотров: 2124
    Последний ответ 06 Июля 2012, 06:43:28
    от Malaheenee
    Debian 6.0.6 squeeze на сервере виснет намертво!

    Автор yura3d

    Ответов: 15
    Просмотров: 5086
    Последний ответ 01 Марта 2013, 20:07:32
    от qupl
    Звук выключения Squeeze.

    Автор Sergey

    Ответов: 9
    Просмотров: 1943
    Последний ответ 19 Июня 2013, 19:45:04
    от noname
    Проблемы с squeeze-backports

    Автор 1hellsing

    Ответов: 3
    Просмотров: 1764
    Последний ответ 04 Апреля 2014, 20:50:14
    от Brainey
    как обновить php5-gd ?

    Автор laughing_man

    Ответов: 2
    Просмотров: 1493
    Последний ответ 25 Августа 2015, 06:30:41
    от endru