[Решено] Комп пикает при загрузке/выключении...

Автор Leo, 08 мая 2012, 01:24:48

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Leo

Приветствую!
Комп пикает (beep) при загрузке и выключении... а также когда в терминале или консоли делаешь какую-то ошибку... как убрать этот ужасный звук? Или хотя бы убавить... пикает в наушники/колонки...
Спасибо.

3.9. На форуме запрещено употребление "олбанскава", "падонкафскаво" и т.п. "езыгов". В данном случае удалено слово "ацки". Malaheenee

calambus

1). Какое Железо ?
2). Какой дистрибутив и DE ?

Leo

#2
-> lspci > http://paste.org.ru/?nrn5wj
-> lsb_release -a
Открыть содержимое (спойлер)

Distributor ID:   Debian
Description:   Debian GNU/Linux 6.0.4 (squeeze)
Release:   6.0.4
Codename:   squeeze
[свернуть]
-> Gnome 2.30.2
-> ядро 2.6.32-5-686

при загрузке пикает сразу после появления окна авторизации gdm3, но перед вводом данных.
при выключении - сразу после нажатия кнопки "Выключить" в окне выхода из системы в Gnome...
тоны сигнала разные...
поставил звуковую тему - думал может поможет ;) нет - сначала пикает, потом тема играет вступление  ;D


p.s.: Malaheenee...  ;)

calambus

#3
ЦитироватьАвтор: Leo
Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Leo выложите под [Sp]ойлер вывод консольной команды :
$ cat /proc/asound/card0/pcm0c/info

Pelseaudio установлено ?

Leo

#4
вот:
Открыть содержимое (спойлер)

card: 0
device: 0
subdevice: 0
stream: CAPTURE
id: STAC92xx Analog
name: STAC92xx Analog
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 3
subdevices_avail: 3
[свернуть]
Цитата: calambus от 08 мая 2012, 13:34:08
Pelseaudio установлено ?
нет не установлено

p.s.: при загрузке пикает так же как в ttl когда все символы в командной строке стерёшь и потом дальше Bksp жмёшь...

calambus

#5
Вот что имеется в поиске по этому звуковому чипсету : звук в Linux  STAC92xx Analog
Попробуйте установить и настроить Pulseaudio ...

Leo

#6
самое интересное - звук то есть в Gnome - из плеера, из бразузера... звуковая тема... всё работает...
неверные настройки?

установил pulseaudio, появился ещё один регулятор громкости в гноме (видимо потому что pulseaudio притащил за собой gnome-sound)... пик при загрузке/выключении/перезагрузке остался... в системе после загрузки звук есть... со звуком всё ок. Пиканье это, я думаю, сообщение об ошибке какое-то... вопрос - как эти системные сигналы настраиваются... на стационарных компах такие звуки ч/з системный динамик идут... а тут (на ноутбуке) через колонки - громко и неприятно.

calambus

#7
Вот что нашёл по этому поводу :
Debian lenny + notebook = звук не только из наушников
Открыть содержимое (спойлер)
Цитировать
    Если звука по прежнему нет, то нужно добавить в файл /etc/modprobe.d/alsa-base.conf одно из следующих значений:

    Для этого в терминале:
    [console]sudo gedit /etc/modprobe.d/alsa-base.conf[/console]
    Добавляем в конце строчку с одним из значений:

        options snd-hda-intel model="значение"

    Чтобы узнать какое именно значение вам нужно, вводим команду в терминале:
    [console]cat /proc/asound/pcm[/console]

    В выводе будут строчки с информацией о чипе наподобие этих:
    [console]00-00: STAC92xx Analog : STAC92xx Analog : playback 1 : capture 1
    00-01: STAC92xx Digital : STAC92xx Digital : playback 1[/console]

    Ниже в таблице ищем свой чип и берем оттуда значения. Описанию большого значения не придавать, оно подобрано владельцами этих звуковых карт.
    Если вам помогло какое-нибудь значение, а в описании этого значения нет модели вашего ноутбука, можете ее смело добавить в таблицу.

295 STAC9200
296 ========
297      ref        Reference board
298      oqo        OQO Model 2
299      dell-d21    Dell (unknown)
300      dell-d22    Dell (unknown)
301      dell-d23    Dell (unknown)
302      dell-m21    Dell Inspiron 630m, Dell Inspiron 640m
303      dell-m22    Dell Latitude D620, Dell Latitude D820
304      dell-m23    Dell XPS M1710, Dell Precision M90
305      dell-m24    Dell Latitude 120L
306      dell-m25    Dell Inspiron E1505n
307      dell-m26    Dell Inspiron 1501
308      dell-m27    Dell Inspiron E1705/9400
309      gateway-m4    Gateway laptops with EAPD control
310      gateway-m4-2    Gateway laptops with EAPD control
311      panasonic    Panasonic CF-74
312      auto        BIOS setup (default)
313   
[свернуть]
Pulseaudio работает поверх ALSA  , нужно запустить :
alsamixer
клавиша [H] --help , поискать там регулятор громкости Системного динамика [Beeper]

Leo

через гномовский интерфейс Параметры звука -> Устройства -> Выпадающий список Профили ставлю значение Off перезагружаю - звуковая тема отключается, а неубиваемый пик как пикал так и пикает...  >:(

calambus

Похоже это BIOS так о себе даёт знать , посмотрите его настройки или сделать сброс BIOS по умолчанию ...

Brainey

Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
  •  

Leo

#11
через alsamixer убавил громкость PC Beep в ноль, звук стал потише, но не исчез
BIOS скинул на настройки по-умолчанию... звук не исчез
совет Brainey не помог... звук не исчез (файл blacklist.conf проверил вручную - строка blacklist pcspkr присутствует, звук тоже)

ZEN

Цитата: Leo от 08 мая 2012, 16:22:48совет Brainey не помог... звук не исчез (файл blacklist.conf проверил вручную - строка blacklist pcspkr присутствует, звук тоже)

Я так понимаю комп не перезагрузил? Впрочем, можно и без перезагрузки выполнить:
sudo rmmod pcspkr
Crimea is Ukraine
  •  

Leo

#13
Цитата: ZEN от 08 мая 2012, 16:40:33
Я так понимаю комп не перезагрузил?
перезагрузил и после его команды и после вашей... проделывал первую в ttl под рутом вторую (вашу) - в терминале под рутом... впрочем это не важно...

поставил пакет beep - побаловаться... да - звук такой же (до этого пакет вообще не стоял, а звук был и разной частоты).

при загрузке/выключении в консоли мелькало сообщение VirtualBox ... (warning)... удалил VirtualBox, сообщение исчезло, звук остался...  >:(

====================

Друзья!
Всем спасибо за участие!
Решил проблему следующим образом: после удаления pulseaudio восстановил в трее стандартный регулятор громкости, далее правым кликом на его иконке, открывается окно "Параметры регулятора громкости", в нём есть список каналов для регулировки, в этом списке выбираю PCBeep, окно не закрываю, тыкаю на регуляторе громкости в трее ЛКМ, ставлю галку "Приглушить"! Всё! Все пики исчезли! В списке каналов в окне параметров ставлю обратно "Общий"! Сразу и не догадаться!
Успехов!

p.s.: лекарство было найдено тут

calambus

Leo , я рад за Вас , оказывается и на бренднеймоских аппаратах HP могу проявляться  заморочки под ALSA ...