Автор Тема: Видеодрайвер ATI / GNOME 3 зависает намертво  (Прочитано 3682 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн .Rock.

  • Пользователь
  • *
  • Сообщений: 25
Здравствуйте. Недавно обновился c Squeeze до Wheezy (unstable). Драйвера на видеокарту не стояли.
Возникли проблемы с гномом. Запускается по умолчанию в режиме совместимости, по экрану порой прыгают черные квадратики, оболочка подвисает. Gnome-shell - вообще тихий ужас, хотя и красивый. Сплошные тормоза.
Захотел поставить драйвера. Пытался как этим способом, так и просто установить из репозитария. В обоих случаях сходная ошибка:
Spoiler: ShowHide

Пакеты, имеющие неудовлетворённые зависимости:
 fglrx-driver : Зависит: xorg-video-abi-11 но он не может быть установлен или
                                xorg-video-abi-10 но он не может быть установлен или
                                xorg-video-abi-8 но он не может быть установлен или
                                xorg-video-abi-6.0
                Зависит: xserver-xorg-core (< 2:1.11.99) но 2:1.12.1-2 будет установлен
                Зависит: glx-alternative-fglrx (>= 0.2) но он не может быть установлен
                Рекомендует: libgl1-fglrx-glx (= 1:12-4-1) но он не будет установлен
 fglrx-glx : Зависит: libgl1-fglrx-glx но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Пытался откатиться до sid'a, там все то же.
« Последнее редактирование: 16 Мая 2012, 22:04:58 от .Rock. »
 

Оффлайн vladimir_ar

Все проще.
Качаете драйвер на свою карту с amd.com
Выходите в консоль Ctr-Alt-F1
переходите в каталог, где лежит драйвер.
sudo sh amd-driver-insatall.......run
sudo aticonfig --initial
reboot

Но. Если у вас не один монитор или не одна карта АТИ, и вы хотите их запустить - ничего хорошего не получится. Нормально Gnome-shell работает только с одной картой АТИ и с одним монитором.

Сообщение объединено: 16 Мая 2012, 00:12:41
Если не хотите использовать проприеритарные драйвера, то обязательно установить firmware-linux-nonfree и, если не установлены, mesa-dri и mesa-glx.
Но с экранами / картами то-же.
« Последнее редактирование: 16 Мая 2012, 00:12:41 от vladimir_ar »
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн HAEMHIK

  • Новичок форума
  • Сообщений: 6
кстати весь fglrx куда-то пропал из Wheezy, может переименовали ?  ???
 

Оффлайн .Rock.

  • Пользователь
  • *
  • Сообщений: 25
sudo sh <файл>.run
Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:3.2.0-2-686-pae; make sure that the version is being
correctly set by --iscurrentdistro
Как я понимаю, данная версия драйверов просто не поддерживается?
Цитировать
Если не хотите использовать проприеритарные драйвера, обязательно установить
А после установки этих пакетов? Как установить собственно драйвера? //Новичок в линукс, сильно не ругайте за глупые вопросы)
 

Оффлайн vladimir_ar

Если устанавливаете от АТИ - эти пакеты не нужны. Но обязательно поставте linux-headers для вашего ядра.
sudo apt-get install linux-headers-3.2.0-2-686-pae
Не уверен в правильности названия пакета, но можно и так
sudo apt-get install linux-headers*поставятся все заголовки, подходящие вам.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн .Rock.

  • Пользователь
  • *
  • Сообщений: 25
Большое спасибо  :)

Безоблачное счастье было недолгим.  GNOME безупречно работает 10 - 80 минут, после чего намертво зависает: содержимое экрана перестает менятся, курсор мыши двигается и даже меняет вид в зависимости от поля, находящимся под ним (поле ввода, например). На этом все. Терминал по Ctrl+Alt+F1, правда, открывается.
« Последнее редактирование: 16 Мая 2012, 22:04:02 от .Rock. »
 

Оффлайн Malaheenee

.Rock., вот здесь последний совет попробуйте.
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн .Rock.

  • Пользователь
  • *
  • Сообщений: 25
Нет, к сожалению, не помогло
« Последнее редактирование: 17 Мая 2012, 17:36:05 от .Rock. »
 

Оффлайн keekdown

Re: Видеодрайвер ATI / GNOME 3 зависает намертво
« Ответ #8 : 06 Июля 2012, 12:51:37 »
Посмотри вывод /var/log/messages.Ошибка там будет с префиксом (EE).Просто стандартный поток вывода и grep -->"cat /var/log/messages | grep (EE) >newfile" и newfile выложишь сюда
 

Теги:
     

    Как установить видеодрайвер, если пакет nvidia-xconfig не найден?

    Автор Мемфис

    Ответов: 5
    Просмотров: 4825
    Последний ответ 23 Августа 2015, 22:44:23
    от ioann.sys
    Видеодрайвер Debian 9.3

    Автор orphdedkai

    Ответов: 1
    Просмотров: 1211
    Последний ответ 18 Февраля 2018, 14:12:10
    от qupl
    Как правильно установить видеодрайвер nVidia?

    Автор CoolAller

    Ответов: 38
    Просмотров: 13690
    Последний ответ 03 Июня 2014, 23:46:32
    от CoolAller