Автор Тема: ошибка при установке  (Прочитано 1780 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ctulhu31

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 46
ошибка при установке
« : 20 Май 2012, 21:43:28 »
Process /usr/bin/session-installer exited with status 1вот это вылезает при установке любого приложения, от рута или от простого пользователя не имеет значения, всеравно лезет ошибка.
 

Оффлайн ihammers

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1742
  • Debian GNU/Linux Stretch
    • Алтайская Группа Пользователей Linux
  • Jabber: ihammers@jabber.ru
Re: ошибка при установке
« Ответ #1 : 20 Май 2012, 22:56:28 »
Process /usr/bin/session-installer exited with status 1вот это вылезает при установке любого приложения, от рута или от простого пользователя не имеет значения, всеравно лезет ошибка.
Приведите полный вывод.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн ctulhu31

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 46
Re: ошибка при установке
« Ответ #2 : 21 Май 2012, 06:37:03 »
ihammers,
root@ctulhu31:/home/ctulhu31/Загрузки# dpkg -i skype-debian_2.2.0.35-1_i386.deb
Selecting previously unselected package skype.
(Чтение базы данных ... на данный момент установлено 132670 файлов и каталогов.)
Распаковывается пакет skype (из файла skype-debian_2.2.0.35-1_i386.deb)...
dpkg: зависимости пакетов не позволяют настроить пакет skype:
 skype зависит от libqt4-dbus (>= 4.4.3), однако:
  Пакет libqt4-dbus не установлен.
 skype зависит от libqt4-network (>= 4.4.3), однако:
  Пакет libqt4-network не установлен.
 skype зависит от libqtcore4 (>= 4.4.3), однако:
  Пакет libqtcore4 не установлен.
 skype зависит от libqtgui4 (>= 4.4.3), однако:
  Пакет libqtgui4 не установлен.
dpkg: не удалось обработать параметр skype (--install):
 проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils ...
Обрабатываются триггеры для gnome-menus ...
При обработке следующих пакетов произошли ошибки:
 skype
root@ctulhu31:/home/ctulhu31/Загрузки# skype
skype: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory
root@ctulhu31:/home/ctulhu31/Загрузки#
вобщем вот так это выглядит в консоли.
А вот так это выглядит из гуя:
 

Оффлайн ihammers

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1742
  • Debian GNU/Linux Stretch
    • Алтайская Группа Пользователей Linux
  • Jabber: ihammers@jabber.ru
Re: ошибка при установке
« Ответ #3 : 21 Май 2012, 08:02:46 »
Так пакет не может установиться, так как он требует ещё несколько пакетов:
apt-get install libqt4-dbus libqt4-network libqtcore4 libqtgui4
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн ctulhu31

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 46
Re: ошибка при установке
« Ответ #4 : 21 Май 2012, 08:05:30 »
ihammers, вот именно весь прикол в том что зависимости автоматом не определяются и не разрешаются, приходится руками все делать, а неохота каждый раз.
 

Оффлайн Malaheenee

  • Ветеран
  • *****
  • Сообщений: 2565
  • Учтите, мы можем дать и вредный совет.
Re: ошибка при установке
« Ответ #5 : 21 Май 2012, 11:39:13 »
При таком способе установки они и не определятся. dpkg самостоятельно не умеет доустанавливать зависимости. Погуглите, ссылок полно.
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн ctulhu31

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 46
Re: ошибка при установке
« Ответ #6 : 21 Май 2012, 13:32:15 »
Malaheenee, собственно вся проблема в том что гуй автоматом умеет зависимости разрешать, однако см. скриншот в 3 посте
 

Теги:
 

Ошибка при обновлении Debian 8 до Debian 9

Автор Ferox2017

Ответов: 4
Просмотров: 1472
Последний ответ 21 Июнь 2017, 10:54:52
от qupl
Ошибка при компиляции в Lazarus

Автор flyer

Ответов: 3
Просмотров: 2448
Последний ответ 22 Сентябрь 2014, 13:15:00
от flyer
[РЕШЕНО] Ошибка в kwrite или нет?

Автор Metrix

Ответов: 3
Просмотров: 2351
Последний ответ 08 Март 2011, 00:38:52
от Ghostdmn
При выполнении команды update-grub ошибка not foundrub-mkconfig: 5

Автор Bojokot

Ответов: 1
Просмотров: 1398
Последний ответ 24 Сентябрь 2017, 14:47:07
от Juriy
Ошибка с locale

Автор diefair

Ответов: 0
Просмотров: 1396
Последний ответ 28 Октябрь 2014, 15:43:21
от diefair