Skype на Debian x86_64

Автор sCode, 28 мая 2012, 20:35:38

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

sCode

Пытаюсь установить:
sudo dpkg -i skype-debian_2.2.0.35-1_amd64.deb(Чтение базы данных ... на данный момент установлено 139462 файла и каталога.)
Подготовка к замене пакета skype 2.2.0.35-1 (используется файл skype-debian_2.2.0.35-1_amd64.deb) ...
Распаковывается замена для пакета skype ...
dpkg: зависимости пакетов не позволяют настроить пакет skype:
skype зависит от lib32stdc++6 (>= 4.1.1-21), однако:
  Пакет lib32stdc++6 не установлен.
skype зависит от lib32asound2 (>> 1.0.14), однако:
  Пакет lib32asound2 не установлен.
skype зависит от ia32-libs, однако:
  Пакет ia32-libs не установлен.
skype зависит от lib32gcc1 (>= 1:4.1.1-21+ia32.libs.1.19), однако:
  Пакет lib32gcc1 не установлен.
skype зависит от ia32-libs-gtk, однако:
  Пакет ia32-libs-gtk не установлен.
dpkg: не удалось обработать параметр skype (--install):
проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils ...
Обрабатываются триггеры для gnome-menus ...
При обработке следующих пакетов произошли ошибки:
skype

Ставлю зависимости:
sudo apt-get install ia32-libs ia32-libs-gtk libasound2-plugins
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
ia32-libs : Зависит: lib32bz2-1.0 но он не будет установлен
             Зависит: lib32asound2 (> 1.0.18) но он не будет установлен
             Зависит: lib32gcc1 (>= 1:4.1.1) но он не будет установлен
             Зависит: lib32ncurses5 (>= 5.7+20100313) но он не будет установлен
             Зависит: lib32stdc++6 (>= 4.1.1) но он не будет установлен
             Зависит: lib32v4l-0 (>= 0.5.0) но он не будет установлен
             Зависит: lib32z1 (>= 1:1.2.3.3.dfsg) но он не будет установлен
ia32-libs-gtk : Зависит: lib32asound2 (> 1.0.18) но он не будет установлен
                 Зависит: lib32gcc1 (>= 1:4.1.1) но он не будет установлен
                 Зависит: lib32stdc++6 (>= 4.1.1) но он не будет установлен
                 Зависит: lib32z1 (>= 1:1.1.4) но он не будет установлен
libasound2-plugins : Зависит: libsamplerate0 но он не будет установлен
skype : Зависит: lib32stdc++6 (>= 4.1.1-21) но он не будет установлен
         Зависит: lib32asound2 (> 1.0.14) но он не будет установлен
         Зависит: lib32gcc1 (>= 1:4.1.1-21+ia32.libs.1.19) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).

Не получилось, может кто знает как решить?
  •  

Udachnik

Просто выполни aptitude install. Первый вариант будет удалить пакеты, а второй как раз установить все необходимые пакеты.
  •  

sCode

Спасибо, а как сменить оформление элементов управления, чтобы они не выглядели как во времена Windows 95?

  •  

SeHELLioN

он на gtk, поэтому, соответственно, сменой темы gtk
  •  

vladimir_ar

У него в настройках есть некоторый выбор тем, в том числе, помоему, и виндовс.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

sCode

Поставил clearlooks, теперь все нормально.
  •  

Легас

Ребята, подскажите как мне установить на 64 архитектуру. Перешёл на 6.0.6 _64 стаб. На обычной 86 всё ставилось. Пробовал с десяток вариантов и не один не дал результатов. А теперь всю систему засерил. Последнее действие напроч тупануло меня. После установки по мануалу на одном из сайтов, скаип вроде как бы установился, появился значок в меню, но не запускается. Пробую в терминале запустить, он мне пишет -  у вас типа в системе нет скайпа. Я его пытаюсь удалить, пишет - скаип не возможно удалить, т.к. он виртуальный.

Может мне на 32 архитектуру вернуца?
  •  

Yrii

По этой инструкции пробывал? - https://wiki.debian.org/skype
  •  

Легас

#8
Этот вариант я как раз самым первым делом и пробовал. Вылезают ошибки, как и у других, нашол несколько постов по этой теме, но ничего???? ???

Охо хо хо хо!!! Наверно вернусь всё же на 32, видимо с 64 пока я не дружу.
  •  

ihammers

Цитата: Легас от 08 марта 2013, 22:56:42
...
Наверно вернусь всё же на 32, видимо с 64 пока я не дружу.
А добавить в систему Multi-Arch?
~# dpkg --add-architecture i386
~# apt-get update
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
  •  

Легас

Ну вот что  он мне выдаёт:

Открыть содержимое (спойлер)
dpkg --add-architecture i386
dpkg: неизвестный параметр --add-architecture

Справка по установке и удалению пакетов доступна по команде dpkg --help
  • ;
    Программа «dselect» или «aptitude» предоставляет дружественный интерфейс
    управления пакетами;
    Чтобы получить список значений флагов отладки dpkg, введите dpkg -Dhelp;
    Чтобы получить информацию об игнорировании проблем, введите dpkg --force-help;
    Чтобы получить справку по работе с файлами *.deb, введите dpkg-deb --help;

    Команды, отмеченные
  • , выводят большое количество информации.
    Объедините их в конвейер с программами «less» или «more»!
[свернуть]
и вот после скачивания пакета skype по wget:
Открыть содержимое (спойлер)
dpkg -i skype-install.deb
dpkg: не удалось обработать параметр skype-install.deb (--install):
архитектура пакета (i386) не соответствует архитектуре системы (amd64)
При обработке следующих пакетов произошли ошибки:
skype-install.deb
[свернуть]

Может тогда 2.2 версию поставить, я где-то видел на 64?


  •  

Евгений

Думаю, что где-то какая-то мелкая ошибка в написании архитектуры или ещё чего-нибудь. У меня 64 и ставлю по рецепту с сайта Skype без проблем - там есть, поищите.
  •  

Легас

Я поставил  версию  2.2.0.35, пока что на время. Подожду 7 стабильную. Меня в принципе всё устраивает.
  •  

Alexsto

Были проблемы с установкой, но только потому, что у каждого своя сборка дистрибутива и разное железо и не все советы подходят, хотя особенности одинаковы.
Как  удалось установить в Deian 6.0.7 — Skype
(для Athlon 64x2 Core Proc.4200+2,20Гц.)
выполняем установку дополнительных библиотек (без них Skype просто откажется работать)
aptitude install ia32-libs ia32-libs-gtk libqt4-core libqt4-gui libqt4-webkit
Переходим в папку где лежит наш deb пакет например : cd /home/user/downloads/
Устанавливаем : dpkg -i --force-architecture skype-ubuntu-lucid_4.1.0.20-1_i386.deb (название пакета может различаться)
Скачиваем эти либы dl.dropbox.com/u/39000641/lib32skype.tar
Распаковываем : tar -xvf lib32skype.tar -C /lib32
На всякий случай выполним еще : apt-get install lib32asound2 ia32-libs ia32-libs-gtk (непомню есть ли они в debian по-умолчанию или нет) — Они были установлены !
Skype  - Установлен ! Если нет записи звука, проверить локальнае настройки.
разбирался по этой ссылке : http://www.debian-blog.ru/internet/ustanovka-skype-na-debian-amd64.html
  •  

noaer

Установи с официального сайта новую версию, чего паришься
Цена величия — это ответственность за каждую свою мысль.
  •