при чём здесь busybox

Автор Olej, 12 июня 2012, 19:25:32

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Olej

- установка Debian 6.0.5
- установка под VirtualBox (4.16 ... - последний, работает под Fedora 15)
- установка из ISO образов debian-testing-i386-netinst.iso и из debian-testing-i386-CD-1.iso ...

Везде история одинаковая: установка базовой системы обрывается с сообщением об ошибке: "... невозможно установить пакет busybox" !

При чём тут вообще BusyBox ???
Я достаточно много встречался с BusyBox ... и в Android, и при сборке embedded образов ... под процессор ARM.

Но какое отношение может иметь  BusyBox к установке десктопного Debian под самый что ни есть i386 ???

Или что там с  debian-testing-i386-* ???

rayanAyar

Дак testing ставите или 6.0.5 ?

Olej


cema

Цитата: Olej от 12 июня 2012, 19:25:32


Или что там с  debian-testing-i386-* ???
поломаный установщик уже несколько дней, пишите багрепорт

Olej

Цитата: rayanAyar от 12 июня 2012, 19:58:24
Дак testing ставите или 6.0.5 ?

Установочный образ "вроде как стабильный"  ;) debian-6.0.5-i386-netinst.iso - тоже битый, из него можно поставить систему, но только без графической системы - в текстовой консоли + потом доставлять (я доставлял Xfce) уже графику через aptitude или apt-get.

Что ж это за такая "нетщательность" в этом дистрибутиве?!

cema

Цитата: Olej от 12 июня 2012, 19:25:32

Установочный образ "вроде как стабильный"  ;) debian-6.0.5-i386-netinst.iso - тоже битый, из него можно поставить систему, но только без графической системы - в текстовой консоли + потом доставлять (я доставлял Xfce) уже графику через aptitude или apt-get.

Что ж это за такая "нетщательность" в этом дистрибутиве?!

а может там в зеркалах проблема? у меня 6.0.5-i386-netinst.iso нормально устанавливается

Olej

#6
Цитата: cema от 12 июня 2012, 20:09:51
поломаный установщик уже несколько дней, пишите багрепорт

я не знаю как и куда это в Debian делается.


Сообщение объединено: 12 июня 2012, 21:47:34

Цитата: cema от 12 июня 2012, 20:41:52а может там в зеркалах проблема? у меня 6.0.5-i386-netinst.iso нормально устанавливается

Может быть и так, но не очень похоже.
Вот только-что поставил debian-6.0.5-i386-CD-1.iso ... вроде как с того же зеркала.

Теперь допишу /etc/apt/sources.list до tested - посмотрю как он теперь будет обновляться.

Но что удивляет, что установщик требует BusyBox:
- BusyBox никогда не используется в десктопных конфигурациях вообще...
- это эквивалент/замена bash ... вообще shell + все GNU утилиты...
- всё это для малых и встроенных конфигураций.

cema

Цитата: Olej от 12 июня 2012, 21:41:23
Цитата: cema от 12 июня 2012, 20:09:51
поломаный установщик уже несколько дней, пишите багрепорт

я не знаю как и куда это в Debian делается.

Вот тут http://lists.debian.org/debian-cd/2012/06/msg00003.html уже есть сообщение о проблеме, остается только ждать когда обратят внимание.

Olej

Цитата: cema от 13 июня 2012, 11:31:02
Цитата: Olej от 12 июня 2012, 21:41:23
Цитата: cema от 12 июня 2012, 20:09:51
поломаный установщик уже несколько дней, пишите багрепорт

я не знаю как и куда это в Debian делается.

Вот тут http://lists.debian.org/debian-cd/2012/06/msg00003.html уже есть сообщение о проблеме, остается только ждать когда обратят внимание.

Т.е. резюме на сегодня должно выглядеть так?:
1. все образы-инсталляторы ветки testing - битые.
2. ставьте stable 6.0.5 ... не выделывайтесь.
3. ждите ... возможно когда-то добрый дядя и подправит.

P.S. сделал такой трюк:
- установился с debian-6.0.5-i386-CD-1.iso
- переписал в /etc/apt/sources.list в репозитариях squeeze на testing ...

$ sudo apt-get update
$ sudo apt-get dist-upgrade

А вот здесь: болт вам ... - что-то с версиями gcc неудовлетворённое.
(хотя когда-то раньше ... месяц назад? у меня подобный номер проходил).

В итоге:
- установка версии testing на сегодня невозможна!

Так такие ж радостные новости должны вывешиваться в новостях на самом входе в любой ресурс Debian, и аршинными буквами bold-шрифтом - чтоб люди не долбались!
 

qupl

ВСЕ
Olej,  это не может быть правдой, потому что я наблюдаю у себя 3 ПК с установленным testing.
[свернуть]

ihammers

Цитата: Olej от 13 июня 2012, 14:31:02
Т.е. резюме на сегодня должно выглядеть так?:
1. все образы-инсталляторы ветки testing - битые.
2. ставьте stable 6.0.5 ... не выделывайтесь.
3. ждите ... возможно когда-то добрый дядя и подправит.

P.S. сделал такой трюк:
- установился с debian-6.0.5-i386-CD-1.iso
- переписал в /etc/apt/sources.list в репозитариях squeeze на testing ...

$ sudo apt-get update
$ sudo apt-get dist-upgrade

А вот здесь: болт вам ... - что-то с версиями gcc неудовлетворённое.
(хотя когда-то раньше ... месяц назад? у меня подобный номер проходил).

В итоге:
- установка версии testing на сегодня невозможна!

Так такие ж радостные новости должны вывешиваться в новостях на самом входе в любой ресурс Debian, и аршинными буквами bold-шрифтом - чтоб люди не долбались!
 

Я у меня получилось установить testing из stable.) 
И все очень просто: качаем debian-6.0.5-amd64-netinst.iso, устанавливаем систему и правим sources.list:
deb http://ftp.ru.debian.org/debian wheezy main contrib non-free
Обновляем список пакетов и обновляем систему:
apt-get update
apt-get upgrade

Перезагружаем систему и обновляемся дальше:
reboot
apt-get dist-upgrade


PS: устанавливал на виртуалку, установка заняла минут 30.  В итоге получаем чистый testing, который можно уже настраивать как вам нужно.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290

Olej

#11
Цитата: ihammers от 13 июня 2012, 15:22:54PS: устанавливал на виртуалку, установка заняла минут 30.  В итоге получаем чистый testing, который можно уже настраивать как вам нужно.

Проверяю.  :)


Сообщение объединено: 13 июня 2012, 16:07:00

Цитата: qupl от 13 июня 2012, 15:12:50Olej,  это не может быть правдой, потому что я наблюдаю у себя 3 ПК с установленным testing.

Что значит не может?
1. оторви задницу от дивана и проверь ручками, а то только "видел, видел ..."  :(
2. эти testing могли быть установлены и неделю назад, и 2, и 3 ... до того самого удачного обновления образов, после которого они остались все неработоспособными.


Сообщение объединено: 13 июня 2012, 16:08:10

А как же с вот этим быть?!  ;):
Цитата: cema от 13 июня 2012, 11:31:02Вот тут http://lists.debian.org/debian-cd/2012/06/msg00003.html уже есть сообщение о проблеме, остается только ждать когда обратят внимание.


cema

Цитата: Olej от 13 июня 2012, 14:31:02все образы-инсталляторы ветки testing - битые.
не факт, я уже во время того как проблема (назовём её #674488, как она зарегистрирована в багрепорте) была, установил testing из образа debian-testing-i386-businesscard.iso
Цитата: Olej от 13 июня 2012, 14:31:02ждите ... возможно когда-то добрый дядя и подправит.
поправят, куда денутся, релиз не за горами. У меня самого работа из-за этой ошибки приостановилась, а то б стал я по форумам заглядывать.

Olej

#13
Цитата: cema от 13 июня 2012, 16:18:13
У меня самого работа из-за этой ошибки приостановилась, а то б стал я по форумам заглядывать.
У меня та же история  :-\


Сообщение объединено: 13 июня 2012, 16:27:35

Цитата: cema от 13 июня 2012, 16:18:13установил testing из образа debian-testing-i386-businesscard.iso

А это что за образ?


Сообщение объединено: 13 июня 2012, 16:41:54

Цитата: ihammers от 13 июня 2012, 15:22:54apt-get dist-upgrade
Цитата: ihammers от 13 июня 2012, 15:22:54у меня получилось установить testing из stable.) 

В точности по вашей инструкции:

root@debian:~# apt-get dist-upgrade
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Расчёт обновлений... Неудачно
Пакеты, имеющие неудовлетворённые зависимости:
libc6-dev : Ломает: gcc-4.4 (< 4.4.6-4) но 4.4.5-8 будет установлен
libgcc1 : Ломает: gcc-4.4 (< 4.4.6-4) но 4.4.5-8 будет установлен
libgfortran3 : Ломает: gcc-4.4 (< 4.4.6-4) но 4.4.5-8 будет установлен
libgomp1 : Ломает: gcc-4.4 (< 4.4.6-4) но 4.4.5-8 будет установлен
libstdc++6 : Ломает: gcc-4.4 (< 4.4.6-4) но 4.4.5-8 будет установлен
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.

- это скопировано с терминала, я сам такого придумать не могу  ;D

Разница может быть:
- у вас debian-6.0.5-amd64-netinst.iso, у меня debian-6.0.5-i386-CD-1.iso (64/32 бит).
- у вас установка с графическим окружением? с каким? у меня с GNOME (дефаулт, CD-1)
- какая VM? (хоть это к установке и не имеет отношения), у меня VirtualBox 4.16.

cema

Цитата: Olej от 13 июня 2012, 16:27:04А это что за образ?
вот тут он лежит http://cdimage.debian.org/cdimage/daily-builds/daily/arch-latest/i386/iso-cd/, отличается от netinstall тем, что для установки базовой системы требует сеть.