psycopg2

Автор xxnikolayxx, 18 июня 2012, 19:53:31

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

xxnikolayxx

Не могу установить пакет на Debian.
# apt-get install python-psycopg2
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:
Пакеты, имеющие неудовлетворённые зависимости:
python-psycopg2 : Зависит: python-egenix-mxdatetime но он не будет установлен
                   Зависит: python (< 2.7) но 2.7.3~rc2-1 будет установлен
Глупая какая-то проблема.
Как ее решить?

qupl

Конечно же до установки делали sudo aptittude update ?
Какая ветка debian? Покажите содержимое /etc/apt/sources.list.

xxnikolayxx

#2
aptitude update
делали.
#  lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 6.0.5 (squeeze)
Release: 6.0.5
Codename: squeeze

# cat /etc/apt/sources.list

# deb cdrom:[Debian GNU/Linux 6.0.5 _Squeeze_ - Official i386 DVD Binary-1 20120512-13:45]/ squeeze contrib main
#deb cdrom:[Debian GNU/Linux 6.0.5 _Squeeze_ - Official i386 DVD Binary-1 20120512-13:45]/ squeeze contrib main
deb http://ftp.fr.debian.org/debian/ lenny main
deb-src http://ftp.fr.debian.org/debian/ lenny main
deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free
deb http://backports.debian.org/debian-backports lenny-backports main contrib non-free
deb-src http://backports.debian.org/debian-backports lenny-backports main contrib non-free
deb http://mirror.yandex.ru/debian/ squeeze main
deb-src http://mirror.yandex.ru/debian/ squeeze main
deb http://security.debian.org/ squeeze/updates main contrib
deb-src http://security.debian.org/ squeeze/updates main contrib
# squeeze-updates, previously known as 'volatile'
deb http://mirror.yandex.ru/debian/ squeeze-updates main contrib
deb http://backports.debian.org/debian-backports squeeze-backports main contrib non-free
deb http://ftp.ru.debian.org/debian testing main non-free contrib
deb http://ftp.ru.debian.org/debian unstable main non-free contrib
deb-src http://mirror.yandex.ru/debian/ squeeze-updates main contrib

Ghostdmn

#3
Н-да. Удалить репы lenny, подключать unstable по мере необходимости. Вот и весь рецепт
8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100

xxnikolayxx

#4
Удалил, проблема сохраняется.

Сообщение объединено: 18 июня 2012, 21:01:35

Может посоветуете правильные репозитории? Или что вообще делать, пакет то нужен.

Brainey

Цитата: xxnikolayxx от 18 июня 2012, 20:53:20Может посоветуете правильные репозитории? Или что вообще делать, пакет то нужен.
Он доступен для всех поддерживающихся релизов. Возможно, установить пакет получится, если привести sources.list в порядок.
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru

xxnikolayxx

Цитата: Brainey от 18 июня 2012, 21:30:55
Цитата: xxnikolayxx от 18 июня 2012, 20:53:20Может посоветуете правильные репозитории? Или что вообще делать, пакет то нужен.
Он доступен для всех поддерживающихся релизов. Возможно, установить пакет получится, если привести sources.list в порядок.
Как в таком случае его привести в порядок?

qupl

offtop
В последнее время наблюдается распространение жутчайшего винегрета в source.list-ах у пользователей.  :(
[свернуть]

Оставить ветки от squeeze, не?

xxnikolayxx

Оставил только их, обновил, проблема осталась.
Придется копать самому.
Если кто поможет, буду рад.

Brainey

Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru

qupl

Попробуй
apt-get --reinstall install python python-psycopg2

Сначала source.list, конечно, привести в порядок!!!

xxnikolayxx

Всем спасибо за отклики, ничего не выходит.
Переставлю систему.
Видимо я намудрил при установке.
И на последок спрошу: Подскажите, как маны полностью русифицировать, статью какую-нить почитать?
И как запретить установку python 26 при установке системы? и ставить сразу 27?

qupl

В squeeze только 2.6 и ниже.

xxnikolayxx

А какую debian посоветуете для веб сервера.
Если конкретнее - для Django проектов?

SeHELLioN

ну вообще для серверва вообще стэйбл обычно ставят (адекватные люди ;D)
Открыть содержимое (спойлер)
что такое Django - не знаю
[свернуть]