Автор Тема: [Решено] Google Chrome - проблема с Flash  (Прочитано 2363 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн oOLokiOo

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
[Решено] Google Chrome - проблема с Flash
« : 10 Август 2012, 21:20:24 »
Доброго времени суток!
Стоит Debian 6 и KDE. Ролики с флешем работают по рандому. То нормально, то стартуют без звука и идёт пару секунд а потом зависают (пока не тыкнешь по линие загрузки. далее опять идут пару секнд и также зависают).
Не подскажите куда смотреть?
« Последнее редактирование: 09 Май 2013, 18:05:16 от qupl »
 

Оффлайн corner

  • Местный житель
  • ***
  • Сообщений: 211
Re: Google Chrome - проблема с Flash
« Ответ #1 : 10 Август 2012, 22:24:53 »
Попробуйте зайти в about:plugins. Там увидите, что у вас указано 2 Flash плагина. Один отключите.
 

Оффлайн oOLokiOo

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
Re: Google Chrome - проблема с Flash
« Ответ #2 : 11 Август 2012, 00:21:23 »
а можно немного подробней? речь о вкладке chrome://chrome/extensions/ ?
просто там нет ничего связанного с флешем , а только те плагины которые я сам ставил
 

Оффлайн corner

  • Местный житель
  • ***
  • Сообщений: 211
Re: Google Chrome - проблема с Flash
« Ответ #3 : 11 Август 2012, 00:37:59 »
Сори... В адресной строке набираете chrome://plugins/
Далее увидите перечень плагинов (во вложенном снимке).
Жмете ссылку справа вверху details, вносите изменения (disable/enable), что означает отключить/включить.
Перезапускает броузер.

P.S. Плагин и расширение (extensions) - две большие разницы, как говорят в Одессе  ;D
« Последнее редактирование: 11 Август 2012, 00:40:10 от corner »
 

Оффлайн oOLokiOo

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
Re: Google Chrome - проблема с Flash
« Ответ #4 : 11 Август 2012, 17:08:34 »
не помогло...


Сообщение объединено: 11 Август 2012, 17:10:16
где-то слышал, что нужно скачать самый свежий флеш с офф. сайта и заменить какие-то файлики в самой папке с хромом, может в эту сторону продолжать копать?
« Последнее редактирование: 11 Август 2012, 17:10:16 от oOLokiOo »
 

Оффлайн corner

  • Местный житель
  • ***
  • Сообщений: 211
Re: Google Chrome - проблема с Flash
« Ответ #5 : 11 Август 2012, 20:52:03 »
1. Вторым плагином у вас Gnash - удалите его совсем. И установите пакет из non-free flashplugin-nonfree, на него и переключитесь.
2. Если у вас видеокарта NVIDIA - попробуйте откатиться на 10-ю версию flashplayer.
Для chrome это просто, к сожалению, уже не просто.
Попробуйте поставить Chromium (+flashplugin-nonfree)- то же самое, в принципе.
 

Оффлайн Ghostdmn

  • Старожил
  • ****
  • Сообщений: 854
  • Jabber: ghostdmn@jabber.cz
Re: Google Chrome - проблема с Flash
« Ответ #6 : 12 Август 2012, 12:53:29 »
Совсем недавно, помнится, 11 флеш для 386 не работал. Откатывал человеку на 10-ий (есть в архивах сайта). Может что и исправили, но имейте в виду
8Gb/GTX750Ti 2Gb/AMD FX(tm)-4300 Quad-Core Processor/HDD 1Tb Toshiba DT01ACA100
 

Оффлайн oOLokiOo

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
Re: Google Chrome - проблема с Flash
« Ответ #7 : 14 Август 2012, 10:59:23 »
Gnash - снёс, а вот с форума, все линки 10ого плеера ведут на битые уже ссылки с adobe.com или macromedia.com
 

Оффлайн corner

  • Местный житель
  • ***
  • Сообщений: 211
Re: Google Chrome - проблема с Flash
« Ответ #8 : 14 Август 2012, 11:24:03 »
Держите. Версия  i386. Вам же под эту архитектуру?
« Последнее редактирование: 14 Август 2012, 11:25:37 от corner »
 

Оффлайн oOLokiOo

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
Re: Google Chrome - проблема с Flash
« Ответ #9 : 14 Август 2012, 21:22:16 »
да что ж ты будешь делать)
поставил Хромиум, там вообще пишет что не может инициализировать флеш плагин.
flashplugin-nonfree - похоже не может найти в моём репозитарии.
везде натыкаюсь на инфу, что нужно просто закинуть libflashplayer.so в /opt/google/chrome/plugins и он сам подхватится, но у меня он не подхватывается... :(
может нужно удалить спрерва этот libpepflashplayer.so и оно от безисходности полезет в /plugins ?
 

Оффлайн corner

  • Местный житель
  • ***
  • Сообщений: 211
Re: Google Chrome - проблема с Flash
« Ответ #10 : 14 Август 2012, 21:50:56 »
1. Flashplugin-nonfree не можете найти наверное потому, что в sources.list не указан contrib.
http://packages.debian.org/squeeze/flashplugin-nonfree
Цитировать
... main contrib non-free
. Как настроить - есть на форуме.
http://wiki.debian.org/SourcesList
После этого # aptitude update && aptitude safe-upgrade && aptitude install flashplugin-nonfree2. Я уже говорил, что с chrome не все так просто. Попробуйте переименовать libflashplayer.so в  libpepflashplayer.so. Но это ничего не даст, потому что при обновлении все изменится на новый файл.
3. "Хитрый" способ понижения версии flashplugin, в частности, состоит в том, чтобы установить flashplugin-nonfree, затем заменить у него файл плагина, после чего "заморозить" пакет от обновления. Такой вот костылек.
4. Ссылка на adobe архив:
http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html
 

Оффлайн oOLokiOo

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 13
Re: Google Chrome - проблема с Flash
« Ответ #11 : 14 Август 2012, 22:17:05 »
и таки да, добавил contrib non-free
сделал aptitude update && aptitude safe-upgrade && aptitude install flashplugin-nonfree
появился /usr/lib/flashplugin-nonfree/libflashplayer.so
задисаблил /opt/google/chrome/PepperFlash/libpepflashplayer.so
все заработало :)
большущее спасибо, corner!)

Сообщение объединено: 15 Август 2012, 15:01:09
но кстати, всё равно немного глюкнуто работает. если открыто несколько табов и в одном из них присутствует видео-ролик, он просвечивается в других табах) но с этим я так полагаю, придёться уже смириться
« Последнее редактирование: 15 Август 2012, 15:01:09 от oOLokiOo »
 

Теги:
 

[Решено] Отключить текстовые сообщения при загрузке Debian.

Автор ilyakarev

Ответов: 5
Просмотров: 4480
Последний ответ 25 Апрель 2012, 11:30:29
от Valeron
Проблема с зависимостями: E: Sub-process /usr/bin/dpkg returned an error code

Автор AndreiRed

Ответов: 16
Просмотров: 4252
Последний ответ 14 Сентябрь 2016, 11:44:27
от endru
Debian для слабого ноутбука. [РЕШЕНО]

Автор sx88

Ответов: 15
Просмотров: 15514
Последний ответ 24 Февраль 2013, 12:08:14
от calambus
Проблема с настройкой Prosody

Автор nihi1ist

Ответов: 0
Просмотров: 1300
Последний ответ 03 Ноябрь 2017, 14:01:26
от nihi1ist
[Решено] Помогите с простым скриптом запуска приложения

Автор Sergei_Alekseev

Ответов: 27
Просмотров: 4670
Последний ответ 06 Август 2013, 06:35:28
от qupl