Автор Тема: Проблемы со звуком. Не работает переключалка аудиоустройств.  (Прочитано 2250 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tarik

Перешел на Дебиан из Убунты, окончательно расстроившись из-за Unity и стремления Убунты в сторону увеличения тормозов.
Установил на ноут Дебиан 6 стабильный.
Имею естественно встроенный звук, а также выносную USB-звуковуху, но в системе почему-то 3 девайса.

tarik@Tarik:~$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xb4100000 irq 22
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xb4020000 irq 17
 2 [USB            ]: USB-Audio - E-MU 0202 | USB
                      E-MU Systems, Inc. E-MU 0202 | USB at usb-0000:00:1d.0-1.2, high speed

tarik@Tarik:/home/tarik# cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel
 2 snd_usb_audio

Через меню Параметры->Звук переключалка между 3 девайсами не работает. Звук идет все время через ноут. В Убунте работало.
Консольный alsamixer тоже ничего не меняет.

Также не работает звук в некоторых программах. Например, в игре Герои4, запущенной под Вайном, звук есть, а в игре WOW - нет.
В собранной для Линукса игре Enemy territory звук не работает, а в броузере и в проигрывателе звук есть.
Хотелось бы научиться в этом разбираться. Не понятно, куда там какие потоки перетекают, кто их куда не пускает.
Если запустить wow под рутом, то звук есть. Пробовал добавлять учетную запись в группу sound. Ничего не изменилось.
К сожалению времени очень мало с этим разбираться, поэтому пишу сюда в надежде на помощь.
 

Оффлайн dimsat1

Если запустить wow под рутом, то звук есть
... попробуй удали папку .pulse по пути /home/пользователь/.pulse
а затем перезапусти пульс:
# killall -9 pulseaudio$ pulseaudio --startПоидее должно помочь :)
debian(jessie) ...DE_Mate... LINUX - FOREVER!
Sams Smart IPTV nStreamLmod_v.3.х
 

Оффлайн Tarik

У меня не стоит pulseaudio, а директорию удалил, осталась от Убунту.
 

Оффлайн I-Jurij

Домашнюю папочку убунты я бы сохранил где-нибудь на всякий на всякий случай, и запустил бы все с пустой папкой home. Мне помогало.
 

Оффлайн Tarik

С пустой папкой home не запускается. Можно поподробнее?
Пробовал также создавать рутом новую директорию пользователя, но с правами так и не разобрался.
При загрузке все ругаются, что не могут в новой папке ничего создать.
 

Оффлайн dimsat1

Так, что ты в папке /home/ удалил папку пользователя?...
Создай нового пользователя через параметры системы->учётные записи пользователей или через команду в терминале:
# adduser имяпример,создаю нового пользователя x:
:)
« Последнее редактирование: 06 Сентября 2012, 01:25:54 от dimsat1 »
debian(jessie) ...DE_Mate... LINUX - FOREVER!
Sams Smart IPTV nStreamLmod_v.3.х
 

Оффлайн Tarik

Не удалил. :)
Завтра попробую. Спасибо за совет.

Сообщение объединено: 06 Сентября 2012, 23:15:03
Создал пользователя. То же самое. Переключалка не работает под новым юзером.
3 карты, 3 модуля, а в гуевой переключалке добавилось 4 устройство, т.к. установил OSS.
А в Убунту было удобно: вставляешь USB, звук переходит на колонки. Причем так было из коробки.
Может надо установить pulseaudio?
« Последнее редактирование: 06 Сентября 2012, 23:15:03 от Tarik »
 

Оффлайн Malaheenee

Tarik, походу, да, раз альса так не дружит.
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн Tarik

Поставив пульс, наконец, услышал звук из колонок, но:
1. В хроме не удается направить звук на колонки (пульс пишет, что нет приложений, использующих звук)
2. В проигрывателе наоборот: звук только через колонки.
3. Вайн по-прежднему требует рута и тоже пульс его не видит, а звук только через ноут идет.
Снес oss. Не знаю, зачем ставил, не знаю, зачем снес. Ничего не изменилось.
Возможно, что проблема только в доступе к аудиодевайсу.
Знать бы еще, как его получить...
 

Теги:
     

    Проблемы при установке Vundle в vim

    Автор Palamar

    Ответов: 0
    Просмотров: 1588
    Последний ответ 21 Марта 2017, 14:16:36
    от Palamar
    Проблемы с dpkg --add-architecture i386

    Автор Tammy

    Ответов: 2
    Просмотров: 3709
    Последний ответ 08 Января 2013, 17:45:40
    от Tammy
    Решит ли переустановка системы проблемы обновления?

    Автор Artuom

    Ответов: 16
    Просмотров: 3871
    Последний ответ 23 Июля 2013, 12:42:39
    от Artuom
    Проблемы с rtf в LO5 под Дебиан9

    Автор ЦарьПушка

    Ответов: 12
    Просмотров: 1564
    Последний ответ 10 Декабря 2017, 14:03:37
    от ЦарьПушка
    Проблемы просле autoremove [РЕШЕНО]

    Автор alimuradov

    Ответов: 11
    Просмотров: 2141
    Последний ответ 20 Января 2014, 09:05:24
    от alimuradov