Автор Тема: ATI+Debian Wheezy  (Прочитано 3943 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Metrix

ATI+Debian Wheezy
« : 08 Октября 2012, 15:13:35 »
Всем доброго!
Сабж такой: устанавливаю драйвер для видеокарты АТИ Mobility Radeon HD 4500 Series в Debian Wheezy руководствуясь вики. После ввода команды
# aticonfig --initialполучаю
aticonfig: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directoryПробывал скачивать с оффсайта драйвера и их установить, результат тот же.
В гугле наткнулся на эту статью. После ввода команд
# export LD_LIBRARY_PATH=/usr/lib64/
# aticonfig --initial
получаю
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saving back-up to /etc/X11/xorg.conf.original-2
но это только до перезагрузки системы. Во время загрузки все равно мелькает сообщение aticonfig: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
В чем проблема и как решить? Собственно иксы не грузятся вот лог
Spoiler: ShowHide
[   143.583]
X.Org X Server 1.12.3.902 (1.12.4 RC 2)
Release Date: 2012-08-19
[   143.584] X Protocol Version 11, Revision 0
[   143.584] Build Operating System: Linux 3.2.0-3-amd64 x86_64 Debian
[   143.584] Current Operating System: Linux debian 3.2.0-3-amd64 #1 SMP Mon Jul 23 02:45:17 UTC 2012 x86_64
[   143.584] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-3-amd64 root=UUID=5fd79afb-82f7-43a9-be01-941697dcf00a ro quiet
[   143.585] Build Date: 21 August 2012  07:36:50PM
[   143.585] xorg-server 2:1.12.3.902-1 (Julien Cristau <jcristau@debian.org>)
[   143.585] Current version of pixman: 0.26.0
[   143.585]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   143.585] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   143.586] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Oct  8 22:50:24 2012
[   143.587] (==) Using config file: "/etc/X11/xorg.conf"
[   143.587] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   143.587] (==) ServerLayout "aticonfig Layout"
[   143.587] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[   143.587] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[   143.588] (**) |   |-->Device "aticonfig-Device[0]-0"
[   143.588] (==) Automatically adding devices
[   143.588] (==) Automatically enabling devices
[   143.588] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   143.588]    Entry deleted from font path.
[   143.588] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[   143.588]    Entry deleted from font path.
[   143.588] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins
[   143.588] (==) ModulePath set to "/usr/lib/xorg/modules"
[   143.588] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[   143.588] (II) Loader magic: 0x7f1f3b69eae0
[   143.588] (II) Module ABI versions:
[   143.588]    X.Org ANSI C Emulation: 0.4
[   143.588]    X.Org Video Driver: 12.1
[   143.588]    X.Org XInput driver : 16.0
[   143.588]    X.Org Server Extension : 6.0
[   143.589] (--) PCI:*(0:2:0:0) 1002:9553:1179:ff80 rev 0, Mem @ 0xd0000000/268435456, 0xcfef0000/65536, I/O @ 0x00009000/256, BIOS @ 0x????????/131072
[   143.589] (II) Open ACPI successful (/var/run/acpid.socket)
[   143.589] (II) "extmod" will be loaded by default.
[   143.589] (II) "dbe" will be loaded by default.
[   143.589] (II) "glx" will be loaded by default.
[   143.589] (II) "record" will be loaded by default.
[   143.589] (II) "dri" will be loaded by default.
[   143.589] (II) "dri2" will be loaded by default.
[   143.589] (II) LoadModule: "extmod"
[   143.589] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   143.590] (II) Module extmod: vendor="X.Org Foundation"
[   143.590]    compiled for 1.12.3.902, module version = 1.0.0
[   143.590]    Module class: X.Org Server Extension
[   143.590]    ABI class: X.Org Server Extension, version 6.0
[   143.590] (II) Loading extension SELinux
[   143.590] (II) Loading extension MIT-SCREEN-SAVER
[   143.590] (II) Loading extension XFree86-VidModeExtension
[   143.590] (II) Loading extension XFree86-DGA
[   143.590] (II) Loading extension DPMS
[   143.590] (II) Loading extension XVideo
[   143.590] (II) Loading extension XVideo-MotionCompensation
[   143.590] (II) Loading extension X-Resource
[   143.590] (II) LoadModule: "dbe"
[   143.590] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   143.590] (II) Module dbe: vendor="X.Org Foundation"
[   143.590]    compiled for 1.12.3.902, module version = 1.0.0
[   143.590]    Module class: X.Org Server Extension
[   143.590]    ABI class: X.Org Server Extension, version 6.0
[   143.590] (II) Loading extension DOUBLE-BUFFER
[   143.590] (II) LoadModule: "glx"
[   143.590] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   143.591] (II) Module glx: vendor="X.Org Foundation"
[   143.591]    compiled for 1.12.3.902, module version = 1.0.0
[   143.591]    ABI class: X.Org Server Extension, version 6.0
[   143.591] (==) AIGLX enabled
[   143.591] (II) Loading extension GLX
[   143.591] (II) LoadModule: "record"
[   143.591] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   143.591] (II) Module record: vendor="X.Org Foundation"
[   143.591]    compiled for 1.12.3.902, module version = 1.13.0
[   143.591]    Module class: X.Org Server Extension
[   143.591]    ABI class: X.Org Server Extension, version 6.0
[   143.591] (II) Loading extension RECORD
[   143.591] (II) LoadModule: "dri"
[   143.591] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   143.591] (II) Module dri: vendor="X.Org Foundation"
[   143.591]    compiled for 1.12.3.902, module version = 1.0.0
[   143.591]    ABI class: X.Org Server Extension, version 6.0
[   143.591] (II) Loading extension XFree86-DRI
[   143.591] (II) LoadModule: "dri2"
[   143.592] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   143.592] (II) Module dri2: vendor="X.Org Foundation"
[   143.592]    compiled for 1.12.3.902, module version = 1.2.0
[   143.592]    ABI class: X.Org Server Extension, version 6.0
[   143.592] (II) Loading extension DRI2
[   143.592] (II) LoadModule: "fglrx"
[   143.592] (WW) Warning, couldn't open module fglrx
[   143.592] (II) UnloadModule: "fglrx"
[   143.592] (II) Unloading fglrx
[   143.592] (EE) Failed to load module "fglrx" (module does not exist, 0)
[   143.592] (EE) No drivers available.
[   143.592]
Fatal server error:
[   143.592] no screens found
[   143.593]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   143.593] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   143.593]


Сообщение объединено: 08 Октября 2012, 15:15:13
Ядро версии 3.2.0-3-amd64

Сообщение объединено: 08 Октября 2012, 15:42:50
Подскажите куда положить libGL.so.1 или как сделать на него линк чтоб стало его видно?
« Последнее редактирование: 08 Октября 2012, 15:42:50 от Metrix »
Юзербар в отпуске
 

Оффлайн vladimir_ar

Re: ATI+Debian Wheezy
« Ответ #1 : 08 Октября 2012, 16:44:08 »
Было похожее. Но не помню точно, как решал. По моему - вычищал все - и дрова от АТИ (/usr/share/ati/amd-uninstall.sh --force), и все, что касается fglrx в системе (может, и xorg и xserver сносил, а потом устанавливал - не помню). То. что решил - помню - как - не точно.

Сообщение объединено: 08 Октября 2012, 16:47:35
И еще. На wheezy ставятся драйвера от ATI не старше прошлого месяца. Более ранние не понимают новый xserver.
« Последнее редактирование: 08 Октября 2012, 16:48:07 от vladimir_ar »
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн Metrix

Re: ATI+Debian Wheezy
« Ответ #2 : 08 Октября 2012, 16:57:58 »
Систему только сегодня обновил и драйвер свежий, скачал сегодня, вот amd-driver-installer-12.6-legacy-x86.x86_64.run
Юзербар в отпуске
 

Оффлайн vladimir_ar

Re: ATI+Debian Wheezy
« Ответ #3 : 08 Октября 2012, 20:29:52 »
12,6 на новом xservere не работает. Нужен новее. И странное имя у драйвера - у меня с офсайта качались с другим именем, слова legacy нет.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн ihammers

Re: ATI+Debian Wheezy
« Ответ #4 : 08 Октября 2012, 20:52:08 »
Странно, что возникли проблемы.  Если можно, то удалите все установленные ранее пакеты, которые вы ставили при установке дров.
И повторите установку с выдачей сообщений, сюда на форум.
Лучше устанавливать дрова из терминала с предварительным  отключением lightdm/gdm/kde и тд.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн Metrix

Re: ATI+Debian Wheezy
« Ответ #5 : 09 Октября 2012, 20:53:30 »
все выложу чуть позже,как ни кстати ноут сломался:(
Юзербар в отпуске
 

Оффлайн aliaksei1818

  • Пользователь
  • *
  • Сообщений: 36
Re: ATI+Debian Wheezy
« Ответ #6 : 12 Октября 2012, 05:30:12 »
Цитата: vladimir
Подскажите куда положить libGL.so.1 или как сделать на него линк чтоб стало его видно?
Сами же ответили на свой вопрос, а теперь не знаете, что делать с этой библиотекой? Конечно же, создать линк в /usr/lib/x86_64-linux-gnu/ или что там у Вас. Ну, а так ковыряйте /etc/ld.so.conf
12,6 на новом xservere не работает. Нужен новее. И странное имя у драйвера - у меня с офсайта качались с другим именем, слова legacy нет.
Драйвер под Вашу карточку максимально оптимизирован, поэтому принято решение о переводе в ветку legacy.
Список поддерживаемого оборудования из неофициальной вики radeon: http://wiki.cchtml.com/index.php/Hardware#Older_RadeonHD_.28Catalyst_.3C.3D_12.4_.26_Open_Source.29
« Последнее редактирование: 12 Октября 2012, 05:47:58 от aliaksei1818 »
 

Оффлайн vladimir_ar

Re: ATI+Debian Wheezy
« Ответ #7 : 12 Октября 2012, 16:59:36 »
Безразницы. Все равно на новом xserver старые дрова не заработают. Я откатывался по xserver и его зависимостям до squeezy и морозил их. Драйвер ставится и работает.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн Metrix

Re: ATI+Debian Wheezy
« Ответ #8 : 12 Октября 2012, 17:27:59 »
Я откатывался по xserver и его зависимостям до squeezy и морозил их
Сможете дать мануал по которому вы откатывались? Тоже попробую откатить xserver
Юзербар в отпуске
 

Оффлайн vladimir_ar

Re: ATI+Debian Wheezy
« Ответ #9 : 12 Октября 2012, 17:38:06 »
Постараюсь на работе ночью вспомнить поточнее как делал.

Сообщение объединено: 13 Октября 2012, 09:15:18
Делал так.
Отключаем репы wheezy и подключил squeezy (не забываем # apt-get update).
Устанавливаем пакет xserver-xorg (понижаем версию). Делал через aptitude, т.к. в нем легче (мне) решать зависимости - понижение версии xserver-xorg повлечет за собой понижение версий пакетов в его зависимостях (у меня 10 - список ниже).
Далее блокируем изменение версий пакетов для обновления (выписка из истории терминала):
Spoiler: ShowHide
  349  echo "xserver-xorg hold" | sudo dpkg --set-selections
  350  echo "xserver-xorg-core hold" | sudo dpkg --set-selections
  351  echo "xserver-xorg-input-all hold" | sudo dpkg --set-selections
  352  echo "xserver-xorg-input-evdev hold" | sudo dpkg --set-selections
  353  echo "xserver-xorg-input-synaptic hold" | sudo dpkg --set-selections
  354  echo "xserver-xorg-input-synaptics hold" | sudo dpkg --set-selections
  355  echo "xserver-xorg-input-wacom hold" | sudo dpkg --set-selections
  356  echo "xserver-xorg-input-fbdev hold" | sudo dpkg --set-selections
  357  echo "xserver-xorg-video-fbdev hold" | sudo dpkg --set-selections
  358  echo "xserver-xorg-video-radeon hold" | sudo dpkg --set-selections
  359  echo "xserver-xorg-video-vmware hold" | sudo dpkg --set-selections

Отключаем репы squeezy и подключаем обратно wheezy. Обновляем список пакетов.
Теперь при выполнении, например, # apt-get upgrade мы видим следующее
Spoiler: ShowHide
sudo apt-get upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакеты, которые будут оставлены в неизменном виде:
  libgl1-mesa-dri xserver-xorg xserver-xorg-core xserver-xorg-input-all
  xserver-xorg-input-evdev xserver-xorg-input-synaptics
  xserver-xorg-input-wacom xserver-xorg-video-fbdev xserver-xorg-video-radeon
  xserver-xorg-video-vmware

В synaptic блокировку делать не советую, потому как у меня команды apt-get и aptitude его проигнорировали (да и странно он в wheezy работает - может это у меня только так?).
« Последнее редактирование: 13 Октября 2012, 09:16:07 от vladimir_ar »
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Теги:
     

    гибридная графика и Debian

    Автор atoha

    Ответов: 12
    Просмотров: 9566
    Последний ответ 17 Мая 2013, 10:07:17
    от qupl
    [РЕШЕНО] Debian 8 - регулярно отваливается swap раздел

    Автор hathory

    Ответов: 15
    Просмотров: 5472
    Последний ответ 17 Июня 2015, 12:09:36
    от hathory
    Debian 9 на ноутбуки Sony Vaio VGN TX3XRP/B и Toshiba Satellite L505-111 PSLS3E

    Автор mkudritsky

    Ответов: 19
    Просмотров: 2326
    Последний ответ 11 Мая 2019, 07:16:06
    от mkudritsky
    Поддержка процессоров Haswell в Debian 7.1

    Автор rulet

    Ответов: 2
    Просмотров: 1956
    Последний ответ 29 Сентября 2013, 18:00:20
    от rulet
    Установке драйвера Nvidia.run в Debian 9

    Автор vik57

    Ответов: 30
    Просмотров: 12312
    Последний ответ 19 Ноября 2017, 11:38:15
    от Дождь