Автор Тема: проблема - тормозит видео fullscreen  (Прочитано 13456 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gotovtsev

  • Активный пользователь
  • **
  • Сообщений: 54
проблема - тормозит видео fullscreen
« : 15 Октября 2012, 08:06:01 »
пользовался ubuntu, но че-то разонравилось.
последние версии тормозно работают у меня,
видимо из-за того что внедрили unity..

установил давеча debian. работает более-менее шустро.
в целом всё нравится пока..

комп такой:
athlon xp 2500+
ati radeon 9600

тормозно показывает кино на полный экран =(
открываю кино через smplayer..
пробовал там тыкать разные настройки.
добился того что видео стало меньше тормозить,
но всё равно заметно, что че-то не так..  :(
да и youtube кажется подтормаживает..

подскажите, что можно пошерудить?  :)
 

Онлайн qupl

Re: проблема - тормозит видео fullscreen
« Ответ #1 : 15 Октября 2012, 08:32:59 »
Можно рассказать какая версия Debian установлена, какой видеодрайвер используется, ну и о DE упомянуть.

Оффлайн gotovtsev

  • Активный пользователь
  • **
  • Сообщений: 54
Re: проблема - тормозит видео fullscreen
« Ответ #2 : 15 Октября 2012, 08:48:52 »
Можно рассказать какая версия Debian установлена, какой видеодрайвер используется, ну и о DE упомянуть.

debian 6.0.6
скачал небольшой образ netinst, закачал на флэшку, загрузился и установил.
видео-драйвер тот, что по умолчанию системой установился.

что такое DE? :)
 

Онлайн qupl

Re: проблема - тормозит видео fullscreen
« Ответ #3 : 15 Октября 2012, 08:58:11 »
DE - окружение рабочего стола (GNOME, XFCE ит.д). Не важно.
Драйвер значит radeon. Эта видеокарта насколько я помню в каких-то драйверах уже не поддерживается (точно не помню в проприетарных или свободных).

Сообщение объединено: 15 Октября 2012, 09:01:11
Дайте выводcat /var/log/Xorg.0.log
« Последнее редактирование: 15 Октября 2012, 09:01:11 от qupl »
 

Оффлайн gotovtsev

  • Активный пользователь
  • **
  • Сообщений: 54
Re: проблема - тормозит видео fullscreen
« Ответ #4 : 15 Октября 2012, 09:05:36 »
DE - окружение рабочего стола (GNOME, XFCE ит.д). Не важно.
Драйвер значит radeon. Эта видеокарта насколько я помню в каких-то драйверах уже не поддерживается (точно не помню в проприетарных или свободных).

Сообщение объединено: 15 Октября 2012, 09:01:11
Дайте выводcat /var/log/Xorg.0.log

да. насколько я понял (хотя могу ошибаться), драйвера с сайта amd не поддерживаются.. пробовал установить..
окружение gnome. сейчас на работе (тут win xp). через полчаса пойду домой на обед - выполню команду и напишу, что выводит..

Сообщение объединено: 15 Октября 2012, 09:54:55
итак. пришел на обед  :)
содержимое файлика Xorg.0.log довольно много места занимает.
прикрепил файл к сообщению. также прикрепил скриншот настроек в smplayer,
при которых (как мне кажется) видео наиболее адекватно показывается..
если в окошке смотреть то всё более-менее.. но дело в том, что у меня к компу подключен
проектор и обычно я смотрю не в окошке  :) на мониторе в fullscreen тоже не адекватно
видео воспроизводится..  :-\

при попытке установки драйвера amd вот что получается..

./ati-driver-installer-9-3-x86.x86_64.run
Created directory fglrx-install.A3kw4X
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.593...
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.32-5-686; make sure that the version is being
correctly set by --iscurrentdistro
« Последнее редактирование: 15 Октября 2012, 09:54:56 от gotovtsev »
 

Онлайн qupl

Re: проблема - тормозит видео fullscreen
« Ответ #5 : 15 Октября 2012, 10:58:18 »
Как мне кажется дело в этом
(WW) RADEON(0): Direct rendering disabled
(II) RADEON(0): Acceleration disabled
Можно поробовать xorg.conf создать и там прописать использование DRI.

Сообщение объединено: 15 Октября 2012, 11:05:54
Про DRI поторопился, есть уже
(II) Loading extension DRI2
« Последнее редактирование: 15 Октября 2012, 11:05:54 от qupl »
 

Оффлайн gotovtsev

  • Активный пользователь
  • **
  • Сообщений: 54
Re: проблема - тормозит видео fullscreen
« Ответ #6 : 15 Октября 2012, 11:15:20 »
Как мне кажется дело в этом
(WW) RADEON(0): Direct rendering disabled
(II) RADEON(0): Acceleration disabled
Можно поробовать xorg.conf создать и там прописать использование DRI.

Сообщение объединено: 15 Октября 2012, 11:05:54
Про DRI поторопился, есть уже
(II) Loading extension DRI2


ммм.. надо чтобы было enabled, я так понимаю.. :)
а что для это сделать? куда копать?
 

Онлайн qupl

Re: проблема - тормозит видео fullscreen
« Ответ #7 : 15 Октября 2012, 11:30:29 »
Попробуй при загрузке в GRUB передавать параметр ядра radeon.modeset=0 или radeon.modeset=1.

Оффлайн gotovtsev

  • Активный пользователь
  • **
  • Сообщений: 54
Re: проблема - тормозит видео fullscreen
« Ответ #8 : 15 Октября 2012, 12:34:45 »
Попробуй при загрузке в GRUB передавать параметр ядра radeon.modeset=0 или radeon.modeset=1.

ок. спасибо!
почитаю про это и вечером попробую.. :)

Сообщение объединено: 15 Октября 2012, 16:18:41
...

если я правильно понял, то при загрузке надо нажать E.
потом ввожу radeon.modeset=1 (или 0), нажимаю ctrl+x (кажись)
и загружаюсь далее. после чего пробовал открывать видео через
smplayer - никаких изменений не заметил..  :(

в smplayer нужно ли менять output driver x11 (slow) и на что его менять?
или я что-то не так делаю?
« Последнее редактирование: 15 Октября 2012, 16:18:41 от gotovtsev »
 

Оффлайн Brainey

Re: проблема - тормозит видео fullscreen
« Ответ #9 : 15 Октября 2012, 19:08:43 »
в smplayer нужно ли менять output driver x11 (slow) и на что его менять?
Попробуйте gl - (быстро ati). Ну и поэкспериментируйте с другими вариантами, если оно понадобится.
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Онлайн qupl

Re: проблема - тормозит видео fullscreen
« Ответ #10 : 15 Октября 2012, 19:28:38 »
gotovtsev, после radeon.modeset=0 посмотрите лог еще раз, что там про direct rendering будет написано.

Оффлайн ihammers

Re: проблема - тормозит видео fullscreen
« Ответ #11 : 15 Октября 2012, 19:43:15 »
Попробуйте использовать ffmpeg:
~$ mplayer -vfm help
~$ mplayer -vfm ffmpeg fiml.mkv
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн Udachnik

Re: проблема - тормозит видео fullscreen
« Ответ #12 : 15 Октября 2012, 20:08:00 »
Как мне кажется дело в этом
(WW) RADEON(0): Direct rendering disabled
(II) RADEON(0): Acceleration disabled
Можно поробовать xorg.conf создать и там прописать использование DRI.

Сообщение объединено: 15 Октября 2012, 11:05:54
Про DRI поторопился, есть уже
(II) Loading extension DRI2


ммм.. надо чтобы было enabled, я так понимаю.. :)
а что для это сделать? куда копать?
http://wiki.debian.org/ru/AtiHowTo
В Debian 6.0 со старыми картами работает только открытый драйвер radeon.
Если хочется увеличить производительность гляньте сюда https://debianforum.ru/index.php?topic=2901.0
 

Оффлайн vladimir_ar

Re: проблема - тормозит видео fullscreen
« Ответ #13 : 15 Октября 2012, 21:43:40 »
Тут еще вопрос - какое видео? У меня был комп с такой картой на базе Р4 2ГГц (одно ядро) - карта с таким процом звезд с небес не хватала - ХД можно было и не пытаться смотреть.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн gotovtsev

  • Активный пользователь
  • **
  • Сообщений: 54
Re: проблема - тормозит видео fullscreen
« Ответ #14 : 15 Октября 2012, 21:49:39 »
gotovtsev, после radeon.modeset=0 посмотрите лог еще раз, что там про direct rendering будет написано.

загрузился, указав этот параметр. открыл файлик с логом - про direct rendering - вообще ничего... :-[

Сообщение объединено: 15 Октября 2012, 21:50:21
в smplayer нужно ли менять output driver x11 (slow) и на что его менять?
Попробуйте gl - (быстро ati). Ну и поэкспериментируйте с другими вариантами, если оно понадобится.

с gl - работает намного хуже.. =(

Сообщение объединено: 15 Октября 2012, 21:54:56
Тут еще вопрос - какое видео? У меня был комп с такой картой на базе Р4 2ГГц (одно ядро) - карта с таким процом звезд с небес не хватала - ХД можно было и не пытаться смотреть.

видео не hd. обычное :)
пока приходится смотреть кино под win xp (установлена на этом же компе).

Сообщение объединено: 15 Октября 2012, 21:57:11
Как мне кажется дело в этом
(WW) RADEON(0): Direct rendering disabled
(II) RADEON(0): Acceleration disabled
Можно поробовать xorg.conf создать и там прописать использование DRI.

Сообщение объединено: 15 Октября 2012, 11:05:54
Про DRI поторопился, есть уже
(II) Loading extension DRI2


ммм.. надо чтобы было enabled, я так понимаю.. :)
а что для это сделать? куда копать?
http://wiki.debian.org/ru/AtiHowTo
В Debian 6.0 со старыми картами работает только открытый драйвер radeon.
Если хочется увеличить производительность гляньте сюда https://debianforum.ru/index.php?topic=2901.0


почитал. че-то запутался немного... =)
кстати, у меня вот что установлено.. тут всё как надо? (скриншот прикрепляю)

Сообщение объединено: 15 Октября 2012, 22:05:42
Попробуйте использовать ffmpeg:
~$ mplayer -vfm help
~$ mplayer -vfm ffmpeg fiml.mkv

запускаю фильм:

mplayer -vfm ffmpeg 2x02_Who_Mourns_for_Adonais.avi
MPlayer 1.0rc3-4.4.4 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing 2x02_Who_Mourns_for_Adonais.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
[aviheader] Audio stream found, -aid 2
VIDEO:  [XVID]  720x544  12bpp  23.976 fps  731.8 kbps (89.3 kbyte/s)
Clip info:
 Software: VirtualDubMod 1.5.10.2 (build 2540/release)
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] This driver only supports the 3Dfx Banshee, Voodoo3 and Voodoo 5.
[VO_3DFX] Unable to open /dev/3dfx.
[VO_XV] It seems there is no Xvideo support for your video card available.
[VO_XV] Run 'xvinfo' to verify its Xv support and read
[VO_XV] DOCS/HTML/en/video.html#xv!
[VO_XV] See 'mplayer -vo help' for other (non-xv) video out drivers.
[VO_XV] Try -vo x11.
[vdpau] Could not open dynamic library libvdpau.so.1
==========================================================================
Trying to force video codec driver family ffmpeg...
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 32000 Hz, 2 ch, s16le, 96.0 kbit/9.38% (ratio: 12000->128000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [pulse] Init failed: Connection refused
Failed to initialize audio driver 'pulse'
AO: [alsa] 32000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 720 x 544 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.32:1 - prescaling to correct movie aspect.
VO: [x11] 720x544 => 720x544 Planar YV12
[swscaler @ 0xb5ef17a0]using unscaled yuv420p -> rgb32 special converter
A:   2.9 V:   2.9 A-V:  0.000 ct:  0.003  70/ 70 13% 11%  0.5% 3 0
  =====  PAUSE  =====


при нажатии F (переход в полноэкранный режим), картинка остается такого же размера, а по краям тьма..  :)
« Последнее редактирование: 15 Октября 2012, 22:06:49 от gotovtsev »
 

Теги:
     

    [Решено]Проблема с настройками easyscreencast

    Автор Whowka

    Ответов: 21
    Просмотров: 1693
    Последний ответ 08 Марта 2021, 11:18:49
    от Whowka
    Проблема со звуком

    Автор cinyflo

    Ответов: 0
    Просмотров: 1674
    Последний ответ 27 Ноября 2012, 11:06:39
    от cinyflo
    Проблема с flash в iceweasel

    Автор xommos

    Ответов: 4
    Просмотров: 3284
    Последний ответ 02 Июня 2013, 17:48:42
    от xommos
    [РЕШЕНО] Проблема со звуком

    Автор Krishnoved

    Ответов: 7
    Просмотров: 3491
    Последний ответ 10 Сентября 2013, 16:30:25
    от vladimir_ar
    Проблема с клиентом google-musicmanager

    Автор manazius

    Ответов: 4
    Просмотров: 2075
    Последний ответ 09 Января 2014, 18:43:43
    от manazius