Автор Тема: Плохо работает звук  (Прочитано 2275 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DarkDigger

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 17
Плохо работает звук
« : 29 Октябрь 2012, 13:14:30 »
Система Debian wheezy 64 битная, поставил из нетинстал, базовую систему,  затем доставил x-window-system, gdm3, gnome-session и т.д.
Странность в том что некоторые проги: vlc, skype воспроизводят звук с хрипами, эхом, искаженно. Вывод стоит в pulseaudio. До тех пор пока не пошевелишь  ползунок громкости. Пошевелил, и всё! Нормально стало... До следующего раза. Тоесть по скайпу поговорил, потом ктонибудь тебе звонит, шевели ползунок громкости...
Гному-3 нужен pulseaudio, поэтому стоит он.
digger@komp:~$ dpkg -l | grep pulse
ii  gstreamer0.10-pulseaudio:amd64        0.10.31-3     
ii  libpulse-mainloop-glib0:amd64            2.0-6                 
ii  libpulse0:amd64                                 2.0-6                       
ii  pulseaudio                                          2.0-6                           
ii  pulseaudio-esound-compat                  2.0-6     
ii  pulseaudio-module-x11                       2.0-6       
ii  pulseaudio-utils                                  2.0-6
ii  vlc-plugin-pulse                                  1:2.0.3-dmo4

digger@komp:~$ dpkg -l | grep alsa
ii  alsa-base                                  1.0.25+2+nmu2 
ii  alsa-tools                                  1.0.25-2   
ii  alsa-utils                                   1.0.25-3   
ii  libwine-alsa-unstable                 1.5.5-0.1 

digger@komp:~$ lspci | grep Audio
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)

ЗЫ Другие проги, которые используют тоже pulse: deadbeef например работают норм...
Помогите пожалуйста, очень не удобно...
 

Оффлайн gardarea51

  • Старожил
  • ****
  • Сообщений: 769
  • Jabber: gard.area51@jabber.ru
Re: Плохо работает звук
« Ответ #1 : 29 Октябрь 2012, 14:53:41 »
Хм.. такая же проблема наблюдалась на Убунте у моей жены. С чем связано - черт его знает.
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
Re: Плохо работает звук
« Ответ #2 : 29 Октябрь 2012, 17:01:59 »
Странность в том что некоторые проги: vlc, skype воспроизводят звук с хрипами, эхом, искаженно.
А так настроить пробовали?
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн DarkDigger

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 17
Re: Плохо работает звук
« Ответ #3 : 29 Октябрь 2012, 18:18:32 »
Комп не слабый 4 ядра, 2 гб видео...
Из-за строчка в  /etc/pulse/default.pa
load-module module-udev-detect tsched=0
вообще пульс пропал, в скайпе можно выбрать alsa  и всё работает хорошо) Но пульс не загрузился...
 

Оффлайн Brainey

  • Ветеран
  • *****
  • Сообщений: 1943
  • Jabber: brainey@jabber.cz
Re: Плохо работает звук
« Ответ #4 : 29 Октябрь 2012, 18:21:30 »
load-module module-udev-detect tsched=0
Я имел в виду раздел
Цитировать
Различные проблемы со Skype
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Re: Плохо работает звук
« Ответ #5 : 29 Октябрь 2012, 18:57:26 »
вообще пульс пропал, в скайпе можно выбрать alsa  и всё работает хорошо) Но пульс не загрузился...
Так удалите пульс и работайте на alsa.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн DarkDigger

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 17
Re: Плохо работает звук
« Ответ #6 : 29 Октябрь 2012, 20:12:58 »
Да не получится удалить, точнее может и получится, но это костыль какой-то... (Гному нужен пульс)
Сделал как написано в той статье: Различные проблемы со Skype
Всё теже глюки...Блин!
 

Оффлайн ihammers

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 1742
  • Debian GNU/Linux Stretch
    • Алтайская Группа Пользователей Linux
  • Jabber: ihammers@jabber.ru
Re: Плохо работает звук
« Ответ #7 : 29 Октябрь 2012, 20:50:21 »
Комп не слабый 4 ядра, 2 гб видео...
...
У меня тоже были хрипы и параметры компа не такие уж слабые, как было указано выше, нужно за лесть в конфиги pulseaudio (/etc/pulse/daemon.conf):
high-priority = yes
nice-level = -11

realtime-scheduling = yes
realtime-priority = 5

default-sample-format = s16le
default-sample-rate = 48000
alternate-sample-rate = 48000

default-fragments = 4
default-fragment-size-msec = 100

/etc/default/pulseaudio
PULSEAUDIO_SYSTEM_START=1
Мне помогли выше указанные параметры, конечно иногда появляются хрипы, но очень редко.

PS: незабываем потом передёрнуть pulseaudio.
PS:: дальше нужно напильником дорабатывать.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн DarkDigger

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 17
Re: Плохо работает звук
« Ответ #8 : 29 Октябрь 2012, 21:25:56 »
Спасибо за конфиг, вбил его полностью, затерев старый, но всё таже хрень.
Кста, обновив vlc, он перестал глючить... Остался только скайп (да и чёрт с ним) и... только сейчас заметил
не работает проверка динамиков, та что на картинке... Нажимаешь на кнопочку и тишина... В принципе и на неё начхать, у меня только 2 колонки и проверять мне нечего, но если кто вкурсе как это лечить, буду премного благодарен.

ЗЫ Прикольный шрифт?

Сообщение объединено: 29 Октябрь 2012, 21:27:37
« Последнее редактирование: 29 Октябрь 2012, 21:27:38 от DarkDigger »
 

Теги:
 

Bluetooth CSR 4.0 плохо работает

Автор pavelkq

Ответов: 9
Просмотров: 1458
Последний ответ 12 Январь 2020, 13:29:56
от Mitai