Автор Тема: Ошибки зависимостей при каждом апдэйте  (Прочитано 3371 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн animegirl

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 175
  • НЯ!
Где-то недели полторы уже как начали появляться ошибки при апдэйтах, захожу в пакет менеджер, там делаю фикс брокен пакетов, прогоняет, но ничего не меняет, вроде как нету проблем. Где глянуть, что это и как от этого избавится?

Сообщение объединено: 04 Декабрь 2012, 23:52:42
Сами апдэйты ставит по итогу, ошибку выкидывает где-то по середине 3 окошка и в конце ещё 3 окошка

Прочтите Руководство по добавлению изображений на форум. Malaheenee
« Последнее редактирование: 05 Декабрь 2012, 09:50:36 от Malaheenee »
 


Оффлайн Alexey_F

  • Местный житель
  • ***
  • Сообщений: 153
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #1 : 05 Декабрь 2012, 00:35:13 »
Для начала, стоило бы нажать на "show terminal", чтобы посмотреть, что на самом деле произошло.

А вообще - советую не заморачиваться с графическими менеджерами пакетов и апдейтов, а сделать просто, понятно и надёжно, например, так:
# aptitude update && aptitude upgrade
 

Оффлайн animegirl

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 175
  • НЯ!
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #2 : 05 Декабрь 2012, 00:37:53 »
Я юзер нуб, мне консоль чужда, я её использую редко. Нажать на терминал не получается, без нажатия на ОК, а если нажать на терминал, оно уже всё пробежит.
Есть файлы логи от этой программки?
 

Оффлайн Alexey_F

  • Местный житель
  • ***
  • Сообщений: 153
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #3 : 05 Декабрь 2012, 01:00:15 »
Вот что бы не возникало таких вопросов, я и советую вышеназванное. Тут тебе и терминал, и "логи", и все 33 удовольствия.

И да, имхо, смотреть в полноценный терминал гораздо удобнее, чем в такую вот встроенную мутную шнягу, которая там вообще, в основном, для чисто наблюдательных/ознакомительных целей и для тех весьма редких случаев, когда надо что-то сообщить установщику пакетов в процессе настройки пакета.

Кстати говоря, ещё один важный аргумент в пользу aptitude - это то, что он способен "умно" разрешать зависимости, в отличие от практически всех остальных пакетных менеджеров.
Есть также и графическая инкарнация оного, если уж так  воротит от работы в текстовом режиме, правда, ничем, кроме внешнего вида, она не отличается.
« Последнее редактирование: 05 Декабрь 2012, 01:11:02 от Alexey_F »
 

Оффлайн BULATUS

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 2056
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #4 : 05 Декабрь 2012, 09:25:51 »
Я юзер нуб, мне консоль чужда, я её использую редко.
И тем не менее, интересно что за ошибки... откройте терминал, залогинтесь в нем под суперпользователем и ведите aptitude update Вывод, можно весь, под спойлер (просто скопируйте всё).

Оффлайн animegirl

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 175
  • НЯ!
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #5 : 13 Декабрь 2012, 16:55:09 »
Вот, что в консоли
 

Оффлайн qupl

  • Главный модератор
  • Ветеран
  • *****
  • Сообщений: 4941
  • memento mori
  • Jabber: qupl@jabber.ru
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #6 : 13 Декабрь 2012, 17:25:18 »
aptitude -f install

Оффлайн animegirl

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 175
  • НЯ!
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #7 : 14 Декабрь 2012, 16:27:15 »
aptitude -f install
Выдало такое предложение:
Spoiler: ShowHide

The following NEW packages will be installed:
  browser-plugin-gnash gnash gnash-common
The following packages will be REMOVED:
  libmozjs12d{u} libmozjs13d{u} libmozjs14d{u} libmozjs15d{u} libpq5{u}
  libvpx1{u}
The following partially installed packages will be configured:
  apache2 apache2-mpm-prefork apache2.2-common mysql-server
  mysql-server-5.1

Меня не устраивает первый пункт, мне флэш не просто не нужен, я его ненавижу, он только тормозит систему скотина.
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #8 : 14 Декабрь 2012, 16:41:31 »
После починки зависимостей удалите лишнее.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн animegirl

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 175
  • НЯ!
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #9 : 14 Декабрь 2012, 16:47:11 »
Не вышло
Spoiler: ShowHide
root@server:/home/server# aptitude -f install
The following NEW packages will be installed:
  browser-plugin-gnash gnash gnash-common
The following packages will be REMOVED:
  libmozjs12d{u} libmozjs13d{u} libmozjs14d{u} libmozjs15d{u} libpq5{u}
  libvpx1{u}
The following partially installed packages will be configured:
  apache2 apache2-mpm-prefork apache2.2-common mysql-server
  mysql-server-5.1
0 packages upgraded, 3 newly installed, 6 to remove and 0 not upgraded.
Need to get 3,111 kB of archives. After unpacking 5,457 kB will be freed.
Do you want to continue? [Y/n/?] y
Get:1 http://security.debian.org/ squeeze/updates/main gnash-common amd64 0.8.8-5+squeeze1 [2,787 kB]
Get:2 http://security.debian.org/ squeeze/updates/main gnash amd64 0.8.8-5+squeeze1 [182 kB]
Get:3 http://security.debian.org/ squeeze/updates/main browser-plugin-gnash amd64 0.8.8-5+squeeze1 [142 kB]
Fetched 3,111 kB in 1s (2,055 kB/s)       
(Reading database ... 216462 files and directories currently installed.)
Removing libmozjs12d ...
Removing libmozjs13d ...
Removing libmozjs14d ...
Removing libmozjs15d ...
Removing libpq5 ...
Removing libvpx1 ...
Selecting previously deselected package gnash-common.
(Reading database ... 216418 files and directories currently installed.)
Unpacking gnash-common (from .../gnash-common_0.8.8-5+squeeze1_amd64.deb) ...
Selecting previously deselected package gnash.
Unpacking gnash (from .../gnash_0.8.8-5+squeeze1_amd64.deb) ...
Selecting previously deselected package browser-plugin-gnash.
Unpacking browser-plugin-gnash (from .../browser-plugin-gnash_0.8.8-5+squeeze1_amd64.deb) ...
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

Processing triggers for man-db ...
Processing triggers for install-info ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Setting up mysql-server-5.1 (5.1.66-0+squeeze1) ...
Stopping MySQL database server: mysqld.
insserv: warning: script 'K01mysqld_multi' missing LSB tags and overrides
insserv: warning: script 'K01vmware' missing LSB tags and overrides
insserv: warning: script 'K08vmware-USBArbitrator' missing LSB tags and overrides
insserv: warning: current start runlevel(s) (3 4 5) of script `mysql' overwrites defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 6) of script `mysql' overwrites defaults (0 1 6).
insserv: warning: script 'vmware-workstation-server' missing LSB tags and overrides
insserv: warning: script 'vmware' missing LSB tags and overrides
insserv: warning: script 'mysqld_multi' missing LSB tags and overrides
insserv: warning: script 'vmware-USBArbitrator' missing LSB tags and overrides
insserv: There is a loop at service stop-bootlogd if started
insserv: There is a loop between service stop-bootlogd and mountnfs if started
insserv:  loop involving service mountnfs at depth 6
insserv:  loop involving service nfs-common at depth 5
insserv: There is a loop between service stop-bootlogd and checkroot if started
insserv:  loop involving service checkroot at depth 3
insserv:  loop involving service hdparm at depth 2
insserv:  loop involving service fuse at depth 11
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Max recursions depth 99 reached
insserv:  loop involving service portmap at depth 8
insserv: There is a loop between service stop-bootlogd and mountall if started
insserv:  loop involving service mountall at depth 6
insserv:  loop involving service checkfs at depth 5
insserv:  loop involving service mtab at depth 4
insserv:  loop involving service mysqld_multi at depth 12
insserv:  loop involving service networking at depth 8
insserv:  loop involving service hostname at depth 4
insserv: There is a loop between service stop-bootlogd and ifupdown-clean if started
insserv:  loop involving service ifupdown-clean at depth 6
insserv:  loop involving service module-init-tools at depth 6
insserv: There is a loop between service stop-bootlogd and mountdevsubfs if started
insserv:  loop involving service mountdevsubfs at depth 2
insserv:  loop involving service udev at depth 1
insserv: There is a loop at service vmware-USBArbitrator if started
insserv:  loop involving service bootlogd at depth 4
insserv:  loop involving service vmware-USBArbitrator at depth 1
insserv: There is a loop between service stop-bootlogd and bootlogd if started
insserv: There is a loop between service stop-bootlogd and mountall-bootclean if started
insserv:  loop involving service mountall-bootclean at depth 1
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing mysql-server-5.1 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up apache2.2-common (2.2.16-6+squeeze10) ...
configured to not write apport reports
                                      insserv: warning: script 'K01mysqld_multi' missing LSB tags and overrides
insserv: warning: script 'K01vmware' missing LSB tags and overrides
insserv: warning: script 'K08vmware-USBArbitrator' missing LSB tags and overrides
insserv: warning: script 'vmware-workstation-server' missing LSB tags and overrides
insserv: warning: script 'vmware' missing LSB tags and overrides
insserv: warning: script 'mysqld_multi' missing LSB tags and overrides
insserv: warning: script 'vmware-USBArbitrator' missing LSB tags and overrides
insserv: There is a loop at service stop-bootlogd if started
insserv: There is a loop between service stop-bootlogd and mountnfs if started
insserv:  loop involving service mountnfs at depth 6
insserv:  loop involving service nfs-common at depth 5
insserv: There is a loop between service stop-bootlogd and checkroot if started
insserv:  loop involving service checkroot at depth 3
insserv:  loop involving service hdparm at depth 2
insserv:  loop involving service fuse at depth 11
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Max recursions depth 99 reached
insserv:  loop involving service portmap at depth 8
insserv: There is a loop between service stop-bootlogd and mountall if started
insserv:  loop involving service mountall at depth 6
insserv:  loop involving service checkfs at depth 5
insserv:  loop involving service mtab at depth 4
insserv:  loop involving service mysqld_multi at depth 12
insserv:  loop involving service networking at depth 8
insserv:  loop involving service hostname at depth 4
insserv: There is a loop between service stop-bootlogd and ifupdown-clean if started
insserv:  loop involving service ifupdown-clean at depth 6
insserv:  loop involving service module-init-tools at depth 6
insserv: There is a loop between service stop-bootlogd and mountdevsubfs if started
insserv:  loop involving service mountdevsubfs at depth 2
insserv:  loop involving service udev at depth 1
insserv: There is a loop at service vmware-USBArbitrator if started
insserv:  loop involving service bootlogd at depth 4
insserv:  loop involving service vmware-USBArbitrator at depth 1
insserv: There is a loop between service stop-bootlogd and bootlogd if started
insserv: There is a loop between service stop-bootlogd and mountall-bootclean if started
insserv:  loop involving service mountall-bootclean at depth 1
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing apache2.2-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apache2-mpm-prefork:
 apache2-mpm-prefork depends on apache2.2-common (= 2.2.16-6+squeeze10); however:
  Package apache2.2-common is not configured yet.
dpkg: error processing apache2-mpm-prefork (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apache2:
 apache2 depends on apache2-mpm-worker (= 2.2.16-6+squeeze10) | apache2-mpm-prefork (= 2.2.16-6+squeeze10) | apache2-mpm-event (= 2.2.16-6+squeeze10) | apache2-mpm-itk (= 2.2.1configured to not write apport reports
                                                                                                                                                                                                                      configured to not write apport reports
                configured to not write apport reports
                                                      configured to not write apport reports
                                                                                            6-6+squeeze10); however:
  Package apache2-mpm-worker is not installed.
  Package apache2-mpm-prefork is not configured yet.
  Package apache2-mpm-event is not installed.
  Package apache2-mpm-itk is not installed.
 apache2 depends on apache2.2-common (= 2.2.16-6+squeeze10); however:
  Package apache2.2-common is not configured yet.
dpkg: error processing apache2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.1; however:
  Package mysql-server-5.1 is not configured yet.
dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
Setting up gnash-common (0.8.8-5+squeeze1) ...
Setting up gnash (0.8.8-5+squeeze1) ...
Setting up browser-plugin-gnash (0.8.8-5+squeeze1) ...
Errors were encountered while processing:
 mysql-server-5.1
 apache2.2-common
 apache2-mpm-prefork
 apache2
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up mysql-server-5.1 (5.1.66-0+squeeze1) ...
Stopping MySQL database server: mysqld.
insserv: warning: script 'K01mysqld_multi' missing LSB tags and overrides
insserv: warning: script 'K01vmware' missing LSB tags and overrides
insserv: warning: script 'K08vmware-USBArbitrator' missing LSB tags and overrides
insserv: warning: current start runlevel(s) (3 4 5) of script `mysql' overwrites defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 6) of script `mysql' overwrites defaults (0 1 6).
insserv: warning: script 'vmware-workstation-server' missing LSB tags and overrides
insserv: warning: script 'vmware' missing LSB tags and overrides
insserv: warning: script 'mysqld_multi' missing LSB tags and overrides
insserv: warning: script 'vmware-USBArbitrator' missing LSB tags and overrides
insserv: There is a loop at service stop-bootlogd if started
insserv: There is a loop between service stop-bootlogd and mountnfs if started
insserv:  loop involving service mountnfs at depth 6
insserv:  loop involving service nfs-common at depth 5
insserv: There is a loop between service stop-bootlogd and checkroot if started
insserv:  loop involving service checkroot at depth 3
insserv:  loop involving service hdparm at depth 2
insserv:  loop involving service fuse at depth 11
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Max recursions depth 99 reached
insserv:  loop involving service portmap at depth 8
insserv: There is a loop between service stop-bootlogd and mountall if started
insserv:  loop involving service mountall at depth 6
insserv:  loop involving service checkfs at depth 5
insserv:  loop involving service mtab at depth 4
insserv:  loop involving service mysqld_multi at depth 12
insserv:  loop involving service networking at depth 8
insserv:  loop involving service hostname at depth 4
insserv: There is a loop between service stop-bootlogd and ifupdown-clean if started
insserv:  loop involving service ifupdown-clean at depth 6
insserv:  loop involving service module-init-tools at depth 6
insserv: There is a loop between service stop-bootlogd and mountdevsubfs if started
insserv:  loop involving service mountdevsubfs at depth 2
insserv:  loop involving service udev at depth 1
insserv: There is a loop at service vmware-USBArbitrator if started
insserv:  loop involving service bootlogd at depth 4
insserv:  loop involving service vmware-USBArbitrator at depth 1
insserv: There is a loop between service stop-bootlogd and bootlogd if started
insserv: There is a loop between service stop-bootlogd and mountall-bootclean if started
insserv:  loop involving service mountall-bootclean at depth 1
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing mysql-server-5.1 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up apache2.2-common (2.2.16-6+squeeze10) ...
insserv: warning: script 'K01mysqld_multi' missing LSB tags and overrides
insserv: warning: script 'K01vmware' missing LSB tags and overrides
insserv: warning: script 'K08vmware-USBArbitrator' missing LSB tags and overrides
insserv: warning: script 'vmware-workstation-server' missing LSB tags and overrides
insserv: warning: script 'vmware' missing LSB tags and overrides
insserv: warning: script 'mysqld_multi' missing LSB tags and overrides
insserv: warning: script 'vmware-USBArbitrator' missing LSB tags and overrides
insserv: There is a loop at service stop-bootlogd if started
insserv: There is a loop between service stop-bootlogd and mountnfs if started
insserv:  loop involving service mountnfs at depth 6
insserv:  loop involving service nfs-common at depth 5
insserv: There is a loop between service stop-bootlogd and checkroot if started
insserv:  loop involving service checkroot at depth 3
insserv:  loop involving service hdparm at depth 2
insserv:  loop involving service fuse at depth 11
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting vmware-USBArbitrator depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Max recursions depth 99 reached
insserv:  loop involving service portmap at depth 8
insserv: There is a loop between service stop-bootlogd and mountall if started
insserv:  loop involving service mountall at depth 6
insserv:  loop involving service checkfs at depth 5
insserv:  loop involving service mtab at depth 4
insserv:  loop involving service mysqld_multi at depth 12
insserv:  loop involving service networking at depth 8
insserv:  loop involving service hostname at depth 4
insserv: There is a loop between service stop-bootlogd and ifupdown-clean if started
insserv:  loop involving service ifupdown-clean at depth 6
insserv:  loop involving service module-init-tools at depth 6
insserv: There is a loop between service stop-bootlogd and mountdevsubfs if started
insserv:  loop involving service mountdevsubfs at depth 2
insserv:  loop involving service udev at depth 1
insserv: There is a loop at service vmware-USBArbitrator if started
insserv:  loop involving service bootlogd at depth 4
insserv:  loop involving service vmware-USBArbitrator at depth 1
insserv: There is a loop between service stop-bootlogd and bootlogd if started
insserv: There is a loop between service stop-bootlogd and mountall-bootclean if started
insserv:  loop involving service mountall-bootclean at depth 1
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing apache2.2-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.1; however:
  Package mysql-server-5.1 is not configured yet.
dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apache2-mpm-prefork:
 apache2-mpm-prefork depends on apache2.2-common (= 2.2.16-6+squeeze10); however:
  Package apache2.2-common is not configured yet.
dpkg: error processing apache2-mpm-prefork (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apache2:
 apache2 depends on apache2-mpm-worker (= 2.2.16-6+squeeze10) | apache2-mpm-prefork (= 2.2.16-6+squeeze10) | apache2-mpm-event (= 2.2.16-6+squeeze10) | apache2-mpm-itk (= 2.2.16-6+squeeze10); however:
  Package apache2-mpm-worker is not installed.
  Package apache2-mpm-prefork is not configured yet.
  Package apache2-mpm-event is not installed.
  Package apache2-mpm-itk is not installed.
 apache2 depends on apache2.2-common (= 2.2.16-6+squeeze10); however:
  Package apache2.2-common is not configured yet.
dpkg: error processing apache2 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 mysql-server-5.1
 apache2.2-common
 mysql-server
 apache2-mpm-prefork
 apache2
                                         
Current status: 24380 new [-5].

И я не могу понять одну вещь, почему каждый раз, когда aptitude, что либо изменяет, каждый раз дергает мой MySQL?
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #10 : 14 Декабрь 2012, 17:45:47 »
Ага. По моему, понятно. Удалите vmware и все получится. Если она так нужна, то потом поставите. Такое было. Это она мешает. По этой причине перешел на virtual box. Потому как vmware достала. Плюс, у нее постоянно косяки с новыми ядрами - она сильно от них отстает и не хочет ставиться.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн animegirl

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 175
  • НЯ!
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #11 : 14 Декабрь 2012, 17:47:38 »
Актуально не завишу, только вопрос: Как её правильно удалить?
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #12 : 14 Декабрь 2012, 18:14:00 »
Там как-то специфично - сразу и вспомню. Попробуйте запустить инсталятор с ключем --help.
Попробуйте еще так
sudo vmware-installer -u vmware-player
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн animegirl

  • Местный житель
  • ***
  • Topic Author
  • Сообщений: 175
  • НЯ!
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #13 : 14 Декабрь 2012, 18:18:34 »
Не могу понять от чего варнунги
Spoiler: ShowHide
root@server:/home/server# aptitude -f install
The following partially installed packages will be configured:
  apache2 apache2-mpm-prefork apache2.2-common mysql-server
  mysql-server-5.1
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Setting up mysql-server-5.1 (5.1.66-0+squeeze1) ...
Stopping MySQL database server: mysqld.
insserv: warning: script 'K01mysqld_multi' missing LSB tags and overrides
insserv: warning: current start runlevel(s) (3 4 5) of script `mysql' overwrites defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 6) of script `mysql' overwrites defaults (0 1 6).
insserv: warning: script 'mysqld_multi' missing LSB tags and overrides
Setting up apache2.2-common (2.2.16-6+squeeze10) ...
insserv: warning: script 'K01mysqld_multi' missing LSB tags and overrides
insserv: warning: script 'mysqld_multi' missing LSB tags and overrides
Setting up apache2-mpm-prefork (2.2.16-6+squeeze10) ...
Starting web server: apache2httpd (pid 1571) already running
.
Setting up apache2 (2.2.16-6+squeeze10) ...
Setting up mysql-server (5.1.66-0+squeeze1) ...

Как проверить, всё ли теперь работает как надо?
 

Оффлайн vladimir_ar

  • Ветеран
  • *****
  • Сообщений: 1624
Re: Ошибки зависимостей при каждом апдэйте
« Ответ #14 : 14 Декабрь 2012, 18:24:10 »
Это уже, как я понимаю, конкретно с сервисами  mysql и apache. Я ими никогда не пользовался и не подскажу. Что-то не так в скриптах серверов.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Теги:
 

Перенесено: Ошибки в Devuan после обновления Firefox?

Автор endru

Ответов: 0
Просмотров: 342
Последний ответ 26 Декабрь 2019, 03:46:57
от endru
"Иксы". Лог ошибки.

Автор windolooser

Ответов: 3
Просмотров: 2838
Последний ответ 13 Январь 2012, 13:44:11
от ihammers
Непонятные ошибки в логах загрузки Debian 6.0.6

Автор vibe

Ответов: 10
Просмотров: 2269
Последний ответ 26 Декабрь 2012, 12:12:23
от qupl
Ошибки при включении

Автор user437

Ответов: 12
Просмотров: 7439
Последний ответ 24 Ноябрь 2014, 11:50:43
от ferum
E: Невозможно исправить ошибки,у вас отложены (held) битые пакеты

Автор sockrat

Ответов: 1
Просмотров: 5100
Последний ответ 20 Апрель 2015, 11:40:41
от endru