Автор Тема: Установка php 5.2.17  (Прочитано 4449 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн PavelTkachev

Установка php 5.2.17
« : 13 Февраля 2013, 15:37:58 »
Мне необходимо установить php 5.2.17. В репозитории Debian я вижу 5.3.3. Где взять именно эту версию php и модули для неё?
 

Оффлайн Malaheenee

Re: Установка php 5.2.17
« Ответ #1 : 13 Февраля 2013, 15:47:02 »
PavelTkachev, подключить репозитории oldstable и если там этой версии нет - собирать вручную.
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн PavelTkachev

Re: Установка php 5.2.17
« Ответ #2 : 13 Февраля 2013, 17:01:56 »
oldstable

Подскажите, пожалуйста, как это сделать.
 

John

  • Гость
Re: Установка php 5.2.17
« Ответ #3 : 13 Февраля 2013, 20:46:03 »
Добавить в /etc/apt/sources.list строку:
deb http://ftp.ru.debian.org/debian oldstable main
 

Оффлайн PavelTkachev

Re: Установка php 5.2.17
« Ответ #4 : 14 Февраля 2013, 11:53:43 »
Добавить в /etc/apt/sources.list строку:
deb http://ftp.ru.debian.org/debian oldstable main


После добавления этой строчки и обновления списка пакетов, новы пакеты не появились. Я также пробовал удалить другие записи из /etc/apt/sources.list и заменить ru на us. Результат тот же.
 

Оффлайн Malaheenee

Re: Установка php 5.2.17
« Ответ #5 : 14 Февраля 2013, 13:29:05 »
Верните остальные записи репозиториев, обновите список заново и выполните команду
aptitide versions php5Должно вывести список всех имеющихся версий.

Сообщение объединено: 14 Февраля 2013, 13:38:57
И не появится ничего, потому что неправильно подключено.
Теперь и мы будем знать, как подключить oldstable:
deb http://archive.debian.org/debian/ lenny main contrib non-free
« Последнее редактирование: 14 Февраля 2013, 13:39:25 от Malaheenee »
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн PavelTkachev

Re: Установка php 5.2.17
« Ответ #6 : 14 Февраля 2013, 15:07:43 »
Спасибо большое за помощь!

К сожалению в oldstable находится версия 5.2.6. Значит буду собирать.

В инструкции к сборке сказано, что нужен bison: Версия 1.28 (предпочтительно), 1.35 или 1.75

aptitide versions bison
Возвращает 1:2.4.1.dfsg-3

Это какая версия?
 

Оффлайн Malaheenee

Re: Установка php 5.2.17
« Ответ #7 : 14 Февраля 2013, 15:55:40 »
PavelTkachev, по системе именования пакетов в debian. "1:" - это так называя версия эпохи (вроде так). Так что реальная версия - после двоеточия. Т.е. 2.4.1

Сообщение объединено: 14 Февраля 2013, 15:57:40
Только ставьте libbison-dev, а то не соберется :) Вообще, для сборки чего-либо, нужно устанавливать имя_бибиотеки-dev.
« Последнее редактирование: 14 Февраля 2013, 15:57:40 от Malaheenee »
Все мы где-то, когда-то и в чем-то были новичками.
 

John

  • Гость
Re: Установка php 5.2.17
« Ответ #8 : 14 Февраля 2013, 16:19:07 »
Верните остальные записи репозиториев, обновите список заново и выполните команду
aptitide versions php5Должно вывести список всех имеющихся версий.

Сообщение объединено: 14 Февраля 2013, 13:38:57
И не появится ничего, потому что неправильно подключено.
Теперь и мы будем знать, как подключить oldstable:
deb http://archive.debian.org/debian/ lenny main contrib non-free
Вы что? Какой ещё contrib и non-free? Только main!
 

Оффлайн Malaheenee

Re: Установка php 5.2.17
« Ответ #9 : 14 Февраля 2013, 16:32:24 »
John, тогда загляните: http://archive.debian.org/debian/dists/lenny/non-free/binary-i386/
Всегда лучше добавлять все ветки, чтобы избежать глупых воплей "Йаво там ниыееет".
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн PavelTkachev

Re: Установка php 5.2.17
« Ответ #10 : 15 Февраля 2013, 16:53:50 »
Я поставил библиотеки, но при установке flex-old написано сообщение

Setting up flex-old (2.5.4a-8) ...
Ignoring install-info called from maintainer script
The package flex-old should be rebuilt with new debhelper to get trigger support

Возможно и при установке других библиотек что-то было не так, я мог не заметить. Как проверить правильность их установки?

Я пока умею только вручную в aptitude просматривать зависимости и искать помеченные красным. В данном случае было не установлено glibc-doc. Я её поставил, но как убедиться что всё теперь хорошо и нет проблем в установленных пакетах?
 

Оффлайн wavedocs

  • Новичок форума
  • Сообщений: 4
  • Jabber: wavedocs@gmail.com
Re: Установка php 5.2.17
« Ответ #11 : 01 Марта 2013, 21:16:59 »
Мне необходимо установить php 5.2.17. В репозитории Debian я вижу 5.3.3. Где взять именно эту версию php и модули для неё?

Для 64 битных систем:
echo "deb http://debian.best-hosting.ru/cluster squeeze main" >> /etc/apt/sources.list && aptitude update
Для 32 битных систем:
echo "deb http://debian.best-hosting.ru binary32/" >> /etc/apt/sources.list && aptitude update
Cорцы пакетов:
echo "deb-src http://debian.best-hosting.ru/cluster squeeze main" >> /etc/apt/sources.list && aptitude update
# aptitude search php52
 

Теги:
     

    Установка мониторинга Monit+MMonit

    Автор Kinak

    Ответов: 4
    Просмотров: 2013
    Последний ответ 15 Января 2017, 14:38:19
    от lenin
    Установка iRedMail на сервер LAMP

    Автор kunsaid

    Ответов: 3
    Просмотров: 2325
    Последний ответ 09 Ноября 2016, 03:54:15
    от endru
    Установка и настройка почтового сервера. Вопросы и возможные решения.

    Автор fatalyst

    Ответов: 5
    Просмотров: 2634
    Последний ответ 01 Октября 2011, 05:57:11
    от fatalyst
    Установка NX Server на Debian

    Автор m-e-f

    Ответов: 0
    Просмотров: 2477
    Последний ответ 15 Июня 2013, 18:42:09
    от m-e-f
    Установка OpenVZ выделенный сервер.

    Автор YVSIK

    Ответов: 6
    Просмотров: 6185
    Последний ответ 10 Июня 2014, 17:44:43
    от siferdj