Автор Тема: Wheezy и Epson Perfection V600  (Прочитано 2565 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Paul

  • Активный пользователь
  • **
  • Сообщений: 74
Wheezy и Epson Perfection V600
« : 07 Апреля 2013, 15:16:39 »
Доброго времени суток!
Уперся в проблему. Сканер Epson Perfection V600 не работает на Debian Wheezy AMD64.
Скачал дрова epkowa (iscan-data и iscan) - не пашут. На ноуте - все работает, на стационаре - "Couldn't send command to scanner. Check the scanner status."
sane-find-scanner выдает:
found USB scanner (vendor=0x04b8 [EPSON], product=0x013a [EPSON Scanner]) at libusb:005:002

Мать - Asus P9X79, перетыкал во все возможные USB-порты.
/etc/sane.d/dll.conf - запили до упора - оставил только epkowa. Пользователь и в группе saned и в группе scanner.
Результата нет :(
 

Оффлайн kobzar

Re: Wheezy и Epson Perfection V600
« Ответ #1 : 07 Апреля 2013, 15:56:40 »
если рабатает на ноуте будет работать и на стационаре.
подключите поочередно сканер к обеим машинам и посмотрите через dmesg как он определяется - сравните.  потом посмотрите чем он подтягиваетя. сравнте установленные пакеты в системах. кстати - разрядность системы на буке и на стационаре одинаковая?
Ты дорого мой друг, заплатишь за ошибку,..
Когда оскал мой милый, ты приймешь за улыбку.
 

Оффлайн Paul

  • Активный пользователь
  • **
  • Сообщений: 74
Re: Wheezy и Epson Perfection V600
« Ответ #2 : 07 Апреля 2013, 18:32:50 »
Сорри, ввел в заблуждение!
На ноуте, после того как установил Wheezy - та же хрень...
Но на Squeeze работало - 100%. Потому как свидетельством тому под сотню отсканированных в GiMPe изображений...
dmesg и другие говорят (воткнул в этот раз в разъем USB 3.0):
[10235.652087] usb 2-2: new high-speed USB device number 2 using xhci_hcd
[10235.671511] usb 2-2: New USB device found, idVendor=04b8, idProduct=013a
[10235.671518] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[10235.671522] usb 2-2: Product: EPSON Scanner
[10235.671524] usb 2-2: Manufacturer: EPSON
[10235.671707] usb 2-2: ep 0x81 - rounding interval to 128 microframes, ep desc says 255 microframes
[10235.671714] usb 2-2: ep 0x2 - rounding interval to 128 microframes, ep desc says 255 microframes

~$ sane-find-scanner -q
found USB scanner (vendor=0x04b8 [EPSON], product=0x013a [EPSON Scanner]) at libusb:002:002

$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Как бы я expecting something different... Явно дело в какой-то фигне... Но я уже весь моск себе вынес....
 

Оффлайн kobzar

Re: Wheezy и Epson Perfection V600
« Ответ #3 : 07 Апреля 2013, 18:53:05 »
а если из под судо запустить команды? (кобзар - хитро щурит глаз...)
Ты дорого мой друг, заплатишь за ошибку,..
Когда оскал мой милый, ты приймешь за улыбку.
 

Оффлайн Paul

  • Активный пользователь
  • **
  • Сообщений: 74
Re: Wheezy и Epson Perfection V600
« Ответ #4 : 07 Апреля 2013, 19:10:03 »
$ sudo sane-find-scanner -q
found USB scanner (vendor=0x04b8 [EPSON], product=0x013a [EPSON Scanner]) at libusb:002:002
$ sudo scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages). :(

Как бы сканер-то видится, а не опознается... Главное, что у энтих утилит практически полное отсутствие параметров командной строки и вывода в какой-то лог... Кабы знать, чего и в какое место насильно подсунуть...
Главное, зараза такая, сканер-то определяется правильно!!! В смысле, что он говорит, что Ёпсон, и даже нумерок модельки сообщает... А вот принимающая сторона никак его аусвайс не признает...


Сообщение объединено: 07 Апреля 2013, 19:24:50
Еще в копилку:
# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 003: ID 04b8:013a Seiko Epson Corp.
Bus 001 Device 003: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
Bus 003 Device 003: ID 046d:c506 Logitech, Inc. MX700 Cordless Mouse Receiver
Bus 003 Device 004: ID 04b8:0803 Seiko Epson Corp. Printer (Composite Device)

/etc/sane.d/epkowa.conf                                                                                     
# epkowa.conf -- sample configuration for the EPKOWA SANE backend
# Copyright (C) 2004, 2008, 2009  Olaf Meeuwissen
#
# See sane-epkowa(5), sane-usb(5) and sane-scsi(5) for details.

# Detect all devices supported by the backend.
# If you don't have a SCSI device, you can comment out the "scsi"
# keyword.  Similarly for the other keywords.
#
usb
#scsi


# For any USB scanner not known to the backend (yet), you may, at your
# own peril(!!), force the backend to recognise and use it via libusb.
# You can do so by the following configuration command:
#
#   usb <USB vendor ID> <USB product ID>
#
# SEIKO EPSON's USB vendor ID is '0x04b8' (without quotes).  In order
# to find the USB product ID, use lsusb(1).
# A sample configuration for the Epson Perfection 1650 (Epson GT-8200),
# which has a product ID of 0x0110, would look as follows:
# usb 0x04b8 0x0110

usb 0x04b8 0x013a

После того, как подправил epkowa.conf,
# scanimage -L - молча себе о чем-то думает... Ждал минут 5, ни каких действий-реакций...
« Последнее редактирование: 07 Апреля 2013, 19:24:50 от Paul »
 

Оффлайн kobzar

Re: Wheezy и Epson Perfection V600
« Ответ #5 : 07 Апреля 2013, 21:01:29 »
попробуйте удалить усб без вендора а то дубль выходит
Ты дорого мой друг, заплатишь за ошибку,..
Когда оскал мой милый, ты приймешь за улыбку.
 

Оффлайн Paul

  • Активный пользователь
  • **
  • Сообщений: 74
Re: Wheezy и Epson Perfection V600
« Ответ #6 : 07 Апреля 2013, 22:08:55 »
# scanimage -L
device `epkowa:usb:002:003' is a Epson (unknown model) flatbed scanner
 :( >:(

Сообщение объединено: 07 Апреля 2013, 22:55:36
Что-то все крутится вокруг udev
Похоже, проблемы там...  Но какие именно, в чем и почему - не могу сказать...
Интересно проверить, на других системах (той же Убунту) на ядре 3.2(+) - если там такие же проблемы, то iscan не пашет с новыми ядрами...
Надо либо ждать обновления дров, либо.... Кто-ж мне исходники даст....
« Последнее редактирование: 07 Апреля 2013, 22:55:36 от Paul »
 

Теги:
     

    [Решено]Энергопотребление в wheezy?

    Автор ogost

    Ответов: 9
    Просмотров: 3797
    Последний ответ 15 Февраля 2013, 15:41:49
    от ogost
    [Решено] Wheezy i686 (на ноутбуке ASUS K52DR) Проблема загрузки

    Автор Med

    Ответов: 7
    Просмотров: 2229
    Последний ответ 20 Апреля 2013, 10:29:48
    от Med
    debian 7 wheezy & bluetooth GPS BT-821

    Автор drebr

    Ответов: 0
    Просмотров: 1697
    Последний ответ 20 Сентября 2013, 13:43:25
    от drebr
    Broadcom BCM43142 (bluetooth + wi-fi) и Debian Wheezy

    Автор khakermp

    Ответов: 6
    Просмотров: 5773
    Последний ответ 21 Ноября 2018, 06:10:03
    от Nathan
    [Решено] wireless brcm4313 на debian/wheezy

    Автор ilyuha21st

    Ответов: 0
    Просмотров: 2302
    Последний ответ 06 Июля 2012, 20:36:26
    от ilyuha21st