Автор Тема: [Решено] Не могу обновиться до wheezy  (Прочитано 12148 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн themaster

  • Пользователь
  • *
  • Сообщений: 42
Несколько дней назад диспечер обновлений сообщил мне, что у него штук четыреста с гаком обновлений. Я в него тыкнул, он меня спрашивает, безопасно обновляемся или нет? Ответ "не безопасно", в смысле, с удалением пакетов, диспечера не устроил, и он завис.
Ладно, обновился безопасно, и решил попробовать ещё раз через командную строку. Aptitude сообщил о куче каких-то битых зависимостей, нагуглить ничего хорошего не удалось.
apt-get оказался посговорчивей и выкачал то ли гигабайт, то ли полтора пакетов, но устанавливать их отказался со следующей формулировкой:
E: Не удалось выполнить оперативную настройку 'default-jre'. Подробней, смотрите в man 5 apt.conf о APT::Immediate-Configure. (2)Порывшись в гугле, нашёл следующую ссылку:
http://lists.debian.org/debian-russian/2012/07/msg00887.html
Изучив которую (и прочие обстоятельства), я понял, что четвёртого мая Debian wheezy стал стабильным, и мне предложили до него обновиться с моего предыдущего squeeze. Предложили, да не получилось, из-за этого самого чего-то, связанного с Явой. А может, не связанного. А может, не с Явой. По крайней мере, понять "правильный ответ" по ссылке не получилось, несмотря на возраст ссылки уже больше года. Может, решение уже всё же нашлось?
« Последнее редактирование: 22 Мая 2013, 06:53:19 от qupl »
 

Оффлайн qupl

Re: Не могу обновиться до wheezy
« Ответ #1 : 10 Мая 2013, 00:12:36 »
Уже пробовали?
aptitude -f install

Оффлайн themaster

  • Пользователь
  • *
  • Сообщений: 42
Re: Не могу обновиться до wheezy
« Ответ #2 : 10 Мая 2013, 00:30:03 »
открыто: 9330; закрыто: 13619; отброшено: 135; конфликтует: 379                                                           OЗа отведённое время решения не было найдено. Попытаться тщательнее? [Y/n]
То самое, о чём писал, что ничего хорошего не нагуглил.
 

Оффлайн qupl

Re: Не могу обновиться до wheezy
« Ответ #3 : 10 Мая 2013, 08:00:16 »
А в /etc/apt/sorces.list что сейчас?

Оффлайн themaster

  • Пользователь
  • *
  • Сообщений: 42
Re: Не могу обновиться до wheezy
« Ответ #4 : 10 Мая 2013, 11:01:25 »
Содержание /etc/apt/sources.list
# Официальный репозиторий Debian
deb ftp://ftp.ru.debian.org/debian/ stable main contrib non-free
deb-src ftp://ftp.ru.debian.org/debian/ stable main contrib non-free
# Debian Squeeze - обновления
deb ftp://ftp.ru.debian.org/debian squeeze-updates main
deb-src ftp://ftp.ru.debian.org/debian squeeze-updates main
# Debian Squeeze - обновления безопасности
deb ftp://ftp.ru.debian.org/debian-security squeeze/updates main non-free contrib
deb-src ftp://ftp.ru.debian.org/debian-security squeeze/updates main non-free contrib
# Debian Squeeze - backports
deb ftp://ftp.ru.debian.org/debian-backports squeeze-backports main contrib
deb-src ftp://ftp.ru.debian.org/debian-backports squeeze-backports main contrib
# Debian Squeeze - proprsed - updates
deb ftp://ftp.ru.debian.org/debian squeeze-proposed-updates main contrib non-free
deb-src ftp://ftp.ru.debian.org/debian squeeze-proposed-updates main contrib non-free

Вообще да, у меня там везде squeeze написано... имеет смысл переписать на wheezy?
 


cinyflo

  • Гость
Re: Не могу обновиться до wheezy
« Ответ #6 : 10 Мая 2013, 13:51:32 »
Вообще да, у меня там везде squeeze написано...
Не могу обновиться до wheezy
имеет смысл переписать на wheezy?

А как вы думаете?
 

Оффлайн themaster

  • Пользователь
  • *
  • Сообщений: 42
Re: Не могу обновиться до wheezy
« Ответ #7 : 10 Мая 2013, 23:45:42 »
Заменил, разобрался, что такое backports и с чем их едят. Толку никакого, та же ошибка с jre чего-то там.
 

Оффлайн Sergei_Alekseev

Re: Не могу обновиться до wheezy
« Ответ #8 : 11 Мая 2013, 00:45:03 »
В смысле backports?
Удалите все пакеты про которые вам ошибки выдаёт
выполните apt-get -f install
замените все ентраи squeeze на wheezy
закомментируйте все сторонние репозитории
выполните apt-get update
потом apt-get upgrade && apt-get dist-upgrade
если вывалится, удалите пакет на котором отвалилось и снова
apt-get -f install
apt-get upgrade && apt-get dist-upgrade
 

Оффлайн themaster

  • Пользователь
  • *
  • Сообщений: 42
Re: Не могу обновиться до wheezy
« Ответ #9 : 11 Мая 2013, 09:49:53 »
Вот часть ошибок, которые мне выдаёт aptitude:
  mono-1.0-devel: Зависит: mono-mcs (= 2.6.7-5.1) но устанавливается 2.10.8.1-8.
  libstdc++6: Ломает: gcc-4.3 (< 4.3.6-1) но установлен 4.3.5-4
  mono-4.0-service: Конфликтует: mono-1.0-service но установлен 2.6.7-5.1
  gir1.2-gstreamer-0.10: Конфликтует: gir1.0-gstreamer-0.10 но установлен 0.10.30-1
  libdigest-sha1-perl: Зависит: perlapi-5.10.1 который является виртуальным пакетом.
  libgdict-common: Ломает: gnome-utils-common (< 3.3) но установлен 2.30.0-2
Их там больше семидесяти строк, так что всё печатать смысла не вижу.
Что сие означает? Удалять libgdict-common? Или gnome-utils-common и устанавливать более новый? Или удалять и то, и то? А может, как-то можно сказать установщику, чтобы он сам всё, что надо, удалил да переставил?
Просто когда я сунулся через synaptic удалять mono-1.0-service (который вроде слишком старый), он мне пол-системы предложил удалить, вместе с gedit'ом, самим synaptic'ом и как бы не всем gnome'ом. Правда, предложил потом и установить кучу всякого всего непонятного...
Короче, мне кажется, что если я начну всё удалять бездумно, то я себе всю систему снесу и обновлять будет тупо нечего...
« Последнее редактирование: 11 Мая 2013, 09:57:24 от themaster »
 

Оффлайн Sergei_Alekseev

Re: Не могу обновиться до wheezy
« Ответ #10 : 11 Мая 2013, 10:24:53 »
ёлы-палы ну сделайте apt-get -f install
если вы и снесёте гном, ничего страшного, поставите заново.
лучше xfce конечно, третий гном отвратителен imho.
 

Оффлайн themaster

  • Пользователь
  • *
  • Сообщений: 42
И всё равно не получается...
« Ответ #11 : 16 Мая 2013, 22:22:22 »
По совету предыдущего пользователя загрузился в текстовом режиме, запустил aptitude и ещё раз внимательно посмотрел на список конфликтующих пакетов. В этот раз список начинался с какого-то пакета про ntfs. Ну, значит, решил с него и начать. Запустил aptitude заново, нашёл эту ntfs'ную библиотеку и нажал кнопку "-", в смысле, удалить. Aptitude сказал мне, что он занимается разрешением зависимостей, и попросил не отвлекать. Но согласился показать поподробнее ход процесса - нажатием кнопки "е:Рассмотреть". В течение двадцати минут он шевелил мозгами, пытаясь посчитать чего-то там под категориями "открыто", "закрыто", "отброшено", "конфликтует", дошёл до ста тысяч под категорией "закрыто" - а дальше мне надоело, и я нажал "Ctrl+C". Следовало подождать подольше? И что, он так будет задумываться при удалении каждого пакета? У меня ж их как бы не с пол-сотни...
Просто я вижу только один альтернативный вариант: выкачать полный дистрибутив нового дебиана, нарезать на болванку/записать на флэшку, ну, и вперёд, ковыряться с настройками вайфайчика и прочих радостей жизни...
 

Оффлайн Sergei_Alekseev

Re: Не могу обновиться до wheezy
« Ответ #12 : 16 Мая 2013, 22:46:55 »
По совету предыдущего пользователя загрузился в текстовом режиме, запустил aptitude...
Я вам не советовал запускать aptitude.
Я вам советовал выполнить apt-get -f install
 

Оффлайн themaster

  • Пользователь
  • *
  • Сообщений: 42
Re: Не могу обновиться до wheezy
« Ответ #13 : 16 Мая 2013, 23:18:09 »
Вы мне посоветовали начхать на гном, снести нафик и поставить заново - его или чего получше. Не получается - не сносится, однако. Причина - см. выше.
А что касается apt-get - ну, он мне ругается на этот самый jre. Удалять - см. выше.
 

Оффлайн vladimir_ar

Re: Не могу обновиться до wheezy
« Ответ #14 : 16 Мая 2013, 23:31:18 »
И чего там страшного? Ну снесли, потом поставили. Делов то.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Теги:
     

    [РЕШЕНО] В меню Grub2 русские буквы отображаются как знак вопроса [???]

    Автор calambus

    Ответов: 8
    Просмотров: 5519
    Последний ответ 24 Апреля 2012, 01:41:58
    от calambus
    [Решено]Проблемы с оборудованием

    Автор Eccentric

    Ответов: 22
    Просмотров: 12727
    Последний ответ 21 Марта 2019, 16:37:43
    от Eccentric
    [Решено] сообщения о ходе загрузки

    Автор PitScvorsov

    Ответов: 3
    Просмотров: 2234
    Последний ответ 23 Марта 2014, 09:20:47
    от PitScvorsov
    [РЕШЕНО] Не устанавливается Debian Jessie

    Автор debianuser

    Ответов: 3
    Просмотров: 2367
    Последний ответ 28 Августа 2014, 03:47:35
    от sandaksatru
    [Решено] Шаманство с /home разделом

    Автор Samoha_Original

    Ответов: 6
    Просмотров: 2531
    Последний ответ 05 Января 2013, 11:40:41
    от Samoha_Original