Автор Тема: [Решено] apt-get autoremove собирается снести всё окружение GNOME  (Прочитано 8246 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн truemailbox

При очистке "осиротевших" пакетов командой # apt-get autoremove пакетный менеджер собирается снести всё окружение GNOME. В Ubuntu с подобным не сталкивался. ЧЯДНТ?
Debian 6.0.7 amd64
« Последнее редактирование: 20 Мая 2013, 07:46:24 от qupl »
 

Оффлайн qupl

Re: APT разбушевался
« Ответ #1 : 16 Мая 2013, 12:02:48 »
Скорее всего удален метапакет, который поставил гном.

Оффлайн truemailbox

Re: APT разбушевался
« Ответ #2 : 16 Мая 2013, 12:06:31 »
Скорее всего удален метапакет, который поставил гном.
И как теперь его вернуть?  :D
 

Онлайн ogost

Re: APT разбушевался
« Ответ #3 : 16 Мая 2013, 12:19:13 »
установить обратно?

dpkg -l gnome*посмотрим, какой именно метапакет у вас пропал.

Оффлайн truemailbox

Re: APT разбушевался
« Ответ #4 : 16 Мая 2013, 12:25:11 »
установить обратно?

dpkg -l gnome*посмотрим, какой именно метапакет у вас пропал.
Вот что выдал:
Spoiler: ShowHide
Желаемый=неизвестно/установить/удалить[r]/вычистить[p]/зафиксировать[h]
| Состояние=не[n]/установлен/настроен[c]/распакован/частично настроен[F]/
            частично установлен[H]/trig-aWait/Trig-pend
|/ Ошибка?=(нет)/требуется переустановка[R] (верхний регистр
в полях состояния и ошибки указывает на ненормальную ситуацию)
||/ Имя         Версия   Описание
+++-==============-==============-============================================
un  gnome          <нет>       (описание недоступно)
ii  gnome-about    2.30.2-2       The GNOME about box
un  gnome-accessib <нет>       (описание недоступно)
ii  gnome-accessib 2.30.2-1       accessibility themes for the GNOME desktop
un  gnome-app-inst <нет>       (описание недоступно)
ii  gnome-applets  2.30.0-3       Various applets for the GNOME panel - binary
ii  gnome-applets- 2.30.0-3       Various applets for the GNOME panel - data f
ii  gnome-backgrou 2.32.0-1       a set of backgrounds packaged with the GNOME
un  gnome-bluetoot <нет>       (описание недоступно)
un  gnome-card-gam <нет>       (описание недоступно)
ii  gnome-cards-da 1:2.30.2-2     data files for the GNOME card games
ii  gnome-codec-in 0.4.7+nmu1     GStreamer codec installer
ii  gnome-control- 1:2.30.1-2     utilities to configure the GNOME desktop
un  gnome-core     <нет>       (описание недоступно)
un  gnome-cups-man <нет>       (описание недоступно)
un  gnome-dbg      <нет>       (описание недоступно)
ii  gnome-desktop- 2.30.2-2       Common files for GNOME desktop apps
un  gnome-desktop- <нет>       (описание недоступно)
un  gnome-device-m <нет>       (описание недоступно)
ii  gnome-dictiona 2.30.0-2       GNOME dictionary application
ii  gnome-disk-uti 2.30.1-2       manage and configure disk drives and media
ii  gnome-doc-util 0.20.1-1       a collection of documentation utilities for
un  gnome-games    <нет>       (описание недоступно)
ii  gnome-games-da 1:2.30.2-2     data files for the GNOME games
ii  gnome-games-ex 2.30.0-1       games for the GNOME desktop (extra artwork)
un  gnome-games-lo <нет>       (описание недоступно)
un  gnome-glines   <нет>       (описание недоступно)
un  gnome-gnobots2 <нет>       (описание недоступно)
un  gnome-gnometri <нет>       (описание недоступно)
un  gnome-hearts   <нет>       (описание недоступно)
un  gnome-iagno    <нет>       (описание недоступно)
ii  gnome-icon-the 2.30.3-2       GNOME Desktop icon theme
un  gnome-intro    <нет>       (описание недоступно)
ii  gnome-js-commo 0.1.1-1        Common modules for GNOME JavaScript interpre
ii  gnome-keyring  2.30.3-5       GNOME keyring services (daemon and tools)
un  gnome-libs-dat <нет>       (описание недоступно)
ii  gnome-mag      1:0.16.1-2     a screen magnifier for the GNOME desktop
un  gnome-mahjongg <нет>       (описание недоступно)
un  gnome-main-men <нет>       (описание недоступно)
un  gnome-media    <нет>       (описание недоступно)
ii  gnome-media-co 2.30.0-1       GNOME media utilities - common files
ii  gnome-menus    2.30.3-1       an implementation of the freedesktop menu sp
ii  gnome-mime-dat 2.18.0-1       base MIME and Application database for GNOME
un  gnome-mount    <нет>       (описание недоступно)
ii  gnome-netstatu 2.28.1-1       Network status applet for GNOME
ii  gnome-nettool  2.30.0-3       network information tool for GNOME
un  gnome-network  <нет>       (описание недоступно)
un  gnome-network- <нет>       (описание недоступно)
un  gnome-office   <нет>       (описание недоступно)
un  gnome-orca     <нет>       (описание недоступно)
un  gnome-orca-com <нет>       (описание недоступно)
un  gnome-osd      <нет>       (описание недоступно)
ii  gnome-panel    2.30.2-2       launcher and docking facility for GNOME
ii  gnome-panel-da 2.30.2-2       common files for the GNOME Panel
un  gnome-pilot    <нет>       (описание недоступно)
ii  gnome-power-ma 2.32.0-2       power management tool for the GNOME desktop
un  gnome-same-gno <нет>       (описание недоступно)
ii  gnome-screensa 2.30.0-2squeez GNOME screen saver and locker
ii  gnome-screensh 2.30.0-2       screenshot application for GNOME
ii  gnome-search-t 2.30.0-2       GNOME tool to search files
ii  gnome-session  2.30.2-3       The GNOME Session Manager - GNOME 2 session
ii  gnome-session- 2.30.2-3       The GNOME Session Manager - Minimal runtime
ii  gnome-session- 0.24-1         GNOME session log in and log out sound event
ii  gnome-session- 2.30.2-3       Common files for the GNOME session manager
ii  gnome-settings 2.30.2-2+squee daemon handling the GNOME session settings
un  gnome-sudo     <нет>       (описание недоступно)
un  gnome-sudoku   <нет>       (описание недоступно)
ii  gnome-system-l 2.30.0-2       system log viewer for GNOME
ii  gnome-system-m 2.28.1-1       Process viewer and system resource monitor f
ii  gnome-system-t 2.30.2-2       Cross-platform configuration utilities for G
ii  gnome-terminal 2.30.2-1       The GNOME terminal emulator application
ii  gnome-terminal 2.30.2-1       Data files for the GNOME terminal emulator
ii  gnome-themes   2.30.2-1       official themes for the GNOME desktop
ii  gnome-themes-e 2.22.0-3       extra themes for the GNOME desktop
ii  gnome-themes-m 0.9.0.deb0.8   various themes for the GNOME desktop
ii  gnome-user-gui 2.30.1-1       GNOME user's guide
un  gnome-user-sha <нет>       (описание недоступно)
un  gnome-utils    <нет>       (описание недоступно)
ii  gnome-utils-co 2.30.0-2       data files for the GNOME utilities
un  gnome-volume-m <нет>       (описание недоступно)
un  gnome-www-brow <нет>       (описание недоступно)
un  gnome2-user-gu <нет>       (описание недоступно)
 

Оффлайн qupl

Re: APT разбушевался
« Ответ #5 : 16 Мая 2013, 12:28:49 »
aptitude install gnome
либо не пользуйтесь autoremove

Оффлайн truemailbox

Re: APT разбушевался
« Ответ #6 : 16 Мая 2013, 12:35:51 »
aptitude install gnome
Зачем возвращать ненужные приложения в систему?
либо не пользуйтесь autoremove
В Ubuntu после любых изменений ПО пользовался и проблем не возникало.
 

Онлайн ogost

Re: APT разбушевался
« Ответ #7 : 16 Мая 2013, 12:46:15 »
Зачем возвращать ненужные приложения в систему?
в данном случае вы не возвращаете ненужные приложения, а устанавливаете метапакет gnome.
В Ubuntu после любых изменений ПО пользовался и проблем не возникало.
афаик разница apt в дебиане и в убунте минимальна. разница в репозиториях, возможно в убунте не настолько жестко привязаны зависимости между пакетами

Оффлайн truemailbox

Re: APT разбушевался
« Ответ #8 : 16 Мая 2013, 12:48:06 »
Зачем возвращать ненужные приложения в систему?
в данном случае вы не возвращаете ненужные приложения, а устанавливаете метапакет gnome.
В Ubuntu после любых изменений ПО пользовался и проблем не возникало.
афаик разница apt в дебиане и в убунте минимальна. разница в репозиториях, возможно в убунте не настолько жестко привязаны зависимости между пакетами
Т.е. при удалении таких феерических "ненужно" как brasero или totem я "осиротил" всё DE?  :o

А нет ли возможности "отвязать" зависимости?
« Последнее редактирование: 16 Мая 2013, 12:49:49 от truemailbox »
 

Оффлайн Malaheenee

Re: APT разбушевался
« Ответ #9 : 16 Мая 2013, 12:50:40 »
феерических "ненужно" как brasero или totem я "осиротил" всё DE?
Отчасти да.
aptitude install -R gnome-coreПоставит Вам минимум (в идеале - только этот метапакет)
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн truemailbox

Re: APT разбушевался
« Ответ #10 : 16 Мая 2013, 13:02:45 »
феерических "ненужно" как brasero или totem я "осиротил" всё DE?
Отчасти да.
aptitude install -R gnome-coreПоставит Вам минимум (в идеале - только этот метапакет)


 :o
Spoiler: ShowHide
Следующие НОВЫЕ пакеты будут установлены:       
  evolution{a} gnome-core totem{a}
Следующие пакеты будут УДАЛЕНЫ:
  apache2.2-bin{u} aptdaemon{u} baobab{u} binfmt-support{u} bluez{u}
  brasero-common{u} bsh{u} bsh-gcj{u} ca-certificates-java{u} cdrdao{u}
  cheese-common{u} cli-common{u} dasher-data{u} default-jre{u}
  default-jre-headless{u} dnsmasq-base{u} dvd+rw-tools{u} empathy-common{u}
  epiphany-extensions{u} espeak{u} espeak-data{u} exiv2{u}
  freedesktop-sound-theme{u} freeglut3{u} gcalctool{u} gcj-4.4-base{u}
  gcj-4.4-jre{u} gcj-4.4-jre-headless{u} gcj-4.4-jre-lib{u} gcj-jre{u}
  gcj-jre-headless{u} gconf-defaults-service{u} gconf-editor{u}
  gedit-plugins{u} genisoimage{u} geoclue{u} geoclue-hostip{u}
  geoclue-localnet{u} geoclue-manual{u} geoclue-yahoo{u} gimp-data{u}
  gnome-accessibility-themes{u} gnome-backgrounds{u} gnome-cards-data{u}
  gnome-codec-install{u} gnome-games-data{u} gnome-games-extra-data{u}
  gnome-mag{u} gnome-media-common{u} gnome-nettool{u} gnome-screenshot{u}
  gnome-search-tool{u} gnome-session-canberra{u} gnome-system-log{u}
  gnome-system-tools{u} gnome-themes-extras{u} gnome-themes-more{u}
  gnuchess{u} gnuchess-book{u} gok{u} gstreamer0.10-nice{u}
  gstreamer0.10-tools{u} gtk2-engines-smooth{u} gucharmap{u}
  guile-1.8-libs{u} gvfs-bin{u} hamster-applet{u} imagemagick{u}
  java-common{u} libaccess-bridge-java{u} libaccess-bridge-java-jni{u}
  libao-common{u} libao4{u} libapache2-mod-dnssd{u} libapr1{u}
  libaprutil1{u} libaprutil1-dbd-sqlite3{u} libaprutil1-ldap{u}
  libart2.0-cil{u} libbabl-0.0-0{u} libbrasero-media0{u} libbrlapi0.5{u}
  libcap-ng0{u} libcdt4{u} libchamplain-0.4-0{u} libchamplain-gtk-0.4-0{u}
  libcheese-gtk18{u} libclutter-gtk-0.10-0{u} libcolamd2.7.1{u}
  libcolorblind0{u} libcommons-beanutils-java{u}
  libcommons-collections3-java{u} libcommons-compress-java{u}
  libcommons-digester-java{u} libcommons-logging-java{u} libcryptui0{u}
  libdb-je-java{u} libdb4.7-java{u} libdb4.7-java-gcj{u} libdiscid0{u}
  libepc-1.0-2{u} libepc-common{u} libepc-ui-1.0-2{u} libespeak1{u}
  libexiv2-9{u} libfreerdp-plugins-standard{u} libfreerdp0{u}
  libgail-gnome-module{u} libgalago3{u} libgcj-bc{u} libgcj-common{u}
  libgcj10{u} libgcj10-awt{u} libgconf2.0-cil{u} libgd2-noxpm{u}
  libgdata-common{u} libgdata7{u} libgee2{u} libgegl-0.0-0{u}
  libgeoclue0{u} libgexiv2-0{u} libgimp2.0{u} libglade2.0-cil{u}
  libglib2.0-cil{u} libgmime2.4-cil{u} libgnome-bluetooth7{u}
  libgnome-mag2{u} libgnome-media0{u} libgnome-speech7{u}
  libgnome-vfs2.0-cil{u} libgnome2.24-cil{u} libgnomepanel2.24-cil{u}
  libgomp1{u} libgpod-common{u} libgpod4{u} libgraph4{u} libgraphite3{u}
  libgssdp-1.0-2{u} libgstfarsight0.10-0{u} libgtk2.0-cil{u}
  libgtkspell0{u} libgupnp-1.0-3{u} libgupnp-igd-1.0-3{u} libgvc5{u}
  libhsqldb-java{u} libhsqldb-java-gcj{u} libhyphen0{u} libicu4j-java{u}
  libilmbase6{u} libjaxp1.3-java{u} libjline-java{u} libjtidy-java{u}
  liblouis-data{u} liblouis2{u} liblqr-1-0{u} liblucene2-java{u}
  libmagick++3{u} libmagickcore3{u} libmagickcore3-extra{u}
  libmagickwand3{u} libmng1{u} libmono-addins-gui0.2-cil{u}
  libmono-addins0.2-cil{u} libmono-cairo2.0-cil{u} libmono-corlib2.0-cil{u}
  libmono-i18n-west2.0-cil{u} libmono-posix2.0-cil{u}
  libmono-security2.0-cil{u} libmono-sharpzip2.84-cil{u}
  libmono-system2.0-cil{u} libmusicbrainz3-6{u} libmythes-1.2-0{u}
  libndesk-dbus-glib1.0-cil{u} libndesk-dbus1.0-cil{u} libnet1{u}
  libnetpbm10{u} libnice0{u} libnl1{u} libnm-glib-vpn1{u} libnm-glib2{u}
  libnm-util1{u} libopal3.6.8{u} libopenexr6{u} libopenobex1{u}
  libopenraw1{u} libpathplan4{u} libpcap0.8{u} libpcsclite1{u}
  libplot2c2{u} libportaudio2{u} libpstoedit0c2a{u} libpt2.6.7{u}
  libpulse-mainloop-glib0{u} libregexp-java{u} libservlet2.5-java{u}
  libspeexdsp1{u} libsrtp0{u} libssh-4{u} libtelepathy-farsight0{u}
  libtelepathy-glib0{u} libtextcat-data-utf8{u} libtidy-0.99-0{u}
  libtracker-client-0.8-0{u} libwmf-bin{u} libwmf0.2-7{u} libwpd8c2a{u}
  libwpg-0.1-1{u} libwps-0.1-1{u} libxdot4{u} liferea-data{u} lp-solve{u}
  media-player-info{u} mesa-utils{u} mobile-broadband-provider-info{u}
  modemmanager{u} mono-2.0-gac{u} mono-gac{u} mono-runtime{u}
  mousetweaks{u} nautilus-sendto{u} nautilus-sendto-empathy{u} netpbm{u}
  network-manager{u} network-manager-gnome{u} obex-data-server{u}
  obexd-client{u} openjdk-6-jre{u} openjdk-6-jre-headless{u}
  openjdk-6-jre-lib{u} perlmagick{u} pkg-config{u} ppp{u} pstoedit{u}
  python-aptdaemon{u} python-aptdaemon-gtk{u} python-axiom{u}
  python-beautifulsoup{u} python-brlapi{u} python-bugbuddy{u}
  python-clientform{u} python-coherence{u} python-configobj{u}
  python-crypto{u} python-epsilon{u} python-evolution{u}
  python-feedparser{u} python-gdata{u} python-gdbm{u} python-gst0.10{u}
  python-gtkglext1{u} python-httplib2{u} python-louie{u} python-louis{u}
  python-mako{u} python-markupsafe{u} python-mechanize{u} python-nevow{u}
  python-opengl{u} python-pyasn1{u} python-pyatspi{u} python-pysqlite2{u}
  python-rdflib{u} python-tagpy{u} python-twisted-conch{u}
  python-utidylib{u} python-webkit{u} remmina-plugin-data{u} seahorse{u}
  seahorse-plugins{u} tcl{u} tcl8.4{u} tcptraceroute{u} telepathy-gabble{u}
  telepathy-mission-control-5{u} telepathy-salut{u} transmission-common{u}
  ttf-liberation{u} ttf-lyx{u} ttf-opensymbol{u} ttf-sil-gentium{u}
  ttf-sil-gentium-basic{u} tzdata-java{u} ufraw-batch{u} uno-libs3{u}
  update-manager-core{u} update-manager-gnome{u} update-notifier{u}
  update-notifier-common{u} ure{u} usb-modeswitch{u} usb-modeswitch-data{u}
  vino{u} wpasupplicant{u} xdg-user-dirs{u} xdg-user-dirs-gtk{u}
  xfonts-mathml{u} xsane-common{u} xulrunner-1.9.1{u}
РЕКОМЕНДУЮТСЯ следующие пакеты, но автоматически они установлены НЕ БУДУТ:
  totem-plugins
0 пакетов обновлено, 3 установлено новых, 298 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0 B/1 848 kB архивов. После распаковки освободится 730 M байт.
Хотите продолжить? [Y/n/?] n
Прервать.


 

Оффлайн qupl

Re: APT разбушевался
« Ответ #11 : 16 Мая 2013, 13:06:44 »
truemailbox,  что-то Вы не договариваете. В каком порядке всё устанавливали? Что недавно удаляли ит.п.?

Оффлайн truemailbox

Re: APT разбушевался
« Ответ #12 : 16 Мая 2013, 13:15:03 »
truemailbox,  что-то Вы не договариваете. В каком порядке всё устанавливали? Что недавно удаляли ит.п.?
Вчера произвёл чистую установку с 6.0.7 DVD-1 полученного из архивной секции на debian.org. После установки первым делом по убунтовской привычке снёс все ненужные мне пакеты приложений #apt-get purge ... , решил удалить оставшиеся от них зависимости и тут <БАЦ!> apt собирается удалить мне DE. Вот и всё собственно, ничего экстраординарного не делал, только в source.list прописал в качестве источников DVD диски с Debian Official.
 

Оффлайн agentgoblin

Re: APT разбушевался
« Ответ #13 : 16 Мая 2013, 16:14:19 »
Чистую установку следовало проводить, сняв в меню инсталлятора отметку с пункта "Окружение рабочего стола" (или как оно там, точно не помню). А уже потом из голой системы ставить нужные пакеты - Xorg и gnome. Хотя врят ли это помогло бы - gnome здорово завязан на "свои" приложения, тут у него стало хуже, чем в Windows - чего только список зависимостей стоит: http://packages.debian.org/ru/wheezy/gnome/gnome. Свой редактор, свой медиаплеер, свой браузер и т.д. Поэтому что-то безболезненно выкинуть оттуда проблематично. Варианта в принципе два: оставить всё как есть, вернув totem и прочее "не нужно" на место, либо подумать о переходе на другой DE или WM.
 

Оффлайн truemailbox

Re: APT разбушевался
« Ответ #14 : 16 Мая 2013, 16:43:59 »
agentgoblin, agentgoblin, agentgoblin, truemailbox, qupl, qupl,
gnome здорово завязан на "свои" приложения, тут у него стало хуже, чем в Windows - чего только список зависимостей стоит: http://packages.debian.org/ru/wheezy/gnome/gnome. Свой редактор, свой медиаплеер, свой браузер и т.д. Поэтому что-то безболезненно выкинуть оттуда проблематично.
Почему то так только в Debian...
 

Теги:
     

    Не запускается tor-browser в дебиан 10 (Решено)

    Автор Листик

    Ответов: 8
    Просмотров: 2463
    Последний ответ 17 Ноября 2019, 00:11:29
    от Gamliel
    [Решено] Помогите с уcтановкой SSH

    Автор pvn_12@mail.ru

    Ответов: 7
    Просмотров: 5422
    Последний ответ 19 Февраля 2013, 10:40:18
    от fry
    [Решено] Права доступа в Debian

    Автор Dremjke

    Ответов: 3
    Просмотров: 4251
    Последний ответ 17 Августа 2013, 18:17:48
    от Malaheenee
    [РЕШЕНО]_Переключение_раскладки

    Автор speed_vm

    Ответов: 8
    Просмотров: 2285
    Последний ответ 18 Декабря 2013, 21:51:15
    от speed_vm
    [РЕШЕНО] Debian 8 MATE. Не запускается Synaptic, не монтируются диски

    Автор panzerfaust

    Ответов: 20
    Просмотров: 10327
    Последний ответ 17 Апреля 2015, 14:27:08
    от panzerfaust