Автор Тема: [Решено] Ищу программу для черчения  (Прочитано 5534 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Artuom

Здравствуйте! Мне нужна программа для черчения среднего уровня чертежей и схем. Искал в гугле - не особо. Может посоветуете что...
Требование пожалуй одно - возможность свободно распечатать. Что то я сомневаюсь, что там распознают линуксовский формат. :)

Нашел программу по адресу www.qcad.org/en/qcad-downloads-trial. Проблема появилась сразу - при установке пишет:
Spoiler: ShowHide
# sh qcad-3.0.0-trial-linux-x86.bin
Verifying archive integrity... All good.
Uncompressing QCAD
[: 12: xTrial: unexpected operator
QCAD Setup...
Making dir /root/opt/qcad-3.0.0-prof-linux...
Copying files...
cp: невозможно выполнить stat для «qcad-bin»: Нет такого файла или каталога
cp: невозможно выполнить stat для «qcad»: Нет такого файла или каталога
Invoking postinstall.sh...
    Installing mimetypes...
    Installing mimetype icons...
    Installing desktop menu entries...
    Installing desktop icon...
    Creating uninstall script...
    Setting executable flag...
chmod: невозможно получить доступ к «/root/opt/qcad-3.0.0-prof-linux/qcad-trial»: Нет такого файла или каталога
chmod: невозможно получить доступ к «/root/opt/qcad-3.0.0-prof-linux/qcad-trial-bin»: Нет такого файла или каталога
QCAD Setup finished.

Т. к. раньше я никогда не имел дела с подобного рода установкой, я ничего не понял... При этом создаются файлы в директории /home/artuompa/opt/qcad-3.0.0-prof-linux, но при запуске выводит ошибку
Spoiler: ShowHide
Не удалось выполнить процесс-потомок «/home/artuompa/opt/qcad-3.0.0-prof-linux/qcad-trial» (Нет такого файла или каталога)

Заранее благодарен! :)

Сообщение объединено: 12 Июня 2013, 09:39:59
Программу я таки домучал :). Скачал оттуда архив и просто его распаковал... Правда теперь остается вопрос - что делать с нерабочим пунктом меню "Приложения --> Графика --> QCAD Trial"... При запуске пишет:
Spoiler: ShowHide
Не удалось выполнить процесс-потомок «/root/opt/qcad-3.0.0-prof-linux/qcad-trial» (Отказано в доступе)


Основной вопрос в силе - какие программы посоветуете? Желательно на русском.
« Последнее редактирование: 17 Июня 2013, 12:25:00 от Artuom »
 

Оффлайн Anonymous

Re: Ищу программу для черчения
« Ответ #1 : 12 Июня 2013, 10:50:25 »
прав на запись/чтение нет в директорию.
 

Оффлайн Artuom

Re: Ищу программу для черчения
« Ответ #2 : 12 Июня 2013, 11:02:58 »
Спасибо огромное за ответ, но я эту команду выполнял три раза - один так, потом два из под рута. Результат выложен по моему рутовский.
Хотя ключевая проблема, пожалуй
Т. к. раньше я никогда не имел дела с подобного рода установкой, я ничего не понял...
;D
Буду читать, разбираться, учиться... :)
 

Оффлайн Udachnik

Re: Ищу программу для черчения
« Ответ #3 : 12 Июня 2013, 11:14:40 »
Librecad не подойдет? Qcad в своё время выкинули из репозитория за страшную глючность.
 

Оффлайн BULATUS

Re: Ищу программу для черчения
« Ответ #4 : 12 Июня 2013, 11:26:36 »
Не пользуюсь, но посмотрите может и пригодится...
посмотрите в репозитарии librecad
подробности:
оф.сайт http://librecad.org/cms/home.html
информация с  http://packages.debian.org/ru/wheezy/librecad
информация с википедии http://ru.wikipedia.org/wiki/LibreCAD
информация от блогера http://obscurityway.blogspot.ru/2012/10/librecad.html

Ставится командой aptitude install librecad

Оффлайн Artuom

Re: Ищу программу для черчения
« Ответ #5 : 12 Июня 2013, 12:14:13 »
Спасибо за программу. Описание очень понравилось.
В процессе установки возникли вопросы: выяснилось, что эта программа есть в репозитории Debian 7.0 (Wheezy). С тем, как добавлять репозитории, я более или не менее разобрался, но вот какой именно - не знаю. Попробовал прописать в источниках приложений "http://ftp.ua.debian.org/debian/ wheezy-updates main", но результат нулевой. :-[
 

Оффлайн ferum

Re: Ищу программу для черчения
« Ответ #6 : 12 Июня 2013, 12:36:22 »
Artuom, Да козлы кто то , то линаши словяне, то ли буржуи. По сему некоторые пакеты нагло отсутствуют на наших зеркалах, однако если вы перейдёте по ссылке http://packages.debian.org/ru/wheezy/amd64/librecad/download ну или http://packages.debian.org/ru/wheezy/i386/librecad/download ток своему удовольствию увидите строчку deb http://ftp.de.debian.org/debian wheezy main
Русские дебианщики против цифрового слабоумия !
 

Оффлайн BULATUS

Re: Ищу программу для черчения
« Ответ #7 : 12 Июня 2013, 12:41:00 »
Не надо ничего добавлять  :) откройте терминал, под root введите команду которую дал.
Уверен Вам должно пригодится https://debianforum.ru/index.php?topic=1563.0 для общего развития...

И кстати, ссылки я дал для ознакомления с программой, и даже там можно понять, что не надо ничего добавлять, ибо программа есть в репозитарии, а это значит программы можно ставить без лишних телодвижений.

Сообщение объединено: 12 Июня 2013, 12:42:39
С тем, как добавлять репозитории, я более или не менее разобрался, но вот какой именно - не знаю.
Проблемы с репозитарием?
Покажите вывод команды в терминале cat /etc/apt/sources.list
« Последнее редактирование: 12 Июня 2013, 12:42:39 от BULATUS »
 

Оффлайн Artuom

Re: Ищу программу для черчения
« Ответ #8 : 12 Июня 2013, 13:27:55 »
Не надо ничего добавлять  :) откройте терминал, под root введите команду которую дал.
Спасибо огромное! Я раньше не знал, как устанавливать этой командой и работал apt, но пакет не был найден и я начал поиски репозитория :)

Проблемы с репозитарием?
Нет, слава Богу  :), просто не мог понять по какому принципу их искать и выбирать (гугль не помог)

Сейчас - новая трудность. Пакет найден, но при установке находит много неудовлетворенных зависимостей и не устанавливает :( Вот, если подробно
Spoiler: ShowHide
root@UserPK:/home/artuompa# aptitude install librecad
[ ERR] Чтение информации о состоянии
E: Не удалось получить доступ к файлу блокировки /var/lock/aptitude - open (11: Ресурс временно недоступен)
Следующие НОВЫЕ пакеты будут установлены:       
  gcc-4.7-base{ab} libdxflib-2.2.0.0{a} libgmp10{a} libmuparser2{a} librecad librecad-data{a} multiarch-support{a}
Следующие пакеты будут обновлены:
  cpp-4.4 gcc-4.4 gcc-4.4-base{b} libc-bin libc-dev-bin libc6 libc6-dev libgcc1{b} libgomp1{b} libmpfr4 libqtcore4 libstdc++6{b} locales make pkg-config
15 пакетов обновлено, 7 установлено новых, 0 пакетов отмечено для удаления, и 1221 пакетов не обновлено.
Необходимо получить 4.877 kB/31,5 MB архивов. После распаковки 21,8 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  libstdc++6: Ломает: gcc-4.3 (< 4.3.6-1) но установлен 4.3.5-4
  libqt4-opengl: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-assistant: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  gcc-4.7-base: Ломает: gcj-4.4-base (< 4.4.6-9~) но установлен 4.4.5-2
  libgfortran3: Зависит: gcc-4.4-base (= 4.4.5-8) но устанавливается 4.4.7-2.
  g++-4.4: Зависит: gcc-4.4-base (= 4.4.5-8) но устанавливается 4.4.7-2.
           Зависит: gcc-4.4 (= 4.4.5-8) но устанавливается 4.4.7-2.
  libqt4-test: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-sql-mysql: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-dbus: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-qt3support: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libgomp1: Ломает: gcc-4.3 (< 4.3.6-1) но установлен 4.3.5-4
  libstdc++6-4.4-dev: Зависит: gcc-4.4-base (= 4.4.5-8) но устанавливается 4.4.7-2.
  libqt4-xmlpatterns: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libc6-i686: ПредЗависит: libc6 (= 2.11.3-4) но устанавливается 2.13-38.
  libgcc1: Ломает: gcc-4.3 (< 4.3.6-1) но установлен 4.3.5-4
  libqt4-help: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-webkit: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-sql-sqlite: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-sql: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-svg: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  gcc-4.4-base: Ломает: gcj-4.4-base (< 4.4.6-9~) но установлен 4.4.5-2
  libqt4-xml: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-network: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-designer: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqtgui4: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-script: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  libqt4-scripttools: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
  qt4-qtconfig: Зависит: libqtcore4 (= 4:4.6.3-4+squeeze1) но устанавливается 4:4.8.2+dfsg-11.
открыто: 384; закрыто: 676; отброшено: 197; конфликтует: 342                                                              oСледующие действия разрешат зависимости:

       Удалить следующие пакеты:       
                                                                                                                 


Сообщение объединено: 12 Июня 2013, 14:24:59
Далее список из 230 пакетов и надпись, что "если вы удалите их все и установите 3 новых пакета, то "будет вам счастье" :)
Что теперь делать?  ???
Простите за грубый просчет OS Debian 6.0.7 (squeeze).
« Последнее редактирование: 12 Июня 2013, 14:26:57 от Artuom »
 

Оффлайн vladimir_ar

Re: Ищу программу для черчения
« Ответ #9 : 12 Июня 2013, 16:18:32 »
DraftSight
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн ferum

Re: Ищу программу для черчения
« Ответ #10 : 12 Июня 2013, 17:47:40 »
Простите за грубый просчет OS Debian 6.0.7 (squeeze).
Ну вот, вы и сами всё поняли! А мы тут все репы исчесали ;D
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Artuom

Re: Ищу программу для черчения
« Ответ #11 : 12 Июня 2013, 20:57:13 »
Простите за глупый вопрос. То есть, имея OS squeeze, пользоватся программами из wheezy я не смогу из за неудовлетворенных зависимостей? Или все таки смогу? :)
« Последнее редактирование: 12 Июня 2013, 20:58:45 от Artuom »
 

Оффлайн ferum

Re: Ищу программу для черчения
« Ответ #12 : 12 Июня 2013, 21:54:52 »
Вопрос не глупый но риторический. для того что бы решить эту проблему вам придётся до wheezy обновиться. Если по каким либо причинам обновляться очень не хочется, можно прицепить убунтовский ppa https://launchpad.net/~librecad-dev/+archive/librecad-stable?field.series_filter= и взять с него deb-src для maverick или natty и сделать для себя бэкпорт.
Можно конечно попробовать и пакет установить, с достаточной долей вероятности страшного не произойдёт, но сообщество крайне не рекомендует такое действие по вполне понятным причинам (систему можно нагнуть) ...однако каждый сам считает средства для достижения цели
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Artuom

Re: Ищу программу для черчения
« Ответ #13 : 13 Июня 2013, 09:53:50 »
Спасибо огромное за потраченное на меня время и данные советы! :) И последний, наверно, вопрос в этой теме: я подозреваю, что по своей неопытности и в силу моих эксперементов (не все делалось с первого раза, разные статьи, инструкции...) с моей системой не все в порядке (при закрузке несколько пунктов загрузки горят красным и зеленым). Мне лучше переустановить систему или все таки попробовать обновиться?
 

Оффлайн SeHELLioN

Re: Ищу программу для черчения
« Ответ #14 : 13 Июня 2013, 17:38:13 »
Spoiler: ShowHide
при закрузке несколько пунктов загрузки горят красным и зеленым
зеленые - все хорошо
красные - смотреть с чем проблемы
но, если систему Вы все-таки настроили, зачем трогать то, что и так работает? переустанавлиать - не наш метод
если Вас смущают красные индикаторы, то гугл и форум в помощь
Asus m5a97+Amd fx-8350+4x4GB DDR3 1600MGz+asus gtx670 DCII (перешита в top)
Debian stable
 

Теги:
     

    [Решено] Не могу корректно выключить debian wheezy

    Автор themaster

    Ответов: 2
    Просмотров: 1931
    Последний ответ 21 Июля 2013, 22:44:12
    от themaster
    [Решено] Как наконец вырубить блютуз?

    Автор Salko

    Ответов: 2
    Просмотров: 1699
    Последний ответ 18 Декабря 2013, 00:17:22
    от htc
    [Решено] Debian сломался, но не полностью

    Автор iormark

    Ответов: 4
    Просмотров: 1605
    Последний ответ 29 Января 2015, 10:06:08
    от iormark
    [Решено] Установка Erlang.

    Автор shaly

    Ответов: 7
    Просмотров: 4407
    Последний ответ 20 Июня 2014, 05:02:50
    от ihammers
    [РЕШЕНО] Оффлайн обновление системы

    Автор speed_vm

    Ответов: 4
    Просмотров: 2879
    Последний ответ 13 Января 2016, 18:52:04
    от speed_vm