[Решено] Установка justniffer из deb-пакета.

Автор yarmol, 29 июня 2013, 10:18:08

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

yarmol

Я хочу установить justniffer (ссылка на deb-пакет: http://sourceforge.net/projects/justniffer/?source=dlp). Применяю gdebi, так как программы нет в репозиториях. При попытке установки мне выдаётся ошибка "Error: Неразрешимая зависимость: libboost-programm-options1.42.0  (>=1.42.0-1)."
Пытаюсь в системе найти что-нибудь похожее на этот пакет. Открываю synaptics и нахожу там установленный пакет "libboost-program-options1.46.1". Очевидно же, что у меня установлена более новая версия пакета. Но всеравно установка производиться почему-то не хочет.
Мои предположения следующие. gdebi нужен пакет именно с названием libboost-programm-options1.42.0. Тут интересно получается, что номер версии сам по себе содержится в названии пакета. У меня не так много опыта в использовании линукса, но я полагаю, что номер версии пакета должен содержатся не в названии пакета, а где-то ещё. Если бы для установки требовался пакет "libboost-programm-options", в названии которого отсутствует номер версии, и если бы новая версия у меня в системе присутствовала бы, то всё установилось бы корректно. Я правильно полагаю?
Теперь не знаю что делать надо. В репозиториях с помощью программы synaptic я вижу только пакет "libboost-program-options1.46.1". Мне нужно в репозиториях найти пакет "libboost-programm-options1.42.0"? Если да, то как это сделать? Или же есть другое решение? Помогите справится с задачей.

  •  

qupl

yarmol, этот пакет есть в squeeze. А у Вас какая версия debian?

yarmol

#2
У меня Кубунту 12.04. Рабочий стол KDE, а суть та же, что и у Дебан и Убунты. Надеюсь это дело не меняет?
  •  

SeHELLioN

Цитата: yarmol от 29 июня 2013, 10:18:08Или же есть другое решение?
собрать пакет из исходников ;)

или же перепаковать его, с правкой зависимостей: http://binsh.ru/2010/10/22/low-level-deb.html
  •  

yarmol

Цитата: SeHELLioN от 29 июня 2013, 16:51:32
Цитата: yarmol от 29 июня 2013, 10:18:08Или же есть другое решение?
собрать пакет из исходников ;)

или же перепаковать его, с правкой зависимостей: http://binsh.ru/2010/10/22/low-level-deb.html

А теми средствами, которыми я располагаю, что нибудь можно сделать? Перпаковка и сбор из исходников это очень сложно для меня.
  •  

SeHELLioN

yarmol, какими средствами?
всего то нужно распаковать, поправить один файл, запаковать обратно
  •  

yarmol

Цитата: SeHELLioN от 29 июня 2013, 18:48:38
всего то нужно распаковать, поправить один файл, запаковать обратно
Распаковал, изменил названия пакетов в файле control и пересобрал deb-пакет, как это предлагалось сделать в статье выше. Установилось нормально, только вот при запуске программа как раз и запросила именно те пакеты, которые были указаны в первоначальном варианте.

justniffer: error while loading shared libraries: libboost_regex.so.1.42.0: cannot open shared object file: No such file or directory

Так что такой способ пересборки deb-файлов применять не слудует. Сейчас мне ещё этот пакет удалять надо, чтобы систему не засорял...
  •  

ferum

Цитата: SeHELLioN от 29 июня 2013, 16:51:32
Цитата: yarmol от 29 июня 2013, 10:18:08Или же есть другое решение?
собрать пакет из исходников ;)

или же перепаковать его, с правкой зависимостей: http://binsh.ru/2010/10/22/low-level-deb.html

Боюсь это совершенно не реально, из любопытства качнул исходники по ссылке. Они даже дебианизированы, однако на столько стары. Однакоyarmol,  коли у вас kubuntu 12.04 у вас и особых проблем то нет.цепляйте репу  https://launchpad.net/~oreste-notelli/+archive/ppa и вперёд заре на встречу, стоял бы wheezy пришлось бы бекпортить. Судьба темы думаю понятна.
Русские дебианщики против цифрового слабоумия !
  •  

yarmol

Из репов получилось установить. Спасибо.
  •