Автор Тема: [Решено] С новой темой не работает некоторые программы!  (Прочитано 5273 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн demon_666_902

  • Пользователь
  • *
  • Topic Author
  • Сообщений: 49
Проблема в следующем - очень мне понравилась тема mediterranean dark, но когда я ее устанавливаю некоторые приложения не запускаются (synaptic, audacious и т.д.)...
При их запуске консоль выкидывает следющее:
Spoiler: ShowHide

sonrac@sonrac-debian-pc:~/gtk+-3.8.2$ audacious

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:685:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:777:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:817:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1028:15: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1028:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1035:18: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1035:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1059:18: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1059:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1256:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1522:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1532:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1811:15: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1811:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2373:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: sidebar.css:17:19: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: sidebar.css:37:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-panel.css:88:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: tabs.css:101:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:127:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:159:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:244:15: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:244:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:281:18: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:281:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:293:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:317:18: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:317:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:332:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:422:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:459:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-mdi.css:631:17: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-applications-light.css:22:18: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-applications-light.css:22:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-applications-light.css:115:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-applications-light.css:122:20: Not using units is deprecated. Assuming 'px'.

(audacious:18299): Gtk-WARNING **: Theme parsing error: gnome-applications-light.css:130:20: Not using units is deprecated. Assuming 'px'.
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 103: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-droid-sans-fonts.conf", line 138: Having multiple values in <test> isn't supported and may not work as expected

(audacious:18299): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(audacious:18299): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.36.3/./gobject/gtype.c:4239: type id `0' is invalid

(audacious:18299): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced
Ошибка сегментирования

Версия gtk:
pkg-config --modversion gtk+-2.0
2.24.20

Может тема использует gtk+3 и моя версия для нее устаревшая?

На всякий случай список пакетов, где встречается gtk в имени:
Spoiler: ShowHide

gir1.2-gtk-2.0               install
gir1.2-gtk-3.0               install
gtk-doc-tools               install
gtk2-engines-murrine:amd64         install
gtk2-engines-pixbuf:amd64         install
gtk2-engines-xfce            install
gtk3-engines-unico:amd64         install
libcanberra-gtk3-0:amd64         install
libcanberra-gtk3-module:amd64         install
libdbusmenu-gtk3-4:amd64         install
libdbusmenu-gtk4:amd64            install
libgtk-3-0:amd64            install
libgtk-3-bin               install
libgtk-3-common               install
libgtk-3-dev               install
libgtk2-perl               install
libgtk2-ruby1.8               install
libgtk2.0-0:amd64            install
libgtk2.0-bin               install
libgtk2.0-cil               install
libgtk2.0-cil-dev            install
libgtk2.0-common            install
libgtk2.0-dev               install
libgtk3.0-cil               install
libgtkglext1               install
libgtkimageview0            install
libgtkmm-2.4-1c2a:amd64            install
libgtksourceview-3.0-0:amd64         deinstall
libgtksourceview2.0-0            install
libgtksourceview2.0-common         install
libgtkspell0               install
libjavascriptcoregtk-1.0-0         install
libjavascriptcoregtk-3.0-0         install
libwebkitgtk-1.0-0            install
libwebkitgtk-1.0-common            install
libwebkitgtk-3.0-0            install
libwebkitgtk-3.0-common            install
libwxgtk2.8-0:amd64            install
pinentry-gtk2               install
python-aptdaemon-gtk            install
python-aptdaemon.gtk3widgets         install
python-aptdaemon.gtkwidgets         install
python-gtk2               install
python-wxgtk2.8               install
ruby-gtk2               install

Если тему вновь изменить на стандартную, то опять все прекрасно работает))
Также прикрепляю саму тему

Сообщение объединено: 18 Июль 2013, 12:22:05
Извините за беспокойство - удалил папку gtk-3.0 и все заработало)))))
« Последнее редактирование: 18 Июль 2013, 14:41:39 от SeHELLioN »
 


Оффлайн Malaheenee

  • Ветеран
  • *****
  • Сообщений: 2565
  • Учтите, мы можем дать и вредный совет.
demon_666_902, это гтк-3.8 такой "поломанный", у нас любимая тема - Орион (пока она оптимизирована только для 3.6) тоже вываливалась с ошибкой сегментирования.
Все мы где-то, когда-то и в чем-то были новичками.
 

Теги:
 

[РЕШЕНО] Как вместЕ установить KDE и GNOME

Автор Metrix

Ответов: 11
Просмотров: 9035
Последний ответ 25 Февраль 2011, 19:43:09
от Metrix
Отключение поторного ввода пароля в LightDM после простоя. (Решено)

Автор Tammy

Ответов: 2
Просмотров: 1701
Последний ответ 06 Апрель 2013, 22:46:56
от Tammy
[РЕШЕНО] Не ставится libgtk2.0-dev

Автор Defman

Ответов: 1
Просмотров: 2520
Последний ответ 29 Июль 2014, 22:56:25
от Ghostdmn
[решено]ratpoison

Автор Тхакур

Ответов: 18
Просмотров: 2922
Последний ответ 15 Апрель 2019, 20:58:11
от Тхакур
[РЕШЕНО]И снова Conky (статистика трафика 3G интернета)

Автор vavun

Ответов: 3
Просмотров: 3788
Последний ответ 11 Январь 2012, 19:43:09
от vavun