Автор Тема: [Решено] Проблема с впн  (Прочитано 5841 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн zaborik

  • Пользователь
  • *
  • Сообщений: 23
[Решено] Проблема с впн
« : 29 Июля 2013, 23:10:18 »
Проблема при подключении опенвпн. Дело в том что сервис впн работает только напрямую через терминал. И в network manager  впн не работает. В терминале ввожу: sudo openvpn --config 'путь к файлу vpn.ovpn'. Коннект идет нормально. Ошибок нету вообще. По ifconfig интерфейс так же поднимается, но никак не хочет работать интернет. Ни по вайфай ни через 3g модем. Лог:
sudo openvpn --config QuadVPN.ovpn
Tue Jul 30 02:09:15 2013 OpenVPN 2.2.1 i486-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] [eurephia] [MH] [PF_INET6] [IPv6 payload 20110424-2 (2.2RC2)] built on Jun 19 2013
Tue Jul 30 02:09:15 2013 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Tue Jul 30 02:09:15 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Tue Jul 30 02:09:15 2013 LZO compression initialized
Tue Jul 30 02:09:15 2013 Attempting to establish TCP connection with [AF_INET]176.9.92.79:1195 [nonblock]
Tue Jul 30 02:09:16 2013 TCP connection established with [AF_INET]176.9.92.79:1195
Tue Jul 30 02:09:16 2013 TCPv4_CLIENT link local: [undef]
Tue Jul 30 02:09:16 2013 TCPv4_CLIENT link remote: [AF_INET]176.9.92.79:1195
Tue Jul 30 02:09:31 2013 [server] Peer Connection Initiated with [AF_INET]176.9.92.79:1195
Tue Jul 30 02:09:35 2013 TUN/TAP device tun0 opened
Tue Jul 30 02:09:35 2013 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Tue Jul 30 02:09:35 2013 /sbin/ifconfig tun0 10.10.248.75 netmask 255.255.0.0 mtu 1500 broadcast 10.10.255.255
Tue Jul 30 02:09:37 2013 Initialization Sequence Completed
Подскажите, пожалуйста где копать.
p.s. без впн все работает нормально.
« Последнее редактирование: 02 Августа 2013, 06:22:06 от qupl »
 

Оффлайн apollyon

Re: Проблема с впн
« Ответ #1 : 30 Июля 2013, 00:07:19 »
а можно как-то поподробнее, кроме "панико, ничего не работает, помогите"
для настройки впн через NetworkManager нужно пакет докинуть network-manager-openvpn, и вот это ещё network-manager-openvpn-gnome
в чём суть проблемы-то?
 

Оффлайн zaborik

  • Пользователь
  • *
  • Сообщений: 23
Re: Проблема с впн
« Ответ #2 : 30 Июля 2013, 00:19:14 »
для настройки впн через NetworkManager нужно пакет докинуть network-manager-openvpn, и вот это ещё network-manager-openvpn-gnome
в чём суть проблемы-то?
Спасибо, я знаю. Я же сказал сервис, предоставляющий впн четко говорит: запускать через терминал, мол в нетворк мане у нас не пашет. Да и пробывалось уже, запускалось через нетворк (с установленными пакетами). Так же тупо подключается и ничего не работает. Я потому и спрашиваю из-за чего не работает. Ни ошибок, ничего.
Суть проблемы: без впн интернет работает, с - нет.
 

Оффлайн apollyon

Re: Проблема с впн
« Ответ #3 : 30 Июля 2013, 00:46:54 »
а что говорит route -n с подключенным впн?
 

Оффлайн zaborik

  • Пользователь
  • *
  • Сообщений: 23
Re: Проблема с впн
« Ответ #4 : 30 Июля 2013, 00:59:21 »
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.10.255.254   128.0.0.0       UG    0      0        0 tun0
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 wlan0
10.10.0.0       0.0.0.0         255.255.0.0     U     0      0        0 tun0
128.0.0.0       10.10.255.254   128.0.0.0       UG    0      0        0 tun0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
176.9.92.79     192.168.0.1     255.255.255.255 UGH   0      0        0 wlan0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
 

Оффлайн apollyon

Re: Проблема с впн
« Ответ #5 : 30 Июля 2013, 01:34:15 »
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.10.255.254   128.0.0.0       UG    0      0        0 tun0
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 wlan0
разберитесь с роутами по дефолту. один роут явно толкает впн-сервер после подключения к нему
 

Оффлайн fry

Re: Проблема с впн
« Ответ #6 : 30 Июля 2013, 10:37:47 »
Что значит не работает впн через нетвор-манагер? он подключается и ничего не работает? или даже подключения не происходит?
P.S.
Перечитал ветку. В настройках ipv4 в маршрутах поставьте галочку "Использовать только для ресурсов данного соединения".
« Последнее редактирование: 30 Июля 2013, 10:42:51 от fry »
Товарищи призывники! Надо понимать всю глубину наших глубин!

Руководство по добавлению изображений на форум
 

Оффлайн zaborik

  • Пользователь
  • *
  • Сообщений: 23
Re: Проблема с впн
« Ответ #7 : 30 Июля 2013, 10:55:05 »
разберитесь с роутами по дефолту. один роут явно толкает впн-сервер после подключения к нему
поподробней? в теминале что нужно сделать всмысле)
Что значит не работает впн через нетвор-манагер? он подключается и ничего не работает? или даже подключения не происходит?
P.S.
Перечитал ветку. В настройках ipv4 в маршрутах поставьте галочку "Использовать только для ресурсов данного соединения".
Галочка стоит. Впн коннектится но не пускает траффик. Та же история что и через запуск с терминала.
 

Оффлайн apollyon

Re: Проблема с впн
« Ответ #8 : 30 Июля 2013, 11:04:17 »
а можно поподробнее, в чём проблема? в том, что инет отваливается после подключения впн, и что он не ходит через впн? какбэ утро, экстрасенсорные способности ещё спят  ???
 

Оффлайн zaborik

  • Пользователь
  • *
  • Сообщений: 23
Re: Проблема с впн
« Ответ #9 : 30 Июля 2013, 11:08:17 »
а можно поподробнее, в чём проблема? в том, что инет отваливается после подключения впн, и что он не ходит через впн? какбэ утро, экстрасенсорные способности ещё спят  ???
Не идет через впн траффик. Т.е. подключается все отлично. Сейчас проверял на фряхе тем же методом - все работает. Думал может ключи битые. Вообщем впн работает, интернет нет = решение?
p.s. у меня уже 2 часа)
 

Оффлайн fry

Re: Проблема с впн
« Ответ #10 : 30 Июля 2013, 11:12:14 »
Галочка стоит. Впн коннектится но не пускает трафик. Та же история что и через запуск с терминала.
потому что у вас два маршрута по умолчанию. то есть, скорее всего, у вас даже до сервера впн пакеты пытаются уйти через поднятый же тунель. у меня все решалось этой галочкой. большего не требовалось. других вариантов даже в голову не приходит. ну если только конфиг кинуть в /etc/openvpn/ . и пусть подключается при загрузке компа.
Товарищи призывники! Надо понимать всю глубину наших глубин!

Руководство по добавлению изображений на форум
 

Оффлайн apollyon

Re: Проблема с впн
« Ответ #11 : 30 Июля 2013, 11:18:51 »
Вариант номер 1 - убрать дефолтный роут в локальную сеть, оставить только в туннель. Если не поможет, вариант второй - ковырять настройки сервера, смотреть там роуты, форвардинг и маскарадинг
 

Оффлайн zaborik

  • Пользователь
  • *
  • Сообщений: 23
Re: Проблема с впн
« Ответ #12 : 01 Августа 2013, 23:46:07 »
проблема решилась установкой gopenvpn. хз почему кстати. всем спасибо.
 

Теги:
     

    [Решено]USB-модем МТС, не могу получить /dev/ttyUSB0

    Автор gardarea51

    Ответов: 8
    Просмотров: 24202
    Последний ответ 07 Декабря 2012, 09:06:14
    от gardarea51
    Настройка маршрутизации openvpn на сервере (решено)

    Автор Ember

    Ответов: 2
    Просмотров: 3298
    Последний ответ 19 Сентября 2014, 18:19:22
    от Ember
    [Решено]пропал сетевой интерфейс

    Автор TheBigSnake

    Ответов: 1
    Просмотров: 657
    Последний ответ 12 Мая 2020, 13:40:54
    от TheBigSnake
    [РЕШЕНО] ipv6

    Автор polzovatel

    Ответов: 5
    Просмотров: 2180
    Последний ответ 06 Апреля 2011, 10:50:50
    от kstati
    [Решено] После задания Ipадреса через ifconfig с перезагрузкой адрес затирается?

    Автор parser82

    Ответов: 5
    Просмотров: 2404
    Последний ответ 19 Сентября 2013, 08:56:32
    от parser82