[Решено] Как правильно решить проблему?

Автор zaborik, 01 августа 2013, 23:53:43

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

zaborik

Следующая проблема. При попытки установить что либо вылазит вот это:
~$ sudo apt-get install pidgin
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
libgl1-mesa-dri-experimental : Зависит: libgl1-mesa-dri (>= 7.11.1) но 7.7.1-5 будет установлен
libgl1-mesa-glx : Зависит: libglapi-mesa (= 9.1.4-1) но 8.0.5-4+deb7u2 будет установлен
pidgin : Зависит: pidgin-data (>= 2.10.6) но он не будет установлен
          Зависит: pidgin-data (< 2.10.6-z) но он не будет установлен
          Зависит: libgtkspell0 (>= 2.0.10) но он не будет установлен
          Зависит: libpurple0 (>= 2.8.0) но он не будет установлен
xserver-xorg-core : Рекомендует: libgl1-mesa-dri (>= 7.10.2-4) но 7.7.1-5 будет установлен
                     Ломает: libgl1-mesa-dri (< 7.10.2-4) но 7.7.1-5 будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

  •  

noname

у тебя ветка какая wheezy,jessy,sid?У тебя подключён experimental,зачем мешаешь если не понимаешь что может быть.
Gentoo x86_64 AMD E-350 Openbox 3.5.2
  •  

zaborik

sid non-free ветка wheezy. Ставил репо по факу для nvidia optimus. Но я не дописал, завис браузер. Мне сейчас нужно удалить как то ти пакеты, а то даже opengl не работает. Но  дело в том что если попытаться удалить конфликты тянет за собой полсистемы на удаление. Кеды, браузер и т.п. Можно как то исправить без переустановки системы?
  •  

noname

 /etc/apt/sources.list там не должно быть компота,да и что там покажи.
Gentoo x86_64 AMD E-350 Openbox 3.5.2
  •  

zaborik

~$ cat /etc/apt/sources.list
#
deb http://ftp.uk.debian.org/debian/ wheezy main
deb-src http://ftp.uk.debian.org/debian/ wheezy main
deb http://packages.mate-desktop.org/repo/debian wheezy main
deb http://mirror1.mate-desktop.org/debian wheezy main
deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.uk.debian.org/debian/ wheezy-updates main
deb-src http://ftp.uk.debian.org/debian/ wheezy-updates main
deb http://http.us.debian.org/debian stable main contrib non-free
deb ftp://ftp.ru.debian.org/debian/ unstable main contrib non-free

  •  

noname

#5
zaborik, про  experimental прошу прощенья коллега

Сообщение объединено: 02 августа 2013, 00:21:03

apt-get -f install не пробывал?
Gentoo x86_64 AMD E-350 Openbox 3.5.2
  •  

zaborik

#6
~$ sudo apt-get -f install
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Исправление зависимостей... не удалось.
Пакеты, имеющие неудовлетворённые зависимости:
libgl1-mesa-dri-experimental : Зависит: libgl1-mesa-dri (>= 7.11.1) но 7.7.1-5 уже установлен
libgl1-mesa-glx : Зависит: libglapi-mesa (= 9.1.4-1) но 8.0.5-4+deb7u2 уже установлен
xserver-xorg-core : Рекомендует: libgl1-mesa-dri (>= 7.10.2-4) но 7.7.1-5 уже установлен
                     Ломает: libgl1-mesa-dri (< 7.10.2-4) но 7.7.1-5 уже установлен
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.
E: Невозможно скорректировать зависимости
  •  

noname

Gentoo x86_64 AMD E-350 Openbox 3.5.2
  •  

zaborik

Нет, если как то решится. Я просто уже хочу сносить кеды и ставить майт если придется эту ересь удалять, то кеды удалятся за ней.
  •  

noname

#9
убери все mate,потом aptitude update  и aptitude upgrade

Сообщение объединено: 02 августа 2013, 01:02:41

оставь это
deb http://ftp.uk.debian.org/debian/ wheezy main
deb-src http://ftp.uk.debian.org/debian/ wheezy main
deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.uk.debian.org/debian/ wheezy-updates main
deb-src http://ftp.uk.debian.org/debian/ wheezy-updates main
deb http://http.us.debian.org/debian stable main contrib non-free

этот из Sid(unstable) ненужен,
deb ftp://ftp.ru.debian.org/debian/ unstable main contrib non-free



Сообщение объединено: 02 августа 2013, 01:04:52

если собирать из исходников не будешь,то всё что начинается с deb-src тоже убери
Gentoo x86_64 AMD E-350 Openbox 3.5.2
  •  

zaborik

Апдейт все норм, а вот апгрейд ошибки
sudo aptitude update && sudo aptitude upgrade
..........
Получено 27,2 MБ в 1мин 32с (293 kБ/с)                                                       
                             
Разрешение зависимостей...                         
Не удалось разрешить зависимости для обновления: решение не найдено.
Не удалось безопасно разрешить зависимости, попробуйте запустить с параметром --full-resolver

Это с пофиксенными репо. Сырцы оставил, мне нужны.
  •  

noname

#11
а этот убрал deb ftp://ftp.ru.debian.org/debian/ unstable main contrib non-free?

Сообщение объединено: 02 августа 2013, 01:17:42

пробуй apt-get update и  apt-get install

Сообщение объединено: 02 августа 2013, 01:25:14

ну как поправилось?
Gentoo x86_64 AMD E-350 Openbox 3.5.2
  •  

zaborik

Нет(
~$ sudo apt-get -f install && sudo apt-get update
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Исправление зависимостей... не удалось.
Пакеты, имеющие неудовлетворённые зависимости:
libgl1-mesa-dri-experimental : Зависит: libgl1-mesa-dri (>= 7.11.1) но 7.7.1-5 уже установлен
libgl1-mesa-glx : Зависит: libglapi-mesa (= 9.1.4-1) но 8.0.5-4+deb7u2 уже установлен
xserver-xorg-core : Рекомендует: libgl1-mesa-dri (>= 7.10.2-4) но 7.7.1-5 уже установлен
                     Ломает: libgl1-mesa-dri (< 7.10.2-4) но 7.7.1-5 уже установлен
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.
E: Невозможно скорректировать зависимости

все таки придется полную переустановку делать?
ветку ту убрал с репо
  •  

noname

попробуй удали libgl1-mesa-dri  (7.7.1-5) и поставь заново 7.11.1

Сообщение объединено: 02 августа 2013, 02:11:55

ptitude update && sudo aptitude upgrade
Gentoo x86_64 AMD E-350 Openbox 3.5.2
  •  

zaborik

#14
Неа:
~$ sudo apt-get remove libgl1-mesa-dri
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
libgl1-mesa-dri-experimental : Зависит: libgl1-mesa-dri (>= 7.11.1) но он не будет установлен
libgl1-mesa-glx : Зависит: libglapi-mesa (= 9.1.4-1) но 8.0.5-4+deb7u2 будет установлен
                   Рекомендует: libgl1-mesa-dri (>= 7.2) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
gleameyes@senbonsakura:~$


Сообщение объединено: 02 августа 2013, 02:21:03

можно удалить через aptitude но тянет за собой 152 пакета, как я и говорил). Т.е. получится удалится тупо все.
  •