Автор Тема: Не ставится Мате  (Прочитано 3814 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Poltergeist

Не ставится Мате
« : 02 Октября 2013, 12:12:19 »
Добрый день! проблема: после переустановки Debian 7.1 x64  визи  :'(  не могу установить мате... :'( хотя до этого все нормально ставилось а сейчас пишет что страница не найдена (о репах) неужели никак нельзя решить проблему?  :'(
Спасибо!
 

Оффлайн Sergei_Alekseev

Re: Не ставится Мате
« Ответ #1 : 02 Октября 2013, 13:02:51 »
Какая страница о репах? Я не понял.
Добавьте в sources.list
deb http://repo.mate-desktop.org/debian wheezy main
 

Оффлайн Poltergeist

Re: Не ставится Мате
« Ответ #2 : 02 Октября 2013, 13:12:47 »
Не пойму что-то, в чем косяк?
При установке пакета: apt-get install mate-desktop-environment-extra (все сразу*)

Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 mate-desktop-environment-extra : Зависит: mate-core (= 1.6.0.2+7.wheezy) но он не будет установлен
                                  Зависит: mate-desktop-environment (= 1.6.0.2+7.wheezy) но он не будет установлен
                                  Зависит: mate-system-tools (>= 1.6.0) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Вот, такие дела  ??? в dpkg --list -- все ok.
« Последнее редактирование: 02 Октября 2013, 13:16:46 от Poltergeist »
 

Онлайн ogost

Re: Не ставится Мате
« Ответ #3 : 02 Октября 2013, 14:26:09 »
Пакеты, имеющие неудовлетворённые зависимости:
 mate-desktop-environment-extra : Зависит: mate-core (= 1.6.0.2+7.wheezy) но он не будет установлен
                                  Зависит: mate-desktop-environment (= 1.6.0.2+7.wheezy) но он не будет установлен
                                  Зависит: mate-system-tools (>= 1.6.0) но он не будет установлен
я извиняюсь, не хочу показаться грубым, но вот система вам черным по белому на родном для вас языке подсказывает в чём проблема! у вас битые зависимости! что бывает чаще(!) всего из-за неправильно подключенных репов (это можно было и выгуглить). для начала покажите sources.list.

Оффлайн ferum

Re: Не ставится Мате
« Ответ #4 : 02 Октября 2013, 16:16:16 »
В принципе конечно репозиторий то сторонний и его могли сломать, это если ошибка будет продолжаться.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Poltergeist

Re: Не ставится Мате
« Ответ #5 : 02 Октября 2013, 17:15:55 »
   ogost я УЖЕ однажды ставил Мате, ставлю по 2 разу и не проходит. С этими же репами.

#

# deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official amd64 DVD Binary-1 20130615-23:06]/ wheezy contrib main

#deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official amd64 DVD Binary-1 20130615-23:06]/ wheezy contrib main
# proposed additions for a 7 point release
deb http://ftp.us.debian.org/debian wheezy-proposed-updates main contrib non-free

deb http://packages.mate-desktop.org/repo/debian/ wheezy main non-free

deb http://ftp.ru.debian.org/debian/ wheezy main contrib non-free

deb http://security.debian.org/ wheezy/updates main contrib non-free

deb http://mirror.yandex.ru/debian-multimedia/ wheezy main non-free

deb http://packages.linuxmint.com debian main upstream import backport romeo


deb http://deb.opera.com/opera/ wheezy non-free

deb http://www.bunkus.org/debian/wheezy/ ./

deb http://debian.nsu.ru/sources/ wheezy main non-free

# Line commented out by installer because it failed to verify:
#deb http://security.debian.org/ wheezy/updates main contrib
# Line commented out by installer because it failed to verify:
#deb-src http://security.debian.org/ wheezy/updates main contrib

# wheezy-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
# deb http://ftp.debian.org/debian/ wheezy-updates main contrib
# deb-src http://ftp.debian.org/debian/ wheezy-updates main contrib
« Последнее редактирование: 02 Октября 2013, 17:20:20 от Poltergeist »
 

Оффлайн cema

  • Пользователь
  • *
  • Сообщений: 39
Re: Не ставится Мате
« Ответ #6 : 02 Октября 2013, 20:09:11 »
А если вот так отключить:

#deb http://packages.linuxmint.com debian main upstream import backport romeo

Оффлайн RoPP

Re: Не ставится Мате
« Ответ #7 : 02 Октября 2013, 23:34:23 »
Poltergeist
я попробовал добавить твою репу с packages - не проходит. убери ее и поставь нормальную(выше было).
у меня mate 1.4 - добавил(repo.mate-desktop) и mate-system-tools 1.6, который у тебя не встает  у меня прошел нормально.
дело в репе.
 

Оффлайн ferum

Re: Не ставится Мате
« Ответ #8 : 03 Октября 2013, 13:04:48 »
К сожалению если у Poltergeist, система обновилась с deb http://packages.linuxmint.com debian main upstream import backport romeo  могут возникнуть дополнительные трудности. возможно потребуется откатить эти пакеты.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн Makar723

  • Пользователь
  • *
  • Сообщений: 29
Re: Не ставится Мате
« Ответ #9 : 20 Ноября 2013, 12:37:51 »
проблема аналогичная, система
uname -a выдает: Linux testgate.server.loc 3.2.0-4-686-pae #1 SMP Debian 3.2.51-1 i686 GNU/Linux
sources.list:
Spoiler: ShowHide

#
# deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official i386 CD Binary-1 20130615-21:54]/ wheezy main
# deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official i386 CD Binary-1 20130615-21:54]/ wheezy main
# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ wheezy/updates main
# Line commented out by installer because it failed to verify:
deb-src http://security.debian.org/ wheezy/updates main
deb-src http://mirror.yandex.ru/debian/ stable main contrib non-free
# debian main
deb http://ftp.debian.org/debian/ squeeze main contrib non-free

# main repository
deb http://repo.mate-desktop.org/debian wheezy main
# mirrors
deb http://packages.mate-desktop.org/repo/debian wheezy main
deb http://mirror1.mate-desktop.org/debian wheezy main

выполняю apt-get update, появляется:
Spoiler: ShowHide

Hit http://mirror.yandex.ru stable Release.gpg
Hit http://mirror.yandex.ru stable Release
Hit http://repo.mate-desktop.org wheezy Release.gpg
Hit http://mirror1.mate-desktop.org wheezy Release.gpg
Hit http://mirror.yandex.ru stable/main Sources
Hit http://mirror.yandex.ru stable/contrib Sources
Hit http://mirror.yandex.ru stable/non-free Sources
Hit http://repo.mate-desktop.org wheezy Release
Hit http://mirror1.mate-desktop.org wheezy Release
Hit http://ftp.debian.org squeeze Release.gpg
Hit http://repo.mate-desktop.org wheezy/main i386 Packages
Hit http://mirror1.mate-desktop.org wheezy/main i386 Packages
Hit http://ftp.debian.org squeeze Release
Hit http://security.debian.org wheezy/updates Release.gpg
Hit http://ftp.debian.org squeeze/main i386 Packages
Hit http://security.debian.org wheezy/updates Release
Hit http://ftp.debian.org squeeze/contrib i386 Packages
Hit http://security.debian.org wheezy/updates/main Sources
Hit http://ftp.debian.org squeeze/non-free i386 Packages
Hit http://security.debian.org wheezy/updates/main i386 Packages
Hit http://security.debian.org wheezy/updates/main Translation-en
Ign http://repo.mate-desktop.org wheezy/main Translation-en_US
Ign http://mirror1.mate-desktop.org wheezy/main Translation-en_US
Ign http://repo.mate-desktop.org wheezy/main Translation-en
Ign http://mirror1.mate-desktop.org wheezy/main Translation-en
Hit http://packages.mate-desktop.org wheezy Release.gpg
Hit http://packages.mate-desktop.org wheezy Release
Hit http://packages.mate-desktop.org wheezy/main i386 Packages
Ign http://packages.mate-desktop.org wheezy/main Translation-en_US
Ign http://packages.mate-desktop.org wheezy/main Translation-en
Reading package lists... Done


далее:
 apt-get --yes --quiet --allow-unauthenticated install mate-archive-keyring
в ответ:
Spoiler: ShowHide
 apt-get --yes --quiet --allow-unauthenticated instal            l mate-archive-keyring
Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
  mate-archive-keyring
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,226 B of archives.
After this operation, 32.8 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  mate-archive-keyring
Authentication warning overridden.
Get:1 http://repo.mate-desktop.org/debian/ wheezy/main mate-archive-keyring all             1.6.0 [3,226 B]
Fetched 3,226 B in 0s (40.5 kB/s)
Selecting previously unselected package mate-archive-keyring.
(Reading database ... 47323 files and directories currently installed.)
Unpacking mate-archive-keyring (from .../mate-archive-keyring_1.6.0_all.deb) ...
Setting up mate-archive-keyring (1.6.0) ...
OK

ну и на закуску:
Spoiler: ShowHide
apt-get install mate-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mate-core : Depends: mate-control-center (>= 1.6.0) but it is not going to be i            nstalled
             Depends: caja (>= 1.6.0) but it is not going to be installed
             Depends: marco (>= 1.6.0) but it is not going to be installed
             Depends: mate-icon-theme (>= 1.6.0) but it is not going to be insta            lled
             Depends: mate-keyring (>= 1.6.0) but it is not going to be installe            d or
                      gnome-keyring but it is not going to be installed
             Depends: mate-notification-daemon (>= 1.6.0) but it is not going to             be installed or
                      notification-daemon
             Depends: mate-session-manager (>= 1.6.0) but it is not going to be             installed
             Depends: mate-panel (>= 1.6.0) but it is not going to be installed
             Depends: mate-polkit (>= 1.6.0) but it is not going to be installed
             Depends: mate-menus (>= 1.6.0) but it is not going to be installed
             Depends: mate-settings-daemon (>= 1.6.0) but it is not going to be             installed
             Depends: mate-terminal (>= 1.6.0) but it is not going to be install            ed
             Depends: mate-desktop (>= 1.6.0) but it is not going to be installe            d
             Depends: gvfs-bin but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Вижу, что битые зависимости, но такое начало проявляться на чистой системе.
 

Оффлайн Sergei_Alekseev

Re: Не ставится Мате
« Ответ #10 : 20 Ноября 2013, 13:21:56 »
Makar723,  так уберите же packages.mate-desktop.org, в repo... есть всё нужное без конфликтов.
 

Оффлайн Makar723

  • Пользователь
  • *
  • Сообщений: 29
Re: Не ставится Мате
« Ответ #11 : 20 Ноября 2013, 14:47:45 »
Sergei_Alekseev, сделал, как Вы сказали:
sources.list
Spoiler: ShowHide
#

# deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official i386 CD Binary-1 20130615-21:54]/ wheezy main

# deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official i386 CD Binary-1 20130615-21:54]/ wheezy main

# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ wheezy/updates main
# Line commented out by installer because it failed to verify:
deb-src http://security.debian.org/ wheezy/updates main
deb-src http://mirror.yandex.ru/debian/ stable main contrib non-free
# debian main
deb http://ftp.debian.org/debian/ squeeze main contrib non-free

# main repository
deb http://repo.mate-desktop.org/debian wheezy main

# mirrors
#deb http://packages.mate-desktop.org/repo/debian wheezy main
deb http://mirror1.mate-desktop.org/debian wheezy main


apt-get update:
Spoiler: ShowHide
root@testgate:/home/master# apt-get update
Hit http://mirror.yandex.ru stable Release.gpg
Hit http://mirror.yandex.ru stable Release
Hit http://repo.mate-desktop.org wheezy Release.gpg
Hit http://security.debian.org wheezy/updates Release.gpg
Hit http://mirror1.mate-desktop.org wheezy Release.gpg
Hit http://mirror.yandex.ru stable/main Sources
Hit http://ftp.debian.org squeeze Release.gpg
Hit http://mirror.yandex.ru stable/contrib Sources
Hit http://repo.mate-desktop.org wheezy Release
Hit http://mirror.yandex.ru stable/non-free Sources
Hit http://security.debian.org wheezy/updates Release
Hit http://mirror1.mate-desktop.org wheezy Release
Hit http://ftp.debian.org squeeze Release
Hit http://repo.mate-desktop.org wheezy/main i386 Packages
Hit http://security.debian.org wheezy/updates/main Sources
Hit http://mirror1.mate-desktop.org wheezy/main i386 Packages
Hit http://ftp.debian.org squeeze/main i386 Packages
Hit http://security.debian.org wheezy/updates/main i386 Packages
Hit http://security.debian.org wheezy/updates/main Translation-en
Hit http://ftp.debian.org squeeze/contrib i386 Packages
Hit http://ftp.debian.org squeeze/non-free i386 Packages
Ign http://repo.mate-desktop.org wheezy/main Translation-en_US
Ign http://repo.mate-desktop.org wheezy/main Translation-en
Ign http://mirror1.mate-desktop.org wheezy/main Translation-en_US
Ign http://mirror1.mate-desktop.org wheezy/main Translation-en
Reading package lists... Done


далее:
Spoiler: ShowHide
apt-get install mate-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mate-core : Depends: mate-control-center (>= 1.6.0) but it is not going to be installed
             Depends: caja (>= 1.6.0) but it is not going to be installed
             Depends: marco (>= 1.6.0) but it is not going to be installed
             Depends: mate-icon-theme (>= 1.6.0) but it is not going to be installed
             Depends: mate-keyring (>= 1.6.0) but it is not going to be installed or
                      gnome-keyring but it is not going to be installed
             Depends: mate-notification-daemon (>= 1.6.0) but it is not going to be installed or
                      notification-daemon
             Depends: mate-session-manager (>= 1.6.0) but it is not going to be installed
             Depends: mate-panel (>= 1.6.0) but it is not going to be installed
             Depends: mate-polkit (>= 1.6.0) but it is not going to be installed
             Depends: mate-menus (>= 1.6.0) but it is not going to be installed
             Depends: mate-settings-daemon (>= 1.6.0) but it is not going to be installed
             Depends: mate-terminal (>= 1.6.0) but it is not going to be installed
             Depends: mate-desktop (>= 1.6.0) but it is not going to be installed
             Depends: gvfs-bin but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
 

Оффлайн Sergei_Alekseev

Re: Не ставится Мате
« Ответ #12 : 20 Ноября 2013, 15:44:33 »
Так deb http://mirror1.mate-desktop.org/debian wheezy main тоже нужно убрать.
И зачем у вас сквизовская строка там?
Забэкапьте ваш лист, отредактируйте в такой вид
deb-src http://ftp.fi.debian.org/debian/ wheezy contrib non-free main
deb http://ftp.fi.debian.org/debian/ wheezy main contrib non-free
deb http://ftp.fi.debian.org/debian/ wheezy-updates contrib non-free main
deb-src http://ftp.fi.debian.org/debian/ wheezy-updates contrib non-free main
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free
deb http://ftp.fi.debian.org/debian/ wheezy-proposed-updates non-free contrib main
deb-src http://ftp.fi.debian.org/debian/ wheezy-proposed-updates non-free contrib main
deb http://www.deb-multimedia.org wheezy main non-free
deb http://ftp.fi.debian.org/debian wheezy-backports main contrib non-free
deb http://repo.mate-desktop.org/debian wheezy main
Потом apt-get update
И устанавливайте.
 

Оффлайн Makar723

  • Пользователь
  • *
  • Сообщений: 29
Re: Не ставится Мате
« Ответ #13 : 20 Ноября 2013, 16:55:22 »
Sergei_Alekseev, спасибо. В результате, сложил 2 метода.
Сначала
apt-get update && apt-get install xorg lightdm mate-core mate-desktop-environment mate-desktop-environment-extra dconf-tools mc gdebi bleachbit synaptic apt-xapian-index iceweasel iceweasel-l10n-ru myspell-ruкак было написано тут: https://debianforum.ru/index.php?topic=2735.msg35714#msg35714
думаю смело можно половину из этого выбросить...
а потом уже запустилось.
Использовал Ваши репозитории.
Спасибо большое!
 

Теги: