ATI Radeon HD 3450 AGP

Автор sofers, 07 октября 2013, 01:27:38

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

sofers

Не устанавливаются драйвера на эту видеокарту ни в одной операционной системе. Ни в одном линуксе, ни в WinXP. BIOS перешерстил вдоль и поперек. Устанавливал драйверы различными способами, различными инструкциями, разных ресурсов. Короче не конфигурируется xorg.conf ни при каких раскладах. Вывод команды aticonfig -initial: aticonfig: No supported adapters detected. Просьба к форумчанам: выложите содержание xorg.conf у кого похожая карта и дрова установлены


qupl

sofers, а свободные драйвера не удовлетворяют?


sofers

#4
Цитата: ogost от 07 октября 2013, 05:16:50
судя по гуглу проблемная карта. здесь читали?
Там о карте PCI-express, у меня AGP Пробовал уже так

Сообщение объединено: 07 октября 2013, 14:20:16

Цитата: endru от 07 октября 2013, 07:39:26
Почитайте тут.
Сверялся уже с этой статейкой. Ну нет у меня файла xorg.conf. Не конфигурируется он. Все необходимые пакеты дров установлены. Если ставить дрова с сайта, то после перезагрузки система не грузится. Доходит до одного момента и висит. Ни какие комбинации клавиш не реагируют.

Сообщение объединено: 07 октября 2013, 14:21:51

Цитата: qupl от 07 октября 2013, 06:36:35
sofers, а свободные драйвера не удовлетворяют?
3D, 2D нету. Видео тормозит. Нужен проприетарный. Свободный не подходит для этой карточки.

mexx

#5
Для поддержки HD2000/3000/4000 в Wheezy надо подключить репозиторий backports и ставить оттуда пакет fglrx-legacy-driver - http://packages.debian.org/wheezy-backports/fglrx-legacy-driver
Об этом написано здесь - https://wiki.debian.org/ATIProprietary#AMD_Catalyst_Legacy_13.1
Текущий fglrx эти карты НЕ поддерживает, о чем доходчиво сообщает при попытке его установить.
Не то?




Сообщение объединено: 07 октября 2013, 16:03:57

А проприетарного драйвера для HD3xxx AGP для Linux на сайте AMD вообще не вижу - http://support.amd.com/us/gpudownload/Pages/index.aspx

Сообщение объединено: 07 октября 2013, 16:14:26

Цитата: sofers от 07 октября 2013, 14:14:41Ну нет у меня файла xorg.conf. Не конфигурируется он.
Он как Суслик :D
Можно сделать вот так:
Цитировать# cp /var/log/Xorg.0.log /var/log/Xorg.1.log
# Xorg -configure :1
Debian 10
Debian 10 KDE
Debian 11 Gnome

sofers

Цитата: mexx от 07 октября 2013, 15:55:47
Для поддержки HD2000/3000/4000 в Wheezy надо подключить репозиторий backports и ставить оттуда пакет fglrx-legacy-driver - http://packages.debian.org/wheezy-backports/fglrx-legacy-driver
Об этом написано здесь - https://wiki.debian.org/ATIProprietary#AMD_Catalyst_Legacy_13.1
Текущий fglrx эти карты НЕ поддерживает, о чем доходчиво сообщает при попытке его установить.
Не то?




Сообщение объединено: 07 октября 2013, 16:03:57

А проприетарного драйвера для HD3xxx AGP для Linux на сайте AMD вообще не вижу - http://support.amd.com/us/gpudownload/Pages/index.aspx

Сообщение объединено: 07 октября 2013, 16:14:26

Цитата: sofers от 07 октября 2013, 14:14:41Ну нет у меня файла xorg.conf. Не конфигурируется он.
Он как Суслик :D
Можно сделать вот так:
Цитировать# cp /var/log/Xorg.0.log /var/log/Xorg.1.log
# Xorg -configure :1
1. Пробовал, подключал репозиторий, ставил из него - фигулькина грамота.
2. Да. AGP как раз нету. И в этом весь сыр-бор. Дрова ставятся, как для PCI. Как выходить из этого?
3. Вывод команды Xorg -configure:1:
X.Org X Server 1.12.4
Release Date: 2012-08-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-5-686-bigmem i686 Debian
Current Operating System: Linux starik 3.2.0-4-686-pae #1 SMP Debian 3.2.41-2 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-686-pae root=UUID=1223d917-273e-4977-8457-b2465626851a ro initrd=/install/gtk/initrd.gz quiet
Build Date: 17 April 2013  11:13:16AM
xorg-server 2:1.12.4-6 (Julien Cristau <jcristau@debian.org>)
Current version of pixman: 0.26.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Mon Oct  7 15:29:55 2013
List of video drivers:
   vboxvideo
   rendition
   ztv
   chips
   radeon
   ati
   geode
   r128
   apm
   vmware
   mach64
   voodoo
   intel
   neomagic
   vesa
   siliconmotion
   sis
   tdfx
   openchrome
   i740
   s3
   savage
   cirrus
   trident
   sisusb
   s3virge
   i128
   ark
   nouveau
   tseng
   mga
   fbdev
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] No DRICreatePCIBusID symbol, no kernel modesetting.
Number of created screens does not match number of detected devices.
  Configuration failed.
Server terminated with error (2). Closing log file.

mexx

#7
Цитата: sofers от 07 октября 2013, 16:34:39
2. Да. AGP как раз нету. И в этом весь сыр-бор. Дрова ставятся, как для PCI. Как выходить из этого?
Не знаю.

Цитата: sofers от 07 октября 2013, 16:34:39
3. Вывод команды Xorg -configure:1:
И /etc/X11/xorg.conf не появился?

Цитата: sofers от 07 октября 2013, 16:34:39
(II) [KMS] No DRICreatePCIBusID symbol, no kernel modesetting.
Перезагрузиться?


Сообщение объединено: 07 октября 2013, 17:01:06

И да - после установки:
Цитировать# aticonfig --initial
Debian 10
Debian 10 KDE
Debian 11 Gnome

sofers

xorg.conf не появился.
Вывод команды aticonfig -initial не изменился:
aticonfig: No supported adapters detected

mexx

Не смогу более ничего посоветовать.
Debian 10
Debian 10 KDE
Debian 11 Gnome

sofers

"Под фигулькиной грамотой" подразумевалось, что дрова - таки стали (с помощью ссылок, прилагающихся в той инструкции). Не запустилась ось с pae, а вод без pae запустилась с квадратиком в правом нижнем углу и без курсора. И больше не запускалась. Откатил назад все изменения. Засада, блин.

mexx

#11
Ну карта достаточно старая. Может попробовать "старый" дистрибутив какой-то и "старый" проприетарный драйвер?

Хотя конечно странно, ибо:
ЦитироватьCatalyst 13.1 Legacy Driver для Linux x86, Linux x86-64 
последняя специализированная версия драйвера для DirectX 10/10.1 видеокарт Radeon серий HD 2000, HD 3000, HD 4000; их мобильный и аналогов Mobility Radeon; AGP-версий видеокарт Radeon HD оснащенных переходным мостом Rialto: HD 2400, HD 2600, HD 3450, HD 3650, HD 3850, HD 4350, HD 4650, HD 4670;
размер 101.96 MB
Как бы намекает, что должен работать.

Кстати да, пробовали 12.6 или 13.1?
Debian 10
Debian 10 KDE
Debian 11 Gnome