Автор Тема: [Решено] Не работает звук на debian 7.1 x64  (Прочитано 4257 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlekseyDebian

Gigabyte GA-970A-DS3, чипсет AMD 970, звук встроенный.

Поставил Debian ( с диска "small installation image"), никаких пакетов сверху не ставил (ни драйверов, ни программ). Звука нет. Под win звук отлично работает.

Как решить проблему?

Сообщение объединено: 31 Октября 2013, 13:43:37
Поставил Debian 7.2 x64 - звука также нет.
« Последнее редактирование: 07 Декабря 2013, 21:41:07 от AlekseyDebian »
 

Оффлайн ogost

Re: Не работает звук на debian 7.1 x64
« Ответ #1 : 31 Октября 2013, 16:39:10 »
вангую, что дров нет.
от рута
lspci -vвыхлопа много будет, поэтому выделите только часть с звуковухой и под спойлер сюда.

Оффлайн Гусак Игорь

Re: Не работает звук на debian 7.1 x64
« Ответ #2 : 31 Октября 2013, 22:53:37 »
Попробуйте открыть регулятор громкости, выбрать "Volume control" и добавить громкость с помощью ползунков. У меня тоже не было звука, пока не поднял ползунки на "KIM"
 

Оффлайн AlekseyDebian

Re: Не работает звук на debian 7.1 x64
« Ответ #3 : 01 Ноября 2013, 04:48:37 »
вангую, что дров нет.
от рута
lspci -vвыхлопа много будет, поэтому выделите только часть с звуковухой и под спойлер сюда.

Spoiler: ShowHide
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
   Subsystem: Giga-byte Technology Device a002
   Flags: bus master, slow devsel, latency 32, IRQ 16
   Memory at fdff4000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [50] Power Management version 2
   Kernel driver in use: snd_hda_intel

01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Juniper HDMI Audio [Radeon HD 5700 Series]
   Subsystem: ASUSTeK Computer Inc. Device aa58
   Flags: bus master, fast devsel, latency 0, IRQ 42
   Memory at fddfc000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [50] Power Management version 3
   Capabilities: [58] Express Legacy Endpoint, MSI 00
   Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
   Capabilities: [150] Advanced Error Reporting
   Kernel driver in use: snd_hda_intel


Штекер от сабуфера воткнут в материнку (аудио система 2+1)
« Последнее редактирование: 01 Ноября 2013, 04:50:35 от AlekseyDebian »
 

Оффлайн vladimir_ar

Re: Не работает звук на debian 7.1 x64
« Ответ #4 : 01 Ноября 2013, 12:22:32 »
У Вас по умолчанию скорее всего стоит выход HDMI. Поменяйте порядок звуковых, или в приложении укажите, через какое устройство звук выводить.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн AlekseyDebian

Re: Не работает звук на debian 7.1 x64
« Ответ #5 : 01 Ноября 2013, 14:30:55 »
У Вас по умолчанию скорее всего стоит выход HDMI. Поменяйте порядок звуковых, или в приложении укажите, через какое устройство звук выводить.

Вот мои настройки звука:







Порядок поменять невозможно: просто нет такого управляющего элемента.


Сообщение объединено: 01 Ноября 2013, 14:36:54
Пикантная подробность: во время установки Debian инсталятор требовал на флешки подсунуть драйвера для встроенной сетевой карточки (значит таких драйверов нет в репозитариях Debian). А так как встроенная звуковая карточка работает с того же чипсета, то можно предположить, что и этих драйверов также нет.

Поэтому я грешу на отсутствие драйверов. Только где их взять для чипсета AMD970? (на сайте Gigabyte- производителя материнки так и написано, что драйвера для Linux ищите на сайтах производителей чипсетов)

Поставил Debian 7.2 с тем же результатом: звука нет.
« Последнее редактирование: 01 Ноября 2013, 14:39:04 от AlekseyDebian »
 

Оффлайн ogost

Re: Не работает звук на debian 7.1 x64
« Ответ #6 : 01 Ноября 2013, 16:14:31 »
в alsamixer пробовали ползунки туда-сюда?
дрова нужны не для чипсета, а только для сетевой карты. она у вас кстати работает? драйвер скорее всего лежит в non-free ветке репозитория. узнать какая карточка:
lspci | grep -i ethernetможно не от рута. потом погуглить в каком пакете лежат и подключив non-free установить их.

Сообщение объединено: 01 Ноября 2013, 16:16:38
пардон, невнимательно скрины посмотрел. У вас на последнем скрине в вкладке "Выход" выбран HDMI. Выберите аналоговый.

Оффлайн qupl

Re: Не работает звук на debian 7.1 x64
« Ответ #7 : 01 Ноября 2013, 19:15:51 »
никаких пакетов сверху не ставил (ни драйверов, ни программ)

#aptitude install firmware-linux-nonfree

Оффлайн Гусак Игорь

Re: Не работает звук на debian 7.1 x64
« Ответ #8 : 01 Ноября 2013, 22:36:15 »
Попробуйте выполнить в терминале команду: alsamixer, и добавить уровни.
 

Оффлайн AlekseyDebian

Re: Не работает звук на debian 7.1 x64
« Ответ #9 : 02 Ноября 2013, 04:29:26 »
в alsamixer пробовали ползунки туда-сюда?
дрова нужны не для чипсета, а только для сетевой карты. она у вас кстати работает? драйвер скорее всего лежит в non-free ветке репозитория. узнать какая карточка:
lspci | grep -i ethernetможно не от рута. потом погуглить в каком пакете лежат и подключив non-free установить их.

Сообщение объединено: 01 Ноября 2013, 16:16:38
пардон, невнимательно скрины посмотрел. У вас на последнем скрине в вкладке "Выход" выбран HDMI. Выберите аналоговый.

Сетевую карточку установил, так что по этому поводу вопросов нет (подсунул нужный файл на флешке во время установки).

На вкладке "Выход" при любых значениях звук не появляется, а на вкладке "Оборудование" значение "Встроенное аудио" не сохраняется (при закрытии и последующем открытии окна настроек опять значение "Juniper HDMI Audio").


Сообщение объединено: 02 Ноября 2013, 04:50:17
#aptitude install firmware-linux-nonfree

Пакеты:
firmware-linux-nonfree 0.28 + squeeze1
firmware-linux-free 3.2  (за компанию)

поставил (что видно в синаптике). Но звука так и нет.


Сообщение объединено: 02 Ноября 2013, 04:54:12
Попробуйте выполнить в терминале команду: alsamixer, и добавить уровни.

Команду выполнил в терминале суперпользователя. Нажал выбор устройств (F6) и получил такую небольшую менюшку:
0 HDA ATI SB
1 HD-AUDIO Generic

Выбрал второй вариант, но у него значение столбика равно нулю (а у первого значение было около 90). И как я не пытался поднять значение с отметки ноль или поменять местами два варианта устройств- никакие клавиши не работают. Как сделать?

Сообщение объединено: 02 Ноября 2013, 06:14:17
РЕШЕНО!!!

Пересобрал ядро как написано тут: http://mydebianblog.blogspot.ru/2006/07/blog-post.html и после запуска под новым ядром звук заработал. Флаги в ветке "Open Sound System" (старые драйвера, если не подходят текущие) пока не включал, так как и без них все получилось.

Всем спасибо!
« Последнее редактирование: 02 Ноября 2013, 06:15:36 от AlekseyDebian »
 

Оффлайн qupl

Re: Не работает звук на debian 7.1 x64
« Ответ #10 : 02 Ноября 2013, 14:16:08 »
AlekseyDebian, пометьте тему решенной, изменив заголовок первого сообщения.

Напишите какую версию ядра собирали.

Оффлайн AlekseyDebian

Re: [Решено] Не работает звук на debian 7.1 x64
« Ответ #11 : 07 Декабря 2013, 21:42:07 »
Напишите какую версию ядра собирали.

Уже не помню какую, но текущую с kernel.org
 

Оффлайн vladimir_ar

Re: [Решено] Не работает звук на debian 7.1 x64
« Ответ #12 : 07 Декабря 2013, 22:07:42 »
Ядро то при чем? Порядок звуковых ставится проще. И на форуме есть, и в гугле масса вариантов.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Теги:
     

    [РЕШЕНО] Драйвер для Mobility Radeon HD 3470

    Автор Aleksey

    Ответов: 12
    Просмотров: 7004
    Последний ответ 02 Ноября 2016, 20:30:15
    от Aalexeey
    [Решено] Как использовать HDMI- разъем на карточке NVIDIA?

    Автор AlekseyDebian

    Ответов: 15
    Просмотров: 5199
    Последний ответ 18 Декабря 2013, 20:48:35
    от ferum
    Нет звука в видеофайле .mkv в SMPlayer [Решено]

    Автор Leo

    Ответов: 1
    Просмотров: 5090
    Последний ответ 20 Января 2013, 22:24:42
    от calambus
    [Решено] Отвалилась запись с микрофона

    Автор sidbar

    Ответов: 2
    Просмотров: 1309
    Последний ответ 03 Февраля 2017, 12:43:24
    от sidbar
    [РЕШЕНО] У регулятора громкости не открываются настройки

    Автор polzovatel

    Ответов: 2
    Просмотров: 2256
    Последний ответ 29 Марта 2011, 01:50:29
    от polzovatel