Установка Webmin

Автор sky, 02 декабря 2013, 19:37:00

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

sky

Привет, как установить Debian package suitable http://prdownloads.sourceforge.net/webadmin/webmin_1.660_all.deb через консоль? Спасибо!

Brainey

Вы не знаете, как установить пакет?
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru

Malaheenee

sky, sudo dpkg -i package_name.deb
Если ругается на зависимости, то устанавливайте и их...
Все мы где-то, когда-то и в чем-то были новичками.

sky

Получаю ошибку:

sudo dpkg -i webmin_1.660_all.deb
dpkg: error processing webmin_1.660_all.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
webmin_1.660_all.deb

ogost

рукалицо...
вы хоть сначала перейдите в ту папку, где лежит скачанный пакет.

sky

1) появляется ошибка:

sudo dpkg -i webmin_1.660_all.deb
Selecting previously unselected package webmin.
(Reading database ... 31986 files and directories currently installed.)
Unpacking webmin (from webmin_1.660_all.deb) ...
dpkg: dependency problems prevent configuration of webmin:
webmin depends on libauthen-pam-perl; however:
Package libauthen-pam-perl is not installed.
webmin depends on libio-pty-perl; however:
Package libio-pty-perl is not installed.
webmin depends on apt-show-versions; however:
Package apt-show-versions is not installed.
dpkg: error processing webmin (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
webmin

2) при добавление http://packages.debian.org/ru/sid/apt-show-versions
deb http://ftp.ru.debian.org/debian sid main

получаю ошибку:
deb http://ftp.ru.debian.org/debian sid main
-bash: deb: command not found

3) для файлов:
http://packages.debian.org/sid/libio-pty-perl
http://packages.debian.org/unstable/perl/libauthen-pam-perl

как узнать архитектуру сервера?

sandaksatru

Цитата: sky от 03 декабря 2013, 15:07:261) появляется ошибка:
Перед установкой пакета установите его зависимости, указанные в выводе ошибки.

Цитата: sky от 03 декабря 2013, 15:07:262) при добавление http://packages.debian.org/ru/sid/apt-show-versions получаю ошибку
man dpkg
man apt-get


Цитата: sky от 03 декабря 2013, 15:07:263)
как узнать архитектуру сервера?
uname -m
lscpu

sky

Пробовал установить по инструкции http://www.webmin.com/deb.html, но получается замкнутый круг в процессе установке, как продолжить?

1) dpkg --install webmin_1.660_all.deb
(Reading database ... 56015 files and directories currently installed.)
Preparing to replace webmin 1.660 (using webmin_1.660_all.deb) ...
Unpacking replacement webmin ...
dpkg: dependency problems prevent configuration of webmin:
webmin depends on libauthen-pam-perl; however:
  Package libauthen-pam-perl is not installed.
webmin depends on libio-pty-perl; however:
  Package libio-pty-perl is not installed.
webmin depends on apt-show-versions; however:
  Package apt-show-versions is not installed.
dpkg: error processing webmin (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
webmin

2) apt-get install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl apt-show-versions python
Reading package lists... Done
Building dependency tree
Reading state information... Done
libnet-ssleay-perl is already the newest version.
libnet-ssleay-perl set to manually installed.
openssl is already the newest version.
openssl set to manually installed.
libpam-runtime is already the newest version.
perl is already the newest version.
perl set to manually installed.
python is already the newest version.
python set to manually installed.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
apt-show-versions : Depends: libapt-pkg-perl (>= 0.1.21) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

3) apt-get install libapt-pkg-perl
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
webmin : Depends: libauthen-pam-perl but it is not going to be installed
          Depends: libio-pty-perl but it is not going to be installed
          Depends: apt-show-versions but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

ogost

#8
Цитата: sky от 05 декабря 2013, 18:14:13E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
с инглишем дружим? если нет, то система предлагает вам запустить выделенную команду. желательно сразу после dpkg --install webmin_1.660_all.deb

Сообщение объединено: 05 декабря 2013, 22:02:16

и вообще это всё элементарно гуглится. вчитывайтесь в вывод системы, там много интересного. возникли ошибки - гуглите, можно тупо скопировать ошибку из терминала и вбить в гугл - очень часто помогает. и тогда вас меньше будут посылать на RTFM.