Автор Тема: Deb - пакет, возможно ли переделать?  (Прочитано 2809 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн izamoo

  • Местный житель
  • ***
  • Сообщений: 154
Deb - пакет, возможно ли переделать?
« : 06 Января 2014, 10:08:24 »
Скажите пожалуйста, а возможно переделать deb-пакет ubuntu в deb для debian 7?
Конкретно интересует вот этот (12.04LTS):
http://www.parom.tv/linux
 

Оффлайн Malaheenee

Re: Deb - пакет, возможно ли переделать?
« Ответ #1 : 06 Января 2014, 11:00:40 »
izamoo, можно. Получаете исходники из подключенного репозитория командой apt-get source, устанавливаете нужные зависимости для сборки, уточняете их версии и собираете.

Сообщение объединено: 06 Января 2014, 11:04:24
А-а-а, там пакет собран банальным checkinstall. В заивсимостях только vlc и qt4-core. Можете ставить и так, только штуковина уж больно проприетарная - бинарник вместо доброго скрипта.
« Последнее редактирование: 06 Января 2014, 11:04:52 от Malaheenee »
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн Гусак Игорь

Re: Deb - пакет, возможно ли переделать?
« Ответ #2 : 07 Января 2014, 22:51:28 »
Неужели снова заработало. Когда-то пользовался, но потом лавочку прикрыли и с тех пор забыл, а программв была неплохая. Сейчас, к сожалению, меньше каналов, но, надеюсь со временем их станет больше.
 

Оффлайн izamoo

  • Местный житель
  • ***
  • Сообщений: 154
Re: Deb - пакет, возможно ли переделать?
« Ответ #3 : 09 Января 2014, 19:03:44 »
Скачал и установил deb пакет для ubuntu 12.04LTS. Не работает.

Терминал выдаёт во что:
vlad@debian:~$ paromplayer
paromplayer: error while loading shared libraries: libQtDeclarative.so.4: cannot open shared object file: No such file or directory

Подскажите как его запустить.
 

Оффлайн Brainey

Re: Deb - пакет, возможно ли переделать?
« Ответ #4 : 09 Января 2014, 19:28:46 »
libqt4-declarative установлен?
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
 

Оффлайн izamoo

  • Местный житель
  • ***
  • Сообщений: 154
Re: Deb - пакет, возможно ли переделать?
« Ответ #5 : 09 Января 2014, 19:33:27 »
libqt4-declarative

установил, теперь пишет вот:
vlad@debian:~$ paromplayer
paromplayer: /lib/i386-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by paromplayer)


Сообщение объединено: 09 Января 2014, 19:45:53
я так понял ему нужна библиотека ibc.so.6(GLIBC_2.15)? Где можно её найти?

Сообщение объединено: 09 Января 2014, 20:25:58
yes. Я его завёл.

Сначала установил libqt4-declarative, затем подключил репозиторий experimental и поставил  ibc.so.6(GLIBC_2.15).

# apt-get install libqt4-declarative
# echo "deb http://ftp.debian.org/debian experimental main" >> /etc/apt/sources.list
# apt-get update
# apt-get -t experimental install libc6-i686

надеюсь надежность ОС от этого не пострадает.  :)
« Последнее редактирование: 09 Января 2014, 20:25:58 от izamoo »
 

Оффлайн Malaheenee

Re: Deb - пакет, возможно ли переделать?
« Ответ #6 : 10 Января 2014, 10:46:19 »
izamoo, мы бы не были так уверены  ;)
Все мы где-то, когда-то и в чем-то были новичками.
 

Теги:
     

    Не могу найти пакет noip2

    Автор TTATPuOT

    Ответов: 9
    Просмотров: 2724
    Последний ответ 09 Апреля 2012, 18:15:44
    от Malaheenee
    Не устанавливается пакет ia32-libs

    Автор 342838

    Ответов: 3
    Просмотров: 1693
    Последний ответ 13 Ноября 2017, 20:54:18
    от ferum
    Возможно ли перейти с testing на stable

    Автор dzhoser

    Ответов: 19
    Просмотров: 923
    Последний ответ 01 Сентября 2021, 16:18:37
    от ogost
    Как установить пакет из SID'а с наименьшим количествоим зависимостей?

    Автор Sferg

    Ответов: 4
    Просмотров: 3343
    Последний ответ 03 Августа 2013, 15:16:05
    от noname
    Существует ли пакет KMSCON для Debian?

    Автор Sferg

    Ответов: 6
    Просмотров: 1642
    Последний ответ 23 Августа 2013, 21:53:11
    от Sferg