Автор Тема: [Решено] не могу установить php4-mcrypt  (Прочитано 11498 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andragen

  • Пользователь
  • *
  • Сообщений: 26
[Решено] не могу установить php4-mcrypt
« : 09 Января 2014, 15:48:30 »
Достался настроенный Debian на нем крутятся несколько сайтом и один из сайтов на битрикс который ругается на одсутствие модуля mcrypt ну я сделал apt-get install php4-mcrypt но он мне выдал
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php5-mcrypt : Depends: libltdl7 (>= 2.4.2) but it is not going to be installed
               Depends: phpapi-20100525
               Depends: php5-common (= 5.4.23-1~dotdeb.1) but 5.3.13-1~dotdeb.0 is to be installed
E: Broken packages
Я так понимаю дело в зависимостях но не знаю как разрешит конфликт. Линуксы плохо, знаю потому и создал тему может кто подскажет. Буду благодарен.
« Последнее редактирование: 10 Января 2014, 17:15:19 от andragen »
 

Оффлайн qupl

Re: не могу установить php4-mcrypt
« Ответ #1 : 09 Января 2014, 16:21:22 »
Дайте помогающим больше информации
lsb_release - a
cat /etc/apt/sources.list

Оффлайн Malaheenee

Re: не могу установить php4-mcrypt
« Ответ #2 : 09 Января 2014, 17:38:16 »
И еще dpkg -l | grep php
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн andragen

  • Пользователь
  • *
  • Сообщений: 26
Re: не могу установить php4-mcrypt
« Ответ #3 : 10 Января 2014, 09:13:09 »
to qupl да конечно, ниже результат.

# lsb_release - a
Usage: lsb_release [options]

lsb_release: error: No arguments are permitted
# lsb_release
No LSB modules are available.

to Malaheenee
# dpkg -l | grep php
ii  libapache2-mod-php5                 5.3.13-1~dotdeb.0            server-side, HTML-embedded scripting language (Apache 2 module)
ii  php-pear                            5.3.13-1~dotdeb.0            PEAR - PHP Extension and Application Repository
ii  php5                                5.3.13-1~dotdeb.0            server-side, HTML-embedded scripting language (metapackage)
ii  php5-apc                            5.3.13-1~dotdeb.0            apc module for php5
ii  php5-cli                            5.3.13-1~dotdeb.0            command-line interpreter for the php5 scripting language
ii  php5-common                         5.3.13-1~dotdeb.0            Common files for packages built from the php5 source
ii  php5-curl                           5.3.13-1~dotdeb.0            CURL module for php5
ii  php5-gd                             5.3.13-1~dotdeb.0            GD module for php5
ii  php5-imap                           5.3.13-1~dotdeb.0            IMAP module for php5
ii  php5-mysql                          5.3.13-1~dotdeb.0            MySQL module for php5
ii  php5-suhosin                        5.3.13-1~dotdeb.0            suhosin module for php5
ii  php5-sybase                         5.3.13-1~dotdeb.0            Sybase / MS SQL Server module for php5
ii  php5-xdebug                         5.3.13-1~dotdeb.0            xdebug module for php5

# php -m
PHP Warning:  PHP Startup: apc.shm_segments setting ignored in MMAP mode in Unknown on line 0
[PHP Modules]
apc
bcmath
bz2
calendar
Core
ctype
curl
date
dba
dom
ereg
exif
fileinfo
filter
ftp
gd
gettext
hash
iconv
imap
json
libxml
mbstring
mhash
mssql
mysql
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_dblib
pdo_mysql
Phar
posix
readline
Reflection
session
shmop
SimpleXML
soap
sockets
SPL
standard
suhosin
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xdebug
xml
xmlreader
xmlwriter
zip
zlib

[Zend Modules]
Xdebug

# php -v
PHP Warning:  PHP Startup: apc.shm_segments setting ignored in MMAP mode in Unknown on line 0
PHP 5.3.13-1~dotdeb.0 with Suhosin-Patch (cli) (built: May  8 2012 21:07:44)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
    with Xdebug v2.2.0, Copyright (c) 2002-2012, by Derick Rethans
    with Suhosin v0.9.33, Copyright (c) 2007-2012, by SektionEins GmbH
 

Оффлайн qupl

Re: не могу установить php4-mcrypt
« Ответ #4 : 10 Января 2014, 10:09:26 »
apt-get install php4-mcrypt
ii  php5                                5.3.13-1~dotdeb.0            server-side, HTML-embedded scripting language (metapackage)
Точно то хотите установить?

Оффлайн Malaheenee

Re: не могу установить php4-mcrypt
« Ответ #5 : 10 Января 2014, 10:17:22 »
А sources.list?
apt-get install -fПросто вывод, не соглшайтесь на то, что он предложит.
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн andragen

  • Пользователь
  • *
  • Сообщений: 26
Re: не могу установить php4-mcrypt
« Ответ #6 : 10 Января 2014, 10:34:20 »
apt-get install php4-mcrypt
делал и так
# apt-get install php5-mcrypt
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php5-mcrypt : Depends: libltdl7 (>= 2.4.2) but 2.2.6b-2 is to be installed
               Depends: phpapi-20100525
               Depends: php5-common (= 5.4.23-1~dotdeb.1) but 5.3.13-1~dotdeb.0 is to be installed
E: Broken packages

А sources.list?
apt-get install -fПросто вывод, не соглшайтесь на то, что он предложит.
вы это имели ввиду?
# apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 88 not upgraded.
 

Оффлайн Malaheenee

Re: не могу установить php4-mcrypt
« Ответ #7 : 10 Января 2014, 10:49:03 »
Что говорит apt-cache policy php5-common?
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн andragen

  • Пользователь
  • *
  • Сообщений: 26
Re: не могу установить php4-mcrypt
« Ответ #8 : 10 Января 2014, 11:01:00 »
~# apt-cache policy php5-common
php5-common:
  Installed: 5.3.13-1~dotdeb.0
  Candidate: 5.3.13-1~dotdeb.0
  Package pin: (not found)
  Version table:
     5.4.23-1~dotdeb.1 991
        500 http://php53.dotdeb.org/ stable/all amd64 Packages
 *** 5.3.13-1~dotdeb.0 991
        100 /var/lib/dpkg/status
     5.3.3-7+squeeze18 991
        500 http://security.debian.org/ squeeze/updates/main amd64 Packages
     5.3.3-7+squeeze17 991
        500 http://mirror.yandex.ru/debian/ squeeze/main amd64 Packages
 

Оффлайн endru

Re: не могу установить php4-mcrypt
« Ответ #9 : 10 Января 2014, 11:01:49 »
0 upgraded, 0 newly installed, 0 to remove and 88 not upgraded.

для начала обновите пакеты, аж 88 штук накопилось... а потом уже ставьте новые

Оффлайн andragen

  • Пользователь
  • *
  • Сообщений: 26
Re: не могу установить php4-mcrypt
« Ответ #10 : 10 Января 2014, 11:06:36 »
Это обязательное условие для решения задачи? Я ни когда не обновлял и сервер боевой, не знаю какие могут быть последствия.
 

Оффлайн Malaheenee

Re: не могу установить php4-mcrypt
« Ответ #11 : 10 Января 2014, 11:17:26 »
andragen, подождите обновлять. Что у Вас в /etc/apt/sources.list (и одноименном каталоге)?
А также /etc/debian_version?
« Последнее редактирование: 10 Января 2014, 11:19:49 от Malaheenee »
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн andragen

  • Пользователь
  • *
  • Сообщений: 26
Re: не могу установить php4-mcrypt
« Ответ #12 : 10 Января 2014, 11:18:04 »
# cat /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 6.0.2.1 _Squeeze_ - Official amd64 DVD Binary-1 20110626-16:33]/ squeeze contrib main

#deb cdrom:[Debian GNU/Linux 6.0.2.1 _Squeeze_ - Official amd64 DVD Binary-1 20110626-16:33]/ squeeze contrib main

deb http://mirror.yandex.ru/debian/ squeeze main non-free contrib
deb-src http://mirror.yandex.ru/debian/ squeeze main non-free contrib

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

#deb http://volatile.debian.org/debian-volatile squeeze/volatile main contrib non-free
#deb-src http://volatile.debian.org/debian-volatile squeeze/volatile main contrib non-free

#deb http://packages.dotdeb.org stable all
#deb-src http://packages.dotdeb.org stable all

deb http://php53.dotdeb.org stable all
deb-src http://php53.dotdeb.org stable all
 

Оффлайн Malaheenee

Re: не могу установить php4-mcrypt
« Ответ #13 : 10 Января 2014, 11:21:26 »
Добавьте строки в /etc/apt/sources.list deb http://packages.dotdeb.org squeeze-php54 all
deb-src http://packages.dotdeb.org squeeze-php54 all
Далее
apt-get updateИ снова попробуйте установить, но не торопитесь жать Y.

Сообщение объединено: 10 Января 2014, 11:25:50
Хотя это одни и те же репозитории, так что обновлять придется. Но очень. очень осторожно - как ежикам  ;)
aptitude install php~i
« Последнее редактирование: 10 Января 2014, 11:25:50 от Malaheenee »
Все мы где-то, когда-то и в чем-то были новичками.
 

Оффлайн andragen

  • Пользователь
  • *
  • Сообщений: 26
Re: не могу установить php4-mcrypt
« Ответ #14 : 10 Января 2014, 11:36:07 »
Начал и пока приостановил
# aptitude install php~i
The following NEW packages will be installed:
  libapache2-mod-php5filter{ab}
The following packages will be upgraded:
  php5-apc{b} php5-imap{b} php5-xdebug{b}
3 packages upgraded, 1 newly installed, 0 to remove and 66 not upgraded.
Need to get 3,051 kB of archives. After unpacking 9,798 kB will be used.
The following packages have unmet dependencies:
  libapache2-mod-php5: Conflicts: libapache2-mod-php5filter but 5.4.23-1~dotdeb.1 is to be installed.
  php5-xdebug: Depends: php5-common (= 5.4.23-1~dotdeb.1) but 5.3.13-1~dotdeb.0 is installed.
  php5-imap: Depends: libssl1.0.0 (>= 1.0.0) which is a virtual package.
             Depends: php5-common (= 5.4.23-1~dotdeb.1) but 5.3.13-1~dotdeb.0 is installed.
  php5-apc: Depends: php5-common (= 5.4.23-1~dotdeb.1) but 5.3.13-1~dotdeb.0 is installed.
  libapache2-mod-php5filter: Depends: libdb5.1 which is a virtual package.
                             Depends: libssl1.0.0 (>= 1.0.0) which is a virtual package.
                             Depends: libxml2 (>= 2.8.0) but 2.7.8.dfsg-2+squeeze4 is installed and it is kept back.
                             Depends: php5-common (= 5.4.23-1~dotdeb.1) but 5.3.13-1~dotdeb.0 is installed.
                             Conflicts: libapache2-mod-php5 but 5.3.13-1~dotdeb.0 is installed.
The following actions will resolve these dependencies:

     Remove the following packages:
1)     php5-apc
2)     php5-imap
3)     php5-xdebug

     Keep the following packages at their current version:
4)     libapache2-mod-php5filter [Not Installed]



Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

Вот почему, сейчас работает PHP 5.3.13 и не приведет ли обновление к тому что версия php повыситься? Могу предположить что из рабочих сайтов не все будут готовы к этому.
 

Теги:
     

    [Решено] Права доступа и ssh

    Автор Rockstar02rus

    Ответов: 0
    Просмотров: 1981
    Последний ответ 27 Апреля 2013, 14:00:49
    от Rockstar02rus
    [Решено] etc/init.d/squid status squid is not running failed! другая проблема

    Автор mirus

    Ответов: 10
    Просмотров: 2615
    Последний ответ 05 Июля 2016, 10:32:30
    от mirus
    vsftpd ftp, нужна помощь срочно! [Решено]

    Автор dsdsda

    Ответов: 2
    Просмотров: 804
    Последний ответ 08 Ноября 2019, 19:08:26
    от dsdsda
    [Решено] Управление доступом к сетевым папкам

    Автор Андрей_1

    Ответов: 6
    Просмотров: 2179
    Последний ответ 11 Сентября 2013, 10:50:53
    от Андрей_1
    Acess denied [РЕШЕНО]

    Автор dsdsda

    Ответов: 4
    Просмотров: 1832
    Последний ответ 14 Февраля 2020, 22:55:25
    от Tammy