Автор Тема: Ruby!! при установке.  (Прочитано 4105 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн YVSIK

Ruby!! при установке.
« : 14 Января 2014, 00:39:20 »
 :(
уже нет сил воевать с этой Ruby
 при установке Ruby ставился только из коробки.
на виртуальных манинах его не было, теперь и в виртуальные его ставится по умолчанию.
может найдется или мануал или толковое пояснение как с этим ботроться, мне он не нужен, вернее сказать,
не нужен тот который ставиться по умолчанию, версия 1.9.4 и ещё какие то буковки, мне эта версия не нужна, нужна предыдущая,
на дебиан-6  уже что-то переходить не хочется, а в семерке он в умолчаниях.
вся задача от него избавиться. при установке.

Пробовал ставить даже без стандартных возможностях всё равно он есть, уже надоел этот Ruby >:(
 

Оффлайн ihammers

Re: Ruby!! при установке.
« Ответ #1 : 14 Января 2014, 23:09:16 »
Вам какая версия требуется?
В тестинге есть например ещё и v.1.8.
И что вы хотите сделать?

PS: Как вариант можно собрать версию из исходников и прописать использование её, по умолчанию.
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64,
LXQt/KDE/OpenBox AMD Phenon X4 / 16Gb RAM / ATI HD7750 Silent
_______________________________
Debian GNU/Linux Stretch, kernel 4.9.0-5-amd64, LXQt/KDE/OpenBox
Acer Aspire One 722 AMD C60 / 4Gb RAM / ATI HD6290
 

Оффлайн YVSIK

Re: Ruby!! при установке.
« Ответ #2 : 14 Января 2014, 23:41:12 »
Хочу сделать:
 на сервере стоит OpenVZ  и на немже возможно поставить панель управления,
правда она бесплатная, и она вполне отличная можно так сказать.
но есть у неё требованиия именно версия Ruby как раз 1.8,....
в дебиан 6 она работает, но только после устаноувки, после перегрузки сервера,  перестает работать,
Что в итоге ,установил посмотрел, она заработала, показала что может, и дальше всё, надо новый сервер делать,
и то это как случиться может и не заработать.
Ладно, резуме , работает только после установки и только на дебиан 6

По началу не мог разобраться в Оф сайт но со вчера начал понимать что и как надо делать.
Инфа на английском, потому трудновато дается.
думаю что разберусь со временем,
 может есть какой нибудь понятный Свежий русский мануал,
и может у кого есть опыт данного использования этой Ruby. 

панель    ovz-web-panel об которой идет речь
 

Оффлайн skvili

  • Пользователь
  • *
  • Сообщений: 12
Re: Ruby!! при установке.
« Ответ #3 : 15 Января 2014, 12:24:56 »
Я не знаю что такое ruby, но по поводу версии, разве не получается сделать как-то вот так?apt-get install ruby=1.8..... а потом aptitude hold ruby чтоб не обновлялся
 

Оффлайн redVi

Re: Ruby!! при установке.
« Ответ #4 : 15 Января 2014, 17:31:14 »
skvili, не думаю, что это хорошая идея.
1. Ruby это...
2. версия 1.8 наличествует в репозитории, но лучше использовать rvm
YVSIK, при желании со временем разберётесь. А английский лучший друг IT-шника, без него вам и в дальнейшем будет сложно: учите.
Debian Sid, Openbox || Gentoo, Openbox
 

Оффлайн YVSIK

Re: Ruby!! при установке.
« Ответ #5 : 16 Января 2014, 08:23:00 »
Отлично, как называется тема как раз подходит.
действия по порядку,
--развернул OpenVZ сервер,
--поставил на на нем же новую виртуальную систему
--по умолчания как раньше и говjрил, RUBY стоит))  >:(
согласно вот этого мануала
--проверяем:
------------------И
шиш с маслом.
root@test31:~# ruby -v
-bash: ruby: command not found
root@test31:~#
нет команды значит и ruby видимо нет  :o
вот и наступает ступор.
Как так нет ни команды ни ruby
/как так ?  :o ладно, решаем, да и нужна ли она нам?
нам, вернее мне нужна панель управления серверами.
пробуем ставить вот так
wget -O - http://ovz-web-panel.googlecode.com/svn/installer/ai.sh | shона потрудится как положено, НО))
в конце скажет стоит не та RUBY
нужна другая,

И начались мытарства, мои мытарства,,,

Ещё раз повторяю: согласно всем источникам , уже понятно что РУБИ стоит
но ответ из консоли отрицательный!

И если бы это было только один раЗ
это повторяется со стабильным постоянством.
Она или есть или её нет))))))))))))))))))))))))))))
так и бегаем по кругу,

Ладно ищем находим, как правильно выше сказано rvm!
управления  версиями, ну не тут то было
пробую удалить, и конечно что то делается и что то удаляется, и тем более откуда-то,
но вот что и как , загадка )) большая загадка,

Говорить что удалилась, проверяю , ан нет)  как стояла так и стоит, и даже после удалеия,

Ладно :::  опять несколько раз по новой и результат с завидным постоянством один и тот же

показать себя не хочет и удалиться не может.

Причем тут мануал?


Сообщение объединено: 16 Января 2014, 08:28:47
А теперь противоречия по каждому пункту
И так цитата
Цитировать
Для начала вы захотите проверить, установлен ли у вас Ruby.  После символа подсказки в командной строке (он обозначен здесь как "%", так что % набирать не надо), введите

 
% ruby -v
(-v дает указание интерепретатору вывести его версию), затем нажмите кнопку Enter.  Если Ruby установлен, вы увидите нечто похожее на:

 
% ruby -v
ruby 1.6.1 (2000-09-27) [i586-linux]
Если Ruby не установлен, Вы можете попросить Вашего администратора установить его или сделать это сами , поскольку Ruby является свободным ПО без ограничений на инсталляцию и использование.
после проверки покзано что её нет наверное?
Но при установки панели панель говорит что она есть и не той версии
куда дальше идти

Собственно я и сеть тот самый администратор, который ставит.
И что я могу поставить или снести, вот только что и как поставить и что снети,
если такие затыки постоянны? 

Сообщение объединено: 16 Января 2014, 09:02:01
ну вот ещё раз пробую ставить панель,

Настраивается пакет gcc (4:4.7.2-1) …
Настраивается пакет libtimedate-perl (1.2000-1) …
Настраивается пакет libdpkg-perl (1.16.12) …
Настраивается пакет dpkg-dev (1.16.12) …
Настраивается пакет gcc-4.6-base:amd64 (4.6.3-14) …
Настраивается пакет cpp-4.6 (4.6.3-14) …
Настраивается пакет fakeroot (1.18.4-2) …
update-alternatives: используется /usr/bin/fakeroot-sysv для предоставления /usr/bin/fakeroot (fakeroot) в автоматический режим
Настраивается пакет gcc-4.6 (4.6.3-14) …
Настраивается пакет libalgorithm-diff-perl (1.19.02-2) …
Настраивается пакет libalgorithm-diff-xs-perl (0.04-2+b1) …
Настраивается пакет libalgorithm-merge-perl (0.08-2) …
Настраивается пакет libfile-fcntllock-perl (0.14-2) …
Настраивается пакет libruby1.9.1 (1.9.3.194-8.1+deb7u2) …
Настраивается пакет libruby (1:1.9.3) …
Настраивается пакет libruby1.8 (1.8.7.358-7.1+deb7u1) …
Настраивается пакет manpages-dev (3.44-1) …
Настраивается пакет ruby1.9.1 (1.9.3.194-8.1+deb7u2) …
update-alternatives: используется /usr/bin/gem1.9.1 для предоставления /usr/bin/gem (gem) в автоматический режим
update-alternatives: используется /usr/bin/ruby1.9.1 для предоставления /usr/bin/ruby (ruby) в автоматический режим
Настраивается пакет ruby (1:1.9.3) …
Настраивается пакет ruby1.8 (1.8.7.358-7.1+deb7u1) …
Настраивается пакет rake (0.9.2.2-4) …
Настраивается пакет ruby-sqlite3 (1.3.6-2) …
Настраивается пакет ruby1.8-dev (1.8.7.358-7.1+deb7u1) …
Настраивается пакет rubygems (1.8.24-1) …
Настраивается пакет zip (3.0-6) …
Настраивается пакет libsqlite3-ruby (1.3.6-2) …
Настраивается пакет g++-4.7 (4.7.2-5) …
Настраивается пакет g++ (4:4.7.2-1) …
update-alternatives: используется /usr/bin/g++ для предоставления /usr/bin/c++ (c++) в автоматический режим
Настраивается пакет build-essential (11.5) …
Настраивается пакет libstdc++6-4.7-dev (4.7.2-5) …
Checking presence of the command: ruby
Fatal error: Panel requires Ruby 1.8 (Ruby 1.9 is not supported).
смотрю и глазам не верю
Fatal error: Panel requires Ruby 1.8 (Ruby 1.9 is not supported).
Однако????????????????????????
проверяю
root@test31:~# ruby -v
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]
root@test31:~#

Хм  ущё больше вопросов возникают.

чИтаю вот это
инсталлятор сам потянет за собой нужные пакеты,

Это что получается, только сейчас в голове отстакнилось,
Это что эта панель сама вытягивает не нужную RUBY
извините но это нонсонс, не будет она тянуть что ей не НАДА, по определнию не будет

вот и повисает вопрос КАК так изначально показано что ruby нет
а теперь оказалось что она есть,
пробовал даже так
прежде чем ставить панель,
проверил стоит , ответ уже вым изветен
не стоит изначально
пробую ставить нужную версию
они говорить что уже стоит последняя

опять , опять??

Так давайте выяснять следующее,
при чистой устоновки она стоит ?
какая  стоит?

Тогда почему говорит что её нет??


если кто то внимательно вникнет в проблему то он поцмет про что идет речь.

Хух, а теперь представте как я сне йвоюю с этой сраной RUBY

* давайте не будем злоупотреблять большим шрифтом. Вас все прекрасно слышат, qupl

Цитировать
* давайте не будем злоупотреблять большим шрифтом. Вас все прекрасно слышат, qupl
согласен, был зол, на RUBY  >:(
« Последнее редактирование: 16 Января 2014, 10:51:04 от YVSIK »
 

Оффлайн qupl

Re: Ruby!! при установке.
« Ответ #6 : 16 Января 2014, 10:16:22 »
whereis ruby

Оффлайн YVSIK

Re: Ruby!! при установке.
« Ответ #7 : 16 Января 2014, 11:10:28 »
отличный ответ, или не зна или забыл , кажется пробовал эту команду но во внимание не принял
и так!! :
root@t30:~# ruby -v
-bash: ruby: команда не найдена
root@t30:~# whereis ruby
ruby:
root@t30:~#
и это на СВЕЖЕУСТАНОВЛЕННОЙ системе!
а теперь берем бубуен-шамана и проделываем все, что писалось выше.
будет результат, что она, ОКАзывается уже есть.
могу только добавить версию системы
root@t30:~# uname -r
2.6.32-openvz-042stab084.17-amd64
root@t30:~# uname -m
x86_64
root@t30:~# cat /proc/version
Linux version 2.6.32-openvz-042stab084.17-amd64 (root@ubu-64-build) (gcc version 4.4.6 (Ubuntu/Linaro 4.4.6-11ubuntu2) ) #1 SMP Fri Dec 27 17:00:12 MSK 2013
и как мене кажется полная его сущность
root@yvs:~# cat /proc/modules
vzethdev 8221 0 - Live 0xffffffffa05e5000
vznetdev 18888 4 - Live 0xffffffffa05db000
pio_nfs 17512 0 - Live 0xffffffffa05d2000
pio_direct 28104 0 - Live 0xffffffffa05c6000
pfmt_raw 3213 0 - Live 0xffffffffa0268000
pfmt_ploop1 6256 0 - Live 0xffffffffa0282000
ploop 114037 4 pio_nfs,pio_direct,pfmt_raw,pfmt_ploop1, Live 0xffffffffa059d000
simfs 4416 2 - Live 0xffffffffa01ce000
vzrst 192281 1 - Live 0xffffffffa0564000
nf_nat 23213 1 vzrst, Live 0xffffffffa055d000
nf_conntrack_ipv4 9978 2 nf_nat, Live 0xffffffffa022e000
nf_defrag_ipv4 1531 1 nf_conntrack_ipv4, Live 0xffffffffa01c7000
vzcpt 145512 1 vzrst, Live 0xffffffffa0531000
nfs 435103 3 pio_nfs,vzrst,vzcpt, Live 0xffffffffa04ac000
nfs_acl 2695 1 nfs, Live 0xffffffffa01aa000
auth_rpcgss 44899 1 nfs, Live 0xffffffffa049b000
fscache 53876 1 nfs, Live 0xffffffffa0485000
lockd 76933 2 vzrst,nfs, Live 0xffffffffa046a000
sunrpc 266569 6 pio_nfs,nfs,nfs_acl,auth_rpcgss,lockd, Live 0xffffffffa0410000
nf_conntrack 80620 4 vzrst,nf_nat,nf_conntrack_ipv4,vzcpt, Live 0xffffffffa03f1000
vziolimit 3751 0 - Live 0xffffffffa018a000
vzdquota 55403 2 [permanent], Live 0xffffffffa03dd000
vzmon 24334 5 vznetdev,vzrst,vzcpt, Live 0xffffffffa01a0000
vzdev 2765 5 vzethdev,vznetdev,vziolimit,vzdquota,vzmon, Live 0xffffffffa0184000
ip6t_REJECT 4743 0 - Live 0xffffffffa017f000
ip6table_mangle 3669 0 - Live 0xffffffffa015f000
ip6table_filter 3033 0 - Live 0xffffffffa0154000
ip6_tables 19746 2 ip6table_mangle,ip6table_filter, Live 0xffffffffa0146000
xt_length 1338 0 - Live 0xffffffffa012e000
xt_hl 1547 0 - Live 0xffffffffa011d000
xt_tcpmss 1623 0 - Live 0xffffffffa010f000
xt_TCPMSS 3525 0 - Live 0xffffffffa0090000
iptable_mangle 3493 0 - Live 0xffffffffa008c000
iptable_filter 2937 0 - Live 0xffffffffa006f000
xt_multiport 2812 0 - Live 0xffffffffa0058000
xt_limit 2102 0 - Live 0xffffffffa0049000
xt_dscp 2073 0 - Live 0xffffffffa0042000
ipt_REJECT 2399 0 - Live 0xffffffffa002e000
ip_tables 18183 2 iptable_mangle,iptable_filter, Live 0xffffffffa0063000
ipv6 326789 173 vzrst,ip6t_REJECT,ip6table_mangle, Live 0xffffffffa038c000
vzevent 2179 1 - Live 0xffffffffa000e000
snd_hda_codec_realtek 68096 1 - Live 0xffffffffa021c000
radeon 920831 1 - Live 0xffffffffa0287000
ttm 80877 1 radeon, Live 0xffffffffa00fa000
snd_hda_intel 27823 0 - Live 0xffffffffa027a000
drm_kms_helper 40183 1 radeon, Live 0xffffffffa026a000
snd_hda_codec 122091 2 snd_hda_codec_realtek,snd_hda_intel, Live 0xffffffffa0233000
drm 266624 3 radeon,ttm,drm_kms_helper, Live 0xffffffffa01d9000
edac_mce_amd 14721 0 - Live 0xffffffffa01d1000
snd_hwdep 6796 1 snd_hda_codec, Live 0xffffffffa01cb000
parport_pc 22818 0 - Live 0xffffffffa01c0000
parport 36305 1 parport_pc, Live 0xffffffffa01b1000
i2c_algo_bit 5951 1 radeon, Live 0xffffffffa01ac000
serio_raw 4706 0 - Live 0xffffffffa01a7000
edac_core 46661 0 - Live 0xffffffffa0193000
snd_pcsp 8775 0 - Live 0xffffffffa018c000
k10temp 3625 0 - Live 0xffffffffa0188000
snd_pcm 87067 3 snd_hda_intel,snd_hda_codec,snd_pcsp, Live 0xffffffffa0168000
snd_page_alloc 8454 2 snd_hda_intel,snd_pcm, Live 0xffffffffa0161000
snd_timer 22587 1 snd_pcm, Live 0xffffffffa0156000
i2c_piix4 12624 0 - Live 0xffffffffa014f000
snd 70451 7 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcsp,snd_pcm,snd_timer, Live 0xffffffffa0133000
i2c_core 31084 5 radeon,drm_kms_helper,drm,i2c_algo_bit,i2c_piix4, Live 0xffffffffa0125000
soundcore 8054 1 snd, Live 0xffffffffa011f000
shpchp 32794 0 - Live 0xffffffffa0111000
ext4 410652 4 - Live 0xffffffffa0094000
jbd2 92508 1 ext4, Live 0xffffffffa0072000
mbcache 8209 1 ext4, Live 0xffffffffa006b000
sg 29670 0 - Live 0xffffffffa005a000
sd_mod 39008 7 - Live 0xffffffffa004b000
crc_t10dif 1557 1 sd_mod, Live 0xffffffffa0047000
ata_generic 3853 0 - Live 0xffffffffa0014000
pata_acpi 3717 0 - Live 0xffffffffa000c000
r8169 60017 0 - Live 0xffffffffa0032000
8139too 30940 0 - Live 0xffffffffa0025000
8139cp 22313 0 - Live 0xffffffffa001b000
pata_atiixp 4227 2 - Live 0xffffffffa0016000
mii 5392 3 r8169,8139too,8139cp, Live 0xffffffffa0011000
ahci 41121 3 - Live 0xffffffffa0000000
root@yvs:~#


 

Оффлайн ogost

Re: Ruby!! при установке.
« Ответ #8 : 16 Января 2014, 11:39:04 »
в репах есть версии 1.8 и 1.9.1. ну это понятно.

в ваших логах выше указывается:
Цитировать
update-alternatives: используется /usr/bin/gem1.9.1 для предоставления /usr/bin/gem (gem) в автоматический режим
update-alternatives: используется /usr/bin/ruby1.9.1 для предоставления /usr/bin/ruby (ruby) в автоматический режим
то бишь копать нужно в эту сторону.

Сообщение объединено: 16 Января 2014, 11:45:03
я запустил скрипт, указанный вами на виртуалке с чистым дебианом. и он действительно качает обе версии руби из репов. нужно только разобратться с update-alternatives, и должно взлететь.

Сообщение объединено: 16 Января 2014, 11:50:23
погуглил, нужно ввести
update-alternatives --config ruby
и там выбрать нужную версию.

Оффлайн YVSIK

Re: Ruby!! при установке.
« Ответ #9 : 16 Января 2014, 11:58:42 »
ogost
ну вот разбирательство получилось.
получается что изначально ruby/ в чистом виде нет на новой машине и панелькачает сразу обе,
значит, что инсталятор не верно это делает или
надо изначально сразу ставить ruby/ ту в которой он нуждается. Отлично , даже очень хорошо.

И сразу вопрос? ну это уже скорее к дебу 7.0.3

Пробую  туже установку на деб 6
ты не поверишь.
в : версии ставиться и даже работать как пытается и не говорить что не так версия!

резюме: на деб 6 ставиться но плохо работает!
на деб 7 качает что и не надо, и ругается при этом .
вот и вышло , что 'дышло ' 
 делает в разных версиях что в голову этой панели придет

ЗЫ. всже я склонен к версии что что то тут с пакетами самого дебиана.
что то не срастается у него

Так,
Осталось вот что сделать раз на пустой системе нет rybu
ставить сразу управление версиями,
потом ставить обе или одну. и в управлениях версиями. ставить по умолчаю ту что надо
 может так свтанет))  :D

Кстати приятный ответ:
низкий поклон!
« Последнее редактирование: 18 Января 2014, 03:24:15 от YVSIK »
 

Оффлайн ogost

Re: Ruby!! при установке.
« Ответ #10 : 16 Января 2014, 12:09:30 »
пожалуйста, но кажется вы упустили момент из моего комментария:
погуглил, нужно ввести
update-alternatives --config ruby
и там выбрать нужную версию.

Оффлайн YVSIK

Re: Ruby!! при установке.
« Ответ #11 : 16 Января 2014, 12:59:14 »
момент из моего комментария:
так и есть упустил.

всеже)
если на дел 6 ставиться и работает, а на деб 7 жалуется
Инсталятор один и тот же ведь- так)

в первой случае не та версия во втором (деб 6) через пень колоду

теперь про команду
 даю команду она выдает версии
 пр предлогает эти вести поставить как надо
Но если панель- инстал уже их поставил и назначил и уже ругается я её уже не могу переставить, ай-яй ща попробуюу
завтра уже отпишу
спасибо в любом случае !

Сообщение объединено: 16 Января 2014, 13:08:55
Starting services...
Starting OpenVZ Web Panel...
Starting watchdog daemon...
[OK] Watchdog daemon was started.
Starting web server webrick on 0.0.0.0:3000...
[OK] Web server was started.
Syncing hardware nodes states...
[OK] Hardware nodes information was synced.
Place hardware daemon on machine with OpenVZ.
To start hardware daemon run:
sudo ruby /opt/ovz-web-panel//utils/hw-daemon/hw-daemon.rb start
Panel should be available at:
http://test31.hostmvc.ru:3000
Default credentials: admin/admin
-----------------------------------
ну вот теперь панель встала но в браузере непускается ))

ЗЫ ну хоть какие то сдвиги, а ту буксую на месте и всё тут)  ;)
« Последнее редактирование: 16 Января 2014, 13:08:55 от YVSIK »
 

Оффлайн ogost

Re: Ruby!! при установке.
« Ответ #12 : 16 Января 2014, 13:25:20 »
ну вот теперь панель встала но в браузере непускается ))
я полагаю, что эти команды вы ввели?
sudo ruby /opt/ovz-web-panel//utils/hw-daemon/hw-daemon.rb start
Panel should be available at:
http://test31.hostmvc.ru:3000
Default credentials: admin/admin

Теги: