Проблема с установкой Wine 1.7.10-1 (Wheezy)

Автор Sinderlok, 17 января 2014, 15:01:01

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Sinderlok

Здравствуйте. Пытался установить последнюю версию wine по этой статье http://www.binarytides.com/install-wine-debian-wheezy/
Но наткнулся на проблему в пункте:

Install latest wine
Now install wine debs.
# gdebi libwine-*
# gdebi wine-*


На моменте установки .deb выдало вот это:
#sinderlok@debian:~/Downloads$ sudo gdebi libwine-unstable_1.7.10-0.1_amd64.deb
  Reading package lists... Done
  Building dependency tree       
  Reading state information... Done
  Building data structures... Done
  Building data structures... Done
  This package is uninstallable
  Dependency is not satisfiable: libc6 (>= 2.17)


Делал все по порядку, все библиотеки стоят. Включая libc6. Перерыл кучу форумов и все равно не нашел решения. Прошу помощи. ::)
  •  

Brainey

Sinderlok, вам обязатльно нужна версия 1.7?
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
  •  

Sinderlok

Цитата: Brainey от 17 января 2014, 15:43:41
Sinderlok, вам обязатльно нужна версия 1.7?
Я сильно не разбираюсь в версиях. Но ведь последняя версия означает большую поддержку приложения и игр. Разве не так?
  •  

Brainey

Sinderlok, версия 1.7 нестабильна, что отражено и в названии пакетов.
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
  •  

Sinderlok

Цитата: Brainey от 17 января 2014, 15:55:16
Sinderlok, версия 1.7 нестабильна, что отражено и в названии пакетов.
Это я заметил. Но wine, насколько я понял, практически некогда не был стабилен.
А вы бы тогда какую версию посоветовали?
  •  

ferum

Сломаные зависимости и ни чего смешного. Можно пробовать пересобрать зависимости от http://dev.carbon-project.org/debian/wine-unstable/ взяв исходный код скорей всего с гита и дебианизацию с http://packages.debian.org/ru/sid/libwine-dev-unstable лучше пробовать под cowbuilder , на край можно за сырцами и в ubuntu заглянуть...но не обязательно всё будет как 2х2. Надо пробовать. разумеется нужно поправлять сборочные и установочные зависимости под wheezy.
Русские дебианщики против цифрового слабоумия !
  •  

Sinderlok

Цитата: ferum от 17 января 2014, 16:18:07
Сломаные зависимости и ни чего смешного. Можно пробовать пересобрать зависимости от http://dev.carbon-project.org/debian/wine-unstable/ взяв исходный код скорей всего с гита и дебианизацию с http://packages.debian.org/ru/sid/libwine-dev-unstable лучше пробовать под cowbuilder , на край можно за сырцами и в ubuntu заглянуть...но не обязательно всё будет как 2х2. Надо пробовать. разумеется нужно поправлять сборочные и установочные зависимости под wheezy.
Сломать я их не мог, точнее просто не успел бы. Дебиан только сегодня поставил. С начало поставил wine 1.4 он на зависимости не ругался. Так же как и другие программы.
  •  

ferum

[ot]Сломаные зависимости применительно пакета, который вы пытаетесь поставить. Это вовсе не значит что вы что то сломали в своей системе а означает что пакет собран неправильно или не для вашего дистрибутива. Скорее всего инструкция которую вы нашли актуальна для одного из тестовых релизов ubuntu или нестабильного debian, вы же используете стабильный wheezy. Естественно имеются ограничения по новизне софта но попробовать собрать последний wine хотя бы из исходников вполне реально.
З.Ы. Интерес к wine как правило проявляют начинающие пользователи постепенно переходящие с windows, по этому сложности с установкой софта их несколько напрягают. Это совершенно нормально , за то мотивация для сборки программы может стать хорошим трамплином для изучения debian в частности и linux в целом.[/ot]
Русские дебианщики против цифрового слабоумия !
  •  

Sinderlok

#8
Цитата: ferum от 17 января 2014, 17:12:27
[ot]Сломаные зависимости применительно пакета, который вы пытаетесь поставить. Это вовсе не значит что вы что то сломали в своей системе а означает что пакет собран неправильно или не для вашего дистрибутива. Скорее всего инструкция которую вы нашли актуальна для одного из тестовых релизов ubuntu или нестабильного debian, вы же используете стабильный wheezy. Естественно имеются ограничения по новизне софта но попробовать собрать последний wine хотя бы из исходников вполне реально.
З.Ы. Интерес к wine как правило проявляют начинающие пользователи постепенно переходящие с windows, по этому сложности с установкой софта их несколько напрягают. Это совершенно нормально , за то мотивация для сборки программы может стать хорошим трамплином для изучения debian в частности и linux в целом.[/ot]
Спасибо. Почитал получше про 1.7.10, решил пока поставить другою версию. На сайте WineHQ наше стабильную версию 1.6.2 Буду её осваивать.

Сообщение объединено: 17 января 2014, 19:27:18

Столкнулся с проблемой при компилировании файлов.
Командой:
#./configure

configure: error: X 32-bit development files not found. Wine will be built without X support, which probably isn't what you want. You will need to install 32-bit development packages of Xlib/Xfree86 at the very least.
Use the --without-x option if you really want this.

Можете подсказать какие именно нужно файлы поставить?

Сообщение объединено: 17 января 2014, 19:56:22

Затупил мне надо wine 64
#./configure --enable-win64
P.S. Мне уже начинает нравиться копаться в системе. Пусть и на таком примитивном уровне. :)
  •  

Sergei_Alekseev

Цитата: Sinderlok от 17 января 2014, 15:01:01Dependency is not satisfiable: libc6 (>= 2.17)
В визи libc6 2.13

Вот здесь выкладывали wine 1.6 пакеты для визи:
https://debianforum.ru/index.php?topic=6828.0
У меня работает хорошо.
  •  

ferum

Русские дебианщики против цифрового слабоумия !
  •  

Brainey

Цитата: ferum от 17 января 2014, 22:26:2764 битную версию wine
А нужно ли, если есть multiarch? В wheezy даже в репозитории лежит 32-битная версия wine.
Конференция форума в jabber: debianforum@conference.jabber.ru | Клуб кедоводов: kde@conference.jabber.ru
  •  

ferum

#12
В принципе под cowbuilder собирается всё без ошибок На выходе wine_1.7.10-1_amd64.deb wine1.7_1.7.10-1_amd64.deb wine1.7-amd64_1.7.10-1_amd64.deb  wine1.7-dbg_1.7.10-1_amd64.deb  wine1.7-dev_1.7.10-1_amd64.deb неразрешённых зависимостей вроде бы нет
Если есть желание потестить могу закинуть на мыло.

Сообщение объединено: 18 января 2014, 10:41:02

Цитата: Brainey от 18 января 2014, 10:29:11А нужно ли, если есть multiarch? В wheezy даже в репозитории лежит 32-битная версия wine.
По всей видимости есть разные решения одной и той же задачи, не попробовав мы не можем дать однозначного ответа.
Русские дебианщики против цифрового слабоумия !
  •  

su16

#13
собственно, на 64-битном Wheezy, 32-битная сборка wine 1.7.19 собирается чуть лучше чем без проблем. Слава мультиарчу и тем, кто его прикрутил!

Для тех кто не осилил, пакет прилепил;)

PS: а биарч кто-нибудь пробовал собрать?
Если вам дают бесплатное, то, скорее всего, товар - это вы.
http://ru.occupyflash.org/
  •  

k0matoznik

Подскажите, у меня проблема следующая - у меня Debian 8 x64.
Установил
i A wine64                                            - Windows API implementation - 64-bit binary loader
i   wine64-bin                                        - Windows API implementation - 64-bit helperv   winetricks:i386                                   -

Тоесть у меня система х64, но до кучи добавил пакеты x32. Сейчас я обновил wine до 1.7:i386 и слетели иксы, сейчас у меня установлен пакет gnome, но при попытке установить его еще раз он говорит что надо удалить пару пакетов :i386 и установить gnome:i386, это нормально?
  •