Автор Тема: Сообщение your current backend does not support installing files  (Прочитано 5522 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн useruser

  • Пользователь
  • *
  • Сообщений: 26
Линукс debian-7.3.0-i386-kde Свежеустановленный.
Пытаюсь установить deb пакет. Появляется сообщение "your current backend does not support installing files".
Гугл внятного ответа на этот вопрос не дал.
Пожалуйста, скажите что мне надо доустановить, чтобы я смог устанавливать deb пакеты?
 

Оффлайн Udachnik

Re: Сообщение your current backend does not support installing files
« Ответ #1 : 23 Января 2014, 15:11:00 »
А как вы его пытаетесь установить?
 

Оффлайн ferum

Re: Сообщение your current backend does not support installing files
« Ответ #2 : 23 Января 2014, 15:13:20 »
На всякий случай хорошенько подумайте стоит ли устанавливать пакеты не из репозитория, но если вы полностью доверяете безопаности пакета и его совместимости с системой всё просто. Для удобства помещаете пакет в корень своей домашней папки, командой su получаете права суперпользователя, dpkg -i название пакета.deb. Если у пакета имеются неудовлетворённые зависимости и dpkg "выругалась" по этому поводу apt-get -f install. Графическая утилита в KDE не работает.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн useruser

  • Пользователь
  • *
  • Сообщений: 26
Re: Сообщение your current backend does not support installing files
« Ответ #3 : 23 Января 2014, 15:27:55 »
Udachnik, я либо щёлкаю по нему, либо открыть с помощью - apper installer/
Ferum - тоже есть опасения. Не хочу переустанавливать Линукс в 3й раз. Но в репозитории этого пакета нет.
 

Оффлайн endru

Re: Сообщение your current backend does not support installing files
« Ответ #4 : 23 Января 2014, 15:35:33 »
useruser,
1. Название пакета?
2. вывод команды под спойлером cat /etc/apt/sources.list

Оффлайн useruser

  • Пользователь
  • *
  • Сообщений: 26
Re: Сообщение your current backend does not support installing files
« Ответ #5 : 23 Января 2014, 15:42:28 »
Пакет скачан с
1 http://ppa.launchpad.net/mobyfab/qstlink2/ubuntu/pool/main/q/qstlink2/
Имя пакета qstlink2_1.0.3~trusty_i386.deb (28-Nov-2013 18:28   150K) Самый нижний.
2




 

Оффлайн vladimir_ar

Re: Сообщение your current backend does not support installing files
« Ответ #6 : 23 Января 2014, 16:37:26 »
Правильнее будет собрать из исходников. Тем более, что они есть.
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн endru

Re: Сообщение your current backend does not support installing files
« Ответ #7 : 23 Января 2014, 16:38:48 »
useruser, есть острая необходимость в установке именно этой пакета? альтернатив точно нет?

И вы скачиваете пакет для последней версии Ubuntu, а он не пойдет на Wheezy

попробуйте Precise, но я вам этого не говорил  :-X

Yrii

  • Гость
Re: Сообщение your current backend does not support installing files
« Ответ #8 : 23 Января 2014, 17:23:58 »
Depends: libc6 (>= 2.4)
т.е. этот пакет в Wheezy просто так не поставить
напомню, что версия libc6 в Wheezy 2.13-38
 

Оффлайн endru

Re: Сообщение your current backend does not support installing files
« Ответ #9 : 23 Января 2014, 17:48:05 »
Yrii, хм...
проверил на VM: ShowHide

dpkg -i qstlink2_1.0.3~precise_i386.deb
Выбор ранее не выбранного пакета qstlink2.
(Чтение базы данных … на данный момент установлено 86958 файлов и каталогов.)
Распаковывается пакет qstlink2 (из файла qstlink2_1.0.3~precise_i386.deb) …
dpkg: зависимости пакетов не позволяют настроить пакет qstlink2:
 qstlink2 зависит от libqt4-xml (>= 4:4.5.3), однако:
  Пакет libqt4-xml не установлен.
 qstlink2 зависит от libqtcore4 (>= 4:4.7.0~beta1), однако:
  Пакет libqtcore4 не установлен.
 qstlink2 зависит от libqtgui4 (>= 4:4.5.3), однако:
  Пакет libqtgui4 не установлен.
 qstlink2 зависит от libqt4-core, однако:
  Пакет libqt4-core не установлен.
 qstlink2 зависит от libqt4-gui, однако:
  Пакет libqt4-gui не установлен.

#apt-get -f install

И... пакет успешно установлен! правда доступа к иксам не имею чтобы запустить...
« Последнее редактирование: 23 Января 2014, 17:52:25 от endru »
 

Yrii

  • Гость
Re: Сообщение your current backend does not support installing files
« Ответ #10 : 23 Января 2014, 20:35:31 »
Цитировать
# apt-get -f install...
не удивлён... не зря я написал "просто так не поставить", но это 1 из способов "костыльно" "поставить"...

i386 потом,если вспомню, проверю... и кстати, я понял почему у тебя поставилось на i386 (выделил красным) там должно быть 14...
Цитировать
Package: qstlink2
Version: 1.0.3~precise
Architecture: i386
Maintainer: Fabien Poussin <fabien.poussin@gmail.com>
Installed-Size: 370
Depends: libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.5.3), libstdc++6 (>= 4.1.1), libusb-0.1-4 (>= 2:0.1.12), libqt4-core, libqt4-gui
Section: devel
Priority: extra
Homepage: http://code.google.com/p/qstlink2/
Description: ST-Link V2 Client based on QT.
 QSTLink2 is a multi-platform ST-Link V2 Client based on QT.
amd64 ругнется
Цитировать
Package: qstlink2
Version: 1.0.3~precise
Architecture: amd64
Maintainer: Fabien Poussin <fabien.poussin@gmail.com>
Installed-Size: 372
Depends: libc6 (>= 2.14), libgcc1 (>= 1:4.1.1), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.5.3), libstdc++6 (>= 4.1.1), libusb-0.1-4 (>= 2:0.1.12), libqt4-core, libqt4-gui
Section: devel
Priority: extra
Homepage: http://code.google.com/p/qstlink2/
Description: ST-Link V2 Client based on QT.
 QSTLink2 is a multi-platform ST-Link V2 Client based on QT.
но это не значит, что ей нужна именно та версия, если я правильно понять исх. текст
просто она при таком раскладе собрана, что не удивительно http://packages.ubuntu.com/precise/libc6
 :)
 

Оффлайн ferum

Re: Сообщение your current backend does not support installing files
« Ответ #11 : 23 Января 2014, 20:45:05 »
Моё мнение такое- у нас на форуме категорически не рекомендуется советовать установку пакетов из ppa для ubuntu, не смотря на то что часто это путь наименьшего сопротивления. То что пакет нормально встаёт и даже нормально удаётся разрешить зависимости это ещё не значит что такое действие не повлечёт последствий для системы в дальнейшем ( может случиться так, что вы получите конфликт при последующей установке софта из родного репозитория), однако что мне нравится в debian и ubuntu приличные разработчики практически всегда сопровождают deb пакеты сорцовыми пакетам (дебианизированными пакетами исходного кода) которые очень хорошо брать за основу для сборки родного пакета. Вы пытаетесь поставить пакет из https://launchpad.net/~mobyfab/+archive/qstlink2. Лучше всего брать за основу сорцовые пакеты для raring  или sausy по сборочным и установочным зависимостям они ближе всего к debian wheezy. Мне понравилось действовать по образцу http://gq.net.ru/2007/03/16/building-deb-packages/ подглядывая в http://help.ubuntu.ru/wiki/создание_deb_пакетов. Версии сборочных и установочных зависимостей удобно посмотреть у себя на компьютере в synaptic.
Поступая таким образом на выходе мы получаем 100% устанавливаемый и удаляемый стандартными средствами пакет, чаще всего полностью работоспособный. Исключение составляют программы использующие сложные стартовые скрипты ( я сталкивался ) так как в ubuntu всё чаще используют upstart, но это уже частный случай и его однозначно придётся учитывать даже при установке программы из исходных кодов. Скорее всего упомянутого пакета последнее замечание не касается.
Русские дебианщики против цифрового слабоумия !
 

Оффлайн useruser

  • Пользователь
  • *
  • Сообщений: 26
Re: Сообщение your current backend does not support installing files
« Ответ #12 : 23 Января 2014, 21:05:14 »
Уважаемые профессионалы!
Скажите новичку, что делать? Иначе я сейчас "пойду по вашим" советам сверху вниз и снова придётся переустанавливать Линукс  :-\
 

Yrii

  • Гость
Re: Сообщение your current backend does not support installing files
« Ответ #13 : 23 Января 2014, 21:14:55 »
ferum, согласен, но свобода выбора всё же отличает linux от др., а там уже на свой страх и риск ;)
разработчик не юзероорентированный =) человек - хотя по специфике софта это понятно ибо он думает, что человек, который пользуется его софтом - всё поймет
да и на гитхабе не особо всё весело у него... на гуглокоде у него хотя бы инструкция есть :)

хех, только что собрал, правда под amd64...  ;D
useruser если подождешь до завтра, то попробую собрать под i386 (если всё норм будет или кто другой раньше не сделает ибо не чего сложного ;) )
:)
« Последнее редактирование: 23 Января 2014, 21:18:53 от Yrii »
 

Оффлайн ferum

Re: Сообщение your current backend does not support installing files
« Ответ #14 : 23 Января 2014, 21:29:56 »
[ot]Действовать на свой страх и риск в моём понимании подразумевает понимать то что делаешь и отдавать отчёт последствиям.
 Как мог ввёл человека в курс дела. Дальше естественно выбор за ним.[/ot]
Русские дебианщики против цифрового слабоумия !
 

Теги:
     

    Отправить сообщение всем локальным юзерам

    Автор os_a

    Ответов: 2
    Просмотров: 1069
    Последний ответ 02 Июля 2015, 14:32:07
    от os_a
    Debian 9 отказывается загружаться. Сообщение"Fixing recursive fault but reboot"

    Автор Zenoxx

    Ответов: 6
    Просмотров: 1561
    Последний ответ 14 Июня 2018, 18:56:58
    от Zenoxx
    Сообщение :command not found 5: в postinstall/postremove скриптах

    Автор Cyberneticist

    Ответов: 3
    Просмотров: 1732
    Последний ответ 27 Октября 2012, 21:07:43
    от kobzar
    Не загружается система.Сообщение "Fixing recursive fault but reboot is needed!"

    Автор Zenoxx

    Ответов: 6
    Просмотров: 3945
    Последний ответ 19 Декабря 2017, 13:00:50
    от Zenoxx
    Synaptic: непонятное сообщение при каждой установке пакета

    Автор Сёмин

    Ответов: 4
    Просмотров: 1389
    Последний ответ 12 Января 2016, 00:40:44
    от Сёмин