Автор Тема: Проблема с сетевыми настройками  (Прочитано 9728 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Антон Валерьевич

Проблема с сетевыми настройками
« : 02 Февраля 2014, 22:39:50 »
Ситуация замечена и в Squeeze и в Wheezy.
При включении системы и сразу после перезагрузки Сетевые имена успешно разрешаются, сайты успешно открываются.
Однако в какой-то момент, примерно через сутки непрерывной работы компьютера начинают возникать сложности с разрешением сетевых имён, долго открываются НЕКОТОРЫЕ сайты, после нескольких попыток могут открыться, а могут так и НЕ открыться. При этом другие сайты открываются гораздо лучше. Лучше открываются те сайты, которыми я чаще пользуюсь, однако утверждать наверняка я отказываюсь. Чаще всего я замечаю появление проблемы по видеороликам, располагающимся на тытрубе.
Другие компьютеры, работающие в локальной сети и выходящие в Сеть с того же IP-адреса при этом работают успешно.
Перезагрузка компьютера полностью устраняет проблему. По прошествии указанного выше времени ситуация повторяется.

Затрудняюсь утверждать о связанности проблем, но замечено ещё такое явление. Используя надстройку к Огнелису, которая называется DownloadHelper, начинаю закачивать какой-нибудь фильм. Зная, что закачка может прерваться, а такое происходит регулярно, я извлекают из списка закачек Огнелиса ссылку на скачиваемый файл и пытаюсь этот же файл скачать, используя wget в эмуляторе терминала. Так вот дело в том, что Огнелис прекрасно понял ссылку и уже качает файл wget ругается на то, что НЕ удаётся разрешить имя сервера. Помогают различные "пляски с бубном" - 1) или попеременно в одном и том же окне эмулятора терминала быстро чередовать попытки скачивания файла wget'ом и ping этого же сервера; 2) или попеременно чередовать запуски wget для скачивания и прекращение и повторный запуск скачивания файла Огнелисом. Первый способ быстрее помогает.

И в Squeeze и в Wheezy проблема появляется после установки apache. mysql, php, которые нужны для запуска по расписанию каждые две минуты файлов php, которые располагаются на этом же компьютере и выполняют обращения к трём другим сетевым ресурсам.

/var/log/apache2/error.log
Spoiler: ShowHide
:/var/log/apache2# cat error.log
[Sun Feb 02 06:25:04 2014] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-14+deb7u7 configured -- resuming normal operations
[Sun Feb 02 08:41:55 2014] [error] [client 123.26.29.208] Invalid method in request \xa91X\xec\xa9\x82\xe7\xed\x8a\\@\x9f\x92\xba\xef\xec\x84UC;_\xdbwgB\xfbK\xfcs4-^3\xb8\x96`\x8d
[Sun Feb 02 11:06:57 2014] [error] [client 89.211.160.174] Invalid method in request M\x89m\xcb\x0c
[Sun Feb 02 12:39:09 2014] [error] [client 24.135.43.95] Invalid method in request \xc2Z(\xad\xa98\xbc\xa8r\xab%HA\xafE\xc1D\xa1\xd4\xf5\xa1mS{\xe33\xfa2F1l\xdc\xc2\x809V/Z\xd6\xe7\xe6s\x14\xfdv0x\x06L\x8di\xf4\x88
[Sun Feb 02 12:49:23 2014] [error] [client 151.245.79.199] Invalid URI in request K\x8e\xad\x01\xa70E)?\xf8\x96)C\xea{\r\x99\xb4\x15\xea>\xd0\x95*
[Sun Feb 02 14:49:49 2014] [error] [client 139.218.215.187] request failed: error reading the headers
[Sun Feb 02 17:23:09 2014] [error] [client 190.83.158.155] Invalid method in request \x84\x97\x93B\x17-\xc1\xeb\xc3\xb24


Во внутренную почту системы постоянно сыпятся сообщения об ошибках и различные предупреждения о работе тех самых файлов php, которые запускаются по расписанию.

Выбор браузера НЕ влияет на проявление проблемы.

Помогите мне найти узкое место, причину возникающих сложностей с открытием сайтов.
Я прошу вас давать максимально простые и понятные указания на необходимые действия, желательно, чтобы мне оставалось лишь копировать команды, выполнять их и сообщать вам выдаваемые результаты.

Не стоит давать столь длинные названия тем. Malaheenee

P.S. Если модератор умеет сразу ставить диагнозы, то пусть лучше рецептом лекарства поделится.
Начальная тема статьи была более точной и менее категоричной. А вы со своими исправлениями заранее людей с толку сбиваете.
И вообще, перестаньте лезть с придирками, лучше по сути напишите.
« Последнее редактирование: 03 Февраля 2014, 00:30:29 от Антон Валерьевич »
 

yura_n

  • Гость
Re: Проблема с сетевыми настройками
« Ответ #1 : 03 Февраля 2014, 01:09:53 »
Глядя на лог, у меня создается впечатление, что вы активно используете ссылки, которые содержат нелатинские символы. Опишите на примерах процесс возникновения ошибки?
 

Оффлайн Антон Валерьевич

Re: Проблема с сетевыми настройками
« Ответ #2 : 03 Февраля 2014, 01:21:04 »
Глядя на лог, у меня создается впечатление, что вы активно используете ссылки, которые содержат нелатинские символы. Опишите на примерах процесс возникновения ошибки?
Лично я стараюсь избегать такие ссылки. Я всегда использую garant.ru вместо гарант.рф и т.п. Исследуемые и обрабатываемые моими файлами php ресурсы также используют полностью англоязычные пути к ресурсам. Мне приходится переходить по кириллическим ссылкам лишь вручную и то когда избежать это невозможно.
Я затрудняюсь указать момент и процесс возникновения затруднений. Я пытался отследить этот момент по различным записям в системе, но тщетно. Именно поэтому я обратился к более умным и опытным людям.
Примерно я могу оценить время возникновения сложностей как сутки после перезагрузки системы.
Вот сейчас у меня такая ситуация, но я воздерживаюсь от перезагрузки, чтобы при появлении каких-либо рекомендаций иметь возможность их тут же проверить. А желание перезагрузить ОС велико.
 

yura_n

  • Гость
Re: Проблема с сетевыми настройками
« Ответ #3 : 03 Февраля 2014, 01:27:25 »
Network manager используется?
 

Оффлайн Антон Валерьевич

Re: Проблема с сетевыми настройками
« Ответ #4 : 03 Февраля 2014, 01:35:57 »
Network manager используется?
Чё ?  :D
Я затрудняюсь ответить на этот вопрос. Я вроде бы НЕ ставил что-то подобное.

=============
Вот сейчас youtube.com
Spoiler: ShowHide
~$ ping youtube.com
PING youtube.com (173.194.39.164) 56(84) bytes of data.
64 bytes from bud02s04-in-f4.1e100.net (173.194.39.164): icmp_req=1 ttl=57 time=23.0 ms
64 bytes from bud02s04-in-f4.1e100.net (173.194.39.164): icmp_req=2 ttl=57 time=22.5 ms
64 bytes from bud02s04-in-f4.1e100.net (173.194.39.164): icmp_req=3 ttl=57 time=22.8 ms
64 bytes from bud02s04-in-f4.1e100.net (173.194.39.164): icmp_req=4 ttl=57 time=22.5 ms
64 bytes from bud02s04-in-f4.1e100.net (173.194.39.164): icmp_req=5 ttl=57 time=22.3 ms
64 bytes from bud02s04-in-f4.1e100.net (173.194.39.164): icmp_req=6 ttl=57 time=22.9 ms
64 bytes from bud02s04-in-f4.1e100.net (173.194.39.164): icmp_req=7 ttl=57 time=23.0 ms
64 bytes from bud02s04-in-f4.1e100.net (173.194.39.164): icmp_req=8 ttl=57 time=22.8 ms
64 bytes from bud02s04-in-f4.1e100.net (173.194.39.164): icmp_req=9 ttl=57 time=22.8 ms
64 bytes from bud02s04-in-f4.1e100.net (173.194.39.164): icmp_req=10 ttl=57 time=22.4 ms
64 bytes from bud02s04-in-f4.1e100.net (173.194.39.164): icmp_req=11 ttl=57 time=22.9 ms
^C
--- youtube.com ping statistics ---
11 packets transmitted, 11 received, 0% packet loss, time 10015ms
rtt min/avg/max/mdev = 22.375/22.766/23.072/0.271 ms

А браузером НЕ открывается. Ну, после двадцатой попытки может открыться. Перезагрузка страницы и опять...
« Последнее редактирование: 03 Февраля 2014, 01:43:23 от Антон Валерьевич »
 

Оффлайн sandaksatru

Re: Проблема с сетевыми настройками
« Ответ #5 : 03 Февраля 2014, 01:49:16 »
Если имена не резолвятся, то значит проблема где-то или с DNS или с резолвером. Давайте посмотрим:
cat /etc/resolv.conf
 

yura_n

  • Гость
Re: Проблема с сетевыми настройками
« Ответ #6 : 03 Февраля 2014, 01:49:57 »
Разлогиньтесь и залогиньтесь опять (не перезагружая). Попробуйте снова.
 

Оффлайн Антон Валерьевич

Re: Проблема с сетевыми настройками
« Ответ #7 : 03 Февраля 2014, 01:52:18 »
cat /etc/resolv.conf
~$ cat /etc/resolv.conf
domain domain
search domain
nameserver 91.196.80.3
nameserver 91.196.80.2

Сообщение объединено: [time]03 Февраль 2014, 01:57:45[/time]
Разлогиньтесь и залогиньтесь опять (не перезагружая). Попробуйте снова.
Я завершил работу графической оболочки, набрал "exit", затем заново авторизовался в системе и вот я с вами снова.
Затруднения с подключениями по-прежнему со мной.

======================
В какой-то момент вдруг как прозрение наступает. Вдруг почему-то загружаются и youtube.com и garant.ru, а потом снова тщетные попытки.
« Последнее редактирование: 03 Февраля 2014, 02:01:35 от Антон Валерьевич »
 

yura_n

  • Гость
Re: Проблема с сетевыми настройками
« Ответ #8 : 03 Февраля 2014, 02:02:36 »
domain domain
search domain
nameserver 91.196.80.3
nameserver 91.196.80.2
Закомментируйте первые две строки решеткой. Сделайте так:
#domain domain
#search domain
nameserver 91.196.80.3
nameserver 91.196.80.2
Попробуйте еще раз.
 

Оффлайн Антон Валерьевич

Re: Проблема с сетевыми настройками
« Ответ #9 : 03 Февраля 2014, 02:17:31 »
Закомментируйте ...

Попробуйте еще раз.
Тщетно.
Я попробовал закомментировать и последнюю строку, а вместо неё использовать "nameserver 8.8.8.8" чуть было обрадовался, но оказалось, что напрасно. И это сработало лишь один раз. Как я уже писал выше - как будто какое-то секундное прозрение наступает, а потом "кто не успел, тот опоздал".
« Последнее редактирование: 03 Февраля 2014, 02:20:00 от Антон Валерьевич »
 

yura_n

  • Гость
Re: Проблема с сетевыми настройками
« Ответ #10 : 03 Февраля 2014, 02:21:13 »
Вот была у меня похожая проблема. А как я ее решал? Напрочь не помню. ;D Вспомню - напишу. Первые две строки оставьте закомментированными, эти опции совместно не используются. Как временный вариант:
/etc/init.d/network restart
Должно по идее помочь.
« Последнее редактирование: 03 Февраля 2014, 02:22:52 от yura_n »
 

Оффлайн Антон Валерьевич

Re: Проблема с сетевыми настройками
« Ответ #11 : 03 Февраля 2014, 02:25:30 »
/etc/init.d/network restart
# /etc/init.d/network restart
bash: /etc/init.d/network: Нет такого файла или каталога

От меня: там есть файл networking. Оно ли ? Его ли перезапустить ?
 

yura_n

  • Гость
Re: Проблема с сетевыми настройками
« Ответ #12 : 03 Февраля 2014, 02:26:51 »
Тогда:
/etc/init.d/networking restart

 

Оффлайн Антон Валерьевич

Re: Проблема с сетевыми настройками
« Ответ #13 : 03 Февраля 2014, 02:34:27 »
Тогда:
/etc/init.d/networking restart
# /etc/init.d/networking restart
[warn] Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces ... (warning).
[....] Reconfiguring network interfaces...Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/90:e6:ba:cb:5d:73
Sending on   LPF/eth0/90:e6:ba:cb:5d:73
Sending on   Socket/fallback
DHCPRELEASE on eth0 to 192.168.1.1 port 67
Reloading /etc/samba/smb.conf: smbd only.
Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon.
done.
----------------------------
Через несколько секунд после этого у меня перестало работать всё сетевое. Я потерял возможность общаться с вами и был вынужден перезагрузиться. Теперь у меня всё работает, как я и описывал. Буду ждать повторения затруднений.
 

yura_n

  • Гость
Re: Проблема с сетевыми настройками
« Ответ #14 : 03 Февраля 2014, 03:16:53 »
Цитировать
Вспомню - напишу.
Вспомнил, пишу. ;D Проблема была все таки с менеджером сети (network manager), лет 5 назад. Я его тогда просто удалил и настроил сеть вручную.
Я потерял возможность общаться с вами и был вынужден перезагрузиться.
Это было необязательно. Достаточно было выполнить:
/etc/init.d/networking stop
/etc/init.d/networking start
restart почему-то deprecated.
« Последнее редактирование: 03 Февраля 2014, 03:18:34 от yura_n »
 

Теги:
     

    iptables + tc -> проблема нарезки скорости

    Автор viking

    Ответов: 6
    Просмотров: 2555
    Последний ответ 17 Февраля 2016, 14:35:38
    от gardarea51
    Проблема с доступом к сетевым файлам Windows из Debian

    Автор IskatelAG

    Ответов: 6
    Просмотров: 4369
    Последний ответ 11 Июля 2016, 04:04:44
    от IskatelAG
    Проблема с отображением списка доступных Wifi сетей

    Автор kot-x120

    Ответов: 4
    Просмотров: 4280
    Последний ответ 25 Августа 2011, 17:45:03
    от kot-x120
    Debian 9.4 проблема с Ethernet

    Автор s18woldemar

    Ответов: 5
    Просмотров: 1719
    Последний ответ 24 Мая 2018, 10:33:25
    от ogost
    Проблема с WiFi адаптером Ralink RT5370

    Автор ShoTo

    Ответов: 2
    Просмотров: 12858
    Последний ответ 14 Сентября 2012, 12:47:14
    от ShoTo