Автор Тема: Установка 1С:i386 на 64-битный Debian  (Прочитано 3722 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн enik

  • Новичок форума
  • Topic Author
  • Сообщений: 3
Установка 1С:i386 на 64-битный Debian
« : 06 Февраль 2014, 22:47:27 »
Подскажите, пожалуйста. Реально ли такое.

Spoiler: ShowHide
root@192:/home/enik/Загрузки# dpkg -i 1c-enterprise83-client_8.3.4-389_i386.deb
(Чтение базы данных … на данный момент установлено 148766 файлов и каталогов.)
Подготовка к замене пакета 1c-enterprise83-client 8.3.4-389 (используется файл 1c-enterprise83-client_8.3.4-389_i386.deb) …
Распаковывается замена для пакета 1c-enterprise83-client …
dpkg: зависимости пакетов не позволяют настроить пакет 1c-enterprise83-client:
 1c-enterprise83-client зависит от libwebkitgtk-1.0-0 (>= 1.2.5).

dpkg: ошибка при обработке параметра 1c-enterprise83-client (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils …
Обрабатываются триггеры для gnome-menus …
Обрабатываются триггеры для hicolor-icon-theme …
При обработке следующих пакетов произошли ошибки:
 1c-enterprise83-client


Spoiler: ShowHide
root@192:/home/enik/Загрузки# aptitude install libwebkitgtk-1.0-0:i386
Следующие НОВЫЕ пакеты будут установлены:       
  aspell:i386{ab} aspell-no:i386{a} enchant:i386{a} glib-networking:i386{a} ifinnish-small:i386{ab} libaspell15:i386{ab} libatk1.0-0:i386{a}
  libcairo2:i386{a} libdbus-glib-1-2:i386{a} libdrm-intel1:i386{a} libdrm-nouveau1a:i386{a} libdrm-radeon1:i386{a} libdrm2:i386{a}
  libenchant1c2a:i386{ab} libgail18:i386{a} libgdk-pixbuf2.0-0:i386{a} libgeoclue0:i386{ab} libgl1-mesa-dri:i386{a} libgl1-mesa-glx:i386{a}
  libglapi-mesa:i386{a} libgpm2:i386{a} libgtk2.0-0:i386{a} libhunspell-1.3-0:i386{a} libjasper1:i386{a} libjavascriptcoregtk-1.0-0:i386{ab}
  libncursesw5:i386{a} libpango1.0-0:i386{a} libpciaccess0:i386{a} libpixman-1-0:i386{a} libproxy0:i386{a} libsoup2.4-1:i386{a} libtinfo5:i386{a}
  libwebkitgtk-1.0-0:i386{b} libx11-xcb1:i386{a} libxcb-glx0:i386{a} libxcb-render0:i386{a} libxcb-shm0:i386{a} libxcomposite1:i386{a}
  libxcursor1:i386{a} libxdamage1:i386{a} libxfixes3:i386{a} libxft2:i386{a} libxi6:i386{a} libxinerama1:i386{a} libxrandr2:i386{a}
  libxslt1.1:i386{a} libxxf86vm1:i386{a}
Следующие частично установленные пакеты будут настроены:
  1c-enterprise83-client:i386
РЕКОМЕНДУЮТСЯ следующие пакеты, но автоматически они установлены НЕ БУДУТ:
  gstreamer0.10-ffmpeg:i386 gstreamer0.10-plugins-bad:i386 gstreamer0.10-plugins-base:i386 gstreamer0.10-plugins-good:i386
0 пакетов обновлено, 47 установлено новых, 0 пакетов отмечено для удаления, и 5 пакетов не обновлено.
Необходимо получить 53,1 MB архивов. После распаковки 192 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 aspell : Конфликтует: aspell:i386 но устанавливается 0.60.7~20110707-1.
 aspell:i386 : Зависит: dictionaries-common:i386 (> 0.40) который является виртуальным пакетом.
               Конфликтует: aspell но установлен 0.60.7~20110707-1
 libgeoclue0 : Конфликтует: libgeoclue0:i386 но устанавливается 0.12.0-4.
 libgeoclue0:i386 : Конфликтует: libgeoclue0 но установлен 0.12.0-4
 libjavascriptcoregtk-1.0-0 : Конфликтует: libjavascriptcoregtk-1.0-0:i386 но устанавливается 1.8.1-3.4.
 libjavascriptcoregtk-1.0-0:i386 : Конфликтует: libjavascriptcoregtk-1.0-0 но установлен 1.8.1-3.4
 ifinnish-small:i386 : Зависит: dictionaries-common:i386 (>= 0.25) который является виртуальным пакетом.
                       Зависит: ispell:i386 (>= 3.3.02) но его установка не запланирована.
 libenchant1c2a : Конфликтует: libenchant1c2a:i386 но устанавливается 1.6.0-7.
 libenchant1c2a:i386 : Конфликтует: libenchant1c2a но установлен 1.6.0-7
 libwebkitgtk-1.0-0 : Конфликтует: libwebkitgtk-1.0-0:i386 но устанавливается 1.8.1-3.4.
 libwebkitgtk-1.0-0:i386 : Зависит: libwebkitgtk-1.0-common:i386 (>= 1.8.1) который является виртуальным пакетом.
                           Конфликтует: libwebkitgtk-1.0-0 но установлен 1.8.1-3.4
 libaspell15 : Конфликтует: libaspell15:i386 но устанавливается 0.60.7~20110707-1.
 libaspell15:i386 : Конфликтует: libaspell15 но установлен 0.60.7~20110707-1
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                                                                       
1)      1c-enterprise83-client:i386                                                                   

      Сохранить для следующих пакетов их текущие версии:                                               
2)      aspell:i386 [Не установлен]                                                                   
3)      aspell-no:i386 [Не установлен]                                                                 
4)      enchant:i386 [Не установлен]                                                                   
5)      ifinnish-small:i386 [Не установлен]                                                           
6)      libaspell15:i386 [Не установлен]                                                               
7)      libenchant1c2a:i386 [Не установлен]                                                           
8)      libgeoclue0:i386 [Не установлен]                                                               
9)      libjavascriptcoregtk-1.0-0:i386 [Не установлен]                                               
10)     libwebkitgtk-1.0-0:i386 [Не установлен]                                                       

      Оставить следующие зависимости неразрешёнными:                                                   
11)     libaspell15:i386 рекомендует aspell-en:i386 | aspell-dictionary:i386 | aspell6a-dictionary:i386
12)     libproxy0:i386 рекомендует libmozjs10d:i386 | libwebkitgtk-1.0-0:i386                         


Принять данное решение? [Y/n/q/?]
 

Оффлайн qupl

Re: Установка 1С:i386 на 64-битный Debian
« Ответ #1 : 07 Февраль 2014, 06:14:01 »
Ключевое слово для поиска multiarch.

Оффлайн vladimir_ar

Re: Установка 1С:i386 на 64-битный Debian
« Ответ #2 : 07 Февраль 2014, 10:56:49 »
Бывает. По версиям не проходят установленные 64 - битные пакеты и нужные 32-х. А какие еще варианты дает aptitude, если ответить <n>?
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
 

Оффлайн enik

  • Новичок форума
  • Topic Author
  • Сообщений: 3
Re: Установка 1С:i386 на 64-битный Debian
« Ответ #3 : 07 Февраль 2014, 13:37:55 »

Бывает. По версиям не проходят установленные 64 - битные пакеты и нужные 32-х. А какие еще варианты дает aptitude, если ответить <n>?

Пока не понял о чем речь. Вечером буду за компом, отпишусь по остальным вариантам.
На ладно там 1С не ставится, с deb - архива.
Так даже элементарное
apt-get install mc:i386, тоже не устанавливается, хотя skype установился нормально.


Сообщение объединено: 07 Февраль 2014, 22:11:21
А какие еще варианты дает aptitude, если ответить <n>?
Дальше еще хуже:
Spoiler: ShowHide
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                                                 
1)      1c-enterprise83-client:i386                                             
2)      gimp                                                                   
3)      gnome                                                                   
4)      libjavascriptcoregtk-1.0-0                                             
5)      libwebkitgtk-1.0-0                                                     

      Сохранить для следующих пакетов их текущие версии:                       
6)      aspell:i386 [Не установлен]                                             
7)      aspell-no:i386 [Не установлен]                                         
8)      enchant:i386 [Не установлен]                                           
9)      ifinnish-small:i386 [Не установлен]                                     
10)     libaspell15:i386 [Не установлен]                                       
11)     libenchant1c2a:i386 [Не установлен]                                     
12)     libgeoclue0:i386 [Не установлен]                                       
13)     libwebkitgtk-1.0-0:i386 [Не установлен]                                 

      Оставить следующие зависимости неразрешёнными:                           
14)     libaspell15:i386 рекомендует aspell-en:i386 | aspell-dictionary:i386 | a
15)     libproxy0:i386 рекомендует libmozjs10d:i386 | libwebkitgtk-1.0-0:i386   
16)     gimp-data рекомендует gimp   


Spoiler: ShowHide
      Удалить следующие пакеты:                                                                       
1)      1c-enterprise83-client:i386                                                                   
2)      aspell                                                                                         
3)      aspell-en                                                                                     
4)      empathy                                                                                       
5)      evolution                                                                                     
6)      evolution-data-server                                                                         
7)      evolution-plugins                                                                             
8)      gdm3                                                                                           
9)      gedit                                                                                         
10)     gedit-plugins                                                                                 
11)     geoclue                                                                                       
12)     geoclue-hostip                                                                                 
13)     geoclue-localnet                                                                               
14)     geoclue-manual                                                                                 
15)     geoclue-yahoo                                                                                 
16)     gimp                                                                                           
17)     gir1.2-goa-1.0                                                                                 
18)     gir1.2-javascriptcoregtk-3.0                                                                   
19)     gir1.2-rb-3.0                                                                                 
20)     gir1.2-webkit-3.0                                                                             
21)     gnome                                                                                         
22)     gnome-contacts                                                                                 
23)     gnome-control-center                                                                           
24)     gnome-core                                                                                     
25)     gnome-documents                                                                               
26)     gnome-online-accounts                                                                         
27)     gnome-session-fallback                                                                         
28)     gnome-sushi                                                                                   
29)     gnome-user-guide                                                                               
30)     inkscape                                                                                       
31)     libaspell15                                                                                   
32)     libedata-book-1.2-13                                                                           
33)     libenchant1c2a                                                                                 
34)     libevolution                                                                                   
35)     libfolks-eds25                                                                                 
36)     libgeoclue0                                                                                   
37)     libgoa-1.0-0                                                                                   
38)     libgtkhtml-4.0-0                                                                               
39)     libgtkhtml-editor-4.0-0                                                                       
40)     libgtkspell0                                                                                   
41)     librhythmbox-core6                                                                             
42)     libwebkitgtk-1.0-0                                                                             
43)     libwebkitgtk-3.0-0                                                                             
44)     libyelp0                                                                                       
45)     metacity                                                                                       
46)     nautilus-sendto-empathy                                                                       
47)     rhythmbox                                                                                     
48)     rhythmbox-plugin-cdrecorder                                                                   
49)     rhythmbox-plugins                                                                             
50)     shotwell                                                                                       
51)     steam-debian                                                                                   
52)     tomboy                                                                                         
53)     yelp                                                                                           
54)     zenity                                                                                         

      Сохранить для следующих пакетов их текущие версии:                                               
55)     aspell:i386 [Не установлен]                                                                   
56)     aspell-no:i386 [Не установлен]                                                                 
57)     enchant:i386 [Не установлен]                                                                   
58)     ifinnish-small:i386 [Не установлен]                                                           
59)     libenchant1c2a:i386 [Не установлен]                                                           
60)     libjavascriptcoregtk-1.0-0:i386 [Не установлен]                                               
61)     libwebkitgtk-1.0-0:i386 [Не установлен]                                                       

      Оставить следующие зависимости неразрешёнными:                                                   
62)     brasero рекомендует yelp                                                                       
63)     cheese рекомендует yelp                                                                       
64)     empathy-common рекомендует yelp                                                               
65)     eog рекомендует yelp                                                                           
66)     evolution-common рекомендует evolution                                                         
67)     libfolks25 рекомендует libfolks-eds25                                                         
68)     gcalctool рекомендует yelp                                                                     
69)     gdm3 рекомендует zenity                                                                       
70)     gedit-common рекомендует gedit                                                                 
71)     gnome-control-center-data рекомендует gnome-control-center (>= 1:3.4.3.1-2)                   
72)     gnome-media рекомендует gnome-control-center                                                   
73)     gnome-online-accounts рекомендует gnome-control-center                                         
74)     gnome-panel рекомендует gnome-session-fallback                                                 
75)     gnome-panel рекомендует gnome-control-center                                                   
76)     gnome-panel рекомендует evolution-data-server                                                 
77)     gnome-session рекомендует gnome-session-fallback                                               
78)     gnome-shell рекомендует gnome-contacts                                                         
79)     gnome-shell рекомендует gnome-control-center                                                   
80)     gnome-shell рекомендует gnome-session-fallback                                                 
81)     gnome-shell рекомендует gnome-user-guide                                                       
82)     gnome-terminal рекомендует yelp                                                               
83)     gucharmap рекомендует yelp                                                                     
84)     inkscape рекомендует aspell                                                                   
85)     gnome рекомендует nautilus-sendto-empathy                                                     
86)     mousetweaks рекомендует gnome-control-center                                                   
87)     nautilus рекомендует gnome-sushi                                                               
88)     rhythmbox-data рекомендует rhythmbox                                                           
89)     shotwell-common рекомендует shotwell                                                           
90)     libaspell15:i386 рекомендует aspell-en:i386 | aspell-dictionary:i386 | aspell6a-dictionary:i386
91)     libproxy0:i386 рекомендует libmozjs10d:i386 | libwebkitgtk-1.0-0:i386                         
92)     gimp-data рекомендует gimp

« Последнее редактирование: 07 Февраль 2014, 22:11:21 от enik »
 

Оффлайн enik

  • Новичок форума
  • Topic Author
  • Сообщений: 3
Re: Установка 1С:i386 на 64-битный Debian
« Ответ #4 : 08 Февраль 2014, 16:25:11 »
И что самое досадное конфликтуют архитектурно не зависимые пакеты.
Libwebkitgtk не устанавливается, из-за пакета libwebkitgtk-1.0-common, в этом пакете одни java-скрипты.

Тот самы mc, не устанавливается из-за пакета mc-data ( тоже арxитеткура стоит ALL).
 

Теги:
 

Установка windows 10 с ОС Linux Debian10

Автор sergey_klcv

Ответов: 1
Просмотров: 781
Последний ответ 24 Август 2019, 21:57:57
от G_r_i_g_a
установка второго диска

Автор igor

Ответов: 6
Просмотров: 8656
Последний ответ 12 Март 2013, 23:21:43
от PbI6A
Установка ограниченных прав на нового пользователя

Автор madwayz1337

Ответов: 3
Просмотров: 1333
Последний ответ 18 Сентябрь 2016, 18:08:19
от alsoijw
[РЕШЕНО] Установка пакетов из списка

Автор SuperGeek256

Ответов: 2
Просмотров: 1580
Последний ответ 14 Июль 2014, 15:37:58
от SuperGeek256
Установка MySQL Workbench

Автор Fire

Ответов: 1
Просмотров: 2493
Последний ответ 23 Март 2011, 00:13:17
от Ghostdmn