[Решено] Radeon 6480 + проприетарные драйвера

Автор hexen, 07 февраля 2014, 03:42:45

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

hexen

Суть: установил Jessie c xfce. Скачал драйвера с оф.сайта AMD: amd-catalyst-14.1-betav1.3-linux-x86.x86_64 (правда, при разархивации там оказалось amd-driver-installer-13.35.1005-x86.x86_64, может быть так и надо, я не знаю), так вот, при установке сего драйвера, выдаёт такую инфу: [ot][/ot]
--force, как и предупреждали, привело к тормозам. Лог выдал следующее: Supported adapter detected.
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers for 3.7 release.  /lib/modules/3.12-1-amd64/build/include/generated/uapi/linux/version.h
Вопрос: что оно требует и как это исправить?
uname -a
Linux debian 3.12-1-amd64 #1 SMP Debian 3.12.9-1 (2014-02-01) x86_64 GNU/Linux
Ноут HP Pavilion g6

Разглагольствования о том, что я не местный и переполз с бубунты (xubuntu), я думаю, излишни. И так всё понятно.) В xubuntu ставил проприетарные драйвера, никогда с таким не сталкивался. Буду рад любой инфе. Спасибо!
HP Pavilion g6, AMD A4-3305M APU
AMD Radeon HD 6480G Discrete-Class
Debian Jessie x64, xfce 4.10
  •  

qupl

hexen, английским побелому пишет , что нужно установить "kernel headers for 3.7 release"
aptitude install linux-headers-XXX
вместо XXX свою версию ядра. 
Судя по тому, что требует 3.7, а в jessie 3.12, то не факт что fglrx установится. Но это только предположение.

Malaheenee

hexen, а fglrx-driver из стандартных репозиториев чем не устраивает? Вы же все равно ставите тестируемый выпуск, там будет обновляться сравнительно часто.
Все мы где-то, когда-то и в чем-то были новичками.
  •  

hexen

Цитата: qupl от 07 февраля 2014, 06:48:55aptitude install linux-headers-XXX
No candidate version found for linux-headers

Цитата: Malaheenee от 07 февраля 2014, 10:29:35fglrx-driver из стандартных репозиториев чем не устраивает? Вы же все равно ставите тестируемый выпуск, там будет обновляться сравнительно часто.
Вы правы. Тем более, полуночное гугление и полтора часа с утра + несколько неудачных проб это подтверждают. Людям с похожей проблемой советуют примерно то же. Что то в этом духе: If you use fglrx, you can go back to wheezy.

Будем считать, что вопрос решён.) Спасибо.
HP Pavilion g6, AMD A4-3305M APU
AMD Radeon HD 6480G Discrete-Class
Debian Jessie x64, xfce 4.10
  •  

qupl

Цитата: hexen от 07 февраля 2014, 11:01:59No candidate version found for linux-headers
вы ХХХ поменяли на что-то такое 3.12-1-amd64 ?

hexen

Цитата: qupl от 07 февраля 2014, 11:36:47вы ХХХ поменяли на что-то такое 3.12-1-amd64 ?
Конечно. И своё пробовал и то что драйвер просит. И с девяткой и с единичкой и с "amd" и без. Всё одно:
No candidate version found for linux-headers
Couldn't find any package whose name or description matched "xxx"
No packages will be installed, upgraded, or removed
HP Pavilion g6, AMD A4-3305M APU
AMD Radeon HD 6480G Discrete-Class
Debian Jessie x64, xfce 4.10
  •  

Malaheenee

Если что, то можно и так установить:
aptitude install linux-headers-$(uname -r)
Все мы где-то, когда-то и в чем-то были новичками.
  •  

qupl


hexen

Цитата: Malaheenee от 07 февраля 2014, 13:10:04aptitude install linux-headers-$(uname -r)
Вот оно! Всё установилось и последние драйвера встали без проблем. Спасибо! Как говорится, а ларчик просто открывался. Когда знаешь как.)
Теперь проблема точно решена. =)
HP Pavilion g6, AMD A4-3305M APU
AMD Radeon HD 6480G Discrete-Class
Debian Jessie x64, xfce 4.10
  •