Настройка после первой установки.

Автор Power, 08 февраля 2014, 15:45:43

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Power

Добрый всем день. Впервые установил Debian. Гляжу иксы не запускаются. Сходил на яндекс, оказывается установил из образа без DE. Скачал на этот раз CD-KDE... Установил. Иксы запустились. Теперь осталась самая главная проблема. Это интернет. Дело в том что у меня доступ только через Мегафон: с помощью телефона на Андроиде(желательно через Wi-Fi), С помощью 4G модема М100-3.
Система свистки видит.
Вот что выдает lsusb

# Bus 001 Device 001: ID ld6b:0002 Linux Foundation 2.0 root hub
# Bus 001 Device 002: ID ld6b:0001 Linux Foundation 1.1 root hub
# Bus 001 Device 002: ID 046d:081b Logitech, Inc. Webcam C310
# Bus 001 Device 003: ID 19d2:1403 ZTE WCDMA Technologies MSM
# Bus 001 Device 014: ID 148f:2070 Ralink Technology, Corp. RT2070 Wireless Adapter
# Bus 001 Device 005: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
# Bus 002 Device 002: ID 046d:c52e Logitech, inc






P.S. AMD 2,7 Мгц, Видео встроенное GeForce 6100 nforce 430 256Мб, память 2Гб
Сильно не ругайте, хоть опыт небольшой имеется, но Дебиан всё таки впервые вижу.
  •  

qupl


Malaheenee

usb_modeswitch также установите (он есть на первом диске вроде бы), а дальше дайте вывод ifconfig -a. Андроид чаще всего определяется как сеть usb0.
Все мы где-то, когда-то и в чем-то были новичками.
  •  

qupl

Цитата: Malaheenee от 08 февраля 2014, 15:52:11Андроид чаще всего определяется как сеть usb0.
Он через wi-fi хочет.

Malaheenee

А, ну тогда пусть поднимает на теле точку доступа. Правда, если не будет прошивки для беспроводной карточки...
Все мы где-то, когда-то и в чем-то были новичками.
  •  

Power

Я так понимаю, что не хватает еще каких-то пакетов. Ведь настройками интернета, кроме прокси, даже баловаться нельзя. Ведь всё равно в системном лотке должна отображаться информация о подключениях, даже если они отсутствуют. Эта  и все перечисленные проблемы могут решиться если я установлюсь с другого образа?
  •  

Malaheenee

Power, дайте вывод командыaptitude search network-manager usb-modeswitch
Все мы где-то, когда-то и в чем-то были новичками.
  •  

Power

Цитата: Malaheenee от 08 февраля 2014, 18:34:19
Power, дайте вывод командыaptitude search network-manager usb-modeswitch
На секунду появляется что-то вроде чтение списка пакетов и всё. В общем ничего нет.
  •  

ferum

Цитата: Power от 09 февраля 2014, 13:52:01На секунду появляется что-то вроде чтение списка пакетов и всё. В общем ничего нет.
                     
                  
                  
                     
                     
                     
                        
Это нормально так как эти пакеты у вас не установлены а интернета пока в системе нет.
У вас два выхода, выбирайте тот который вам больше нравится:
1) Качаете пакеты в ручную, учитывая все зависимости например из винды и подкидываете через флешку и устанавливаете через dpkg -i  По такому принципу http://packages.debian.org/wheezy/usb-modeswitch
Скорее всего для вафли вам ещё потребуется пакет http://packages.debian.org/ru/wheezy/connman , так трафика меньше главное учесть все зависимости.
2) Трафика нужно больше, качать придётся образ первого DVD ( с него в принципе можно устанавливать систему ) но в любом случае его придётся использовать в качестве репозитория http://4debian.info/repository/ можно резать на болванку или просто скопировать и примонтировать образ. В этом случае apt или aptitude автоматически разрешат зависимости.
При наличии достаточного внимания и самообладания первый способ быстрее. Если действительно возникнет проблема с несвободной прошивкой для вафли её ищут http://cdimage.debian.org/cdimage/unofficial/non-free/firmware/
Русские дебианщики против цифрового слабоумия !
  •  

Malaheenee

ferum, connman из wheezy не пригоден к использованию.
А вообще, Network Manager должен вроде быть на первом cd.
Все мы где-то, когда-то и в чем-то были новичками.
  •  

ferum

Цитата: Malaheenee от 09 февраля 2014, 17:16:19connman из wheezy не пригоден к использованию
Да спасибо за уточнение, нашёл https://groups.google.com/forum/#!topic/linux.debian.bugs.dist/dG8rbtCXnEI
Только вроде как получается наоборот wheezy не пригоден для использования Connman из за отсутствия библиотеки libxtables.so.7 но по большому счёту это ни чего не меняет  >:(
Русские дебианщики против цифрового слабоумия !
  •  

Malaheenee

[ot]ferum, вообще, мы имели ввиду староватую версию в Debian вообще, которая еще много не умеет  ::) О таком глюке и не знали (правда, stable и не пользуемся).[/ot]
Все мы где-то, когда-то и в чем-то были новичками.
  •