[РЕШЕНО] Нет подключения по кабелю

Автор phantom85, 11 февраля 2014, 15:56:02

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

phantom85

Всем привет, очень прошу вашей помощи так как я в линуксе вообще новичок. При установки дебиан 7.3 выбрал подключение по WI FI, после установки все замечательно запустилось, интернет есть, столкнулся с тем что нужно подключиться по кабелю, а ноут его не видит, в трее тоже нет настроек лан только беспроводные сети.
сетевая карта
Qualcomm Atheros AR8172/8176/8178 PCI-E Fast Ethernet Controller (NDIS 6.30)
Что делать? Много уже сайтов перебрал с похожими проблемами ничего не подходит, при установке Линукс минт или убунту работает и лан и вай фай, но мне они не нравятся хочу дебиан.
Linux 3.12-0.bpo.1-amd64 #1 SMP Debian 3.12.9-1~bpo70+1 (2014-02-07) x86_64 GNU/Linux
  •  

Malaheenee

Скорее всего нет прошивки. firmware-linux-nonfree и frimware-atheros установлены?
Все мы где-то, когда-то и в чем-то были новичками.
  •  

phantom85

Linux 3.12-0.bpo.1-amd64 #1 SMP Debian 3.12.9-1~bpo70+1 (2014-02-07) x86_64 GNU/Linux
  •  

Malaheenee

Гугуление говорит, что лучшим выходом будет установка ядра из бэкпортов.
Все мы где-то, когда-то и в чем-то были новичками.
  •  

phantom85

А подскажите пожалуйста каким образом это сделать?
Linux 3.12-0.bpo.1-amd64 #1 SMP Debian 3.12.9-1~bpo70+1 (2014-02-07) x86_64 GNU/Linux
  •  

Malaheenee

Вообще, установщик сам должен был предложить подключить репозитории.
В /etc/apt/sources.list
deb http://ftp.debian.org/debian/ wheezy-backports main contrib non-free
Потом
aptitude update
aptitude install firmware~i linux-image-3.12-0.bpo.1-686-pae

Строка для установки ядра 32-бит.
Все мы где-то, когда-то и в чем-то были новичками.
  •  

phantom85

Linux 3.12-0.bpo.1-amd64 #1 SMP Debian 3.12.9-1~bpo70+1 (2014-02-07) x86_64 GNU/Linux
  •  

Malaheenee

Все мы где-то, когда-то и в чем-то были новичками.
  •  

phantom85

команда должна выглядеть так?
aptitude install firmware~i linux-image-3.12-0.bpo.1-amd64
Linux 3.12-0.bpo.1-amd64 #1 SMP Debian 3.12.9-1~bpo70+1 (2014-02-07) x86_64 GNU/Linux
  •  

Malaheenee

Все мы где-то, когда-то и в чем-то были новичками.
  •  

phantom85

#10
Спасибо вечером домой доберусь, попробую и отпишусь

Сообщение объединено: 11 февраля 2014, 20:34:58

Все без изменений так и не работает (((((
Linux 3.12-0.bpo.1-amd64 #1 SMP Debian 3.12.9-1~bpo70+1 (2014-02-07) x86_64 GNU/Linux
  •  

Malaheenee

#11
uname -a и aptitude search linux-image из работающей системы.
Все мы где-то, когда-то и в чем-то были новичками.
  •  

phantom85

#12
root@admin:~# uname -a
Linux admin 3.2.0-4-amd64 #1 SMP Debian 3.2.54-2 x86_64 GNU/Linux

root@admin:~# aptitude search linux-image
Открыть содержимое (спойлер)
v   linux-image                     -                                           
v   linux-image:i386                -                                           
v   linux-image-2.6                 -                                           
v   linux-image-2.6:i386            -                                           
p   linux-image-2.6-486:i386        - Linux for older PCs (dummy package)       
p   linux-image-2.6-686:i386        - Linux for modern PCs (dummy package)     
p   linux-image-2.6-686-bigmem:i386 - Linux for PCs with 4GB+ RAM (dummy package
p   linux-image-2.6-686-pae:i386    - Linux for modern PCs (dummy package)     
p   linux-image-2.6-amd64           - Linux for 64-bit PCs (dummy package)     
p   linux-image-2.6-amd64:i386      - Linux for 64-bit PCs (dummy package)     
p   linux-image-2.6-openvz-686:i386 - Linux 2.6 for modern PCs (meta-package), O
p   linux-image-2.6-openvz-amd64    - Linux 2.6 for 64-bit PCs (meta-package), O
p   linux-image-2.6-vserver-686:i38 - Linux 2.6 for modern PCs (meta-package), L
p   linux-image-2.6-vserver-686-big - Linux 2.6 for PCs with 4GB+ RAM (meta-pack
p   linux-image-2.6-vserver-amd64   - Linux 2.6 for 64-bit PCs (meta-package), L
p   linux-image-2.6-xen-686:i386    - Linux 2.6 for modern PCs (meta-package), X
p   linux-image-2.6-xen-amd64       - Linux 2.6 for 64-bit PCs (meta-package), X
p   linux-image-2.6.32-5-486:i386   - Linux 2.6.32 for old PCs                 
p   linux-image-2.6.32-5-686:i386   - Linux 2.6.32 for modern PCs               
p   linux-image-2.6.32-5-686-bigmem - Linux 2.6.32 for PCs with 4GB+ RAM       
p   linux-image-2.6.32-5-686-bigmem - Debugging infos for Linux 2.6.32-5-686-big
p   linux-image-2.6.32-5-amd64      - Linux 2.6.32 for 64-bit PCs               
p   linux-image-2.6.32-5-amd64:i386 - Linux 2.6.32 for 64-bit PCs               
p   linux-image-2.6.32-5-amd64-dbg  - Debugging infos for Linux 2.6.32-5-amd64 
p   linux-image-2.6.32-5-openvz-686 - Linux 2.6.32 for modern PCs, OpenVZ suppor
p   linux-image-2.6.32-5-openvz-686 - Debugging infos for Linux 2.6.32-5-openvz-
p   linux-image-2.6.32-5-openvz-amd - Linux 2.6.32 for 64-bit PCs, OpenVZ suppor
p   linux-image-2.6.32-5-openvz-amd - Debugging infos for Linux 2.6.32-5-openvz-
p   linux-image-2.6.32-5-vserver-68 - Linux 2.6.32 for modern PCs, Linux-VServer
p   linux-image-2.6.32-5-vserver-68 - Linux 2.6.32 for PCs with 4GB+ RAM, Linux-
p   linux-image-2.6.32-5-vserver-68 - Debugging infos for Linux 2.6.32-5-vserver
p   linux-image-2.6.32-5-vserver-am - Linux 2.6.32 for 64-bit PCs, Linux-VServer
p   linux-image-2.6.32-5-vserver-am - Debugging infos for Linux 2.6.32-5-vserver
p   linux-image-2.6.32-5-xen-686:i3 - Linux 2.6.32 for modern PCs, Xen dom0 supp
p   linux-image-2.6.32-5-xen-686-db - Debugging infos for Linux 2.6.32-5-xen-686
p   linux-image-2.6.32-5-xen-amd64  - Linux 2.6.32 for 64-bit PCs, Xen dom0 supp
p   linux-image-2.6.32-5-xen-amd64- - Debugging infos for Linux 2.6.32-5-xen-amd
p   linux-image-3.12-0.bpo.1-486:i3 - Linux 3.12 for older PCs                 
p   linux-image-3.12-0.bpo.1-686-pa - Linux 3.12 for modern PCs                 
p   linux-image-3.12-0.bpo.1-686-pa - Debugging symbols for Linux 3.12-0.bpo.1-6
p   linux-image-3.12-0.bpo.1-amd64  - Linux 3.12 for 64-bit PCs                 
p   linux-image-3.12-0.bpo.1-amd64: - Linux 3.12 for 64-bit PCs                 
p   linux-image-3.12-0.bpo.1-amd64- - Debugging symbols for Linux 3.12-0.bpo.1-a
p   linux-image-3.12-0.bpo.1-rt-686 - Linux 3.12 for modern PCs, PREEMPT_RT     
p   linux-image-3.12-0.bpo.1-rt-686 - Debugging symbols for Linux 3.12-0.bpo.1-r
p   linux-image-3.12-0.bpo.1-rt-amd - Linux 3.12 for 64-bit PCs, PREEMPT_RT     
p   linux-image-3.12-0.bpo.1-rt-amd - Debugging symbols for Linux 3.12-0.bpo.1-r
p   linux-image-3.2.0-4-486:i386    - Linux 3.2 for older PCs                   
p   linux-image-3.2.0-4-686-pae:i38 - Linux 3.2 for modern PCs                 
p   linux-image-3.2.0-4-686-pae-dbg - Debugging symbols for Linux 3.2.0-4-686-pa
i A linux-image-3.2.0-4-amd64       - Linux 3.2 for 64-bit PCs                 
p   linux-image-3.2.0-4-amd64:i386  - Linux 3.2 for 64-bit PCs                 
p   linux-image-3.2.0-4-amd64-dbg   - Debugging symbols for Linux 3.2.0-4-amd64
p   linux-image-3.2.0-4-rt-686-pae: - Linux 3.2 for modern PCs, PREEMPT_RT     
p   linux-image-3.2.0-4-rt-686-pae- - Debugging symbols for Linux 3.2.0-4-rt-686
p   linux-image-3.2.0-4-rt-amd64    - Linux 3.2 for 64-bit PCs, PREEMPT_RT     
p   linux-image-3.2.0-4-rt-amd64-db - Debugging symbols for Linux 3.2.0-4-rt-amd
p   linux-image-486:i386            - Linux for older PCs (meta-package)       
p   linux-image-686:i386            - Linux for modern PCs (dummy package)     
p   linux-image-686-bigmem:i386     - Linux for PCs with 4GB+ RAM (dummy package
p   linux-image-686-pae:i386        - Linux for modern PCs (meta-package)       
p   linux-image-686-pae-dbg:i386    - Debugging symbols for Linux 686-pae config
i   linux-image-amd64               - Linux for 64-bit PCs (meta-package)       
p   linux-image-amd64:i386          - Linux for 64-bit PCs (meta-package)       
p   linux-image-amd64-dbg           - Debugging symbols for Linux amd64 configur
p   linux-image-openvz-686:i386     - Linux for modern PCs (meta-package), OpenV
p   linux-image-openvz-amd64        - Linux for 64-bit PCs (meta-package), OpenV
p   linux-image-rt-686-pae:i386     - Linux for modern PCs (meta-package), PREEM
p   linux-image-rt-686-pae-dbg:i386 - Debugging symbols for Linux rt-686-pae con
p   linux-image-rt-amd64            - Linux for 64-bit PCs (meta-package), PREEM
p   linux-image-rt-amd64-dbg        - Debugging symbols for Linux rt-amd64 confi
p   linux-image-vserver-686:i386    - Linux for modern PCs (meta-package), Linux
p   linux-image-vserver-686-bigmem: - Linux for PCs with 4GB+ RAM (meta-package)
p   linux-image-vserver-amd64       - Linux for 64-bit PCs (meta-package), Linux
p   linux-image-xen-686:i386        - Linux for modern PCs (meta-package), Xen d
p   linux-image-xen-amd64           - Linux for 64-bit PCs (meta-package), Xen d
[свернуть]
Linux 3.12-0.bpo.1-amd64 #1 SMP Debian 3.12.9-1~bpo70+1 (2014-02-07) x86_64 GNU/Linux
  •  

Malaheenee

так Вы его не установили.
aptitude install -t wheezy-backports firmware~i linux-image-3.12-0.bpo.1-amd64
Что говорит?
Все мы где-то, когда-то и в чем-то были новичками.
  •  

phantom85

aptitude install -t wheezy-backports firmware~i linux-image-3.12-0.bpo.1-amd64
Открыть содержимое (спойлер)
Следующие НОВЫЕ пакеты будут установлены:       
  linux-image-3.12-0.bpo.1-amd64{b}
0 пакетов обновлено, 1 установлено новых, 0 пакетов отмечено для удаления, и 5 пакетов не обновлено.
Необходимо получить 29,6 MB архивов. После распаковки 138 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
linux-image-3.12-0.bpo.1-amd64 : Ломает: initramfs-tools (< 0.110~) но установлен 0.109.1
                                  Ломает: initramfs-tools:i386 (< 0.110~) который является виртуальным пакетом.
Следующие действия разрешат зависимости:

     Удалить следующие пакеты:                                       
1)     initramfs-tools                                               

     Установить следующие пакеты:                                   
2)     cryptsetup [2:1.4.3-4 (stable)]                               
3)     dmraid [1.0.0.rc16-4.2 (stable)]                             
4)     dracut [020-2 (stable)]                                       
5)     kpartx [0.4.9+git0.4dfdaf2b-7~deb7u2 (stable, stable-updates)]
6)     libdmraid1.0.0.rc16 [1.0.0.rc16-4.2 (stable)]                 
7)     lvm2 [2.02.95-8 (stable)]                                     
8)     mdadm [3.2.5-5 (stable)]                                     



Принять данное решение? [Y/n/q/?]
[свернуть]
Linux 3.12-0.bpo.1-amd64 #1 SMP Debian 3.12.9-1~bpo70+1 (2014-02-07) x86_64 GNU/Linux
  •