ati -fglrx не могу поставить

Автор kroko, 26 февраля 2014, 19:22:07

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

kroko

Дебиан 7.4 lxde неделю назад ставил систему все получилось с драйверами -руководствовался статьей  https://wiki.debian.org/ru/ATIProprietary скачал деб пакеты при установке писалось -такие драйвера присутствуют в синаптике -ставил оттуда и даже дискретная видео отключалась -не нарадовался ноут холодный был -пока не занялся настройкой тачпада (кстати без успеха) и убил систему .Ставлю тот же дистр нет в синаптике fglrx-добавляю репозиторий нон фрее-появляются в синаптике =Но в синаптике не ставятся -пишет у вас битые пакеты пока не исправите бесполезно -да откуда они битые то система чистая .Ставлю снова -все так же.Пытаюсь ставить деб пакеты половина ставится половина пишет неразрешимая зависимость  libfglrx   fglrx-driver  . В KDE прекрасно ставились деб пакеты.Пробовал и стабильные и тестируемые пакеты-бесполезно -Я бы бросил если бы с начала не получилось -ноут с дискретной графиком -редкий дистр подходит -а тут сразу температура была около 50гр
  •  

endru

показывайте вывод команды:
cat /etc/apt/sources.list

kroko

deb cdrom:[Debian GNU/Linux 7 _Wheezy_ - Official Snapshot amd64 LIVE/INSTALL Binary 20140209-19:06]/ wheezy main

deb cdrom:[Debian GNU/Linux 7 _Wheezy_ - Official Snapshot amd64 LIVE/INSTALL Binary 20140209-19:06]/ wheezy main

deb http://mirror.yandex.ru/debian/ wheezy main
deb-src http://mirror.yandex.ru/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://mirror.yandex.ru/debian/ wheezy-updates main
deb-src http://mirror.yandex.ru/debian/ wheezy-updates main
=я ничего не добавлял только зеркало при установке и при разных установках разные зеркала.Раньше добавлял эти-deb http://ftp.au.debian.org/debian stable main non-free
deb-src http://ftp.au.debian.org/debian stable main non-free

deb http://ftp.debian.org/debian/ wheezy-updates main non-free
deb-src http://ftp.debian.org/debian/ wheezy-updates main non-free -в синаптике добавлялся fglrx но сразу появлялись битые пакеты
  •  

endru

к такому виду приведите /etc/apt/sources.list
Цитировать#deb cdrom:[Debian GNU/Linux 7 _Wheezy_ - Official Snapshot amd64 LIVE/INSTALL Binary 20140209-19:06]/ wheezy main
#deb cdrom:[Debian GNU/Linux 7 _Wheezy_ - Official Snapshot amd64 LIVE/INSTALL Binary 20140209-19:06]/ wheezy main
deb http://mirror.yandex.ru/debian/ wheezy main non-free
deb-src http://mirror.yandex.ru/debian/ wheezy main non-free

deb http://security.debian.org/ wheezy/updates main non-free
deb-src http://security.debian.org/ wheezy/updates main non-free

# wheezy-updates, previously known as 'volatile'
deb http://mirror.yandex.ru/debian/ wheezy-updates main non-free
deb-src http://mirror.yandex.ru/debian/ wheezy-updates main non-free
и далее:
apt-get update && apt-get upgrade
будут ошибки под спойлером показывайте.

kroko

Ничего не получается все по прежнему -хотел поставить программу для снятия скриншотов -тоже не получается -битые пакеты.Fglrx появился но нет возможности применить изменения необходимо исправить битые пакеты.Подскажите где скачать тестируемую lxde или их нет -что то я не могу найти -с этой что то никак не идет
  •  

endru

не торопитесь переустанавливать систему, всё решаемо!  :)

показывайте полностью: что делаете и какую информацию на экран выводит.

kroko

#6
устанавливаю систему с нуля-в синаптике ставлю хромиум там у меня закладки с помощью.в синаптике набираю по советам(https://wiki.debian.org/ru/ATIProprietary )fglrx-driver:libgl1-fglrx-glx:fglrx-modules-dkms :amd-clinfo :amd-opencl-icd :fglrx-atieventsd:fglrx-control:libgl1-fglrx-glx::xvba-va-driver:=нет в наличие.иду на источники репозиториев добавляю несвободные и обновленые -весь этот список появляется в синаптике -отмечаю нажимаю применить =получаю табличку невозможно применить у вас отложены битые пакеты.убираю репозитории добавленые битые пакеты исчезают как и fglrx.пробую деб пакеты -я их успешно устанавливал в кде -половина ставится а главные  с драйверами(неразрешимая зависимость  glx-alternative-fglrx.Пробовал и тестируемые деб  безрезультативно.Думал с образом что то качал другие все так же-ну я ведь ставил и у меня появлялся катализ контрол центр и все работало

Сообщение объединено: 26 февраля 2014, 21:45:17

в синаптике нажимаю исправить оибки получаю-E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.
E: Невозможно исправить зависимости
  •  

ChubaDuba

1. Отредактируйте sources.list как вам тут советовали.
2. Открывайте /var/lib/dpkg/status и удаляйте в нём всё, что связано с fglrx
3. apt-get update
4. Установите через Synaptic fglrx
  •  

endru

kroko, давайте выполним команды в терминале (от root пользователя или через sudo)
uname -a
aptitude install fglrx-driver

скопируйте вывод команд сюда.

kroko

#9
root@dell:/home/vik# uname -a
Linux dell 3.2.0-4-amd64 #1 SMP Debian 3.2.54-2 x86_64 GNU/Linux
root@dell:/home/vik# aptitude install fglrx-driver
Следующие НОВЫЕ пакеты будут установлены:       
  fglrx-driver{b} libfglrx{a} libfglrx-amdxvba1{a} libgl1-fglrx-glx{ab}
РЕКОМЕНДУЮТСЯ следующие пакеты, но автоматически они установлены НЕ БУДУТ:
  fglrx-atieventsd fglrx-glx-ia32 fglrx-modules-dkms
0 пакетов обновлено, 4 установлено новых, 0 пакетов отмечено для удаления, и 1 пакетов не обновлено.
Необходимо получить 25,5 MB архивов. После распаковки 79,5 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
libgl1-fglrx-glx : Зависит: glx-alternative-fglrx (>= 0.2) который является виртуальным пакетом.
fglrx-driver : Зависит: glx-alternative-fglrx (>= 0.2) который является виртуальным пакетом.
Следующие действия разрешат зависимости:

     Сохранить для следующих пакетов их текущие версии:         
1)     fglrx-driver [Не установлен]                             
2)     libfglrx-amdxvba1 [Не установлен]                       
3)     libgl1-fglrx-glx [Не установлен]                         

     Оставить следующие зависимости неразрешёнными:             
4)     libfglrx рекомендует libfglrx-amdxvba1 (= 1:12-6+point-3)


Сообщение объединено: 27 февраля 2014, 09:31:15


Принять данное решение? [Y/n/q/?]
  •  

vladimir_ar

А ответить <n> на предложение aptitude и посмотреть варианты решения?
Еще как вариант
# aptitude install -f
Debian Testing, kernel 3.16-2-amd64, OpenBox
AMD A8-3750 / 16Gb RAM / ATI HD6550D (onboard) / Sound ASUS Xonar - DS
_______________________________
Debian Testing, kernel 3.14-2-amd64, OpenBox
HP-655 AMD E1 / 8Gb RAM / ATI HD7310M
  •  

endru


kroko

И aptitude install -f и aptitude search ~b ничего не решают по прежнему в синаптике определяет битые пакеты
  •  

endru

kroko, aptitude search ~b  -пустой вывод? или что то было?  :)


ChubaDuba

Повторюсь...
Откройте от root /var/lib/dpkg/status и отредактируйте его, удалив все записи касающиеся битых пакетов.
  •